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Overview 

The WLANipulator is a graphical user interface for 

easy control of the Marvell® LabTool. The LabTool is 

a command line application to control the various 

Marvell® Wi-Fi/BT chip sets with a personal 

computer. The main target of the WLANipulator is to 

simplify the handling for the user. 

 Features 

• Start/stop the LabTool 

• Control the LabTool 

• Display the LabTool log file 

• Create batch files to run the LabTool 

• Save/load WLAN and Bluetooth settings 
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By purchase of any of the products described in this document the customer accepts the 

document's validity and declares their agreement and understanding of its contents and 

recommendations. Panasonic reserves the right to make changes as required at any time 

without notification. Please consult the most recently issued product specification before 

initiating or completing a design. 

 

© Panasonic Industrial Devices Europe GmbH 2017. 

All rights reserved. 

This user guide does not lodge the claim to be complete and free of mistakes. 

 

 

Disclaimer 

The information contained herein is presented only as guidance for Product use. No responsibility is 

assumed by PANASONIC for any infringement of patents or any other intellectual property rights of third 

parties that may result from the use of Product. No license to any intellectual property right is granted by 

this document, whether express or implied, by estoppel or otherwise. 

 Description of hardware, software, and other information in this document is only intended to 

illustrate the functionality of the referred PANASONIC product. It should not be construed as 

guaranteeing specific functionality of the product as described or suitable for a particular 

application. 

 Any provided (source ) code or command sequence shall not be used or incorporated into any 

products or systems whose manufacture, use, or sale is prohibited under any applicable laws or 

regulations. 

 Any outlined or referenced (source ) code or command sequence within this document is 

provided on an “as is” basis without any right to technical support or updates and without 

warranty of any kind on a free of charge basis according to § 516 German Civil Law (BGB) 

including without limitation, any warranties or conditions of title, non-infringement, merchantability, 

or fitness for a particular purpose. Customer acknowledges that (source) code or command 

sequence may bear defects and errors. 

 The third-party tools mentioned in this document are offered by independent third-party providers 

who are solely responsible for these products. PANASONIC has no responsibility whatsoever for 

the performance, product descriptions, specifications, referenced content, or any and all claims or 

representations of these third-party providers. PANASONIC makes no warranty whatsoever, 

neither express nor implied, with respect to the goods, the referenced contents or any and all 

claims or representations of the third-party providers. 

 To the maximum extent allowable by Law PANASONIC assumes no liability whatsoever including 

without limitation, indirect, consequential, special, or incidental damages or loss, including without 

limitation loss of profits, loss of opportunities, business interruption and loss of data. 
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1 About This Document 

1.1 Purpose and Audience 

This user guide provides details on the functional and operational characteristics of the 

Panasonic WLANipulator software. It is intended for hardware design, certification, and OEM 

engineers. The tool is referred to as “the WLANipulator” or “the software” within this document. 

 

1.2 Revision History 

Revision Date Modifications/Remarks Software Version 

0.1 22.03.2017 1st preliminary version 0.5.1 

 

1.3 Use of Symbols 

Symbol Description 

   

Note: Indicates important information for the proper use of the product. 

Non-observance can lead to errors. 

   

Attention: Indicates important notes that, if not observed, can put the product’s 

functionality at risk. 

 
Tip: Indicates useful information designed to facilitate working with the 

module/software. 

 
Indicates a requirement that must be met before you can complete the 

corresponding tasks. 

 Indicates the result of a task or the result of a series of tasks. 

 [chapter number] 

[chapter title] 

Cross reference: Indicates crossreferences within the document. 

Example: Description of the symbols used in this document  1.3 Use of 

Symbols. 

This font Indicates fixed terms and texts of the graphical user interface. 

Example: Click Save. 

Menu > Menu 

item 

Indicates a path, e.g. for accessing a dialog. 

Example: In the menu, select: File > Setup page. 

[ Key ] Indicates a key on the keyboard, e.g.: [ F10 ]. 

 

1.4 Related Documents 

Please refer to the Panasonic website for related documents  9.1.2 Product Information. 
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2 Product Overview 

 

WLANipulator GUI 

 

The WLANipulator is a graphical user interface (GUI) for easy control of the Marvell® LabTool. 

The LabTool is a command line application to control the various Marvell® Wi-Fi/BT chip sets 

with a personal computer. The main target of the WLANipulator is to simplify the handling for 

the user with regard to engineering, evaluation, and certification. 

 

Please refer to the Panasonic website for related documents  9.1.2 Product Information. 
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3 Installation 

3.1 Requirements 

The following requirements must be met to run the WLANipulator: 

 Microsoft Windows 7 or higher
1
 

 Microsoft .NET Framework 4
2
 

 Functional Test Setup with Panasonic PAN9xxx DUT 
 

3.2 Test Setup 

Test Setup with PAN90xx 

 
 

Test Setup with PAN93xx/94xx 

 

  

                                                           
1
 Tested with Microsoft Windows 7, 64bit. 

2
 Tested with Microsoft .NET Framework version 4.0.30319.36365. 

HOST PC

HOST IP

Windows OS

WLANipulator

LabTool

Virt ual M achine /

Bridge PC

DUT IP

Linux OS

mfgbridge

DUT

PAN90xx

ETH/LAN

Virtual ETH

DUT Interface

(USB/SDIO)

HOST PC

COM (Serial Port )

Windows OS

WLANipulator

LabTool

USB

UART

DUT

PAN93xx

PAN94xx

UART-to-WiFi 

Bridge installed 

on DUT
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3.3 Installation 

 

If you have a ZIP archive file with the LabTool and the WLANipulator bundle for 

a specific Panasonic module, you can skip the installation process. Simply 

unzip the archive to a preferred location on your hard disk.  

 

Copy the WLANipulator ZIP archive into the installation directory of the LabTool. Unzip the 

archive without creating a directory.  

The following files should now be located in the same directory as the LabTool executable file: 

• IronPython.dll 

• IronPython.Modules.dll 

• Microsoft.Dynamic.dll 

• Microsoft.Scripting.dll 

• Microsoft.Scripting.Metadata.dll 

• WLANipulator2.dll 

• WLANipulator2.exe 

• WLANipulator2.exe.config 

• sendkey.exe 

• sendkeys.exe 
 

If you want to use predefined values for the target power of the module, you need one of the 

files listed in table  Optional Files for Target Power. 

Ensure that the name of the executable LabTool file matches the correct name in the table  

LabTool Executable Files. 

The figure  Exemplary Setup depicts a complete installation of the WLANipulator and the 

LabTool for the PAN9020U. The directory looks similar for other Panasonic modules. Some files 

may differ. 
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LabTool Executable Files 

Panasonic Module LabTool-EXE 

PAN9020U DutApiBRIDGEETH8782U.exe 

PAN9020S DutApiBRIDGEETH8782S.exe 

PAN9026 DutApiSisoBt.exe 

PAN9055 DutApiMimoBtFmBrdigeUart.exe 

DutApiMimoBtFmBrdigeEth.exe 

PAN9320 DutApiBridgeUART8782.exe 

PAN9321 DutApiBridgeUART8782.exe 

PAN9420 DutApiWiFiMW30XBrdigeUart.exe 

 

Optional Files for Target Power 

Panasonic Module File With Target Power Values 

Dummy TxCal_PAN9xxx.ini 

PAN9020U TxCal_PAN9020.ini 

PAN9020S 

PAN9026 TxCal_PAN9026.ini 

PAN9055 TxCal_PAN9055.ini 

PAN9320 TxCal_PAN9320.ini 

PAN9321 TxCal_PAN9321.ini 

PAN9420 TxCal_PAN9420.ini 

 

Exemplary Setup 
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4 Use 

4.1 Get Started 

1. Double-click the WLANipulator2.exe. 

The program will run a batch file to check the program version of the LabTool to configure 

some version dependent settings. 

The WLANipulator main window opens. The window contains two tabs: For WLAN (left) and 

for Bluetooth (right). If the Panasonic module does not support Bluetooth, the Bluetooth tab 

will not be visible. 

  
 

2. Select one of the operational modes: Normal Mode, Certification Mode, or Batch Export 

Mode. 

 

The Normal Mode is used for engineering: It provides the most accessible settings. 
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The Certification Mode is used for certification purposes: All calibration data is read from 

the One Time Programmable (OTP) and most settings are fixed. 

The Batch File Mode creates batch files (the LabTool is not started). The batch files can be 

used to run the LabTool with fixed settings. 

For additional information about the different modes see  6 Operational Modes.  

 

3. Select the appropriate model name and configure the communication settings: 

a) For PAN90xx 

DUT IP address and Host IP address from your test setup  Test Setup with PAN90xx  

 

 

 

 

The Host IP address is given by the HOST PC (MS Windows) running 

the WLANipulator and LabTool. The assigned IP address of the LAN 

connection or Virtual Network Adapter please find at [Control Panel] 

[Network and Sharing Center] [Local Area Connection] [Properties]. 

The DUT IP need to be assigned on the Bridge PC or Virtual Machine 

(Linux OS) and should be in the same address range and subnet (sub-

net mask 255.255.255.0) as the Host IP. 

A successful communication between WLANipulator / LabTool and 

DUT requires the installation of the Marvell® device specific Kernel 

drivers and a running Marvell® MFGbridge on the Linux system. The 

device specific Linux SW package and the MFGTool release are avail-

able at the Marvell® XtraNet. To register and get access to the Marvell® 

XtraNet please find contact  9.1.1 Contact Us 

 

b) For PAN93xx / PAN94xx 

Serial Port number (Com No) and baud rate from your test setup  Test Setup with 

PAN93xx/94xx 

 

 

 

The serial Port number (Com No) is given by the HOST PC if hardware 

of connected USB to UART converter is detected. The assigned Com 

No please find at [Control Panel] [Device Manager] [Ports (COM & 

LPT)]. For a successful communication use a baud rate of 1 500 000 

baud and the assigned Com No. 

 

Example 

Example 
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The readMAC mode is selected by default. 

4. Click the green Run button to read the MAC address from the memory of the module. 

The following warning is displayed: 

 

  

 

 

The WLANipulator emulates the keyboard input to the LabTool. For that 

reason, it is very important that the LabTool does not lose the focus: Do 

not use the mouse or the keyboard. 

 

At the same time, the color of the Run button changes to yellow and the text on the button 

changes to Wait. The status bar contains the message Please wait… 

 

 

5. Click OK to confirm the warning. 

The WLANipulator reads the MAC address from the module and displays it. A valid MAC 

address enables additional modes to the readMAC mode.  

A warning is displayed with the instruction to reset the Device Under Test (DUT): 
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Changing the Use Cal Data from setting leads to the need to reset the 

module to ensure that the change will come into effect. 

 

Now you can modify the WLAN or Bluetooth setting. If you change the mode, the standard, 

or the frequency band, some settings may be reset. 

6. Click the green Run button to run the chosen settings.  

7. Follow the description (4-5) above until the Wait button changes to red and the label to 

Stop. The settings are now applied to the DUT. The LabTool remains open until you click 

the red Stop button to stop the DUT. 

 

 

 

Do not close the LabTool manually. Always stop the LabTool using the 

WLANipulator. 
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4.2 Advanced Use 

4.2.1 Change the DUT 

1. Before changing the Device Under Test (DUT): Click Stop to stop the ongoing 

measurement. 

2. Change the DUT. 

3. Click New DUT to reset the WLANipulator with the initial software settings.  

4. Click Run to read the MAC address of the new DUT. 

 

4.2.2 The LabTool  Log 

The WLANipulator analyses the log file of the LabTool after the tool has been run. The status 

bar contains a message with the information, whether the run was successful. If the status bar 

does not contain the word Success, the last error message is displayed. The tooltip of the 

status bar contains all error messages. 

 

Open the complete log 

Double-click on the error message in the status bar or click View > LabTool Log. 

 

A new window opens: 
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All status codes are highlighted in green, error codes in red. You can export the log into a text 

file (default) or a rich text format file. 

 

Export the log into rich text format 

1. Change the file extension in the text field from *.txt to *.rtf.  

2. Click Export to save the log file in the current directory. 

 

The log files are named with the date (YYYY-MM-DD), the time (hhmmss), and the MAC 

address xxxxxxxxxxx as follows: 

YYYY-MM-DD-hhmmss-xxxxxxxxxxx-Log.txt 

 

4.2.3 Save And Load Settings 

The WLANipulator can save your settings on the hard disk drive and it can load them from 

there. To save the current settings into a csv file
3
: Click File > Save. To load settings from a file 

to the program: Click File > Load. 

                                                           
3
 Comma-separated values file with plain text. 
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4.2.4 Transmitter Tests 

Use the Tx DutyCycle, the Tx HighDutyCycle, the Tx Continuous or the Tx CW mode to test the 

Device Under Test (DUT) as a transmitter. For further information   7.1 WLAN Modes. 

1. Switch the WLAN mode to Tx DutyCycle, Tx HighDutyCycle, Tx Continuous or Tx CW 

mode. 

2. Configure your settings. 

3. Click Run to set the module in transmitter mode. 

 

4.2.5 Receiver Tests 

Use the Rx mode to test the Device Under Test (DUT) as a receiver. You need an external 

WLAN source as a transmitter. 

1. Switch the WLAN mode to Rx mode. 

2. Configure your settings. 

3. Click Run to set the module in receiver mode and reset the counter. 

4. Switch on your transmitter. 

5. Wait until the transmission is finished. 

6. Click Stop to stop the receiver mode and stop the counter. 

7. The Rx Packet, Multi Cast, and Error Count values are displayed in the status bar. 
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Alternatively, click View > LabTool Log to view the receive statistics in the LabTool Log. 

 
 

 

4.2.6 Export Batch Files 

The WLANipulator can export the settings to batch files. These batch files can also control the 

LabTool.  

1. Switch the operating mode to Export Batch File mode. 

2. Configure your settings. 

3. Click Export Batch-File. 

 
 

A batch file with the file extension *.bat is written to the WLANipulator directory. The file 

name has the following convention:   

Module 

Name 

Mode IEEE 802.11 

Standard 

Modulation Data 

Rate 

Channel Frequency File 

Extension 

PAN9020U TxDC 11b DSSS 1Mbps CH1 2412 .bat 

 

 PAN9020U_TxDC_11b_DSSS_1Mbps_CH1_2412.bat  

 

  



  WLANipulator 
    

 5 Settings 
 

 
 

User Guide Rev. 0.1  Page 18 
 

5 Settings 

This section briefly describes the meaning of the various WLANipulator settings including the 

value ranges. 

 

General Setting 

Option Description Range 

Model Name Name of the Panasonic module e.g. PAN9420 

Use Cal Data from Location of the calibration data: 

EEPROM, configuration file, non-volatile memory (OTP) 

- 

Host IP Host IP network address 0.0.0.0 to 255.255.255.255 

DUT IP DUT IP network address 0.0.0.0 to 255.255.255.255 

Com No COM serial port number Integer 1  n  65535 

Baud Symbol rate of the COM port - 

Input Delay Delay of the input of two commands? Integer 0  t  5 

Hold Time The time span in seconds in which the DUT stays active 

in the current mode 

Integer 1  t  3 600 

 

WLAN Settings 

Option Description Value 

Mode Operating mode - 

Standard WLAN standard defined in IEEE 802.11 - 

Greenfield An operational mode of the IEEE 802.11n standard 

(allow only 802.11n devices) 

True/false 

Tx Buffer Transmit buffer True/false 

Short Preamble IEEE 802.11b/n shorter preamble True/false 

Advanced Coding  True/false 

Short Guard Interval IEEE 802.11n supports shorter Guard Intervals True/false 

Carrier Suppression 

Mode 

Suppress the carrier in the output signal True/false 

Compensation  True/false 

Power ID Let the Power ID be -1 to follow the bandwidth settings Integer -1  t  15 

STBC Space Time Block Coding Two bits 00 to 11 

Payload  Integer 0  t  100 

Pattern Pattern of the transmitted pseudo data Hex value 00 to FF 

Bssid Basic Service Set Identifier 00.00.00.00.00.00 to 

FF.FF.FF.FF.FF.FF 

Adjust Tx Burst Gap  True/False 

Burst Sifs Length of the Short Interframe Space in µs Integer 0  t  255 

Length  Integer 1  t  400 

MAC Media Access Control address 00.00.00.00.00.00 to 

FF.FF.FF.FF.FF.FF 
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Option Description Value 

Tx/Rx Path Which path is set: 0 or 1, or 0 and 1 ‘Path 0’, ‘Path 1’, or 

‘Path 0 + 1’ 

Path Path which settings are displayed by the GUI 0 or 1 

Channel Channel number of the 2.4 GHz or 5 GHz WLAN band - 

Offset The channel number indicates whether the upper or 

lower part of the 40 MHz bandwidth channel is used 

‘-‘, ‘up’ or ‘lo’ 

Bandwidth Bandwidth in MHz 20 or 40 

Frequency Frequency in the 2.4 GHz or 5 GHz WLAN band in MHz - 

Tx Power Target power at the output of the module in dBm Integer 0  p  20 

Use target power from 

file 

If checked: Use power values from file True/false 

Datarate Transmit data rate in Mbps; depends on the IEEE 

802.11n standard 

- 

 

 



  WLANipulator 
    

 6 Operational Modes 
 

 
 

User Guide Rev. 0.1  Page 20 
 

6 Operational Modes 

6.1 Normal Mode 

The Normal Mode is the regular operational mode for the WLANipulator. It supports all 

necessary settings for customers. 

 

Features 

• All modes and standards 

 

Restrictions 

• Payload Weight is fixed (WLAN) 

• Pattern is fixed (WLAN) 

• Burst SIFS (Short Interframe Space) is fixed (WLAN) 

• BSSID (Basic Service Set Identifier) is fixed (WLAN) 

• Payload Length in Byte is fixed (Bluetooth) 

• Channel Access Mode is fixed (Bluetooth) 
 

6.2 Certification Mode 

The Certification Mode is the recommended operational mode for certification purpose. It 

ensures that the right calibration data are used while testing. 

 

Features 

• Some defined settings for certification. 

 

Restrictions 

• Calibration Data are only read from the One Time Programmable (OTP). 

• Payload Weight is fixed (WLAN) 

• Pattern is fixed (WLAN) 

• Burst SIFS (Short Interframe Space) is fixed (WLAN) 

• BSSID (Basic Service Set Identifier) is fixed (WLAN) 

• Payload Length in Byte is fixed (Bluetooth) 

• Channel Access Mode is fixed (Bluetooth) 

 

6.3 Batch Export Mode 

The WLANipulator is able to export the settings to Batch files. These Batch files control the 

LabTool like the WLANipulator but with fixed settings. You can use the Batch files to repeat a 

measurement without using the WLANipulator. 

For further description see  4.2.6 Export Batch Files. 
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Features 

• A connection to a DUT is not mandatory. 

• A queue of settings is possible. 
 

Restrictions 

• The LabTool is disabled. 
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7 WLAN and Bluetooth Modes 

 

All WLAN and Bluetooth Tx and Rx modes used by the WLANipulator and 

LabTool are based on the non-signaling condition. 

 

7.1 WLAN Modes 

7.1.1 readMAC 

In this mode the WLANipulator reads the Media Access Control (MAC) address from the DUT. 

The MAC address is verified by the WLANipulator. 

 

An invalid or empty MAC address will cause an abnormal termination of the 

WLANipulator  8 Troubleshooting.  

 

7.1.2 Tx DutyCycle 

The standard transmit mode for WLAN. It supports the IEEE 802.11 standards a/b/g/n. 

 

This mode for WLAN is deprecated for PAN9xxx modules using Marvell 

chipset generation 88W87xx. Use the Tx HighDutyCycle instead  7.1.3 Tx 

HighDutyCycle. 

 

7.1.3 Tx HighDutyCycle 

This mode is the further development of the Tx DutyCycle mode. It supports the IEEE 802.11 

standards a/b/g/n. 

 

7.1.4 Tx Continuous 

Transmission of a continuous modulated WLAN signal. 

 

7.1.5 Tx CW 

Transmission of an unmodulated continuous wave signal. 

 

Some modules may overheat if operated in this mode for a longer duration.  
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7.1.6 Rx 

The module receives WLAN data from a transmitting source. The Start button resets the 

counter for received packets. The module receives data packets until the operating is stopped 

by clicking the Stop button. The Rx Packet, Multi Cast, and Error Count values will be displayed 

in the status bar at the bottom of the WLANipulator. Alternatively, they can be viewed in the 

LabTool log.  

For a detailed description  4.2.5 Receiver Tests. 

 

7.2 Bluetooth Modes 

The description of the Bluetooth modes will be added in the next version of this document. 
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8 Troubleshooting 

The WLANipulator crashes on start-up and produces one of the following messages in 

the Log.txt file: 

 

• No module found. 
Please make sure that your module is supported by the actual version of the 
WLANipulator. 
If your PAN9xxx is supported,  9.1.1 Contact Us. 

 

The WLANipulator crashes and produces one of the following messages in the Log.txt 

file: 

 

• 0x4D6143FF 
Open the Test.txt file in the LabTool and WLANipulator directory. If the content is not 
readable: Delete, rename, or move the Test.txt file and retry the measurement. 
 
Please email us, if the problem persists  9.1.1 Contact Us. 

 

The shell displays the message: “The command “sendkey.exe” […] can not be found.” or 

“Der Befehl “sendkey.exe” ist entweder falsch geschrieben oder konnte nicht gefunden 

werden.”  

Verify that the sendkey.exe is located in the LabTool directory. 

 

The shell displays the message: “The command “sendkeys.exe” […] can not be found.” 

or “Der Befehl “sendkeys.exe” ist entweder falsch geschrieben oder konnte nicht 

gefunden werden.”  

Verify that the sendkeys.exe is located in the LabTool directory. 

 

The LabTool produces errors because of incomplete or mixed up commands. 

The LabTool is not fast enough to process the commands sent by the WLANipulator. Try to 

increase the input delay in the WLANipulator. The connected module needs to be reset. 

 

The model name of your module is not selectable. 

Not all variants of the modules are listed separately. Check if the antenna version of your 

module is selectable, for example: PAN9010U > PAN9020U or PAN9045 > PAN9055. 

 

The settings for DUT IP address, HOST IP address, Com Port number and Baud rate are 

not restored from the SetUp.ini. 

Check if all of the following files are located in the LabTool directory: SetUp.ini and/or 

SetUp.ini.old. 

 

The ‘Use Cal Data from’ setting is not taken into account by the DUT. 

Reset the DUT after each change of this option. 
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The target power values cannot be read from the TxCal_PAN9xxx.ini. 

Verify that the checkbox next to the target power is checked and that the correct INI-file (e.g. 

TxCal_PAN9026.ini) is located in the current directory.  

 

The program does not create a batch file in Batch Export Mode. 

The program is not able to keep old files with the same file name. The old file will be replaced. 

 

The program crashes when loading a “save” file. 

The file may be corrupted. Save a new file and compare it with the damaged file regarding item 

count etc. The “save” files contain comma-separated values (CSV). 
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9 Appendix 

Supported Devices and Variants 

Brand Name Description DUT Interface 

PAN9020U WLAN Radio Module USB 

PAN9020S WLAN Radio Module SDIO 

PAN9026 WLAN & Bluetooth Radio Module SDIO 

PAN9055 WLAN & Bluetooth Radio Module USB/SDIO 

PAN9320 WLAN Fully Embedded Module UART0 

PAN9321 WLAN Fully Embedded Module UART0 

PAN9420 WLAN Fully Embedded Module UART0 

 

For further information please refer to our product documentation  9.1.2 Product Information. 
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9.1 Contact Details 

9.1.1 Contact Us 

 

Please contact your local Panasonic Sales office for details on additional product options and 

services: 

 

For Panasonic Sales assistance in the EU, visit 

https://eu.industrial.panasonic.com/about-us/contact-us 

Email: wireless@eu.panasonic.com 

 

For Panasonic Sales assistance in North America, visit the Panasonic Sales & Support Tool to 

find assistance near you at 

https://na.industrial.panasonic.com/distributors 

 

 

 

Please visit the Panasonic Wireless Technical Forum to submit a question at  

https://forum.na.industrial.panasonic.com 

 

 

 

9.1.2 Product Information 

 

Please refer to the Panasonic Wireless Connectivity website for further information on our 

products and related documents: 

 

For complete Panasonic product details in the EU, visit 

http://pideu.panasonic.de/products/wireless-modules.html 

 

For complete Panasonic product details in North America, visit 

http://www.panasonic.com/rfmodules 


