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Embedded Studio

Introduction

This guide is divided into a number of sections:

Introduction
Covers installing SEGGER Embedded Studio on your machine and verifying that it operates correctly,
followed by a brief guide to the operation of the SEGGER Embedded Studio integrated development
environment, debugger, and other software supplied in the product.

SEGGER Embedded Studio User Guide
Contains information on how to use the SEGGER Embedded Studio development environment to manage

your projects, build, and debug your applications.

hcc
Contains documentation for the C compiler, including syntax and usage details and a description of
extensions provided by SEGGER Embedded Studio.

has
Contains detailed documentation covering how to use the assembler, the assembler notation, macros, and
other assembler features.
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What is SEGGER Embedded Studio?

C compiler

SEGGER Embedded Studio C is a faithful implementation of the ANSI and ISO standards for the programming

language C. We have added some extensions that enhance usability in a microcontroller environment.

SEGGER Embedded Studio C Library

SEGGER Embedded Studio has its own royalty-free ANSI and ISO C compliant C library that has been specifically
designed for use within embedded systems.

SEGGER Embedded Studio IDE

SEGGER Embedded Studio is a streamlined integrated development environment for building, testing, and
deploying your applications. SEGGER Embedded Studio provides:

Source Code Editor:A powerful source code editor with multi-level undo and redo, makes editing your
code a breeze.

Project System:A complete project system organizes your source code and build rules.

Build System:With a single key press you can build all your applications in a solution, ready for them to be
loaded onto a target microcontroller.

Debugger and Flash Programming:You can download your programs directly into Flash and debug them
seamlessly from within the IDE using a wide range of target interfaces.

Help system:The built-in help system provides context-sensitive help and a complete reference to the
SEGGER Embedded Studio IDE and tools.

Core Simulator:As well as providing cross-compilation technology, SEGGER Embedded Studio provides
a PC-based fully functional simulation of the target microcontroller core so you can debug parts of your
application without waiting for hardware.

SEGGER Embedded Studio Tools

SEGGER Embedded Studio supplies command line tools that enable you to build your application on the
command line using the same project file that the IDE uses.

10
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What we don't tell you

This documentation does not attempt to teach the C or assembly language programming; rather, you should
seek out one of the many introductory texts available. And similarly the documentation doesn't cover the

SEGGER architecture or microcontroller application development in any great depth.

We also assume that you're fairly familiar with the operating system of the host computer being used.

C programming guides
These are must-have books for any C programmer:

Kernighan, B.W. and Ritchie, D.M., The C Programming Language (2nd edition, 1988). Prentice-Hall,
Englewood Cliffs, NJ, USA. ISBN 0-13-110362-8.

The original C bible, updated to cover the essentials of ANSI C (1990 version).

Harbison, S.P. and Steele, G.L., C: A Reference Manual (second edition, 1987). Prentice-Hall, Englewood
Cliffs, NJ, USA. ISBN 0-13-109802-0.

A nice reference guide to C, including a useful amount of information on ANSI C. Co-authored by Guy

Steele, a noted language expert.

ANSI C reference

If you're serious about C programming, you may want to have the ISO standard on hand:

ISO/IEC 9899:1990, C Standard and ISO/IEC 9899:1999, C Standard. The standard is available from your
national standards body or directly from ISO at http://www.iso.ch/.

11
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Getting Started

You will need to install a CPU support package:

Choose Tools > Package Manager

Choose the CPU support packages you wish to install and complete the dialog.

You will need to create a project:

Choose File > New Project
Select the appropriate Executable project type
Specify a location for the project

Complete the dialog selecting the appropriate Target Processor value
You will need to build the project:

Choose Build | Build 'Project’
To debug on the simulator

Choose Project | Options... to show the project options dialog
In the Search Options type in Simulator

Choose Simulator for the Target Connection option
To debug on hardware

Choose Project | Options... to show the project options dialog
In the Search Options type in J-Link
Choose J-Link for the Target Connection option

To start debugging

Choose Debug | Go

The debugger will stop the program at the main, you can now debug the application.

12
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Text conventions

Menus and user interface elements

When this document refers to any user interface element, it will do so in bold font. For instance, you will often
see reference to the Project Explorer, which is taken to mean the project explorer window. Similarly, you'll see
references to the Standard toolbar which is positioned at the top of the SEGGER Embedded Studio window, just

below the menu bar on Windows and Linux.

When you are directed to select an item from a menu in SEGGER Embedded Studio, we use the form menu-
name > item-name. For instance, File > Save means that you need to click the File menu in the menu bar and
then select the Save item. This form extends to items in sub-menus, so File > Open With Binary Editor has the

obvious meaning.

Keyboard accelerators

Frequently-used commands are assigned keyboard accelerators to speed up common tasks. SEGGER Embedded
Studio uses standard Windows and Mac OS keyboard accelerators wherever possible.

Windows and Linux have three key modifiers which are Ctrl, Alt, and Shift. For instance, Ctrl+Alt+P means that
you should hold down the Ctrl and Alt buttons whilst pressing the P key; and Shift+F5 means that you should
hold down the Shift key whilst pressing F5.

Mac OS has four key modifiers which are (command), (option), (control), and (shift). Generally there is a one-
to-one correspondence between the Windows modifiers and the Mac OS modifiers: Ctrl is , Alt is , and Shift
is . SEGGER Embedded Studio on Mac OS has its own set of unique key sequences using (control) that have no

direct Windows equivalent.

SEGGER Embedded Studio on Windows and Linux also uses key chords to expand the set of accelerators. Key
chords are key sequences composed of two or more key presses. For instance, the key chord Ctrl+T, D means
that you should type Ctrl+T followed by D; and Ctrl+K, Ctrl+Z means that you should type Ctrl+T followed by
Ctrl+Z. Mac OS does not support accelerator key chords.

Code examples and human interaction

Throughout the documentation, text printed in this typeface represents verbatim communication with the
computer: for example, pieces of C text, commands to the operating system, or responses from the computer.
In examples, text printed in this typeface is not to be used verbatim: it represents a class of items, one of which
should be used. For example, this is the format of one kind of compilation command:

hcl source-file
This means that the command consists of:

The word hdl, typed exactly like that.

A source-file: not the text source-file, but an item of the source-file class, for example myprog.c.

13
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Whenever commands to and responses from the computer are mixed in the same example, the commands
(i.e. the items which you enter) will be presentedi n t hi s t ypef ace.For example, here is a dialog with the

computer using the format of the compilation command given above:
c:\ code\ exanpl es>hcl -v nyprog.c

The user types the text hcl -v myprog.c and then presses the enter key (which is assumed and is not shown); the

computer responds with the rest.

14
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Embedded Studio

SEGGER Embedded Studio User Guide

This is the user guide for the SEGGER Embedded Studio integrated development environment (IDE). The SEGGER
Embedded Studio IDE consists of:

a project system to organize your source files

a build system to build your applications

programmer aids to navigate and work effectively

a target programmer to download applications into RAM or flash
a debugger to pinpoint bugs

15
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SEGGER Embedded Studio standard layout

SEGGER Embedded Studio's main window is divided into the following areas:

Title bar:Displays the name of the current solution.

Menu bar:Menus for editing, building, and debugging your program.

Toolbars:Frequently used actions are quickly accessible on toolbars below the menu bar.

Editing area:A tabbed view of any open editor windows and the HTML viewer.

Docked windows:SEGGER Embedded Studio has many windows that dock to the left, right, or below the
editing area. You can configure which windows will be visible, and their placement, when editing and
debugging.

Status bar At the bottom of the main window, the status bar contains useful information about the

current editor, build status, and debugging environment.

16
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Menu bar

The menu bar contains menus for editing, building, and debugging your program. You can navigate menus
using the keyboard or the mouse.

Navigating menus using the mouse

To navigate menus using the mouse:

1. Click a menu title in the menu bar to show the related menu.

2. Click the desired command in the menu to execute that command.

or

1. Click and hold the mouse on a menu title in the menu bar to show the related menu.
2. Drag the mouse to the desired command in the menu.

3. Release the mouse while it is over the command to execute that command.

Navigating menus with the keyboard

To navigate menus using the keyboard:

1. Tap the Alt key activate the menu bar.

Tap Return to display the menu.

Use the Left and Right keys to select the required menu.

Use the Up or Down key to select the required command or submenu.
Press Enter to execute the selected command.

SR T

Press Alt or Esc at any time to cancel menu selection.

After you press the Alt key once, each menu on the menu bar has one letter underlinedits shortcut key. So, to
activate a menu using the keyboard:

While holding down the Alt key, type the desired menu's shortcut key.
After the menu appears, you can navigate it using the cursor keys:

Use Up and Down to move up and down the list of menu items.
Use Esc to cancel a menu.

Use Right or Enter to open a submenu.

Use Left or Esc to close a submenu and return to the parent menu.

Type the underlined letter in a command's name to execute that command.

17



SEGGER Embedded Studio Reference Manual SEGGER Embedded Studio User Guide

Title bar

The first item shown in the title bar is SEGGER Embedded Studio's name. Because SEGGER Embedded Studio
can be used to target different processors, the name of the target processor family is also shown, to help you
distinguish between instances of SEGGER Embedded Studio when debugging multi-processor or multi-core

systems.

The filename of the active editor follows SEGGER Embedded Studio's name; you can configure the presentation
of this filename as described below.

After the filename, the title bar displays status information on SEGGER Embedded Studio's state:

[building] SEGGER Embedded Studio is building a solution, building a project, or compiling a file.
[run] An application is running under control of SEGGER Embedded Studio's debugger.
[break] The debugger is stopped at a breakpoint.

[autostep] The debugger is single stepping the application without user interaction (autostepping).

18



SEGGER Embedded Studio Reference Manual SEGGER Embedded Studio User Guide

Status bar

At the bottom of the window, the status bar contains useful information about the current editor, build status,
and debugging environment. The status bar is divided into two regions: one contains a set of fixed panels and

the other is used for messages.

The message area

The leftmost part of the status bar is a message area used for things such as status tips, progress information,

warnings, errors, and other notifications.

Status bar panels

You can show or hide the following panels on the status bar:

Panel Description

Displays the connected target interface. When
connected, this panel contains the selected target
interface's name and, if applicable, the processor to
which the target interface is connected. The LED icon
Target device status flashes green when a program is running, is solid red
when stopped at a breakpoint, and is yellow when
connected to a target but not running a program.
Double-clicking this panel displays the Targets pane,
and right-clicking it invokes the Target shortcut menu.

Cycle count panel Displays the number of processor cycles used by the
executing program. This panel is only visible if the
connected target supports performance counters
that can report the total number of cycles executed.
Double-clicking this panel resets the cycle counter to
zero, and right-clicking it brings up the Cycle Count
shortcut menu.

Insert/overwrite status Indicates whether the current editor is in insert or
overwrite mode. In overwrite mode, the panel displays
"OVR"; in insert mode, the panel displays "INS".

Read-only status Indicates whether the editor is in read-only mode. If
the editor is editing a read-only file or is in read-only
mode, the panel display "R/O"; if the editor is in read-
write mode, the panel displays "R/W".

Build status Indicates the success or failure of the last build. If
the last build completed without errors or warnings,
the build status pane contains Built OK; otherwise, it
contains the number of errors and warnings reported.
If there were errors, double-clicking this panel displays
the Build Log in the Output pane.

19
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Caret position Indicates the insertion position position in the editor
window. For text files, the caret position pane displays
the line number and column number of the insertion
point in the active window; when editing binary files, it
displays the address being edited.

Time panel Displays the current time.

Configuring the status bar panels

To configure which panels are shown on the status bar:

Choose View > Status Bar.
From the status bar menu, select the panels to display and deselect the ones you want hidden.

or
Right-click the status bar.
From the status bar menu, select the panels to display and deselect the ones you want to hide.
To show or hide the status bar:

Choose View > Status Bar.
From the status bar menu, select or deselect the Status Bar item.

You can choose to hide or display the size grip when SEGGER Embedded Studio's main window is not maximized.
(The size grip is never shown in full-screen mode or when maximized.)
To show or hide the size grip

Choose View > Status Bar.
From the status bar menu, select or deselect the Size Grip item.

20
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Editing workspace

The main area of SEGGER Embedded Studio is the editing workspace. It contains any files being edited, the on-
line help system's HTML browser, and the Dashboard.

21
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Docking windows

SEGGER Embedded Studio has a flexible docking system you can use to position windows as you like them. You
can dock windows in the SEGGER Embedded Studio window or in the four head-up display windows. SEGGER
Embedded Studio will remember the position of the windows when you leave the IDE and will restore them

when you return.

Window groups

You can organize SEGGER Embedded Studio windows into window groups. A window group has multiple
windows docked in it, only one of which is active at a time. The window group displays the active window's title

for each of the windows docked in the group.

Clicking on the window icons in the window group's header changes the active window. Hovering over a

docked window's icon in the header will display that window's title in a tooltip.

To dock a window to a different window group:

Press and hold the left mouse button over the title of the window you wish to move.

As you start dragging, all window groups, including hidden window groups, become visible.
Drag the window over the window group to dock in.

Release the mouse button.

Holding Ctrl when moving the window will prevent the window from being docked. If you do not dock a

window on a window group, the window will float in a new window group.

Perspectives

SEGGER Embedded Studio remembers the dock position and visibility of each window in each perspective. The
most common use for this is to lay your windows out in the Standard perspective, which is the perspective
used when you are editing and not debugging. When SEGGER Embedded Studio starts to debug a program,

it switches to the Debug perspective. You can now lay out your windows in this perspective and SEGGER
Embedded Studio will remember how you laid them them out. When you stop debugging, SEGGER Embedded
Studio will revert to the Standard perspective and that window layout for editing; when you return to Debug
perspective on the next debug session, the windows will be restored to how you laid them out in that for

debugging.

SEGGER Embedded Studio remembers the layout of windows, in all perspectives, such that they can be restored
when you run SEGGER Embedded Studio again. However, you may wish to revert back to the standard docking

positions; to do this:

22
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Dashboard

When SEGGER Embedded Studio starts, it presents the Dashboard, a collection of panels that provide useful

information, one-click loading of recent projects, and at-a-glance summaries of activity relevant to you.

Tasks

The Tasks panel indicates tasks you need to carry out before SEGGER Embedded Studio is fully functionalfor

instance, whether you need to activate SEGGER Embedded Studio, install packages, and so on.

Updates

The Updates panel indicates whether any packages you have installed are now out of date because a newer
version is available. You can install each new package individually by clicking the Install button under each
notification, or install all packages by clicking the Install all updates link at the bottom of the panel.

Projects

The Projects panel contains links to projects you have worked on recently. You can load a project by clicking the
appropriate link, or clear the project history by clicking the Clear List button. To manage the contents of the list,

click the Manage Projects link and edit the list of projects in the Recent Projects window.

News

The News panel summarizes the activity of any RSS and Atom feeds you have subscribed to. Clicking a link will
display the published article in an external web browser. You can manage your feed subscriptions to by clicking
the Manage Feed:s link at the end of the News panel and pinning the feeds in the Favorites windowyou are only

subscribed to the pinned feeds.

Links

The Links panel is a handy set of links to your favorite websites. If you pin a link in the Favorites window, it

appears in the Links panel.

23
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SEGGER Embedded Studio help and assistance

SEGGER Embedded Studio provides context-sensitive help in increasing detail:

Tooltips
When you position the pointer over a button and keep it still, a small window displays a brief description of

the button and its keyboard shortcut, if it has one.

Status tips
In addition to tooltips, SEGGER Embedded Studio provides a longer description in the status bar when you

hover over a button or menu item.

Online manual
SEGGER Embedded Studio has links from all windows to the online help system.

The browser

Documentation pages are shown in the Browser.

Help using SEGGER Embedded Studio

SEGGER Embedded Studio provides an extensive, HTML-based help system that is available at all times.

To view the help text for a particular window or other user-interface element:

Click to select the item with which you want assistance.
Choose Help > Help or press F1.

Help within the text editor

The text editor is linked to the help system in a special way. If you place the insertion point within a word and
press F1, the help-system page most likely to be useful is displayed in the HTML browser. This a great way to
quickly find the help text for functions provided in the library.

Browsing the documentation

The Contents window lists all the topics in the SEGGER Embedded Studio documentation and gives a way to

search through them.

The highlighted entry indicates the current help topic. When you click a topic, the corresponding page appears

in the Browser window.
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The Next Topic and Previous Topic items in the Help menu, or the buttons on the Contents window toolbar,

help navigate through topics.

To search the online documentation, type a search phrase into the Search box on the Contents window toolbar.

To search the online documentation:

Choose Help > Contents or press Ctrl+Alt+F1.
Enter your search phrase in the Search box and press Enter (or Return on Macs).

The search commences and the table of contents is replaced by links to pages matching your query, listed in

order of relevance. To clear the search and return to the table of contents, click the clear icon in the Search box.

25
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Creating and managing projects

A SEGGER Embedded Studio project is a container for everything required to build your applications. It contains
all the assorted resources and maintains the relationships between them.

A project is a convenient place to find every file and piece of information associated with your work. You place

projects into a solution, which can contain one or more projects.

This chapter introduces the various parts of a project, shows how to create projects, and describes how to
organize the contents of a project. It describes how to use the Project Explorer and Project Manager for project-
management tasks.

26
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Solutions and projects

To develop a product using SEGGER Embedded Studio, you must understand the concepts of projects and

solutions.
A project contains and organizes everything you need to create a single application or a library.
A solution is a collection of projects and configurations.

Organizing your projects into a solution allows you to build all the projects in a solution with a single keystroke,
and to load them onto the target ready for debugging.

In your SEGGER Embedded Studio project, you

organize build-system inputs for building a product.
add information about items in the project, and their relationships, to assist you in the development

process.

Projects in a solution can reside in the same or different directories. Project directories are always relative to the

directory of the solution file, which enables you to more-easily move or share project-file hierarchies.

The Project Explorer organizes your projects and files, and provides quick access to the commands that operate

on them. A toolbar at the top of the window offers quick access to commonly used commands.

Solutions

When you have created a solution, it is stored in a project file. Project files are text files, with the file extension
emProject, that contain an XML description of your project. See Project file format for a description of the

project-file format.

Projects

The projects you create within a solution have a project type SEGGER Embedded Studio uses to determine how
to build the project. The project type is selected when you use the New Project dialog. The available project
types depend on the SEGGER Embedded Studio variant you are using, but the following are present in most
SEGGER Embedded Studio variants:

Executable: a program that can be loaded and executed.

Externally Built Executable: an executable that is not built by the SEGGER Embedded Studio internal build
process.

Library: a group of object files collected into a single file (sometimes called an archive).

Externally Built Library: a library that is not built by the SEGGER Embedded Studio internal build process.

Object File: the result of a single compilation.
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Staging: a project that will apply a user-defined command to each file in a project.
Combining: a project that can be used to apply a user-defined command when any files in a project have
changed.

Project options and configurations

Project options are attached to project nodes. They are usually used in the build process, for example, to define
C preprocessor symbols. You can assign different values to the same project option, based on a configuration:
for example, you can assign one value to a C preprocessor symbol for release build and a different value for a
debug build.

Folders and Dynamic Folders

Projects can contain folders, which are used to group related files. Automated grouping uses the files' extensions
to, for example, put all .c files in one folder, etc. Grouping also can be done manually by explicitly creating a
file within a folder. Note that these project folders do not map onto directories in the file system, they are used

solely to structure the display of content shown in the Project Explorer.

Projects can also contain dynamic folders which will can show the directories and files contained in the file
system in the project explorer. You can specify if the dynamic folder is recursive and use wildcards to include and

exclude files.

Source files

Source files are all the files used to build a product. These include source code files and also section-placement
files, memory-map files, and script files. All the source files you use for a particular product, or for a suite of
related products, are managed in a SEGGER Embedded Studio project. A project can also contain files that
are not directly used by SEGGER Embedded Studio to build a product but contain information you use during
development, such as documentation. You edit source files during development using SEGGER Embedded
Studio's built-in text editor, and you organize files into a target (described next) to define the build-system

inputs for creating the product.

The source files of your project can be placed in folders or directly in the project. Ideally, the paths to files
placed in a project should be relative to the project directory, but at times you might want to refer to a file in an

absolute location and this is supported by the project system.

When you add a file to a project, the project system detects whether the file is in the project directory. If a

file is not in the project directory, the project system tries to make a relative path from the file to the project
directory. If the file isn't relative to the project directory, the project system detects whether the file is relative to
the $(StudioDir) directory; if so, the filename is defined using $(StudioDir). If a file is not relative to the project

directory or to $(StudioDir), the full, absolute pathname is used.
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The project system will allow (with a warning) duplicate files to be put into a project.
The project system uses a file's extension to determine the appropriate build action to perform on the file:

A file with the extension .c will be compiled by a C compiler.

A file with the extension .s or .asm will be compiled by an assembler.

A file with the object-file extension .hzo will be linked.

A file with the library-file extension .hza will be linked.

A file with the extension .xml will be opened and its file type determined by the XML document type.

Files with other file extensions will not be compiled or linked.

You can modify this behavior by setting a file's File Type project option with the Common configuration

selected, which enables files with non-standard extensions to be compiled by the project system.

Externally Built Executables

You can use an external build process for Externally Built Executable project types by setting the Build
Command project option, for example to make target. Alternatively you can set command lines for specific
build steps to compile/assemble and link. When you create an Externally Built Executable project type

configurations will be created that create command lines for a variety of external tool chains.

Solution links

You can create links to existing project files from a solution, which enables you to create hierarchical builds. For
example, you could have a solution that builds a library together with a stub test driver executable. You can
link to that solution from your current solution by right-clicking the solution node of the Project Explorer and
selecting Add Existing Project. Your current solution can then use the library built by the other project.

Session files

When you exit SEGGER Embedded Studio, details of your current session are stored in a session file. Session files
are text files, with the file extension emSession, that contain details such as which files you have opened in the

editor and what breakpoints you have set in the Breakpoint window.
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Creating a project
You can create a new solution for each project or place multiple projects in an existing solution.

To create a new project in an existing solution:

1. Choose Project > Add New Project.

2. Inthe New Project wizard, select the type of project you wish to create and specify where it will be
placed.

3. Ensure that Add the project to current solution is checked.

4. Click OK to go to next stage or Cancel to cancel the project's creation.

The project name must be unique to the solution and, ideally, the project directory should be relative to the
solution directory. The project system will use the project directory as the current directory when it builds your
project. Once complete, the Project Explorer displays the new solution, project, and files contained in the
project. To add another project to the solution, repeat the above steps.

To create a new project in a new solution:

1. Choose File > New Project or press Ctrl+Shift+N.

2. Select the type of project you wish to create and where it will be placed.
3. Click OK.
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Adding existing files to a project

You can add existing files to a project in a number of ways.

To add existing files to the active project:
Choose Project > Add Existing File or press Ctrl+P, A.

Using the Open File dialog, navigate to the directory containing the files and select the ones you wish to add to

the project.
Click OK.

The selected files are added to the folders whose filter matches the extension of each of the files. If no filter
matches a file's extension, the file is placed underneath the project node.
To add existing files to a specific project:

1. In the Project Explorer, right-click the project to which you wish to add a new file.

2. Choose Add Existing File.
To add existing files to a specific folder:

1. In the Project Explorer, right-click the folder to which you wish to add a new file.
2. Choose Add Existing File.

The files are added to the specified folder without using filter matching.

To create a dynamic folder:

1. In the Project Explore, right click on the project to which you wish to add a new folder.

2. Choose New Folder....

3. Using the New Folder dialog name the folder and then show the dynamic folder options.
4

. Specify the required Source Folder and the Filter Specification.

The files that match the filter specification in the source folder will appear in the newly created folder.
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Adding new files to a project

You can add new files to a project in a number of ways.

To add new files to the active project:

Choose Project > Add New File or press Ctrl+N.

To add a new file to a project:

1. In the Project Explorer, right-click the project to which you wish to add a new file.
2. Choose Add New File.

When adding a new file, SEGGER Embedded Studio displays the New File dialog, from which you can choose
the type of file to add, its filename, and where it will be stored. Once created, the new file is added to the folder
whose filter matches the extension of the newly added file. If no filter matches the newly added file extension,
the new file is placed underneath the project node.

To add new files to a folder:

1. In the Project Explorer, right-click the folder to which you wish to add a new file.
2. Choose Add New File.

The new file is added to the folder without using filter matching.
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Removing a file, folder, project, or project link

You can remove whole projects, folders, or files from a project, or you can remove a project from a solution,
using the Remove button on the Project Explorer toolbar. Note that removing a source file from a project does
not remove it from disk.

To remove an item from the solution:

1. In the Project Explorer, select the item to remove.
2. Choose Edit > Delete or press Del.

or

1. In the Project Explorer, right-click the item to remove.

2. Choose Remove.
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Building your application

SEGGER Embedded Studio builds your application using the resources and build rules it finds in your solution.

When SEGGER Embedded Studio builds your application, it tries to avoid building files that have not changed
since they were last built. It does this by comparing the modification dates of the generated files with the
modification dates of the dependent files together with the modification dates of the project options that
pertain to the build. But if you are copying files, sometimes the modification dates may not be updated when

the file is copiedin this instance, it is wise to use the Rebuild command rather than the Build command.

You can see the build rationale SEGGER Embedded Studio currently is using by setting the Environment
Options > Building > Show Build Information environment option. To see the build commands themselves, set
the Environment Options > Building > Echo Build Command environment option.

You may have a solution that contains several interdependent projects. Typically, you might have several
executable projects and some library projects. The Project Dependencies dialog specifies the dependencies
between projects and to see the effect of those dependencies on the solution build order. Note that
dependencies can be set on a per-configuration basis, but the default is for dependencies to be defined in the

Common configuration.

You will also notice that a new folder titled Dependencies has appeared in the Project Explorer. This folder
contains the list of newly generated files and the files from which they were generated. To see if one of files
can be decoded and displayed in the editor, right-click the file to see if the View command is available on the

shortcut menu.

If you have the Symbols window open, it will be updated with the symbol and section information of all
executable files built in the solution.

To generalize your builds, you can define macro values that are substituted when the project options are used.
These macro values can be defined globally at the solution and project level, and can be defined on a per-

configuration basis.

The combination of configurations, project options with inheritance, dependencies, and macros provides a
very powerful build-management system. However, such systems can become complicated. To understand the
implications of changing build settings, right-click a node in the Project Explorer and select Options to view a
dialog that shows which macros and project options apply to that project node.
To build all projects in the solution:

1. Choose Build > Build Solution or press Shift+F7.

or

1. Right-click the solution in the Project Explorer window.

2. Choose Build from the shortcut menu.
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To build a single project:

1. Select the required project in the Project Explorer.
2. Choose Build > Build or press F7.

or
1. Right-click the project in the Project Explorer.
2. Choose Build.

To compile a single file:

1. In the Project Explorer, click to select the source file to compile.

2. Choose Build > Compile or press Ctrl+F7.
or

1. In the Project Explorer, right-click the source file to compile.

2. Choose Compile from the shortcut menu.

Correcting errors after building

The results of a build are recorded in a Build Log that is displayed in the Output window. Errors are highlighted
in red, warnings are highlighted in yellow. Double-clicking an error, warning, or note will move the insertion

point to the line of source code that triggered that log entry.
You can move forward and backward through errors using Search > Next Location and Search > Next Location.

When you build a single project in a single configuration, the Transcript will display the memory used by the

application and a summary for each memory area.
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Creating variants using configurations

SEGGER Embedded Studio provides a facility to build projects in various configurations. Project configurations

are used to create different software builds for your projects.

A configuration defines a set of project options. For example, the output of a compilation can be put into
different directories, dependent upon the configuration. When you create a solution, some default project
configurations are created.

Build configurations and their uses

Configurations are typically used to differentiate debug builds from release builds. For example, the compiler
options for debug builds will differ from those of a release build: a debug build will set options so the project can
be debugged easily, whereas a release build will enable optimization to reduce program size or to increase its
speed. Configurations have other uses; for example, you can use configurations to produce variants of software,

such as custom libraries for several different hardware variants.

Configurations inherit project options from other configurations. This provides a single point of change for
definitions common to several configurations. A particular project option can be overridden in a particular

configuration to provide configuration-specific settings.

When a solution is created, two configurations are generated Debug and Release and you can create additional
configurations by choosing Build > Build Configurations. Before you build, ensure that the appropriate
configuration is set using Build > Set Active Build Configuration or, alternatively, the Active Configuration
combo box in the Project Explorer.

Selecting a configuration

To set the configuration that affects your building and debugging, use the combo box in the Project Explorer or
select Build > Set Active Build Configuration

Creating a configuration

To create your own configurations, select Build > Build Configurations to invoke the Configurations dialog. The
New button will produce a dialog allowing you to name your configuration. You can now specify the existing

configurations from which your new configuration will inherit values.

Deleting a configuration

You can delete a configuration by selecting it and clicking the Remove button. This deletion cannot be undone

or canceled, so beware.
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Private configurations

Some configurations are defined purely for inheriting and, as such, should not appear in the Build combo box.

When you select a configuration in the Configuration dialog, you can choose to hide that configuration.
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Project options

For solutions, projects, folders, and files, project options can be defined that are used by the project system in
the build process. These project options can be viewed and modified by using the Options dialog in conjunction
with the Project Explorer.

Some project options are only applicable to a given item type. For example, linker project options are only
applicable to a project that builds an executable file. However, other project options can be applied either at
the file, project, or solution project node. For example, a compiler project option can be applied to a solution,
project, or individual file. By setting a project option at the solution level, you enable all files of the solution to
use that project option's value.

Unique project options

A unique project option has one value. When a build is done, the value of a unique project option is the first one
defined in the project hierarchy. For example, the Treat Warnings As Errors project option could be set to Yes
at the solution level, which would then be applicable to every file in the solution that is compiled, assembled,
and linked. You can then selectively define project options for other project items. For example, a particular
source file may have warnings you decide are allowable, so you set the Treat Warnings As Errors to No for that
particular file.

solution Treat Warnings As Errors = Yes
projectl Treat Warnings As Errors = Yes
filel Treat Warnings As Errors Yes
file2 Treat Warnings As Errors No
project2 Treat Warnings As Errors = No
filel Treat Warnings As Errors No
file2 Treat Warnings As Errors Yes

In the above example, the files will be compiled with these values for Treat Warnings As Errors:

project1/file1 Yes
project1/file2 No
project2/file1 No
project2/file2 Yes

Aggregate project options

An aggregating project option collects all the values defined for it in the project hierarchy. For example, when a
Cfile is compiled, the Preprocessor Definitions project option will take all the values defined at the file, project,
and solution levels.

solution Preprocessor Definitions = Sol utionDef

38



SEGGER Embedded Studio Reference Manual SEGGER Embedded Studio User Guide

projectl Preprocessor Definitions =
filel Preprocessor Definitions
file2 Preprocessor Definitions Fi | e1lDef

project2 Preprocessor Definitions = Project Def
filel Preprocessor Definitions
file2 Preprocessor Definitions

Fi | e2Def

In the above example, the files will be compiled with these preprocessor definitions:

project1/filel SolutionDef

project1/file2 SolutionDef, File1Def
project2/file1 SolutionDef, ProjectDef
project2/file2 SolutionDef, ProjectDef, File2Def
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Configurations and project options

Project options are defined for a configuration so you can have different values for a project option for
different builds. A given configuration can inherit the project options of other configurations. When the project
system requires a project option value, it checks for the existence of the project option value in the current
configuration and then in the set of inherited configurations. You can specify the set of inherited configurations

using the Configurations dialog.

A special configuration named Common is always inherited by a configuration. The Common configuration
allows you to set project options that will apply to all configurations you create. If you are modifying a project
option of your project, you almost certainly want each configuration to inherit it, so ensure that the Common

configuration is selected.

If the project option is unique, the build system will use the one defined for the particular configuration. If
the project option isn't defined for this configuration, the build system uses an arbitrary one from the set of

inherited configurations.

If the option is still undefined, the build system uses the value for the Common configuration. If it is still
undefined, the build system tries to find the value in the next higher level of the project hierarchy.
sol ution [Common] Preprocessor Definitions = ConmbnSol uti onDef
sol ution [Debug] Preprocessor Definitions = DebugSol uti onDef
solution [Rel ease] Preprocessor Definitions = Rel easeSol uti onDef
projectl - Preprocessor Definitions =
filel - Preprocessor Definitions =
file2 [Commobn] Preprocessor Definitions = CommonFil elDef
file2 [Debug] Preprocessor Definitions = DebugFil elDef
project2 [Conmon] Preprocessor Definitions = ProjectDef
filel Preprocessor Definitions =
file2 [Common] - Preprocessor Definitions = Fil e2Def

In the above example, the files will be compiled with these preprocessor definitions when in Debug

configuration

File Setting
project1/filel CommonSolutionDef, DebugSolutionDef
project1/file2 CommonSolutionDef,

DebugSolutionDef,CommonFile1Def, DebugFile1Def

project2/filel CommonSolutionDef, DebugSolutionDef, ProjectDef

40



SEGGER Embedded Studio Reference Manual SEGGER Embedded Studio User Guide

project2/file2 ComonSolutionDef, DebugSolutionDef, ProjectDef,
File2Def

and the files will be compiled with these Preprocessor Definitions when in Release configuration:

File Setting
project1/filel CommonSolutionDef, ReleaseSolutionDef
project1/file2 CommonSolutionDef, ReleaseSolutionDef,

CommonfFile1Def

project2/file1 CommonSolutionDef, ReleaseSolutionDef, ProjectDef
project2/file2 ComonSolutionDef, ReleaseSolutionDef, ProjectDef,
File2Def
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Project macros

You can use macros to modify the way the project system refers to files.
Macros are divided into four classes:

System macros defined by SEGGER Embedded Studio relay information about the environment, such as
paths to common directories.

Global macros are saved in the environment and are shared across all solutions and projects. Typically,
you would set up paths to libraries and any external items here.

Project macros are saved as project options in the project file and can define values specific to the solution
or project in which they are defined.

Build macros are generated by the project system when you build your project.

System macros

System macros are defined by SEGGER Embedded Studio itself and as such are read-only. System macros can be
used in project options, environment settings and to refer to files. See System macros list for the list of System
macros.

Global macros

Global macros are store in the environment option Build Macros.

To define a global macro:

1. Use Tools > Options to show the environment options dialog.

2. In the Environment Options dialog's Building group, select the Build Macros option.
3. Click the ellipsis button on the right.

4, Set the macro using the syntax name = replacement text.

Project macros

To define a project macro:
To set the project macros:

Select the appropriate solution/project in the Project Explorer.

Use Project > Options to show the project options dialog.

In the Project Options dialog's General Options group, select the Macros option.
Click the ellipsis button on the right.

vk W=

Set the macro using the syntax name = replacement text.
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Build macros

Build macros are defined by the project system for a build of a given project node. See Build macros list for the

list of build macros.

Using macros

You can use a macro for a project option or environment setting by using the $(macro) syntax. For example, the
Object File Name option has a default value of $( I nt Di r) / $( | nput Nane) $( OBJ).

You can also specify a default value for a macro if it is undefined using the $(macro:default) syntax. For example,
$(MyMacr 0: 0) would expand to 0 if the macro MyMacr o has not been defined.
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Dependencies and build order

You can set up dependency relationships between projects using the Project Dependencies dialog. Project
dependencies make it possible to build solutions in the correct order and, where the target permits, to load
and delete applications and libraries in the correct order. A typical usage of project dependencies is to make
an executable project dependent upon a library executable. When you elect to build the executable, the build
system will ensure that the library it depends upon is up to date. In the case of a dependent library, the output

file of the library build is supplied as an input to the executable build, so you don't have to worry about it.

Project dependencies are stored as project options and, as such, can be defined differently based upon the
selected configuration. You almost always want project dependencies to be independent of the configuration,

so the Project Dependencies dialog selects the Common configuration by default.

To make one project dependent upon another:

1. Choose Project > Project Dependencies.

2. From the Project dropdown, select the target project that depends upon other projects.

3. In the Depends Upon list box, select the projects the target project depends upon and deselect the
projects it does not depend upon.

Some items in the Depends Upon list box may be dimmed, indicating that a circular dependency would result
if any of those projects were selected. In this way, SEGGER Embedded Studio prevents you from constructing
circular dependencies using the Project Dependencies dialog.

If your target supports loading multiple projects, the Build Order also reflects the order in which projects are
loaded onto the target. Projects will load, in order, from top to bottom. Generally, libraries need to be loaded
before the applications that use them, and you can ensure this happens by making the application dependent

upon the library. With this dependency set, the library gets built and loaded before the application does.

Applications are deleted from a target in reverse of their build order; in this way, applications are removed

before the libraries on which they depend.
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Precompile Header File support

You can specify a single file in your project to be a precompiled header by setting the project option
Precompiled Header File on the file node of the project. The file should be project local i.e. in the same directory
as the project file and should include the header files that you wish to be compiled.

You must set the project level option Enable Precompiled Header File which supplies the output file generated
by the precompiled header file to the compilation of each file in the project.
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Linking and section placement

Executable programs consist of a number of sections. Typically, there are program sections for code, initialized
data, and zeroed data. There is often more than one code section and they must be placed at specific addresses

in memory.

To describe how the program sections of your program are positioned in memory, the SEGGER Embedded
Studio project system uses memory-map files and section-placement files. These XML-formatted files are
described in Memory Map file format and Section Placement file format. They can be edited with the SEGGER
Embedded Studio text editor. The memory-map file specifies the start address and size of target memory
segments. The section-placement file specifies where to place program sections in the target's memory
segments. Separating the memory map from the section-placement scheme enables a single hardware
description to be shared across projects and also enables a project to be built for a variety of hardware

descriptions.

For example, a memory-map file representing a device with two memory segments called FLASH and SRAM

could look something like this in the memory-map editor.

< nane="Devi cel" >
< nane="FLASH' start="0x10000000" si ze="0x10000" />
< nanme="SRAM' st art="0x20000000" si ze="0x1000" />

A corresponding section-placement file will refer to the memory segments of the memory-map file and will
list the sections to be placed in those segments. This is done by using a memory-segment name in the section-
placement file that matches the corresponding memory-segment name in the memory-map file.

For example, a section-placement file that places a section called .stack in the SRAM segment and the .vectors

and .text sections in the FLASH segment would look like this:

< nane="Fl ash Section Pl acenent">
< nanme="FLASH' >
< nane=".vectors" | oad="Yes" />
< name=".text" | oad="Yes" />
</ >
< nanme="SRAM' >
< nane=".stack" | oad="No" />
</ >
</ >

Note that the order of section placement within a segment is top down; in this example .vectors is placed at

lower addresses than .text.

The memory-map file and section-placement file to use for linkage can be included as a part of the project or,

alternatively, they can be specified in the project's linker options.

You can create a new program section using either the assembler or the compiler. For the C compiler, this can be

achieved using one of the #pragma directives. For example:

#pragna codeseg(".foo")
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voi d foobar (void);
#pragnma codeseq(defaul t)

This will allocate foobar in the section called .foo. Alternatively, you can specify the names for the code,

constant, data, and zeroed-data sections of an entire compilation unit by using the Section Options options.

You can now place the section into the section placement file using the editor so that it will be located after the

vectors sections as follows:

< nane="Fl ash Section Pl acenent">
< name="FLASH" >
< name=".vectors" |oad="Yes" />
< name=".foo0" | oad="Yes" />
< nane=".text" | oad="Yes" />
</ >
< name=" SRAM' >
< name=".stack" | oad="No" />
</ >
</ >

If you are modifying a section-placement file that is supplied in the SEGGER Embedded Studio distribution, you

will need to import it into your project using the Project Explorer.

Sections containing code and constant data should have their load project option set to Yes. Some sections
don't require any loading, such as stack sections and zeroed-data sections; such sections should have their load

project option set to No.

You can specify that initialization data is stored in the default program section using the | NI T directive, and you
can refer to the start and end of the section using the SFE and SFB directives. If, for example, you create a new

data section called | DATA2, you can store this in the program by putting the following into the startup code:

_data2_init_begin::
INIT "1 DATA2"
_data2_init_end::

You can then use these symbols to copy the stored section information into the data section using (an assembly-

coded version of):

/* Section image |located in flash */
extern const unsigned char data2_init_begin[];
extern const unsigned char data2_init_end[];

mencpy( SFB( | DATA2), data2_init_begin, data2_init_end-data2_init_end)
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Using source control

Source control is an essential tool for individuals or development teams. SEGGER Embedded Studio integrates
with several popular source-control systems to provide this feature for files in your SEGGER Embedded Studio
projects.

Source-control capability is implemented by a number of third-party providers, but the set of functions provided
by SEGGER Embedded Studio aims to be provider independent.
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Source control capabilities

The source-control integration capability provides:

Connecting to the source-control repository and mapping files in the SEGGER Embedded Studio project to
those in source control.

Showing the source-control status of files in the project.

Adding files in the project to source control.

Fetching files in the project from source control.

Optionally locking and unlocking files in the project for editing.

Comparing a file in the project with the latest version in source control.

Updating a file in the project by merging changes from the latest version in source control.

Committing changes made to project files into source control.
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Configuring source-control providers

SEGGER Embedded Studio supports Subversion, Git, and Mercurial as source-control systems. To enable
SEGGER Embedded Studio to utilize source-control features, you need to install, on your operating system, the

appropriate command line client for the source-control systems that you will use.

Once you have installed the command line client, you must configure SEGGER Embedded Studio to use it.

To configure Subversion:

1. Choose Tools > Options or press Alt+,.

2. Select the Source Control category in the options dialog.

3. Set the Executable environment option of the Subversion Options group to point to Subversion svn
command. On Windows operating systems, the Subversion command is svn. exe.

To configure Git:

1. Choose Tools > Options or press Alt+,.
2. Select the Source Control category in the options dialog.
3. Set the Executable environment option of the Git Options group to point to Git gi t command. On

Windows operating systems, the Git commandisgi t . exe.

To configure Mercurial:

1. Choose Tools > Options or press Alt+,.
2. Select the Source Control category in the options dialog.
3. Set the Executable environment option of the Mercurial Options group to point to Git hg command. On

Windows operating systems, the Git command is hg. exe.
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Connecting to the source-control system

When SEGGER Embedded Studio loads a project, it examines the file system folder that contains the project to
determine the source-control system the project uses. If SEGGER Embedded Studio cannot determine, from the

file system, the source-control system in use, it disables source-control integration.

That s, if you have not set up the paths to the source-control command line clients, even if a working copy exists
and the appropriate command line client is installed, SEGGER Embedded Studio cannot establish source-control

integration for the project.

User credentials

You can set the credentials that the source-control system uses, for commands that require credentials, using
VCS > Options > Configure. From here you can set the user name and password. These details are saved to the
session file (the password is encrypted) so you won't need to specify this information each time the project is
loaded.

Note

SEGGER Embedded Studio has no facility to create repositories from scratch, nor to clone, pull, or checkout
repositories to a working copy: it is your responsibility to create a working copy outside of SEGGER Embedded

Studio using your selected command-line client or Windows Explorer extension.

The "Tortoise" products are a popular set of tools to provide source-control facilities in the Windows shell. Use

Google to find TortoiseSVN, TortoiseGit, and TortoiseHG and see if you like them.

51



SEGGER Embedded Studio Reference Manual SEGGER Embedded Studio User Guide

File source-control status

Determining the source-control status of a file can be expensive for large repositories, so SEGGER Embedded

Studio updates the source-control status in the background. Priority is given to items that are displayed.
A file will be in one of the following states:

Clean:The file is in source control and matches the tip revision.

Not Controlled:The file is not in source control.

Conflicted:The file is in conflict with changes made to the repository.

Locked:The file is locked.

Update Available:The file is older than the most-recent version in source control.
Added:The file is scheduled to be added to the repository.

Removed:The file is scheduled to be removed from the repository.

If the file has been modified, its status is displayed in red in the Project Explorer. Note that if a file is not under

the local root, it will not have a source-control status.

You can reset any stored source-control file status by choosing VCS > Refresh.
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Source-control operations

Source-control operations can be performed on single files or recursively on multiple files in the Project
Explorer hierarchy. Single-file operations are available on the Source Control toolbar and on the text editor's
shortcut menu. All operations are available using the VCS menu. The operations are described in terms of the
Project Explorer shortcut menu.
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Adding files to source control

To add files to the source-control system:

1. In the Project Explorer, select the file to add. If you select a folder, project, or solution, any eligible child
items will also be added to source control.

choose Source Control > Add or press Ctrl+R, A.

The dialog will list the files that can be added.

In that dialog, you can deselect any files you don't want to add to source control.

Click Add.

vk N

Note

Files are scheduled to be added to source control and will only be committed to source control (and seen by

others) when you commit the file.

Enabling the VCS > Options > Add Immediately option will bypass the dialog and immediately add (but not

commit) the files.
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Updating files

To update files from source control:

1. In the Project Explorer, select the file to update. If you select a folder, project, or solution, any eligible
child items will also be updated from source control.

choose Source Control > Update or press Ctrl+R, U.

The dialog will list the files that can be updated.

In that dialog, you can deselect any files you don't want to update from source control.

Click Update.

vk N

Note

Enabling the VCS > Options > Update Immediately option will bypass the dialog and immediately update the

files.
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Committing files

To commit files:

1. In the Project Explorer, select the file to commit. If you select a folder, project, or solution, any eligible
child items will also be committed.

Choose Source Control > Commit or press Ctrl+R, C.

The dialog will list the files that can be committed.

In that dialog, you can deselect any files you don't want to commit and enter an optional comment.
Click Commit.

vk N

Note

Enabling the VCS > Options > Commit Immediately option will bypass the dialog and immediately commit the

files without a comment.
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Reverting files

To revert files:

1. In the Project Explorer, select the file to revert. If you select a folder, project, or solution, any eligible child
items will also be reverted.

Choose Source Control > Revert or press Ctrl+R, V.

The dialog will list the files that can be reverted.

In that dialog, you can deselect any files you don't want to revert.

Click Revert.

vk N

Note

Enabling the VCS > Options > Revert Imnmediately option will bypass the dialog and immediately revert files.
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Locking files

To lock files:

1. In the Project Explorer, select the file to lock. If you select a folder, project, or solution, any eligible child
items will also be locked.

Choose Source Control > Lock or press Ctrl+R, L.

The dialog will list the files that can be locked.

In that dialog, you can deselect any files you don't want to lock and enter an optional comment.

Click Lock.

vk N

Note

Enabling the VCS > Options > Lock Immediately option will bypass the dialog and immediately lock files

without a comment.
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Unlocking files

To unlock files:

1. In the Project Explorer, select the file to lock. If you select a folder, project, or solution, any eligible child
items will also be unlocked.

Choose Source Control > Unlock or press Ctrl+R, N.

The dialog will list the files that can be unlocked.

In that dialog, you can deselect any files you don't want to unlock.

Click Unlock.

vk N

Note

Enabling the VCS > Options > Unlock Immediately option will bypass the dialog and immediately unlock files.
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Removing files from source control

To remove files from source control:

1. In the Project Explorer, select the file to remove. If you select a folder, project, or solution, any eligible
child items will also be removed.

choose Source Control > Remove or press Ctrl+R, R.

The dialog will list the files that can be removed.

In that dialog, you can deselect any files you don't want to remove.

vk N

Click Remove.

Note

Files are scheduled to be removed from source control and will still be and seen by others, giving you the

opportunity to revert the removal. When you commit the file, the file is removed from source control.

Enabling the VCS > Options > Remove Immediately option will bypass the dialog and immediately remove (but

not commit) files.
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Showing differences between files

To show the differences between the file in the project and the version checked into source control, do the

following:

1. In the Project Explorer, right-click the file.
2. From the shortcut menu, choose Source Control > Show Differences.

You can use an external diff tool in preference to the built-in SEGGER Embedded Studio diff tool. To define
the diff command line SEGGER Embedded Studio generates, choose Tools > Options > Source Control > Diff
Command Line. The command line is defined as a list of strings to avoid problems with spaces in arguments.

The diff command line can contain the following macros:

S(localfile):The filename of the file in the project.
S(remotefile):The filename of the latest version of the file in source control.
S(localname):A display name for $(localfile).

S(remotename):A display name for $(remotefile).
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Source-control properties

When a file in the project is in source control, the Properties window shows the following properties in the
Source Control Options group:

Property Description

The source-control status of working copy as viewed

SEGGER Embedded Studio Status by SEGGER Embedded Studio,

last Author The author of the file's head revision.

Path: Relative The item's path relative to the repository root.

Path: Repository The pathname of the file in the source-control system,
typically a URL.

Path: Working Copy The pathname of the file in the working copy.

Provider The name of the source-control system managing this
file.

Provider Status The status of the file as reported by the source-control
provider.

Revision: Local The revision number/name of the local file.

Revision: Remote The revision number/name of the most-recent version

in source control.

Status: In Conflict? If Yes, updates merged into the file using Update
conflict with the changes you made locally; if No,
the file is not locked. When conflicted, must resolve
the conflicts and mark them Resol ved before
committing the file.

Status: Locked? If Yes, the file is lock by you; if No, the file is not locked.

Status: Modified? If Yes, the checked-out file differs from the version in
the source control system; if No, they are identical.

Status: Update Available? If Yes, the file in the project location is an old version
compared to the latest version in the source-control
systemuse Update to merge in the latest changes.
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Subversion provider

The Subversion source-control provider has been tested with SVN 1.4.3.

Provider-specific options

The following environment options are supported:

Property Description
Executable The path to the svn executable.
Lock Supported If Yes, check out and undo check out operations

are supported. Check out will issue the svn | ock
command; check in and undo check out will issue the
svn unl ock command.

Authentication Selects whether authentication (user name and
password) is sent with every command.

Show Updates Selects whether the update (- u flag) is sent with
status requests in order to show that new versions are
available in the repository. Note that this requires a
live connection to the repository: if you are working
without a network connection to your repository, you
can disable this switch and continue to enjoy source
control status information in the Project Explorer and
Pending Changes windows.

Connecting to the source-control system

When connecting to source control, the provider checks if the local root is in SVN control. If this is the case, the
local and remote root will be set accordingly. If the local root is not in SVN control after you have set the remote
root,asvn checkout - Ncommand will beissued to make the local root SVN controlled. This command will

also copy any files in the remote root to the local root.

The user name and password you enter will be supplied with each svn command the provider issues.

Source control operations

The SEGGER Embedded Studio source-control operations are implemented using Subversion commands.
Mapping SEGGER Embedded Studio source-control operations to Subversion source-control operations is

straightforward:

Operation Command
Commit svn conmi t for the file, with optional comment.
Update svn updat e for each file.
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Revert
Resolved
Lock
Unlock
Add
Remove

Source Control Explorer

svn

svn

svn

svn

svn

svn

svn
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revert foreach file.

r esol ved for each file.

| ock for each file, with optional comment.
unl ock for each file.

add for each file.

r enove for each file.

| i st with aremote root.svn mnkdi r to create

directories in the repository.
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CVS provider

The CVS source-control provider has been tested with CYSNT 2.5.03. The CVS source-control provider uses the
CVSr | s command to browse the repositorythis command is implemented in CVS 1.12 but usage of . as the root

of the module name is not supported.

Provider-specific options

The following environment options are supported:

Property Description
CVSROOT The CVSROOT value to access the repository.
Edit/Unedit Supported If Yes, Check Out and Undo Check Out commands

are supported. Any check-out operation will issue the
cvs edit command; any check-in or undo-check-
out operation will issue the cvs unedi t command;
the status operation will issue the cvs ss command.

Executable The path to the cvs executable.

Login/Logout Required If Yes, Connect will issue the cvs | ogi n command.

Connecting to the source-control system

When connecting to source control, the provider checks if the local root is in CVS control. If this is the case, the
local and remote root will be set accordingly. If the local root is not in CVS control after you have set the remote
root,acvs checkout -1 -dcommand will beissued to make the local root CVS controlled. This command

will also copy any files in the remote root to the local root.

Source-control operations

The SEGGER Embedded Studio source-control operations have been implemented using CVS commands. There

are no multiple-file operations, each operation is done on a single file and committed as part of the operation.

Operation Command

cvs st at us and optionalcvs edi t or s for local
Get Status directories in CVS control.cvs rl s - e for directories
in the repository.

Add To Source Control cvs add for each directory not in CVS control.
cvs add for the file.cvs commi t for the file and
directories.

Get Latest cvs update -I -d foreach directory notin CVS

control.cvs updat e to merge the local file. cvs
updat e - Cto overwrite the local file.
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Check Out

Undo Check Out

Check In

Source Control Explorer
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Optional cvs updat e - Cto get the latest version.
cvs edit tolockthefile.

cvs unedit to unlock the file. Optional cvs
updat e to get the latest version.

cvs comm t forthefile.

cvs rls - e witharemote root starting with .. cvs
i mport to create directories in the repository.
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Package management

Additional target-support functions can be added to, and removed from, SEGGER Embedded Studio with

packages.

A SEGGER Embedded Studio package is an archive file containing a collection of target-support files. Installing
a package involves copying the files it contains to an appropriate destination directory and registering the
package with SEGGER Embedded Studio's package system. Keeping target-support files separate from the
main SEGGER Embedded Studio installation allows us to support new hardware and issue bug fixes for existing
hardware-support files between SEGGER Embedded Studio releases, and it allows third parties to develop their

own support packages.

Installing packages

Use the Package Manager to automate the download, installation, upgrade and removal of packages.

To activate the Package Manager:
Choose Tools > Manage Packages.

In some situations, such as using SEGGER Embedded Studio on a computer without Internet access or when you
want to install packages that are not on the website, you cannot use the Package Manager to install packages
and it will be necessary to manually install them.

To manually install a package:

1. Choose Tools > Manually Install Packages.
2. Select one or more package files you want to install.
3. Click Open to install the packages.

Choose Tools > Show Installed Packages to see more information on the installed packages.

The Package Manager window will remove manually installed packages.

The package manager

The Package Manager manages the support packages installed on your system. It lists the available packages,
shows the installed packages, and allows you to install, update, reinstall, and remove them.
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. 3
¥ Package Manager @Iéj
Select Packages
Search Packages -
Title Type Status Action -
Analog Devices ADUCTO00 CPU Support Package CPU Support Package Mot Installed Mo Action
Analog Devices ADuCT020 Eval Board Support Package Board Support Package Mot Installed Mo Adion  |=
Analog Devices ADuCT7024 Eval Board Support Package Board Support Package Mot Installed Mo Action
Analog Devices ADUCT026 Eval Board Support Package Board Support Package Mot Installed Mo Action
Analog Devices ADUCT128 Eval Board Support Package Board Support Package Mot Installed Mo Action
Anglia Calumbus STRY1x USE Evaluation Board Support Package Board Support Package Mot Installed Mo Action
ARM Evaluator-7T Board Support Package Board Support Package | Installed Mo Action
Atmel ATO1SAMT CPU Support Package CPU Support Package Update Available  Update
Atmel ATOLSAMTAZ-EK Board Support Package Board Support Package Mot Installed Install
Atmel AT915AMYTL-5TK Board Support Package Board Support Package Mot Installed Mo Action
Atmel AT91SAM7TSE-EK Board Support Package Board Support Package Mot Installed Mo Action
Atmel AT915AM7S-EK Board Support Package Board Support Package Mot Installed Mo Action
Atmel AT9LSAMTX-EK Board Support Package Board Support Package Mot Installed Mo Action
Atmel ATO15AMO260-EK Board Support Package Board Support Package  Installed Mo Action
Atmel AT915AM9261-EK Board Support Package Board Support Package Mot Installed Mo Action
Atmel AT915AMO263-EK Board Support Package Board Support Package | Installed Mo Action
Atmel EBO1 Board Support Package Board Support Package Mot Installed No Adtion
Atmal FRAAA Raard Sonnnart Darkana Rnard Soonnnart Darkana Mlnt Trctallad Mo Artinn
Package Information -
Description This package contains project templates and system files for the Atmel AT915AM7,
Installed Version 17
Latest Version 15
Package Version History
13

Added support for AT91SAMTLES and ATI1SAMTLIIE,
Loaders now set the boot from internal FLASH NVM bit by default.
17 -

Mext l [ Cancel

To activate the Package Manager:

Choose Tools > Manage Packages.

Filtering the package list

By default, the Package Manager lists all available and installed packages. You can filter the displayed packages
in a number of ways.
To filter by package status:

Click on the disclosure icon near the top-right corner of the dialog.

Use the pop-up menu to choose how to filter the list of packages.
The list-filter choices are:

Display All Show all packages irrespective of their status.

Display Not Installed Show packages that are available but are not currently installed.
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Display Installed Only show packages that are installed.
Display Updates Only show packages that are installed but are not up-to-date because a newer version is
available.

You can also filter the list of packages by the text in the package's title and documentation.

To filter packages by keyword:

Type the keyword into the Search Packages box at the top-left corner of the dialog.

Installing a package

The package-installation operation downloads a package to $(PackagesDir)/downloads, if it has not been

downloaded already, and unpacks the files contained within the package to their destination directory.

To install a package:

Choose Tools > Package Manager and set the status filter to Display Not Installed.

Select the package or packages you wish to install.

Right-click the selected packages and choose Install Selected Packages from the shortcut menu.
Click Next; you will be see the actions the Package Manager is about to carry out.

Click Next and the Package Manager will install the selected packages.

IS L T o

When installation is complete, click Finish to close the Package Manager.

Updating a package

The package-update operation first removes existing package files, then it downloads the updated package to
$(PackagesDir)/downloads and unpacks the files contained within the package to their destination directory.

To update a package:

Choose Tools > Package Manager and set the status filter to Display Updates.

Select the package or packages you wish to update.

Right-click the selected packages and choose Update Selected Packages from the shortcut menu.
Click Next; you will see the actions the Package Manager is about to carry out.

Click Next and the Package Manager will update the package(s).

AL O o e

When the update is complete, click Finish to close the Package Manager.

Removing a package

The package-remove operation removes all the files that were extracted when the package was installed.

69



SEGGER Embedded Studio Reference Manual SEGGER Embedded Studio User Guide

To remove a package:

IS e

Choose Tools > Package Manager and set the status filter to Display Installed.

Select the package or packages you wish to remove.

Right-click the selected packages and choose Remove Selected Packages from the shortcut menu.
Click Next; you will see the actions the Package Manager is about to carry out.

Click Next and the Package Manager will remove the package(s).

When the operation is complete, click Finish to close the Package Manager.

Reinstalling a package

The package-reinstall operation carries out a package-remove operation followed by a package-install

operation.

To reinstall a package:

1.

S T

Choose Tools > Package Manager and set the status filter to Display Installed.

Select the package or packages you wish to reinstall.

Right-click the packages to reinstall and choose Reinstall Selected Packages from the shortcut menu.
Click Next; you will see the actions the Package Manager is about to carry out.

Click Next and the Package Manager will reinstall the packages.

When the operation is complete, click Finish to close the Package Manager.
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Exploring your application

In this section, we discuss the SEGGER Embedded Studio tools that help you examine how your application is
built.
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Project explorer

The Project Explorer is the user interface of the SEGGER Embedded Studio project system. It organizes your
projects and files and provides access to the commands that operate on them. A toolbar at the top of the
window offers quick access to commonly used commands for the selected project node or the active project.
Right-click to reveal a shortcut menu with a larger set of commands that will work on the selected project node,

ignoring the active project.

The selected project node determines what operations you can perform. For example, the Compile operation
will compile a single file if a file project node is selected; if a folder project node is selected, each of the files in

the folder are compiled.

You can select project nodes by clicking them in the Project Explorer. Additionally, as you switch between files

in the editor, the selection in the Project Explorer changes to highlight the file you're editing.

To activate the Project Explorer:

Choose View > Project Explorer or press Ctrl+Alt+P.

Left-click operations
The following operations are available in the Project Explorer with a left-click of the mouse:

Action Description

Select the node. If the node is already selected and

Single click is a solution, project, or folder node, a rename editor
appears.
Double click Double-clicking a solution node or folder node will

reveal or hide the node's children. Double-clicking a
project node selects it as the active project. Double-
clicking a file opens the file with the default editor for
that file's type.

Toolbar commands

The following buttons are on the toolbar:

Button Description

_:iinl Add a new file to the active project using the New File
— dialog.

@ Add existing files to the active project.
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Shortcut menu commands
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Remove files, folders, projects, and links from the
project.

Create a new folder in the active project.
Menu of build operations.
Disassemble the active project.

Menu of Project Explorer options.

Display the properties dialog for the selected item.

The shortcut menu, displayed by right-clicking, contains the commands listed below.

For solutions:
Item
Build and Batch Build

Rebuild and Batch Rebuild

Clean and Batch Clean

Export Build and Batch Export Build

Add New Project
Add Existing Project
Paste

Remove

Rename

Source Control Operations

Edit Solution As Text

Save Solution As

Properties

Description

Build all projects under the solution in the current or
batch build configuration.

Rebuild all projects under the solution in the current or
batch build configuration.

Remove all output and intermediate build files for the
projects under the solution in the current or batch
build configuration.

Create an editor with the build commands for the
projects under the solution in the current or batch
build configuration.

Add a new project to the solution.

Create a link from an existing solution to this solution.
Paste a copied project into the solution.

Remove the link to another solution from the solution.
Rename the solution node.

Source-control operations on the project file and
recursive operations on all files in the solution.

Create an editor containing the project file.

Change the filename of the project filenote that the
saved project file is not reloaded.

Show the Properties dialog with the solution node
selected.
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For projects:
Item
Build and Batch Build

Rebuild and Batch Rebuild
Clean and Batch Clean
Export Build and Batch Export Build

Link

Set As Active Project
Debugging Commands

Memory-Map Commands

Section-Placement Commands

Target Processor

Add New File
Add Existing File
New Folder

Cut

Copy

Paste

Remove

Rename

SEGGER Embedded Studio User Guide

Description

Build the project in the current or batch build
configuration.

Reuild the project in the current or batch build
configuration.

Remove all output and intermediate build files for the
project in the current or batch build configuration.

Create an editor with the build commands for the
project in the current or batch build configuration.

Perform the project node build operation: link for an
Executable project type, archive for a Library project
type, and the combine command for a Combining
project type.

Set the project to be the active project.

For Executable and Externally Built Executable project
types, the following debugging operations are
available on the project node: Start Debugging, Step
Into Debugging, Reset And Debug, Start Without
Debugging, Attach Debugger, and Verify.

For Executable project types that don't have memory-
map files in the project and have the memory-map file
project option set, there are commands to view the
memory-map file and to import it into the project.

For Executable project types that don't have section-
placement files in the project but have the section-
placement file project option set, there are commands
to view the section-placement file and to import it into
the project.

For Executable and Externally Built Executable project
types that have a Target Processor option group, the
selected target can be changed.

Add a new file to the project.

Add an existing file to the project.

Create a new folder in the project.

Cut the project from the solution.

Copy the project from the solution.

Paste a copied folder or file into the project.
Remove the project from the solution.

Rename the project.
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Source Control Operations

Find in Project Files

Properties

For folders:

Item

Add New File
Add Existing File
New Folder

Cut

Copy

Paste

Remove
Rename

Source Control Operations
Compile

Properties

For files:

Item
Open
Open With

Select in File Explorer

Compile

Export Build

Exclude From Build

Disassemble

Preprocess

SEGGER Embedded Studio User Guide

Source-control, recursive operations on all files in the
project.

Run Find in Files in the project directory.

Show the Project Manager dialog and select the
project node.

Description

Add a new file to the folder.

Add an existing file to the folder.

Create a new folder in the folder.

Cut the folder from the project or folder.
Copy the folder from the project or folder.
Paste a copied folder or file into the folder.
Remove the folder from the project or folder.
Rename the folder.

Source-control recursive operations on all files in the
folder.

Compile each file in the folder.

Show the properties dialog with the folder node
selected.

Description
Edit the file with the default editor for the file's type.

Edit the file with a selected editor. You can choose
from the Binary Editor, Text Editor, and Web Browser.

Create a operating system file system window with the
file selected.

Compile the file.

Create an editor window containing the commands to
compile the file in the active build configuration.

Set the Exclude From Build option to Yes for this
project node in the active build configuration.

Disassemble the output file of the compile into an
editor window.

Run the C preprocessor on the file and show the
output in an editor window.
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Cut Cut the file from the project or folder.

Copy Copy the file from the project or folder.

Remove Remove the file from the project or folder.

Import Import the file into the project.

Source Control Operations Source-control operations on the file.

Properties Show the properties dialog with the file node selected.
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Source navigator window

One of the best ways to find your way around your source code is using the Source Navigator. It parses the
active project's source code and organizes classes, functions, and variables in various ways.
To activate the Source Navigator:

Choose View > Source Navigator or press Ctrl+Alt+N.

The main part of the Source Navigator window provides an overview of your application's functions, classes,
and variables.

SEGGER Embedded Studio displays these icons to the left of each object:

Icon Description
{} A Cor C++ structure or a C++ namespace.
L+ 2N A C++ class.
£

A C++ member function declared pri vat e ora
function declared with st at i ¢ linkage.

e

‘E" A C++ member function declared pr ot ect ed.
& A C++ member function declared publ i c ora
function declared with ext er n linkage.
% A C++ member variable declared pri vat e ora
variable declared with st at i c linkage.
‘E’@ A C++ member variable declared pr ot ect ed.
++ member variable declared publ i ¢ or a variable
@ AC b iable declared publ i iabl

declared with ext er n linkage.

Re-parsing after editing

The Source Navigator does not update automatically, only when you ask it to. To parse source files manually,
click the Refresh button on the Source Navigator toolbar.

SEGGER Embedded Studio re-parses all files in the active project, and any dependent project, and updates the
Source Navigator with the changes. Parsing progress is shown as a progress bar in the in the Source Navigator
window. Errors and warnings detected during parsing are sent to the Source Navigator Log in the Output
windowyou can show the log quickly by clicking the Show Source Navigator Log tool button on the Source
Navigator toolbar.
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Sorting and grouping

You can group objects by their type; that is, whether they are classes, functions, namespaces, structures, or

variables. Each object is placed into a folder according to its type.

To group objects by type:

1. On the Source Navigator toolbar, click the arrow to the right of the Cycle Grouping button.
2. Choose Group By Type
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References window

The References window shows the results of the last Find References operation. The Find References facility
is closely related to the Source Navigator in that it indexes your project and searches for references within the

active source code regions.
To activate the References window:

If you have hidden the References window and want to see it again:

Choose View > References or press Ctrl+Alt+R.

To find all references in a project:

1. Open a source file that is part of the active project, or one of its dependent projects.

2. In the editor, move the insertion point within the name of the function, variable, method, or macro to
find.

3. Choose Navigate > Find References or press Alt+R.

4. SEGGER Embedded Studio shows the References window, without moving focus, and searches your

project in the background.

You can also find references directly from the text editor's context menu: right-click the item to find and choose
Find References. As a convenience, SEGGER Embedded Studio is configured to also run Find References when

you Alt+Right-click in the text editorsee Mouse-click accelerators.

To search within the results:

Type the text to search for in the Reference window's search box. As you type, the search results are
narrowed.

Click the close button to clear the search text and show all references.

To replace within the results:

Type the replacement text in the Reference window's replace box.
Use the buttons to navigate and replace the text.

The documents that have had replaced text will appear unsaved in the text editor.
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Symbol browser window

The Symbol Browser shows useful information about your linked application and complements the information
displayed in the Project Explorer window. You can select different ways to filter and group the information in
the Symbol Browser to provide an at-a-glance overview of your application. You can use the Symbol Browser to
drill down to see the size and location of each part of your program. The way symbols are sorted and grouped is
saved between runs; so, when you rebuild an application, SEGGER Embedded Studio automatically updates the

Symbol Browser so you can see the effect of your changes on the memory layout of your program.

User interface

Button Description

{L"l Group symbols by source filename.

{q; Group symbols by symbol type (equates, functions,

labels, sections, and variables).

{. Group symbols by the section where they are defined.
& | Move the insertion point to the statement that defined

+ the symbol.

Select columns to display.

The main part of the Symbol Browser displays each symbol (both external and static) that is linked into an
application. SEGGER Embedded Studio displays the following icons to the left of each symbol:

Icon Description
% Private Equate A private symbol not defined relative to
a section.

Public Equate A public symbol that is not defined
relative to a section.

Private Function A private function symbol.
Public Function A public function symbol.

Private Label A private data symbol, defined relative to
a section.

Public Label A public data symbol, defined relative to a
section.

e 5 @ » o

Section A program section.
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Choosing what to show

To activate the Symbol Browser window:
Choose View > Symbol Browser or press Ctrl+Alt+Y.
You can choose to display the following fields for each symbol:

Value:The value of the symbol. For labels, code, and data symbols, this will be the address of the symbol.
For absolute or symbolic equates, this will be the value of the symbol.

Range:The range of addresses the code or data item covers. For code symbols that correspond to high-
level functions, the range is the range of addresses used for that function's code. For data addresses that
correspond to high-level static or extern variables, the range is the range of addresses used to store that
data item. These ranges are only available if the corresponding source file was compiled with debugging
information turned on: if no debugging information is available, the range will simply be the first address
of the function or data item.

Size:The size, in bytes, of the code or data item. The Size column is derived from the Range of the symbol:
if the symbol corresponds to a high-level code or data item and has a range, Size is calculated as the
difference between the start and end addresses of the range. If a symbol has no range, the size column is
blank.

Section:The section in which the symbol is defined. If the symbol is not defined within a section, the
Section column is blank.

Type:The high-level type for the data or code item. If the source file that defines the symbol is compiled
with debugging information turned off, type information is not available and the Type column is blank.
Frame Size:The amount of stack space used by a call to the function symbol. If the source file that defines
the symbol is compiled with debugging information turned off, frame size information is not available

and the Type column is blank.

Initially the Range and Size columns are shown in the Symbol Browser. To select which columns to display, use

the Field Chooser button on the Symbol Browser toolbar.

To select the fields to display:

1. Click the Field Chooser button on the Symbol Browser toolbar.
2. Select the fields you wish to display and deselect the fields you wish to hide.

Organizing and sorting symbols

When you group symbols by section, each symbol is grouped underneath the section in which it is defined.
Symbols that are absolute or are not defined within a section are grouped beneath (No Section).

To group symbols by section:

1. On the Symbol Browser toolbar, click the arrow next to the Cycle Grouping button.
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2. From the pop-up menu, choose Group By Section.
The Cycle Grouping icon will change to indicate that the Symbol Browser is grouping symbols by section.
When you group symbols by type, each symbol is classified as one of the following:

An Equate has an absolute value and is not defined as relative to, or inside, a section.

A Function is defined by a high-level code sequence.

A Variable is defined by a high-level data declaration.

A Label is defined by an assembly language module. Label is also used when high-level modules are

compiled with debugging information turned off.

When you group symbols by source file, each symbol is grouped underneath the source file in which it is
defined. Symbols that are absolute, are not defined within a source file, or are compiled without debugging
information, are grouped beneath (Unknown).

To group symbols by type:

1. On the Symbol Browser toolbar, click the arrow next to the Cycle Grouping button.

2. Choose Group By Type from the pop-up menu.

The Cycle Grouping icon will change to indicate that the Symbol Browser is grouping symbols by type.

To group symbols by source file:

1. On the Symbol Browser toolbar, click the arrow next to the Cycle Grouping button.

2. Choose Group By Source File.
The Cycle Grouping icon will change to indicate that the Symbol Browser is grouping symbols by source file.

When you sort symbols alphabetically, all symbols are displayed in a single list in alphabetical order.

To list symbols alphabetically:

1. On the Symbol Browser toolbar, click the arrow next to the Cycle Grouping button.
2. Choose Sort Alphabetically.

The Cycle Grouping icon will change to indicate that the Symbol Browser is grouping symbols alphabetically.

Filtering and finding symbols

When you're dealing with big projects with hundreds, or even thousands, of symbols, a way to filter those
symbols in order to isolate just the ones you need is very useful. The Symbol Browser's toolbar provides an
editable combobox} you can use to specify the symbols you'd like displayed. You can type * to match a sequence

of zero or more characters and ? to match exactly one character.
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The symbols are filtered and redisplayed as you type into the combo box. Typing the first few characters of a
symbol name is usually enough to narrow the display to the symbol you need. Note: the C compiler prefixes all
high-level language symbols with an underscore character, so the variable ext ern i nt u or the function
voi d fn(voi d) have low-level symbol names _u and _f n. The Symbol Browser uses the low-level symbol
name when displaying and filtering, so you must type the leading underscore to match high-level symbols.
To display symbols that start with a common prefix:

Type the desired prefix text into the combo box, optionally followed by a "*".
For instance, to display all symbols that start with "i2c_", type "i2¢_" and all matching symbols are displayedyou
don't need to add a trailing "*" in this case, because it is implied.
To display symbols that end with a common suffix:

Type * into the combo box, followed by the required suffix.

For instance, to display all symbols that end in _data, type *_data and all matching symbols are displayedin this

case, the leading * is required.

When you have found the symbol you're interested in and your source files have been compiled with debugging
information turned on, you can jump to a symbol's definition using the Go To Definition button.

To jump to the definition of a symbol:

1. Select the symbol from the list of symbols.
2. On the Symbol Browser toolbar, click Go To Definition.

or

1. Right-click the symbol in the list of symbols.
2. Choose Go To Definition from the shortcut menu.

Watching symbols

If a symbol's range and type is known, you can add it to the most recently opened Watch window or Memory

window.

To add a symbol to the Watch window:

1. In the Symbol Browser, right-click the symbol you wish to add to the Watch window.
2. On the shortcut menu, choose Add To Watch.

To add a symbol to the Memory window:

1. In the Symbol Browser, right-click the symbol you wish to add to the Memory window.
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2. Choose Locate Memory from the shortcut menu.

Using size information

Here are a few common ways to use the Symbol Browser:

What function uses the most code space? What requires the most data space?

IS L T o e

Choose View > Symbol Browser or press Ctrl+Alt+Y.

In the Grouping button menu on the Symbol Browser toolbar, select Group By Type.
Ensure the Size field is checked in the Field Chooser button's menu.

Ensure that the filter on the Symbol Browser toolbar is empty.

Click on the Size field in the header to sort by data size.

The sizes of variables and of functions are shown in separate lists.

What's the overall size of my application?

> W

Choose View > Symbol Browser or press Ctrl+Alt+Y.

In the Grouping button menu on the Symbol Browser toolbar, select Group By Section.
Ensure the Range and Size fields are checked in the Field Chooser button's menu.

Read the section sizes and ranges of each section in the application.
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Stack usage window

The Stack Usage Window finds the call paths of your linked application and displays them as a call tree
together with their minimal stack requirements. A call path of your application is any function that has been
linked in but has no direct call made to it but will make calls to other functions. The main function is the most
obvious example of a call path, an interrupt handler or a function that is called only as a function pointer are
other examples. To use the stack usage window your linked application must be compiled with debugging
information enabled.

User interface

Button Description
i Move the insertion point to the statement that defined
=7 the symbol.
= Collapse the selected open call tree.
ok Open the selected open call tree.
.:':' Show only the deepest call path through the selected
= call tree.
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Memory usage window

The Memory Usage window displays a graphical summary of how memory has been used in each memory

segment of a linked application.

Bdemal _FLASH (e BO00000C
B 2.9MB free of 4 MB

Extemal _SRAM b8 1 0000

Each bar represents an entire memory segment. Green represents the area of the segment that contains code or
data.
To activate the Memory Usage window:

Choose View > Memory Usage or press Ctrl+Alt+Z.

The memory-usage graph will only be visible if your active project's target is an executable file and the file exists.
If the executable file has not been linked by SEGGER Embedded Studio, memory-usage information may not be

available.

Displaying section information

The Memory Usage window can also be used to visualize how program sections have been placed in memory.
To display the program sections, simply click the memory segment to expand it; or, alternatively, right-click and
choose Show Memory Sections from the shortcut menu.
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SRAM (4 000000
4 11.3kB free of 16 kB

wvectors_ram (e DOD0000

&0 bytes used

data (4000003
1 kB used

b=s (cA00004 3c
1.1 kB used

heap (4000084
1 kB used

stack (e A0000cc4

1 kB uszed

Each bar represents an entire memory segment. Green represents the area of the segment that contains the
program section.

Displaying segment overflow

The Memory Usage window also displays segment overflows when the total size of the program sections placed
in a segment is larger than the segment size. When this happens, the segment and section bars represents the
total memory used, green areas represent the code or data within the segment, and red areas represent code or
data placed outside the segment.
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Extemal _SRAM (b3 1 000000

4 65 kB over 1 MBE

data? (bc8 1000000

65 kB used

bss2 (31010400

1 ME used

Getting more-detailed information

If you require more-detailed information than that provided by the Memory Usage window, such as the location
of specific objects within memory, use the Symbol browser window.
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Bookmarks window

The Bookmarks window contains a list of bookmarks that are set in the project. The bookmarks are stored in the
session file associated with the project and persist across runs of SEGGER Embedded Studioif you remove the

session file, the bookmarks associated with the project are lost.

User interface

Button Description

Toggle a bookmark at the insertion point in the active
(I editor. Equivalent to choosing Edit > Bookmarks >
Toggle Bookmark or pressing Ctrl+F2.

O Go to the previous bookmark in the bookmark list.
Equivalent to choosing Edit > Bookmarks > Previous
Bookmark or pressing Alt+Shift+F2.

o Go to the next next bookmark in the bookmark list.
i Equivalent to choosing Edit > Bookmarks > Next
Bookmark or pressing Alt+F2.

g{ Clear all bookmarksyou confirm the action using a
dialog. Equivalent to choosing Edit > Bookmarks >
Clear All Bookmarks or pressing Ctrl+K, Alt+F2.

O Selects the fill color for newly created bookmarks.

Double-clicking a bookmark in the bookmark list moves focus to the the bookmark.

You can set bookmarks with the mouse or using keystrokessee Using bookmarks.
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Code Outline Window

The Code Outline window shows the structure of the text of the focused code editor. For C and C++ documents
the top level symbols and types are displayed, for XML documents the nodes are displayed. For Cand C+

+ documents the Preview tab can display documentation on the top level symbols and types. The defacto
standard doxygen commands are supported for example:

/**

* \brief Convert a given full parsed comment to an XM. docunent.

*

* A Rel ax NG schema for the XML can be found in coment-xm-schema.rng file
* inside clang source tree.
*
*

\ param Conment a \c CXComment _Ful | Conment AST node.

*

* \returns string containing an XM. docunent .
*/
Cl NDEX_LI NKAGE CXString clang_Ful | Conment _get AsXM.( CXConmrent Conment ) ;
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Analyzing Source Code

The Analyze action is available on the context menu of the project explorer at project, folder and file level. The
analyze action will run the https://clang.llvm.org/extra/clang-tidy linter tool on the C/C++ files selected by the
project explorer node and display warnings in the output window. The default checks will be the same as the
clang analyzer. You can enable additional checks by setting the Clang Tidy Checks project option. For example
you can enable the bugprone code constructs check and disable a specific clang analyzer diagnostic check as

follows

bugpr one- *
-cl ang-di agnosti c- par ent heses-equal ity

You can also set the project option Analyze After Compile which will run the analyzer each time the compiler is

run.
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Editing your code

SEGGER Embedded Studio has a built-in editor that allows you to edit text, but some features make it particularly

well suited to editing code.

You can open multiple code editors to browse or edit project source code, and you can copy and paste among

them. The Windows menu contains a list of all open code editors.

The code editor supports the language of the source file it is editing, showing code with syntax highlighting and

offering smart indenting.
You can open a code editor in several ways, some of which are:

By double-clicking a file in the Project Explorer or by right-clicking a file and selecting Open from the
shortcut menu.
Using the File > New File or File > Open commands.

Elements of the code editor

The code editor is composed of several elements, which are described here.

Code pane:The area where you edit code. You can set options that affect the code pane's text indents,
tabs, drag-and-drop behavior, and so forth.

Margin gutter:A gray area on the left side of the code editor where margin indicators such as breakpoints,
bookmarks, and shortcuts are displayed. Clicking this area sets a breakpoint on the corresponding line of
code.

Horizontal and vertical scroll bars:You can scroll the code pane horizontally and vertically to view code that

extends beyond the edges of the pane.
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Basic editing
This section is a whirlwind tour of the basic editing features SEGGER Embedded Studio's code editor provides.

Whether you are editing code, HTML, or plain text, the code editor is just like many other text editors or word
processors. For code that is part of a project, the project's programming language support provides syntax

highlighting (colorization), indentation, and so on.

This section is not a reference for everything the code editor provides; for that, look in the following sections.
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Moving the insertion point

The most common way to navigate through text is to use use the mouse or the keyboard's cursor keys.

Using the mouse

You can move the insertion point within a document by clicking the mouse inside the editor window.

Using the keyboard

The keystrokes most commonly used to navigate through a document are:

Keystroke Description

Up Move the insertion point up one line

Down Move the insertion point down one line

Left Move the insertion point left one character

Right Move the insertion point right one character

Home Move the insertion point to the first non-whitespace

character on the line pressing Home a second time
moves the insertion point to the leftmost column

End Move the insertion point to the end of the line
PageUp Move the insertion point up one page

PageDown Move the insertion point down one page

Ctrl+Home Move the insertion point to the start of the document
Ctrl+End Move the insertion point to the end of the document
Ctrl+Left Move the insertion point left one word

Ctrl+Right Move the insertion point right one word

SEGGER Embedded Studio offers additional movement keystrokes, though most users are more comfortable

using repeated simple keystrokes to accomplish the same thing:

Keystroke Description

Alt+Up Move the insertion point up five lines

Alt+Down Move the insertion point down five lines

Alt+Home Move the insertion point to the top of the window
Alt+End Move the insertion point to the bottom of the window
Ctrl+Up Scroll the document up one line in the window

without moving the insertion point
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Ctrl+Down Scroll the document down one line in the window
without moving the insertion point

If you are editing source code, the are source-related keystrokes too:

Keystroke Description

Move the insertion point backwards to the previous
Ctrl+PgUp ) P P

function or method.
Ctrl+PgDn Move the insertion point forwards to the next function

or method.
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Adding text

The editor has two text-input modes:

Insertion mode:As you type on the keyboard, text is entered at the insertion point and any text to the right
of the insertion point is shifted along. A visual indication of insertion mode is that the cursor is a flashing
line.

Overstrike mode:As you type on the keyboard, text at the insertion point is replaced with your typing. A

visual indication of insertion mode is that the cursor is a flashing block.
Insert and overstrike modes are common to all editors: if one editor is in insert mode, all editors are in insert
mode. To configure the cursor appearance, choose Tools > Options.
To toggle between insertion and overstrike mode:

Click Insert.
When overstrike mode is enabled, the mode indicator changes from INS to OVR and the cursor will change to
the overstrike cursor.
To add or insert text:

1. Move the insertion point to the place text is to be inserted.
2. Enter the text using the keyboard.

To overwrite characters in an existing line, press the Insert key to place the editor into overstrike mode.

To add or insert text on multiple lines:

1. Hold down the Alt key and use block selection to mark the place text is to be inserted.

2. Enter the text using the keyboard.
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Deleting text

The text editor supports the following common editing keystrokes:

Keystroke Description

Backspace Delete the character before the insertion point
Delete Delete the character after the insertion point
Ctrl+Backspace Delete one word before the insertion point
Ctrl+Delete Delete one word after the insertion point

To delete characters or words:

1. Place the insertion point before the word or letter you want to delete.
2. Press Delete as many times as needed.

or
1. Place the insertion point after the letter or word you want to delete.
2. Press Backspace as many times as needed.

To delete text that spans more than a few characters:

1. Select the text you want to delete.
2. Press Delete or Backspace to delete it.

To delete a text block:

1. Hold down the Alt key and use block selection to mark the text you want to delete.
2. Press Delete or Backspace to delete it.

To delete characters on multiple lines:

1. Hold down the Alt key and use block selection to mark the lines.
2. Press Delete or Backspace as many times as needed to delete the characters.
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Using the clipboard

You can select text by using the keyboard or the mouse.

To select text with the keyboard:

Hold down the Shift key while using the cursor keys.

To select text with the mouse:

1. Click the start of the selection.
2. Drag the mouse to mark the selection.

3. Release the mouse to end selecting.

To select a block of text with the keyboard:

Hold down the Shift+Alt keys while using the cursor keys.

To select a block of text with the mouse:

1. Hold down the Alt key.

2. Click the start of the selection.

3. Drag the mouse to mark the selection.
4

. Release the mouse to end selecting.

To copy selected text to the clipboard:

Choose Edit > Copy or press Ctrl+C.

SEGGER Embedded Studio User Guide

The standard Windows key sequence Ctrl+Ins also copies text to the clipboard.

To cut selected text to the clipboard:

Choose Edit > Cut or press Ctrl+X.

The standard Windows key sequence Shift+Del also cuts text to the clipboard.

To insert the clipboard content at the insertion point:

Choose Edit > Paste or press Ctrl+V.

The standard Windows key sequence Shift+Ins also inserts the clipboard content at the insertion point.
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Undo and redo

The editor has an undo facility to undo previous editing actions. The redo feature can be used to re-apply
previously undone actions.
To undo one editing action:

Choose Edit > Undo or press Ctrl+Z.

The standard Windows key sequence Alt+Backspace also undoes an edit.

To undo multiple editing actions:
1. On the Standard toolbar, click the arrow next to the Undo button.
2. Select the editing operations to undo.

To undo all edits:

Choose Edit > Others > Undo All or press Ctrl+K, Ctrl+Z.

To redo one editing action:
Choose Edit > Redo or press Ctrl+Y.

The standard Windows key sequence Alt+Shift+Backspace also redoes an edit.

To redo multiple editing actions:

1. On the Standard toolbar, click the arrow next to the Redo tool button.
2. From the pop-up menu, select the editing operations to redo.

To redo all edits:

Choose Edit > Others > Redo All or press Ctrl+K, Ctrl+Y.
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Drag and drop

You can select text, then drag it to another location. You can drop the text at a different location in the same
window or in another one.
To drag and drop text:

1. Select the text you want to move.
2. Press and hold the mouse button to drag the selected text to where you want to place it.

3. Release the mouse button to drop the text.

Dragging text moves it to the new location. To copy it to a new location, hold down the Ctrl key while dragging
the text: the mouse pointer changes to indicate a copy operation. Press the Esc key while dragging text to cancel
the drag-and-drop edit.

By default, drag-and drop-editing is disabled and you must enable it if you want to use it.

To enable or disable drag-and-drop editing:

1. Choose Tools > Options or press Alt+,.
2. Click Text Editor.
3. Set Allow Drag and Drop Editing to Yes to enable or to No to disable drag-and-drop editing.
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Searching

To find text in the current file:

1. Press Ctrl+F.

2. Enter the string to search for.

As you type, the editor searches the file for a match. The pop-up shows how many matches are in the current file.
To move through the matches while the Find box is still active, press Tab or F3 to move to the next match and
Shift+Tab or Shift+F3 to move to the previous match.

If you press Ctrl+F a second time, SEGGER Embedded Studio pops up the standard Find dialog to search the file.
If you wish to bring up the Find dialog without pressing Ct r | +F twice, choose Search > Find.
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Advanced editing

You can do anything using its basic code-editing features, but the SEGGER Embedded Studio text editor has a

host of labor-saving features that make editing programs a snap.

This section describes the code-editor features intended to make editing source code easier.
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Indenting source code

The editor uses the Tab key to increase or decrease the indentation level of the selected text.

To increase indentation:

Select the text to indent.

Choose Selection > Increase Line Indent or press Tab.

To decrease indentation:

Select the text to indent.

Choose Selection > Decrease Line Indent or press Shift+Tab.

The indentation size can be changed in the Language Properties pane of the editor's Properties window, as can
all the indent-related features listed below.

To change indentation size:

Choose Tools > Options or press Alt+,.
Select the Languages page.
Set the Indent Size environment option for the required language.

You can choose to use spaces or tab tab characters to fill whitespace when indenting.

To set tab or space fill when indenting:

Choose Tools > Options or press Alt+,.
Select the Languages page.
Set the Use Tabs environment option for the required language. Note: changing this setting does not add

or remove existing tabs from files, the change will only affect new indents.

The editor can assist with source code indentation while inserting text. There are three levels of indentation

assistance:

None:The indentation of the source code is left to the user.

Indent:This is the default. The editor maintains the current indentation level. When you press Return or
Enter, the editor moves the insertion point down one line and indented to the same level as the now-
previous line.

Smart:The editor analyzes the source code to compute the appropriate indentation level for each line.
You can change how many lines before the insertion point will be analyzed for context. The smart-indent

mode can be configured to indent either open and closing braces or the lines following the braces.

Changing indentation options:

To change the indentation mode:
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Set the Indent Mode environment option for the required language.
To change whether opening braces are indented in smart-indent mode:

Set the Indent Opening Brace environment option for the required language.
To change whether closing braces are indented in smart-indent mode:

Set the Indent Closing Brace environment option for the required language.
To change the number of previous lines used for context in smart-indent mode:

Set the Indent Context Lines environment option for the required language.
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Commenting out sections of code

To comment selected text:

Choose Selection > Comment or press Ctrl+/.

To uncomment selected text:
Choose Selection > Uncomment or press Ctrl+Shift+/.

You can also toggle the commenting of a selection by typing /. This has no menu equivalent.
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Adjusting letter case

The editor can change the case of the current word or the selection. The editor will change the case of the
selection, if there is a selection, otherwise it will change the case of word at the insertion point.
To change text to uppercase:

Choose Selection > Make Uppercase or press Ctrl+K, U.

This changes, for instance, Hello to HELLO.

To change text to lowercase:
Choose Selection > Make Lowercase or press Ctrl+U.

This changes, for instance, Hello to hello.

To switch between uppercase and lowercase:
Choose Selection > Switch Case.
This changes, for instance, Hello to hELLO.

With large software teams or imported source code, sometimes identifiers don't conform to your local coding
style. To assist in conversion between two common coding styles for identifiers, SEGGER Embedded Studio's

editor offers the following two shortcuts:

To change from split case to camel case:
Choose Selection > Camel Case or press Ctrl+K, Ctrl+Shift+U.

This changes, for instance, this_is_wrong to thislsWrong.

To change from camel case to split case:
Choose Selection > Split Case or press Ctrl+K, Ctrl+U.

This changes, for instance, thislsWrong to this_is_wrong.
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Using bookmarks

To edit a document elsewhere and then return to your current location, add a bookmark. The Bookmarks
window maintains a list of the bookmarks set in source files see Bookmarks window.
To place a bookmark:

1. Move the insertion point to the line you wish to bookmark.
2. Choose Edit > Bookmarks > Toggle Bookmark or press Ctrl+F2.

A bookmark symbol appears next to the line in the indicator margin to show the bookmark is set.

To place a bookmark using the mouse:

1. Right-click the margin gutter where the bookmark should be set.
2. Choose Toggle Bookmark.

The default color to use for new bookmarks is configured in the Bookmarks window. You can choose a specific

color for the bookmark as follows:

1. Press and hold the Alt key.
2. Click the margin gutter where the bookmark should be set.
3. From the palette, click the bookmark color to use for the bookmark.

To navigate forward through bookmarks:

1. Choose Edit > Bookmarks > Next Bookmark In Document or press F2.
2. The editor moves the insertion point to the next bookmark in the document.

If there is no following bookmark, the insertion point moves to the first bookmark in the document.

To navigate backward through bookmarks:

1. Choose Edit > Bookmarks > Previous Bookmark In Document or press Shift+F2.

2. The editor moves the insertion point to the previous bookmark in the document.

If there is no previous bookmark, the insertion point moves to the last bookmark in the document.

To remove a bookmark:

1. Move the insertion point to the line containing the bookmark.
2. Choose Edit > Bookmarks > Toggle Bookmark or press Ctrl+F2.

The bookmark symbol disappears, indicating the bookmark is no longer set.

To remove all bookmarks in a document:

Choose Edit > Bookmarks > Clear Bookmarks In Document or press Ctrl+K, F2.
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Quick reference for bookmark operations

Keystroke
Ctrl+F2

Ctrl+K, 0

F2

Shift+F2

Ctrl+Q, F2

Ctrl+Q, Shift+F2

Ctrl+K, F2

Alt+F2

Alt+Shift+F2

Ctrl+Q, Alt+F2

Ctrl+Q, Alt+Shift+F2

Ctrl+K, Alt+F2

Menu

Edit > Bookmarks > Toggle
Bookmark

Edit > Bookmarks > Next
Bookmark In Document

Edit > Bookmarks > Previous
Bookmark In Document

Edit > Bookmarks > First
Bookmark In Document

Edit > Bookmarks > Last Bookmark
In Document

Edit > Bookmarks > Clear
Bookmarks In Document

Edit > Bookmarks > Next
Bookmark

Edit > Bookmarks > Previous
Bookmark

Edit > Bookmarks > First
Bookmark

Edit > Bookmarks > Last Bookmark

Edit > Bookmarks > Clear All
Bookmarks
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Description

Toggle a bookmark at the insertion
point.

Clear the bookmark at the insertion
point.

Move the insertion point to next
bookmark in the document.

Move the insertion point to
previous bookmark in the
document.

Move the insertion point to the first
bookmark in the document.

Move the insertion point to the last
bookmark in the document.

Clear all bookmarks in the
document.

Move the insertion point to the next
bookmark in the Bookmarks list.

Move the insertion point to
the previous bookmark in the
Bookmarks list.

Move the insertion point to the first
bookmark in the Bookmarks list.

Move the insertion point to the last
bookmark in the Bookmarks list.

Clear all bookmarks in all
documents.
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Find and Replace window

The Find and Replace window allows you to search for and replace text in the current document or in a range of

specified files.

To activate the Find and Replace window:

Choose Search > Replace in Files or press Ctrl+Alt+F.

To find text in a single file:

Select Current Document in the context combo box.

Enter the string to be found in the text edit input.

If the search will be case sensitive, set the Match case option.

If the search will be for a whole wordi.e., there will be whitespace, such as spaces or the beginning or end
of the line, on both sides of the string being searched forset the Whole word option.

If the search string is a regular expression, set the Use regexp option.

Click the Find button to find all occurrences of the string in the current document.

To find and replace text in a single file:

Click the Replace button on the toolbar.

Enter the string to search for into the Find what input.

Enter the replacement string into the Replace with input. If the search string is a regular expression, the n
back-reference can be used in the replacement string to reference captured text.

If the search will be case sensitive, set the Match case option.

If the search will be for a whole wordi.e., there will be whitespace, such as spaces or the beginning or end
of the line, on both sides of the string being searched forset the Match whole word option.

If the search string is a regular expression, set the Use regular expression option.

Click the Find Next button to find next occurrence of the string, then click the Replace button to replace

the found string with the replacement string; or click Replace All to replace all occurrences of the search

string without prompting.

To find text in multiple files:

Click the Find In Files button on the toolbar.

Enter the string to search for into the Find what input.

Select the appropriate option in the Look in input to select whether to carry out the search in all open
documents, all documents in the current project, all documents in the current solution, or all files in a
specified folder.

If you have specified that you want to search in a folder, select the folder you want to search by entering
its path in the Folder input and use the Look in files matching input to specify the type of files you want

to search.
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If the search will be case sensitive, set the Match case option.

If the search will be for a whole wordi.e., there will be whitespace, such as spaces or the beginning or end
of the line, on both sides of the string being searched forset the Match whole word option.

If the search string is a regular expression, set the Use regular expression option.

Click the Find All button to find all occurrences of the string in the specified files, or click the Bookmark

All button to bookmark all the occurrences of the string in the specified files.

To replace text in multiple files:

Click the Replace In Files button on the toolbar.

Enter the string to search for into the Find what input.

Enter the replacement string into the Replace with input. If the search string is a regular expression, the n
back-reference can be used in the replacement string to reference captured text.

Select the appropriate option in the Look in input to select whether you want to carry out the search and
replace in the current or in all open documents.

If you have specified that you want to search in a folder, select the folder you want to search by entering
its path in the Folder input and use the Look in files matching input to specify the type of files you want
to search.

If the search will be case sensitive, set the Match case option.

If the search will be for a whole wordi.e., there will be whitespace, such as spaces or the beginning or end
of the line, on both sides of the string being searched forset the Match whole word option.

If the search string is a regular expression, set the Use regular expression option.

Click the Replace All button to replace all occurrences of the string in the specified files.
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Clipboard Ring window

The code editor captures all cut and copy operations, and stores the cut or copied item on the clipboard ring. The
clipboard ring stores the last 20 cut or copied text items, but you can configure the maximum number by using
the environment options dialog. The clipboard ring is an excellent place to store scraps of text when you're
working with many documents and need to cut and paste between them.

To activate the clipboard ring:

Choose Edit > Clipboard Ring > Clipboard Ring or press Ctrl+Alt+C.

To paste from the clipboard ring:

1. Cut or copy some text from your code. The last item you cut or copy into the clipboard ring is the current
item for pasting.

2. Press Ctrl+Shift+V to paste the clipboard ring's current item into the current document.

3. Repeatedly press Ctrl+Shift+V to cycle through the entries in the clipboard ring until you get to the one
you want to permanently paste into the document. Each time you press Ctrl+Shift+V, the editor replaces
the last entry you pasted from the clipboard ring, so you end up with just the last one you selected. The
item you stop on then becomes the current item.

4. Move to another location or cancel the selection. You can use Ctrl+Shift+V to paste the current item
again or to cycle the clipboard ring to a new item.

Clicking an item in the clipboard ring makes it the current item.

To paste a specific item from the clipboard ring:

1. Move the insertion point to the position to paste the item in the document.
2. Click the arrow at the right of the item to paste.
3. Choose Paste from the pop-up menu.

or

1. Click the item to paste to make it the current item.
2. Move the insertion point to the position to paste the item in the document.
3. Press Ctrl+Shift+V.

To paste all items into a document:

To paste all items on the clipboard ring into the current document, move the insertion point to where you want
to paste the items and do one of the following:

Choose Edit > Clipboard Ring > Paste All.

or
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On the Clipboard Ring toolbar, click the Paste All button.

To remove an item from the clipboard ring:
1. Click the arrow at the right of the item to remove.
2. Choose Delete from the pop-up menu.
To remove all items from the clipboard ring:
Choose Edit > Clipboard Ring > Clear Clipboard Ring.
or

On the Clipboard Ring toolbar, click the Clear Clipboard Ring button.

To configure the clipboard ring:

1. Choose Tools > Options or press Alt+,.

2. Click the Windows category to show the Clipboard Ring Options group.

3. Select Preserve Contents Between Runs to save the content of the clipboard ring between runs, or
deselect it to start with an empty clipboard ring.

4. Change Maximum Items Held In Ring to configure the maximum number of items stored on the

clipboard ring.
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Mouse-click accelerators

SEGGER Embedded Studio provides a number of mouse-click accelerators in the editor that speed access to

commonly used functions. The mouse-click accelerators are user configurable using Tools > Options.

Default mouse-click assignments

Click Default

Left Not configurable start selection.
Shift+Left Not configurable extend selection.
Ctrl+Left Select word.

Alt+Left Execute Go To Definition.

Middle No action.

Shift+Middle Display Go To Include menu.
Ctrl+Middle No action.

Alt+Middle Display Go To Method menu.
Right Not configurable show context menu.
Shift+Right No action.

Ctrl+Right No action.

Alt+Right Execute Find References.

Each accelerator can be assigned one of the following actions:

Default:The system default for that click.

Go To Definition:Go to the definition of the item clicked, equivalent to choosing Navigate > Go To
Definition or pressing Alt+G.

Find References:Find references to the item clicked, equivalent to choosing Navigate > Find References or
pressing Alt+R.

Find in Solution:Textually find the item clicked in all the files in the solution, equivalent to choosing Search
> Find Extras > Find in Solution or pressing Alt+U.

Find Help:Use F1-help on the item clicked, equivalent to choosing Help > Help or pressing F1.

Go To Method:Display the Go To Method menu, equivalent to choosing Navigate > Find Method or
pressing Ctrl+M.

Go To Include:Display the Go To Include menu, equivalent to choosing Navigate > Find Include or
pressing Ctrl+Shift+M.

Paste:Paste the clipboard at the position clicked, equivalent to choosing Edit > Paste or pressing Ctrl+V.
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Configuring Mac OS X

On Mac OS X you must configure the mouse to pass middle clicks and right clicks to the application if you wish
to use mouse-click accelerators in SEGGER Embedded Studio. Configure the mouse preferences in the Mouse

control panel in Mac OS X System Preferences to the following:

Right mouse button set to Secondary Button.
Middle mouse button set to Button 3.

114



SEGGER Embedded Studio Reference Manual SEGGER Embedded Studio User Guide

Regular expressions

The editor can search and replace text using regular expressions. A regular expression is a string that uses
special characters to describe and reference patterns of text. The regular expression system used by the editor
is modeled on Perl's regexp language. For more information on regular expressions, see Mastering Regular
Expressions, Jeffrey E F Freidl, ISBN 0596002890.

Summary of special characters

The following table summarizes the special characters the SEGGER Embedded Studio editor supports

Pattern Description

\d Match a numeric character.

\D Match a non-numeric character.

\s Match a whitespace character.

\S Match a non-whitespace character.

\w Match a word character.

\W Match a non-word character.

[c] Match set of characters; e.g., [ch] matches characters

cor h. A range can be specified using the - character;
e.g., [0-27-9] matches if the characteris 0, 1,2, 7 8, or
9. A range can be negated using the A character; e.g.,
[Aa-z] matches if the character is anything other than a
lowercase alphabetic character.

\c¢ Match the literal character c. For example, you would
use \\* to match the character *.

\a Match ASCII bell character (ASCIl code 7).

\f Match ASCII form feed character (ASCIl code 12).

\t Match ASCII horizontal tab character (ASCll code 9).

\v Match ASCII vertical tab character.

\xhhhh Match Unicode character specified by hexadecimal
number hhhh.
Match any character.

* Match zero or more occurrences of the preceding
expression.

+ Match one or more occurrences of the preceding
expression.

? Match zero or one occurrences of the preceding

expression.
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{n}
{n}

\b
\B
(e)

\n

Examples

SEGGER Embedded Studio User Guide

Match n occurrences of the preceding expression.

Match at least n occurrences of the preceding
expression.

Match at most m occurrences of the preceding
expression.

Match at least n and at most m occurrences of the
preceding expression.

Beginning of line.
End of line.

Word boundary.
Non-word boundary.
Capture expression e.

Back-reference to nth captured text.

The following regular expressions can be used with the editor's search-and-replace operations. To use the

regular expression mode, the Use regular expression checkbox must be set in the search-and-replace dialog.
Once enabled, regular expressions can be used in the Find what search string. The Replace With strings can use

the "n" back-reference string to reference any captured strings.

"Find what" "Replace With"
u\w.d

AXS

(typedef.+\s+)(\S+); \TTEST_\2;

Description

Search for any-length string
containing one or more word
characters beginning with the
character u and ending in the
character d.

Search for any lines ending in a
semicolon.

Find C type definition and insert the
string TEST onto the beginning of
the type name.
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Locals window

The Locals window displays a list of all variables that are in scope of the selected stack frame in the Call Stack.

The Locals window has a toolbar and a main data display.

Button Description

Mo Display the selected item in binary.

Xg Display the selected item in octal.

Xig Display the selected item in decimal.

¥ Display the selected item in hexadecimal.

;;:1% Display the selected item as a signed decimal.

' Display the selected item as a character or Unicode
character.

Set the range displayed in the active Memory window
to span the memory allocated to the selected item.

Sort variables alphabetically by name.

z4
8
3

Sort variables numerically by address or register
number (default).

-—

Using the Locals window

The Locals window shows the local variables of the active function when the debugger is stopped. The contents
of the Locals window changes when you use the Debug Location toolbar items or select a new frame in the Call
Stack window. When the program stops at a breakpoint, or is stepped, the Locals window updates to show the
active stack frame. ltems that have changed since they were previously displayed are highlighted in red.
To activate the Locals window:

Choose View > Locals or press Ctrl+Alt+L.
When you select a variable in the main part of the display, the display-format button highlighted on the Locals
window toolbar changes to show the selected item's display format.

To change the display format of a local variable:

Right-click the item to change.

From the shortcut menu, choose the desired display format.
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or

Click the item to change.

On the Locals window toolbar, select the desired display format.
To modify the value of a local variable:

Click the value of the local variable to modify.
Enter the new value for the local variable. Prefix hexadecimal numbers with 0x, binary numbers with Ob,
and octal numbers with 0.

or

Right-click the value of the local variable to modify.

From the shortcut menu, select one of the commands to modify the local variable's value.
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Globals window

The Globals window displays a list of all variables that are global to the program. The operations available on the
entries in this window are the same as the Watch window, except you cannot add or delete variables from the
Globals window.

Globals window user interface
The Globals window consists of a toolbar and main data display.

Globals toolbar

Button Description

Xq Display the selected item in binary.

Xg Display the selected item in octal.

¥y Display the selected item in decimal.

X Display the selected item in hexadecimal.

}qﬁj Display the selected item as a signed decimal.

' Display the selected item as a character or Unicode
character.

Set the range displayed in the active Memory window
to span the memory allocated to the selected item.

Sort variables alphabetically by name.

2
8
9

Sort variables numerically by address or register
number (default).

-—

Using the Globals window

The Globals window shows the global variables of the application when the debugger is stopped. When the
program stops at a breakpoint, or is stepped, the Globals window updates to show the active stack frame and

new variable values. Items that have changed since they were previously displayed are highlighted in red.

To activate the Globals window:

Choose View > Globals or press Ctrl+Alt+G.

119



SEGGER Embedded Studio Reference Manual SEGGER Embedded Studio User Guide

Changing the display format

When you select a variable in the main part of the display, the display-format button highlighted on the Globals
window toolbar changes to show the item's display format.

To change the display format of a global variable:

Right-click the item to change.
From the shortcut menu, choose the desired display format.

or
Click the item to change.
On the Globals window toolbar, select the desired display format.
To modify the value of a global variable:

Click the value of the global variable to modify.
Enter the new value for the global variable. Prefix hexadecimal numbers with 0x, binary numbers with Ob,

and octal numbers with 0.
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Watch window

The Watch window provides a means to evaluate expressions and to display the results of those expressions.
Typically, expressions are just the name of a variable to be displayed, but they can be considerably more
complex; see Debug expressions. Note: expressions are always evaluated when your program stops, so the
expression you are watching is the one that is in scope of the stopped program position.

The Watch window is divided into a toolbar and the main data display.

Button Description

Xy Display the selected item in binary.

Xg Display the selected item in octal.

Xig Display the selected item in decimal.

¥ Display the selected item in hexadecimal.

Kﬁ;. Display the selected item as a signed decimal.

' Display the selected item as a character or Unicode
character.

Set the range displayed in the active Memory window
to span the memory allocated to the selected item.

m Remove the selected watch item.

% Remove all the watches.

Right-clicking a watch item shows a shortcut menu with commands that are not available from the toolbar.

Button Description
" View pointer or array as a null-terminated string.
%[] View pointer or array as an array.

% View pointer value.

* Set watch value to zero.

Set watch value to one.
¥ Increment watched variable by one.

13 Decrement watched variable by one.
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Negated watched variable.

=X
% Invert watched variable.
View the properties of the watch value.

You can view details of the watched item using the Properties dialog.

Filename
The filename context of the watch item.

Line number
The line number context of the watch item.

(Name)
The name of the watch item.

Address
The address or register of the watch item.

Expression
The debug expression of the watch item.

Previous Value
The previous watch value.

Size In Bytes
The size of the watch item in bytes.

Type
The type of the watch item.

Value
The value of the watch item.

Using the Watch window

Each expression appears as a row in the display. Each row contains the expression and its value. If the value of an

expression is structured (for example, an array), you can open the structure to see its contents.

The display updates each time the debugger locates to source code. So it will update each time your program
stops on a breakpoint, or single steps, and whenever you traverse the call stack. tems that have changed since

they were previously displayed are highlighted in red.

To activate the Watch window:

Choose View > Watch > Watch 1 or press Ctrl+T, W, 1.
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You can show other Watch windows similarly.

You can add a new expression to be watched by clicking and typing into the last entry in the Watch window.

You can change an expression by clicking its entry and editing its contents.

When you select a variable in the main part of the display, the display format button highlighted on the Watch
window toolbar changes to show the item's display format.

To change the display format of an expression:

Right-click the item to change.

From the shortcut menu, choose the desired display format.
or

Click the item to change.

On the Watch window toolbar, select the desired display format.

The selected display format will then be used for all subsequent displays and will be preserved after the debug

session stops.

For C programs, the interpretation of pointer types can be changed by right-clicking and selecting from the

shortcut menu. A pointer can be interpreted as:

a null-terminated ASClI string
an array
an integer

dereferenced

To modify the value of an expression:

Click the value of the local variable to modify.
Enter the new value of the local variable. Prefix hexadecimal numbers with 0x, binary numbers with 0b,
and octal numbers with 0.

or

Right-click the value of the local variable to modify.
From the shortcut menu, choose one of the commands to modify the variable's value.
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Register window

The Register windows show the values of both CPU registers and the processor's special function or peripheral
registers. Because microcontrollers are becoming very highly integrated, it's not unusual for them to have
hundreds of special function registers or peripheral registers, so SEGGER Embedded Studio provides four
register windows. You can configure each register window to display one or more register groups for the
processor being debugged.

A Register window has a toolbar and a main data display.

Button Description

Display the CPU, special function register, and
peripheral register groups.

,ﬂ Display the CPU registers.

gt Hide the CPU registers.

—» Force-read a register, ignoring the access attribute of
the register.

Update the selected register group.

Set the active memory window to the address and size
of the selected register group.

Using the registers window

Both CPU registers and special function registers are shown in the main part of the Registers window. When the
program stops at a breakpoint, or is stepped, the Registers windows update to show the current values of the

registers. Items that have changed since they were previously displayed are highlighted in red.

To activate the first register window:
Choose View > Registers > Registers 1 or press Ctrl+T, R, 1.

Other register windows can be similarly activated.

Displaying CPU registers

The values of the CPU registers displayed in the Registers window depend up upon the selected context. The
selected context can be:

The register state the CPU stopped in.

The register state when a function call occurred using the Call Stack window.
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The register state of the currently selected thread using the the Threads window.
The register state you supplied with the Debug > Locate operation.
To display a group of CPU registers:

On the Registers window toolbar, click the Groups button.
From the pop-up menu, select the register groups to display and deselect the ones to hide.

You can deselect all CPU register groups to allow more space in the display for special function registers or
peripheral registers. So, for instance, you can have one register window showing the CPU registers and other

register windows showing different peripheral registers.

Displaying special function or peripheral registers

The Registers window shows the set of register groups defined in the memory-map file the application was built
with. If there is no memory-map file associated with a project, the Registers window will show only the CPU

registers.

To display a special function or peripheral register:

On the Registers toolbar, click the Groups button.
From the pop-up menu, select the register groups to display and deselect the ones to hide.

Changing display format

When you select a register in the main part of the display, the display-format button highlighted on the
Registers window toolbar changes to show the item's display format.

To change the display format of a register:

Right-click the item to change.
From the shortcut menu, choose the desired display format.

or

Click the item to change.

On the Registers window toolbar, select the desired display format.

Modifying register values

To modify the value of a register:

Click the value of the register to modify.
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Enter the new value for the register. Prefix hexadecimal numbers with 0x, binary numbers with 0b, and

octal numbers with 0.
or

Right-click the value of the register to modify.
From the shortcut menu, choose one of the commands to modify the register value.

Modifying the saved register value of a function or thread may not be supported.
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Memory window

The Memory window shows the contents of the connected target's memory areas and allows the memory to be
edited. SEGGER Embedded Studio provides four memory windows, you can configure each memory window to
display different memory ranges.

The Memory window has a toolbar and a data display/edit area

Field/Button Description

Address Address to dlsplay. This can be a numeric value or a
debug expression.

Size Number of bytes to display. This can be a number or
a debug expression. If unspecified, the number of
bytes required to fill the window will be automatically
calculated.

Columns Number of columns to display. If unspecified, the
number of columns required to fill the window will be
automatically calculated.

X Select binary display.

Mg Select octal display.

X10 Select unsigned decimal display.

Kﬁ;. Select signed decimal display.

¥ Select hexadecimal display (default).

+:§+ Select byte display (default).

J_ﬁ_' Select 2-byte display.

1-3-:+ Select 4-byte display.

Display both data and text (default).

Display data only.

Display text only.

E

Display an incrementing address range that starts from
the selected address (default).

Display a decrementing address range that starts from
the selected address.

—
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[E Display an incrementing address range that ends at
the selected address.

[ Display a decrementing address range that ends at the
selected address.

G Evaluate the address and size expressions, and update
the Memory window.

Using the memory window

The memory window does not show the complete address space of the target, instead you must enter both the
address and the number of bytes to display. You can specify the address and size using numeric values or debug
expressions which enable you to position the memory display at the address of a variable or at the value of a
register. You can also specify whether you want the expressions to be evaluated each time the memory window
is updated, or you can re-evaluate them yourself with the press of a button. Memory windows update each time
your program stops on a breakpoint, after a single step and whenever you traverse the call stack. If any values
that were previously displayed have changed, they are highlighted in red.

To activate the first Memory window:
Choose View > Memory > Memory 1 or press Ctrl+T, M, 1.

Other register windows can be similarly activated.

Using the mouse
You can move the memory window's edit cursor by clicking on a data or text entry.

The vertical scroll bar can be used to modify the address being viewed by clicking the up and down buttons, the
page up and down areas or using the vertical scroll wheel when the scroll bar is at it's furthest extent. Holding

down the Shift key while scrolling will prevent the address being modified.

Using the keyboard

Keystroke Description

Up Mov§ the cursor up one ling, or if thf& cursor is on the
first line, move the address up one line.

Down Move the cursor down one line, or if the cursor is on
the last line, move the address down line line.

Left Move the cursor left one character.

Right Move the cursor right one character.

Home Move the cursor to the first entry.

End Move the cursor to the last entry.
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PageUp
PageDown

Ctrl+E

Editing memory

SEGGER Embedded Studio User Guide

Move the cursor up one page, or if the cursor is on first
page, move the address up one page.

Move the cursor down one page, or if the cursor is on
the last page, move the address down one page.

Toggle the cursor between data and text editing.

To edit memory, simply move the cursor to the data or text entry you want to modify and start typing. The

memory entry will be written and read back as you type.

Shortcut menu commands

The shortcut menu contains the following commands:

Action

Access Memory By Display Width
Address Order

Auto Evaluate

Auto Refresh

Export To Binary Editor

Save As

Load From

Display formats

Description
Access memory in terms of the display width.

Specify whether the address range shown uses
Address as the start or end address and whether
addresses should increment or decrement.

Re-evaluate Address and Size each time the Memory
window is updated.

Specify how frequently the memory window should
automatically refresh.

Create a binary editor with the current Memory
window contents.

Save the current Memory window contents to a file.
Supported file formats are Binary File, Motorola S-
Record File, Intel Hex File, TI Hex File, and Hex File.

Load the current Memory window from a file.
Supported file formats are Binary File, Motorola S-
Record File, Intel Hex File, Tl Hex File, and Hex File.

You can set the Memory window to display 8-bit, 16-bit, and 32-bit values that are formatted as hexadecimal,

decimal, unsigned decimal, octal, or binary. You can also specify how many columns to display.

Saving memory contents

You can save the displayed contents of the memory window to a file in various formats. Alternatively, you can

export the contents to a binary editor to work on them.
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You can save the displayed memory values as a binary file, Motorola S-record file, Intel hex file, or a Texas

Instruments TXT file.

To save the current state of memory to a file:

Select the start address and number of bytes to save by editing the Start Address and Size fields in the
Memory window toolbar.

Right-click the main memory display.

From the shortcut menu, select Save As, then choose the format from the submenu.

To export the current state of memory to a binary editor:

Select the start address and number of bytes to save by editing the Start Address and Size fields in the
Memory window toolbar.

Right-click the main memory display.

Choose Export to Binary Editor from the shortcut menu.

Note that subsequent modifications in the binary editor will not modify memory in the target.

Copying to clipboard

You can copy the contents of the memory window to the clipboard as text. If an address range is selected, the
data or text of the selected range will be copied to the clipboard depending on whether the selection has been
made in the data or text view. If no address range is selected, the current memory window view will be copied to
the clipboard.
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Breakpoints window

The Breakpoints window manages the list of currently set breakpoints on the solution. Using the Breakpoints

window, you can:

Enable, disable, and delete existing breakpoints.
Add new breakpoints.

Show the status of existing breakpoints.

Breakpoints are stored in the session file, so they will be remembered each time you work on a particular
project. When running in the debugger, you can set breakpoints on assembly code addresses. These low-level
breakpoints appear in the Breakpoints window for the duration of the debug run but are not saved when you

stop debugging.

When a breakpoint is reached, the matching breakpoint is highlighted in the Breakpoints window.

Breakpoints window layout
The Breakpoints window has a toolbar and a main breakpoint display.

Button Description

Create a new breakpoint using the New Breakpoint
dialog.

Toggle the selected breakpoint between enabled and
disabled states.

Remove the selected breakpoint.

Move the insertion point to the statement where the
selected breakpoint is set.

Delete all breakpoints.
Disable all breakpoints.

Enable all breakpoints.

LEE & e 3

Create a new breakpoint group and makes it active.

The main part of the Breakpoints window shows what breakpoints are set and the state they are in. You can

organize breakpoints into folders, called breakpoint groups.
SEGGER Embedded Studio displays these icons to the left of each breakpoint:

Icon Description
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Enabled breakpoint An enabled breakpoint will stop
P your program running when the breakpoint condition
is met.

Disabled breakpoint A disabled breakpoint will not
stop the program when execution passes through it.

7] Invalid breakpoint An invalid breakpoint is one
where the breakpoint cannot be set; for example, no
executable code is associated with the source code
line where the breakpoint is set or the processor does
not have enough hardware breakpoints.

Showing the Breakpoints window

To activate the Breakpoints window:

Choose Breakpoints > Breakpoints or press Ctrl+Alt+B.

Managing single breakpoints

You can manage breakpoints in the Breakpoint window.

To delete a breakpoint:

In the Breakpoints window, click the breakpoint to delete.

From the Breakpoints window toolbar, click the Delete Breakpoint} button.
To edit a breakpoint:

In the Breakpoints window, right-click the breakpoint to edit.
Choose Edit Breakpoint from the shortcut menu.
Edit the breakpoint in the New Breakpoint dialog.

To toggle the enabled state of a breakpoint:

In the Breakpoints window, right-click the breakpoint to enable or disable.

Choose Enable/Disable Breakpoint from the shortcut menu.
or

In the Breakpoints window, click the breakpoint to enable or disable.
Press Ctrl+F9.
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Breakpoint groups

Breakpoints are divided into breakpoint groups. You can use breakpoint groups to specify sets of breakpoints
that are applicable to a particular project in the solution or for a particular debug scenario. Initially, there is a

single breakpoint group, named Default, to which all new breakpoints are added.

To create a new breakpoint group:

From the Breakpoints window toolbar, click the New Breakpoint Group button.
or

From the Debug menu, choose Breakpoints then New Breakpoint Group.
or

Right-click anywhere in the Breakpoints window.

Choose New Breakpoint Group from the shortcut menu.
In the New Breakpoint Group dialog, enter the name of the breakpoint group.

When you create a breakpoint, it is added to the active breakpoint group.

To make a group the active group:

In the Breakpoints window, right-click the breakpoint group to make active.

Choose Set as Active Group from the shortcut menu.

To delete a breakpoint group:

In the Breakpoints window, right-click the breakpoint group to delete.

Choose Delete Breakpoint Group from the shortcut menu.

You can enable all breakpoints within a group at once.

To enable all breakpoints in a group:

In the Breakpoints window, right-click the breakpoint group to enable.

Choose Enable Breakpoint Group from the shortcut menu.

You can disable all breakpoints within a group at once.

To disable all breakpoints in a group:

In the Breakpoints window, right-click the breakpoint group to disable.
Choose Disable Breakpoint Group from the shortcut menu.

Managing all breakpoints

You can delete, enable, or disable all breakpoints at once.

133



SEGGER Embedded Studio Reference Manual SEGGER Embedded Studio User Guide

To delete all breakpoints:
Choose Breakpoints > Clear All Breakpoints or press Ctrl+Shift+F9.
or

On the Breakpoints window toolbar, click the Delete All Breakpoints button.

To enable all breakpoints:

Choose Breakpoints > Enable All Breakpoints or press Ctrl+B, N.
or

On the Breakpoints window toolbar, click the Enable All Breakpoints button.

To disable all breakpoints:
Choose Breakpoints > Disable All Breakpoints or press Ctrl+B, X.
or

On the Breakpoints window toolbar, click the Disable All Breakpoints button.
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Call Stack window

The Call Stack window displays the list of function calls (stack frames) that were active when program execution
halted. When execution halts, SEGGER Embedded Studio populates the call-stack window from the active
(currently executing) task. For simple, single-threaded applications not using the SEGGER Embedded Studio
tasking library, there is only a single task; but for multi-tasking programs that use the SEGGER Embedded Studio
Tasking Library, there may be any number of tasks. SEGGER Embedded Studio updates the Call Stack window

when you change the active task in the Threads window.

The Call Stack window has a toolbar and a main call-stack display.

Button Description

Move the insertion point to where the call was made
to the selected frame.

55

Set the debugger context to the selected stack frame.

Move the debugger context down one stack to the
called function.

> ¢ ¥

Move the debugger context up one stack to the calling
function.

Select the fields to display for each entry in the call
stack.

[

Set the debugger context to the most recent stack
frame and move the insertion point to the currently
executing statement.

tul

The main part of the Call Stack window displays each unfinished function call (active stack frame) at the point
when program execution halted. The most recent stack frame is displayed at the bottom of the list and the
oldest is displayed at the top of the list.

SEGGER Embedded Studio displays these icons to the left of each function name:

Icon Description

s Indicates the stack frame of the current task.

[ Indicates the stack frame selected for the debugger
context.

... Indicates that a breakpoint is active and when the

function returns to its caller.

These icons can be overlaid to show, for instance, the debugger context and a breakpoint on the same stack

frame.
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Showing the call-stack window

To activate the Call Stack window:

Choose View > Call Stack or press Ctrl+Alt+S.

Configuring the call-stack window

Each entry in the Call Stack window displays the function name and, additionally, parameter names, types, and
values. You can configure the Call Stack window to show varying amounts of information for each stack frame.
By default, SEGGER Embedded Studio displays all information.

To show or hide a field:

1. On the Call Stack toolbar, click the Options button on the far right.
2. Select the fields to show, and deselect the ones that should be hidden.

Changing the debugger context

You can select the stack frame for the debugger context from the Call Stack window.

To move the debugger context to a specific stack frame:
In the Call Stack window, double-click the stack frame to move to.
or

In the Call Stack window, select the stack frame to move to.
On the Call Stack window's toolbar, click the Switch To Frame button.

or

In the Call Stack window, right-click the stack frame to move to.

Choose Switch To Frame from the shortcut menu.

The debugger moves the insertion point to the statement where the call was made. If there is no debug
information for the statement at the call location, SEGGER Embedded Studio opens a disassembly window at the
instruction.

To move the debugger context up one stack frame:

On the Call Stack window's toolbar, click the Up One Stack Frame button.

or
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On the Debug Location toolbar, click the Up One Stack Frame button.
or
Press Alt+-.
The debugger moves the insertion point to the statement where the call was made. If there is no debug
information for the statement at the call location, SEGGER Embedded Studio opens a disassembly window at the
instruction.
To move the debugger context down one stack frame:
On the Call Stack window's toolbar, click the Down One Stack Frame button.
or
On the Debug Location toolbar, click the Down One Stack Frame button.
or
Press Alt++.

The debugger moves the insertion point to the statement where the call was made. If there is no debug
information for the statement at the call location, SEGGER Embedded Studio opens a disassembly window at the

instruction.

Setting a breakpoint on a return to a function

To set a breakpoint on return to a function:

In the Call Stack window, click the stack frame on the function to stop at on return.

On the Build toolbar, click the Toggle Breakpoint button.
or

In the Call Stack window, click the stack frame on the function to stop at on return.
Press F9.

or

In the Call Stack window, right-click the function to stop at on return.

Choose Toggle Breakpoint from the shortcut menu.
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Threads window

The Threads window displays the set of executing contexts on the target processor structured as a set of

queues.

To activate the Threads window:
Choose View > More Debug Windows > Threads or press Ctrl+Alt+H.

The window is populated using the threads script, which is a JavaScript program store in a file whose file-type

project option is "Threads Script” (or is called t hr eads. j s) and is in the project that is being debugged.

When debugging starts, the threads script is loaded and the function init() is called to determine which columns

are displayed in the Threads window.

When the application stops on a breakpoint, the function update() is called to create entries in the Threads
window corresponding to the columns that have been created together with the saved execution context
(register state) of the thread. By double-clicking one of the entries, the debugger displays its saved execution

contextto put the debugger back into the default execution context, use Show Next Statement.

Writing the threads script
The threads script controls the Threads window with the Threads object.

The methods Threads.setColumns, Threads.setSortByNumber and Threads.setColor can be called from the

function init().

function init()

{
Thr eads. set Col utms( " Nane", "Priority", "State", "Time");
Thr eads. set Sort ByNunber (" Ti me") ;
Thr eads. set Col or ("State", "Ready", "Executing", "Witing");

}

The above example creates the named columns Name, Priority, State, and Time in the Threads window, with
the Time column sorted numerically rather than alphabetically. The states Ready, Executing and Waiting will

have yellow, green and red colored pixmaps respectively.

If you don't supply the function init() in the threads script, the Threads window will create the default columns

Name, Priority, and State.

The methods Threads.clear(), Threads.newqueue(), and Threads.add() can be called from the function

update().
The Threads.clear() method clears the Threads window.

The Threads.newqueue() function takes a string argument and creates a new, top-level entry in the Threads
window. Subsequent entries added to this window will go under this entry. If you don't call this, new entries will

all be at the top level of the Threads window.
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The Threads.add() function takes a variable number of string arguments, which should correspond to the
number of columns displayed by the Threads window. The last argument to the Threads.add() function
should be an array (possibly empty) containing the registers of the thread or, alternatively, a handle that can
be supplied a call to the threads script function getregs(handle), which will return an array when the thread is
selected in the Threads window. The array containing the registers should have elements in the same order in
which they are displayed in the CPU Registers displaytypically this will be in register-number order, e.g., r0, r1,

and so on.

function update()
{
Threads. cl ear ();
Thr eads. newgueue(" My Tasks");
Thr eads. add(" Task1", "0", "Executing", "1000", [O,
Thr eads. add(" Task2", "1", "Witing", "2000", [O,1

The above example will create a fixed output on the Threads window and is here to demonstrate how to call the
methods.

To get real thread state, you need to access the debugger from the threads script. To do this, you can use
the JavaScript method Debug.evaluate("expression"), which will evaluate the string argument as a debug
expression and return the result. The returned result will be an object if you evaluate an expression that denotes

a structure or an array. If the expression denotes a structure, each field can be accessed by using its field name.
So, if you have structs in the application as follows

struct task {
char *nane;
unsi gned char priority;
char *state,;
unsi gned time;
struct task *next;
unsi gned registers[17];
unsi gned t hread_| ocal _storage[4];

b

struct task task2 =
{
"Task2",
i
"Wai ting",
2000,

0,

{01,23,4,5,6,7,8,9, 10, 11, 12, 13, 14, 15, 16 },
{ 01,23}

b

struct task taskl =
{
"Task1",
0,
"Executing",
1000,
&t ask2,
{01,2,34,56,7,8,9, 10, 11, 12, 13, 14, 15, 16 },
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{ 01,23}
b

you can update() the Threads window using the following:

taskl = Debug. eval uate("taskl");
Threads. add(taskl. nane, taskl.priority, taskl.state, taskl.tine, taskl.registers);

You can use pointers and C-style cast to enable linked-list traversal.

var next = Debug. eval uate("&t askl");
whi | e (next)
{

var xt = Debug. eval uate("*(struct task*)"+next);
Threads. add(xt.nane, xt.priority, xt.state, xt.time, xt.registers);
next = xt.next;

Note that, if the threads script goes into an endless loop, the debuggerand consequently SEGGER Embedded
Studiowill become unresponsive and you will need to kill SEGGER Embedded Studio using a task manager.

Therefore, the above loop is better coded as follows:

var next = Debug. eval uate("&t askl");

var count = O;

whil e (next && count < 10)

{

var xt = Debug.eval uate("*(struct task*)"+next);
Thr eads. add( xt.nane, xt.priority, xt.state, xt.time, xt.registers);
next = Xt.next;
count ++;

You can speed up the Threads window update by not supplying the registers of the thread to the Threads.add()
function. To do this, you should supply a handle/pointer to the thread as the last argument to the Threads.add()

function. For example:

var next = Debug. eval uat e(" &t ask1");
var count = O;
whil e (next && count < 10)

{

var xt = Debug.eval uate("*(struct task*)"+next);

Thr eads. add(xt.name, xt.priority, xt.state, xt.tine, next);
next =xt . next;

count ++;

When the thread is selected, the Threads window will call getregs(x) in the threads script. That function should

return the array of registers, for example:

function getregs(x)

{

return Debug. eval uate("((struct task*)"+x+")->registers");

}
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If you use thread local storage, implementing the gettls(x) function enables you to return the base address of
the thread local storage, for example:

function gettls(x)

{
}

return Debug. eval uate("((struct task*)"+x+")->thread_| ocal _storage");

The gettls(x) function can also be called with null as a parameter. In this case you will have to evaluate an

expression that returns the current thread local storage, for example:

function gettls(x)

{
if (x==null)
X = Debug. eval uat e(" &current Task") ;
return Debug. eval uate("((struct task*)"+x+")->thread_| ocal _storage");
}

The debugger may require the name of a thread which you can provide by implementing the getname(x)

function, for example:

function getnane(x)

{
}

return Debug. eval uate("((struct task*)"+x+")->nanme");

Adding extra queues to the threads window

You can add extra information to the threads window to display other RTOS queues. In the function init() you

can use Threads.setColumns2 to create an additional display in the threads window, for example:

function init()

{

Thr eads. set Col ums2("Ti mers", "1d(Timers)", "Nane", "Hook", "Timeout", "Period", "Active");

The first argument is identifier of the queue which is also supplied to Threads.add2 in the function update() as
follows

function update()

{

Thr eads. add2(" Ti mers", "Ox1FFOA30", "MTinmer", "O0x46C8 (Tinmer50)", "50(550)", "50", "1");
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Execution Profile window

The Execution Profile window shows a list of source locations and the number of times those source locations
have been executed. This window is only available for targets that support the collection of jump trace

information.
To activate the Execution Profile window:

Choose View > More Debug Windows > Execution Profile or press Ctrl+T, P.

The count value displayed is the number of times the first instruction of the source code location has been
executed. The source locations displayed are target dependent: they could represent each statement of the
program or each jump target of the program. If however the debugger is in intermixed or disassembly mode

then the count values will be displayed on a per instruction basis.

The execution counts window is updated each time your program stops and the window is visible so if you have

this window displayed then single stepping may be slower than usual.

142



SEGGER Embedded Studio Reference Manual SEGGER Embedded Studio User Guide

Execution Trace window

The trace window displays historical information on the instructions executed by the target.

To activate the Trace window:
Choose View > More Debug Windows > Execution Trace or press Ctrl+T, T.

The type and number of the trace entries depends upon the target that is connected when gathering trace
information. Some targets may trace all instructions, others may trace jump instructions, and some may trace

modifications to variables. You'll find the trace capabilities of your target on the shortcut menu.

Each entry in the trace window has a unique number, and the lower the number the earlier the trace. You can
click on the header to show earliest to latest or the latest to earliest trace entries. If a trace entry can have source

code located to it then double-clicking the trace entry will show the appropriate source display.
Some targets may provide timing information which will be displayed in the ticks column.

The trace window is updated each time the debugger stops when it is visible so single stepping is likely to be

slower if you have this window displayed.
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Debug file search editor

When a program is built with debugging enabled, the debugging information contains the paths and filenames
of all the source files for the program in order to allow the debugger to find them. If a program or library linked
into the program is on a different machine than the one on which it was compiled, or if the source files were

moved after the program was compiled, the debugger will not be able to find the source files.

In this situation, the simplest way to help SEGGER Embedded Studio find the source files is to add the directory
containing the source files to one of its source-file search paths. Alternatively, if SEGGER Embedded Studio

cannot find a source file, it will prompt you for its location and will record its new location in the source-file map.

Debug source-file search paths

Debug's source-file search paths can be used to help the debugger locate source files that are no longer located
where they were at compile time. When a source file cannot be found, the search-path directories will be
checked, in turn, to see if they contain the source file. SEGGER Embedded Studio maintains two debug source-

file search paths:

Project-session search path:This path is for the current project session and does not apply to all projects.

The global search path:This system-wide path applies to all projects.

The project-session search path is checked before the global search path.

To edit the debug search paths:

Choose Debug > Options > Search Paths.

Debug source file map

If a source file cannot be found while debugging and the debugger has to prompt the user for its location,

the results are stored in the debug source file map. The debug source file map simply correlates, or maps, the
original pathnames to the new locations. When a file cannot be found at its original location or in the debug
search paths, the debug source file map is checked to see if a new location has been recorded for the file or if the
user has specified that the file does not exist. Each project session maintains its own source file map, the map is
not shared by all projects.

To view the debug source file map:

Choose Debug > Options > Search Paths.

To remove individual entries from the debug source file map:

Choose Debug > Options > Search Paths.
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Right-click the mapping to delete.
Choose Delete Mapping from the shortcut menu.

To remove all entries from the debug source file map:

Choose Debug > Options > Search Paths.
Right-click any mapping.

Choose Delete All Mappings from the shortcut menu.
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Debug Terminal window

The Debug Terminal window displays debug output from the target application and can also be used to be

provide debug input to the target application.

To activate the Debug Terminal window:

Choose View > Debug Terminal.
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Breakpoint expressions

The debugger can set breakpoints by evaluating simple C-like expressions. Note that the exact capabilities
offered by the hardware to assist in data breakpointing will vary from target to target; please refer to the
particular target interface you are using and the capabilities of your target silicon for exact details. The simplest
expression supported is a symbol name. If the symbol name is a function, a breakpoint occurs when the first
instruction of the symbol is about to be executed. If the symbol name is a variable, a breakpoint occurs when the
symbol has been accessed; this is termed a data breakpoint. For example, the expression X will breakpoint when
xis accessed. You can use a debug expression (see Debug expressions) as a breakpoint expression. For example,
X[ 4] will breakpoint when element 4 of array x is accessed, and @ p will breakpoint when the sp register is

accessed.

Data breakpoints can be specified, using the == operator, to occur when a symbol is accessed with a specific
value. The expression X == 4 will breakpoint when x is accessed and its value is 4. The operators <, >=, >;, >=,
==, and = can be used similarly. For example, @p <= 0x1000 will breakpoint when register sp is accessed

and its value is less than or equal to 0x1000.

You can use the operator & to mask the value you wish to break on. For example, (x & 1) == 1 will

breakpoint when x is accessed and has an odd value.

You can use the operator && to combine comparisons. For example
(x >= 2) && (x <= 14)

will breakpoint when x is accessed and its value is between 2 and 14.

You can specify an arbitrary memory range using an array cast expression. For example, (char [ 256] )
(0x1000) will breakpoint when the memory region 0x10000x10FF is accessed.

You can specify an inverse memory range using the ! operator. For example ! (char [ 256] ) (0x1000) will

breakpoint when memory outside the range 0x10000x10FF is accessed.
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Debug expressions

The debugger can evaluate simple expressions that can be displayed in the Watch window or as a tool-tip in the

code editor.
The simplest expression is an identifier the debugger tries to interpret in the following order:

an identifier that exists in the scope of the current context.

the name of a global identifier in the program of the current context.
Numbers can be used in expressions. Hexadecimal numbers must be prefixed with 0x.
Registers can be referenced by prefixing the register name with @

The standard C and C++ operators !, ~,*,/ , %+, - ,>>,<<, <, <=,>,>=,==,| ,& ", &%, and | | are supported

on numeric types.

The standard assignment operators =, +=, - =, * =,/ =, %, >>, >>=, <<=, &=, | =, *= are supported on numeric

types.

The array subscript operator [] is supported on array and pointer types.

The structure access operator . is supported on structured types (this also works on pointers to structures), and -

> works similarly.

The dereference operator (prefix *) is supported on pointers, the address-of (prefix &) and sizeof operators are

supported.

The addr essof ( filename, linenumber) operator will return the address of the specified source code line

number.
Function calling with parameters and return results.

Casting to basic pointer types is supported. For example, (unsigned char *)0x300 can be used to display the

memory at a given location.

Casting to basic array types is supported. For example, (unsigned char[256])0x100 can be used to reference a

memory region.
Arrays can be sliced using [a:b] where a is the first element and b is the last element to display.

Operators have the precedence and associativity one expects of a C-like programming language.
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Terminal emulator window

The Terminal Emulator window contains a basic serial-terminal emulator that allows you to receive and transmit
data over a serial interface.
To activate the Terminal Emulator window:

Choose Tools > Terminal Emulator > Terminal Emulator or press Ctrl+Alt+M.

To use the terminal emulator:

1. Set the required terminal emulator properties.
2. Connect the terminal emulator to the communications port by clicking the button on the toolbar or by

selecting Connect from the shortcut menu.

Once connected, any input in the Terminal Emulator window is sent to the communications port and any data

received from the communications port is displayed on the terminal.

Connection may be refused if the communication port is in use by another application or if the port doesn't
exist.

To disconnect the terminal emulator:

1. Disconnect the communications port by clicking the Disconnect icon on the toolbar or by right-clicking

to select Disconnect from the shortcut menu.

This will release the communications port for use in other applications.

Supported control codes

The terminal supports a limited set of control codes:

Control code Description

<BS> Backspace

<CR> Carriage return

<LF> Linefeed

<ESC>[{attr1};....{attrn}m Set display attributes. The attributes 2-Dim, 5-Blink, 7-

Reverse, and 8-Hidden are not supported.

149



SEGGER Embedded Studio Reference Manual SEGGER Embedded Studio User Guide

150



SEGGER Embedded Studio Reference Manual

Command-line options

This section describes the command-line options accepted by SEGGER Embedded Studio.

Usage

emStudio [options] [files]
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-D (Define macro)

Syntax

-D macro=value

Description

Define a SEGGER Embedded Studio macro value.
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-noclang (Disable Clang support)

Syntax

-noclang

Description

Disable Clang support.
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-noload (Disable loading of last project)

Syntax

-noload

Description

Disable loading of last project on startup.
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-packagesdir (Specify packages directory)

Syntax

-packagesdir dir

Description

Override the default value of the $(PackagesDir) macro.
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-permit-multiple-studio-instances (Permit multiple
studio instances)

Syntax

-permit-multiple-studio-instances

Description

Allow multiple instances of SEGGER Embedded Studio to run at the same time. This behaviour can also be
enabled using the Environment > Startup Options > Allow Multiple SEGGER Embedded Studios environment
option.
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-rootuserdir (Set the root user data directory)

Syntax

-rootuserdir dir

Description

Set the SEGGER Embedded Studio root user data directory.
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-save-settings-off (Disable saving of environment
settings)

Syntax

-save-settings-off

Description

Disable the saving of modified environment settings.
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-set-setting (Set environment setting)

Syntax

-set-setting environment_setting=value

Description
Sets an environment setting to a specified value. For example:

-set-setting "Environment/Buil d/ Show Conmand Li nes=Yes"
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-templatesfile (Set project templates path)

Syntax

-templatesfile path

Description

Sets the search path for finding project template files.
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Embedded Studio

Uninstalling SEGGER Embedded Studio

This section describes how to completely uninstall SEGGER Embedded Studio for each supported operating

system:

Uninstalling SEGGER Embedded Studio from Windows
Uninstalling SEGGER Embedded Studio from macOS
Uninstalling SEGGER Embedded Studio from Linux

Uninstalling SEGGER Embedded Studio from Windows

Removing user data and settings

The uninstaller does not remove any user data such as settings or installed packages. To completely remove the
user data you will need to carry out the following operations for each user that has used SEGGER Embedded

Studio on your system.
To remove user data using SEGGER Embedded Studio:

1. Start SEGGER Embedded Studio.
2. Click Tools > Admin > Remove All User Data...

Alternatively, if SEGGER Embedded Studio has already been uninstalled you can manually remove the user data

as follows:

1. Click the Windows Start button.
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S T

Type %LOCALAPPDATA% in the search field and press enter to open the local application data folder.
Open the SEGGER folder.

Open the SEGGER Embedded Studio folder.

Delete the v8 folder.

If you want to delete user data for all versions of the software, delete the SEGGER Embedded Studio folder

as well.

Uninstalling SEGGER Embedded Studio

To uninstall SEGGER Embedded Studio:

vk N =

If SEGGER Embedded Studio is running, click File > Exit to shut it down.

Click the Start Menu and select Control Panel. The Control Panel window will open.

In the Control Panel window, click the Uninstall a program link under the Programs section.
From the list of currently installed programs, select SEGGER Embedded Studio 8.22a.

To begin the uninstall, click the Uninstall button at the top of the list.

Uninstalling SEGGER Embedded Studio from macOS

Removing user data and settings

Uninstalling does not remove any user data such as settings or installed packages. To completely remove the

user data you will need to carry out the following operations for each user that has used SEGGER Embedded

Studio on your system.

To remove user data using SEGGER Embedded Studio:

1.
2.

Start SEGGER Embedded Studio.
Click Tools > Admin > Remove All User Data...

Alternatively, if SEGGER Embedded Studio has already been uninstalled you can manually remove the user data

as follows:

1. Open Finder.

2. Go to the SHOME/Library/SEGGER/SEGGER Embedded Studio directory.

3.

4. If you want to delete user data for all versions of the software, drag the SEGGER Embedded Studio folder to

Drag the v8 folder to the Trash.

the Trash as well.

Uninstalling SEGGER Embedded Studio

To uninstall SEGGER Embedded Studio:
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1. If SEGGER Embedded Studio is running, shut it down.
2. Open the /Applications/SEGGER folder in Finder.
3. Drag the SEGGER Embedded Studio 8.22a folder to the Trash.

Uninstalling SEGGER Embedded Studio from Linux

Removing user data and settings

The uninstaller does not remove any user data such as settings or installed packages. To completely remove the
user data you will need to carry out the following operations for each user that has used SEGGER Embedded

Studio on your system.
To remove user data using SEGGER Embedded Studio:

1. Start SEGGER Embedded Studio.
2. Click Tools > Admin > Remove All User Data...

Alternatively, if SEGGER Embedded Studio has already been uninstalled you can manually remove the user data

as follows:

1. Open a terminal window or file browser.
Go to the SHOME/.segger/SEGGER Embedded Studio directory.
Delete the v8 directory.

> W

If you want to delete user data for all versions of the software, delete the SEGGER Embedded Studio

directory as well.

Uninstalling SEGGER Embedded Studio
To uninstall SEGGER Embedded Studio:

1. If SEGGER Embedded Studio is running, click File > Exit to shut it down.

2. Open a terminal window.

3. Go to the SEGGER Embedded Studio bin directory (this is /opt/SEGGER/segger_embedded_studio_8.22a/
bin by default).

4. Run sudo ./uninstall to start the uninstaller.
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The SEGGER Compiler

The SEGGER Compiler

Embedded Studio

You can use the SEGGER compiler by setting the project option Compiler to SEGGER.
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The SEGGER Linker

The SEGGER Linker

Embedded Studio

You can use the SEGGER linker by setting the project option Linker to SEGGER.

167



SEGGER Embedded Studio Reference Manual The SEGGER Linker

168



SEGGER Embedded Studio Reference Manual

The SEGGER Runtime Library

Embedded Studio

The SEGGER Runtime Library

The SEGGER runtime library is used by default.
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Embedded Studio

Utilities Reference
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Command-Line Compiler

This section describes the switches accepted by the compiler driver, cc. The compiler driver is capable of
controlling compilation by all supported language compilers and the final link by the linker. It can also construct

libraries automatically.

File naming conventions

The compiler driver uses file extensions to distinguish the language the source file is written in. The compiler

driver recognizes the extension .c as C source files, .s and .asm as assembly code files.

The compiler driver recognizes the extension .hzo as object files, .hza as library files and .xml as special-purpose
XML files.

We strongly recommend that you adopt these extensions for your source files and object files because you'll find

that using the tools is much easier if you do.

Clanguage files

When the compiler driver finds a file with a .c extension, it runs the C compiler to convert it to object code.

Alternatively you can specify that it is a C file using

cc -x ¢ cfile.notc ...

Assembly language files

When the compiler driver finds a file with a .s or .asm extension, it runs the C preprocessor and then the

assembler to convert it to object code. Alternatively you can specify that it is an assembly language file using

cc -x asmasnfile.nots ...

Object code files

When the compiler driver finds a file with a .hzo or .hza extension, it passes it to the linker to include it in the

final application.

Compilation

To compile or assemble a file you should supply the -c option together with the source file and provide a name

for the output file using the -o option

cc -c file.c -o file.o
if you don't supply an output name then the output file will be use the basename of the source file.
You can supply the file to be compiled from the standard input using the

cC -C - -0 main.o
int main()
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{

}
<ECF>

return 3;

You can preprocess the source file rather than compile it using the -E option
cc -E main.c
This will send the output to the standard output or you can use -o to send it to a named file.
You can show the preprocessor defines that are defined for the compilation using the -dM option
cc -E-dMmain.c
You can supply preprocessor defines and include directories using -D and -l options
cc -c file.c -Dnydefine -Inyincludedir
You can include a file before compilation using -include
cc -c file.c -include file.h
There is also a variant that will just use the #defines that are declared in the included file
cc -c file.c -imacros file.h

If you wish to not use the default C/C++ library you can use -I- and then supply your own system library directory

using -isystem

cc -c file.c -1- -isystemmysysteni ncludedir

You can using the -g option to include debugging information in the output file
cc -c file.c -g

You can use the -O option to set the desired optimization level

cc -c file.c -00

Linking

You can compile/link a number of files with the standard libraries

cc Cortex_MStartup.s thunmb_crt0.s main.o -o nain.elf

You'll also need to supply linker control details. There are a number of ways of doing this

cc .. -placenent ram pl acenent.xnl -placenmentsegnents "SRAM RW 0x0 0x1000" -ereset_handl er
cc .. -nenorymap map. xm - pl acement segments " SRAM RW 0x0 0x1000" -ereset_handl er
cc .. -Tlinker.icf -ereset_handl er
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Target Selection

Advanced

You can create a precompile header using the -pch option
cc -c -xc -pch main.h -o main.h.pch

Note that the output file must be in the same directory as the input file. You can use this precompiled header file
cC -c nmmin.c -include-pch main.h.pch

You can create a C++ 20 module using
cct++ -Cc -xc++ main.cxx -std=c++20 -fnodul es-ts -fnodul e-file=nai n=main.o -o main.o

The module file will be named either .gcm or .pcm and can be used by another file using

cc++ -c -Xc++ anot her.cxx -std=c++20 -fnodul es-ts -fnodul e-fil e=mai n=nain.o -0 another.o

Options:

Option Description

- input is taken from standard input

- #H# show commands but don't execute them

-allownul tiple-definition allow multiple symbol definition when linking

- ansi enforce ANSI checking

-ar create library from input files

-ar ch=val set cpu architecture to 'val', use list to display
supported

-arm generate ARM code

- ar nb4 generate ARM64 code

- be big endian target

- be8 big endian target

-builtins use builtin compiler functions

-C compile the files, no link/library

-cnsel i b=l create cmse output library in 'I'

- codec=c set file codec to 'c', use list to display supported

- common allocate global variables in the common section

- cpu=val set cpu core to 'val', use list to display supported

- depend file generate dependency file in ‘file'

- dependufile generate dependency file in 'file' with user header files
only
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-dM show #defines

- Dnane define the preprocessor macro 'name’

- Dnane=val define the preprocessor macro 'name’ as 'val'

- dnane=val define the linker symbol 'name’ as 'val'

-E preprocess file and write to standard output
-emt-rel ocs emit relocations into executable

- enane set program entry symbol to 'name’

- exceptions enable C++ exceptions

- Fbin create an additional binary output file
-fbuiltin enable compiler builtin functions

- f conmon place global variables in COMMON section
-fcoroutines enable C++ coroutine support

- fdebug-t ypes-section generate .debug_types section

- f di agnosti cs- col or =al ways color diagnostic output of the compiler

- f di agnosti cs- col or =never do not color diagnostic output of the compiler
- fdi agnosti cs- show- car et show caret in diagostic output of the compiler
-fexceptions enable C++ exception support

- Fhex create an additional hex output file

-fill=b fill gaps in the additional output file with byte 'b'
-flto generate code suitable for link time optimization
-fmat h-errno set errno after calling math functions
-fmodul e-fi | e=' nane’ get module dependencies from the file 'name’
-fmodul es-ts enable c++20 modules

-fno-builtin disable compiler builtin functions

- f no- conmon place global variables in bss section

-f no- di agnosti cs- show- car et do not show caret in diagostic output of the compiler
-fno- excepti ons disable C++ exception support

-fno-mat h-errno set errno after calling math functions
-fno-om t-frane-pointer disable framepointer generation

-fno-rtti disable C++ RTTI support

-fno-short - enuns enumerations are int sized

-fno-short -wchar wide characters are 32-bit

- f no- si gned- char char is considered to be unsigned char
-fomt-frame-pointer disable framepointer generation
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- f pabi =hard generate FPU instructions passing fp arguments in FPU
registers

- f pabi =sof t do not generate FPU instructions

-f pabi =sof tfp generate FPU instructions passing fp arguments in
CPU registers

- f pu=val set fpu to 'val', use list to display supported

- franmepoi nt er generate code to maintain a frame pointer register

-freti enable C++ RTTI support

-fshort-enuns enumerations are minimal container sized

-fshort-wchar wide characters are 16-bit

- f si gned- char char is considered to be signed char

-Fsrec create an additional srec output file

-ftree-vectorize perform vectorization on trees

-funwi nd-t abl es generate unwind tables

-9l generate only backtrace and line number debugging
information

-g2 generate level 1 and variable display debugging
information

-03 generate level 2 and macro display debugging
information

-gcc use gcc assembler/compiler/Ito

-gcc-target =nane select gcc 'name’ tools to use

- gdwarf - 2 generate dwarf-2 debugging information

- gdwarf -3 generate dwarf-3 debugging information

-gdwarf -4 generate dwarf-4 debugging information

-gdwar f -5 generate dwarf-5 debugging information

-gnu-1d use gnu linker

- gpubnanes generate .debug_pubnames and .debug_pubtypes
sections

- hascnse v8m architecture has cmse instructions

-hascrc v8a architecuture has crc instructions

-hascrypto v8a architecture has crypto instructions

- hasdsp v8m architecture has dsp instructions

- hasi di v v7ar architecture has integer divide instructions

-hassmal I nul tiplier cortex-m0/mO0+/m1 architecture has small multiplier

- heap=basi c use basic heap implementation

- heap=m ni nal use minimal heap implementation
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- heap=rt

-hel p
-1 -
-ldir

nmacr os file
ncl ude file

ncl ude- pch file

nput fi |l es file
nst r ument
o=none

o=rtt

o=sem host

o=sem host f

0=sSWo

0=SWOI

- i syst emdir
-Jddir

-kasm

- ki nd

-kl dscri pt

-klto

- Knane

- kpp

- 1i bdir dir

-l nane

-1 ocal es=m ni nal

-l ongcal I s

-1 unwi nd

-M

Utilities Reference

use real-time heap implementation

show this text

do not search any standard directories for include files
add 'dir' to the end of the user include search list
same as -include but only keep #defines

#include 'file' before the source file

#include precompiled header 'file' before the source
file

list of files in 'file' to link or archive

instrument functions

use user supplied implementation for library io
use RTT implementation for library io

use semihosted implementation for library io

use host formatted semihosted implementation for
library io

use SWO implementation for library io

use SWO with interrupts disabled implementation for
library io

add 'dir' to the end of the system include search list
add 'dir' to the end of the system include search list
keep assembly code output

keep indirect files

keep generated linker script

keep Ito generated files

keep symbol 'name' in the linked output

keep preprocessor output

disable linking of standard libraries

search directory 'dir' to find libraries

little endian target

specify system library directory 'dir'

search library 'name’ to resolve symbols

locales implementation

generate long calling instruction sequences
generate stack unwind tables

generate linkage map file
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- mar ch=val
-marm

- mhe8

- nmbi g- endi an
-ntnse

- ncpu=val

- menor ynap file
- MENDr ymapmacr oS macros

-nf | oat - abi =val

-nf pl6-f or mat =i eee

- nf pu=val
-nittle-endi an
- mo-t hunb-i nt er wor k

-mo- unal i gned- access

-t hunb

- nt p=soft

-munal i gned- access

-n
-nodefaul tlibs
- noshort enuns
- noshort wchar
-nostderr

- nost di nc
-nostdlib

- nowar n- enunsi ze

- nowar n- m snat ch

- nowar n- r wx- segnent s

- nowar n- wchar si ze

Utilities Reference

set cpu architecture to 'val', use list to display
supported

generate arm code

big endian target

big endian target

v8m architecture has cmse instructions

set cpu core to 'val', use list to display supported
supply memory map file in ‘file'

define macros for memory map file in 'macros'

specify the floating-point abi to use, val can be 'soft’,
'softfp’, 'hard'

specify the format of the __fp16 half-precision
floating-point type

set fpu to 'val', use list to display supported
little endian target
do not generate interworking code for v4t architecture

disable unaligned word and half-word load/store
instructions

generate thumb code, default is to generate ARM code
for processors that support it

specify the thread local storage model

enable unaligned word and half-word load/store
instructions

show commands but don't execute them

disable linking of standard libraries

enumerations are int sized

wide characters are 32-bit

redirect output from stderr to stdout

do not search any standard directories for include files
disable linking of standard libraries

no linker warning on mismatched enum sized input
files

no linker warning on mismatched architecture input
files

no linker warning on load segments with RWX
permissions

no linker warning on mismatched wchar sized input
files
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- o file leave output in ‘file'

-Q0 set optimization level to level 0

-0 set optimization level to level 1

-2 set optimization level to level 2

- set optimization level to level 3

-Cs set optimization level to optimize for size

-z set optimization level to optimize for more size

- pat ch cmd run 'cmd' after link but before the creation of the

additional output file

- pch generate a precompiled header file

- pedanti c warning on non-standard language usage

-pedantic-errors error on non-standard language usage

- pl acenent file supply placement file in 'file'

- pl acenent macr 0os macros define macros for placement file in 'macros’

- pl acenent segnent s segments memory segments for placement in 'segments'

-printf=d[I1][w double, optional long long, optional wchar

-printf=f[I1][w float, optional long long, optional wchar

-printf=i[p][W integer, optional width and precision, optional wchar

-printf=l1[p][wW long long integer, optional width and precision,
optional wchar

- Rc, nane name the default code section to 'name’

- Rd, nane name the default data section to 'name'

- Rk, nanme name the default const section to 'name'

-rtti enable C++ rtti

- Rz, nane name the default bss section to 'name’

-scanf=d[I1]][c] double, optional long long, optional %][...] and %][A...]
character class

-scanf=l1[c] long long integer, optional %l...] and %[A...] character
class

- segger use SEGGER assembler/compiler/Ito

-segger-1d use SEGGER linker

-short enuns enumerations are minimal container sized

-short wchar wide characters are 16-bit

- si md=neon generate simd vector processing code

-stack-si zes generate stack-sizes section
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-std=s

-stop
-stripdebug
-stripsynbol s
- synbol s=s
-Tfile

-t humb

- unwi ndt abl es
-v
-vectori ze
-W

-w

- VW4, X

-W, X

-we

-\Veérror

-W, x

-Xt

-xa

- xasm
-xassenbl er-wi t h-cpp
- XC

- XC++

-Xli nker x

- X0

Utilities Reference

set language standard to 's', use list to display
supported

generate stack overflow protection code

strip debug information from linked executable
strip symbols from linked executable

link symbols file 's' into executable

use ‘file' as linker script

generate thumb code, default is to generate ARM code
for processors that support it

generate stack unwind tables

show command lines as they are executed

enable auto vectorization code generation

supply option to the compiler

suppress warnings

pass 'x' to the assembler

pass 'x' to the compiler

treat warnings as errors

treat warnings as errors

pass 'x' to the linker

subsequent files are considered to be of file type 't'
subsequent files are considered to be library files
subsequent files are considered to be assembly code
subsequent files are considered to be assembly code
subsequent files are considered to be C code
subsequent files are considered to be C++ code

pass 'x' to the linker

subsequent files are considered to be object code
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Command-Line Project Builder

emBuild is a program used to build your software from the command line without using SEGGER Embedded

Studio. You can, for example, use emBuild for nightly (automated) builds, production builds, and batch builds.

Building with a SEGGER Embedded Studio project file

You can specify a SEGGER Embedded Studio project file:

Syntax
emBuild [options] project-file
You must specify a configuration to build using -config. For instance:

enBuild -config "V5T Thunb LE Rel ease" arm enProj ect

The above example uses the configuration V5T Thumb LE Release to build all projects in the solution contained

in arm.emProject.
To build a specific project that is in a solution, you can specify it using the -project option. For example:

enBuild -config "V5T Thunb LE Rel ease" -project "libni" |ibc.enProject

This example will use the configuration V5T Thumb LE Release to build the project libm that is contained in

libc.emProject.

If your project file imports other project files (using the <import> mechanism), when denoting projects you must

specify the solution names as a comma-separated list in parentheses after the project name:
enBuild -config "V5T Thunb LE Rel ease" -project "libc(C Library)" arm enProject

libc(C Library) specifies the libc project in the C Library solution that has been imported by the project file

arm.emProject.

To build a specific solution that has been imported from other project files, you can use the -solution option.

This option takes the solution names as a comma-separated list. For example:
enBui |l d -config "ARM Debug" -solution "ARM Targets, EB55" arm enPr oj ect

In this example, ARM Targets,EB55 specifies the EB55 solution imported by the ARM Targets solution, which

was itself imported by the project file arm.emProject.
You can do a batch build using the -batch option:

enBuild -config "ARM Debug" -batch |ibc. enProj ect

This will build the projects in libc.emProject that are marked for batch build in the configuration ARM Debug.
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By default, a make-style build will be donei.e., the dates of input files are checked against the dates of output
files, and the build is avoided if the output is up to date. You can force a complete build by using the -rebuild
option. Alternatively, to remove all output files, use the -clean option.

To see the commands being used in the build, use the -echo option. To also see why commands are being
executed, use the -verbose option. You can see what commands will be executed, without executing them, by

using the -show option.

Building without a SEGGER Embedded Studio project file

To use emBuild without a SEGGER Embedded Studio project, specify the name of an installed project template,

the name of the project, and the files to build. For example:

enBuild -config -tenplate LMBS EXE -project nyproject -file main.c
Or, instead of a template, you can specify a project type:

enBuild -config -type "Library" -project nyproject -file main.c
You can specify project properties with the -property option:

enBuild -property Target=LM3S811

Options:

Option Description

- bat ch batch build

-cl ean remove all output and intermediate files

- confi g 'name’ (batch) build in 'name’ configuration

- D'name'='value' set global macro $('name’) to 'value'
-echo show command lines as they are executed
-export-build show the command lines and dependencies
-file'name' add file 'name’ to template-created project
-hel p show help text

- keepgoi ng keep building when errors occur
-nostderr redirect output from stderr to stdout
-houni ty disable unity building

- packagesdi r 'name' set $(PackagesDir) to 'name'

- proj ect 'name’ (batch) build 'name’ project

- property 'name'='value set project property 'name' to 'value'

-rebuild always do the build steps
-sconfi g 'name' solution properties are set in 'name’ configuration
- show show the build steps but don't execute them
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-sol uti on'name' (batch) build 'name' solution

- sproperty 'name'='value' set solution property 'name' to 'value'

- studi odi r 'name' set $(StudioDir) to 'name’

-t enpl at e 'name’ create the project from the template 'name’
-tenpl at esfi | e 'path’ get project template files from 'path'

-t hreadnum'n’ use 'n' threads for build

-time show time taken

-type 'type' create the project from the project 'type'
-ver bose show build information
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Command-Line Simulator

emSim is a program that allows you to run SEGGER Embedded Studio's instruction set simulator from the

command line.

The primary purpose of emSim is to enable command line tests to be run. The debug 1/O provided by SEGGER

Embedded Studio is supported, as are command line arguments and exit.

emSim will accept a single elf file, it will allocate and load memory regions based on the program sections in the
elf file. emSim will start execution from the entry point symbol contained in the elf file. emSim will terminate
when exit is called or execution reaches a specified symbol.

Example

Assuming that app.c contains the following

#i ncl ude <stdio. h>
#i ncl ude <stdlib. h>

i nt

mai n(int argc, const char *argv[])

{
int i;
for (i = 1; i < argc; i++)

printf("argv[%] =%\n", i, argv[i])

exi t (EXI T_SUCCESS) ;

}

and app.elf has been built with the preprocessor definition FULL_LIBRARY then
enSi m app.elf hello world
will produce the output

argv[ 1] =hell o
argv[ 2] =world

if the debug I/0 implementation has to set breakpoints or poll memory locations then you can supply the name

of the symbol to breakpoint on that will enable the debug I/O
enSi m app. el f -startup _ startup_conplete hello world

if the application uses memory that isn't allocated in the elf file then you can supply the memory segments that

the simulator should create

enSi m app. el f -segnments 0x08000000; 0x10000; 0x20000000; 0x10000

and there is an alternative form of this
enSi m app. el f -nmenory-segnents "FLASH RX 0x08000000 0x10000; SRAM RWK 0x20000000 0x10000"

The simulator attempts to determine the machine architecture from data in the elf file this can be override using
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If the simulator doesn't support the architecture then the the list of supported architectures will be displayed.

The simulator will start executing at the entry point symbol in the elf file. If the application doesn't set the stack
pointer then you can supply this

ent5i m app. el f -stackpointer __stack_end__

If the application doesn't call exit then you can supply a symbol to breakpoint on that will terminate the

simulation

enSi m app.elf -end _Exit

You can show an instruction trace

enSi m app. el f -trace

Which will show the addresses of instructions, the instruction opcode and the disassembly

0x000002d8 E59F003C I dr r0, =0xE01FCO00
0x000002dc E3A01000 nov rl, #0
0x000002e0 E5801000 str r1, [rO]
0x000002e4 E3A01003 mov rl, #3
0x000002e8 E5801004 str rl, [r0, #4]
0x000002ec E3A01002 nov rl, #2

You can display the instruction execution counts at the end of the simulation
enSi m app. el f -counts
Which will show the addresses of instructions, with the number of times executed

0x08000298=1
0x0800029a=1

0x080008ac=278
0x080008ae=2

You can supply a list of memory word values to simulate ROM or hardware status registers
enSi m app. el f -val ues "0xE0082000=0x FEEDFACE"
Which will always return OXFEEDFACE when the address 0xE0082000 is read or fetched.
Similarly to you can supply a list of memory half word values
entSi m app. el f -val ues2 "0xE0082000=0xFACE; 0xE0082000=0x FEED"
The address is evaluated as a debug expression so you can supply symbol names
entSi m app. el f -val ues2 " Syst enl ni t =0x8082"

Which will cause the simulator to execute a RISC-V return instruction when Systeminit is called.
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Usage:

entsi mfile [options] args

Option Description

-arch'd Specify architecture to simulate

-ar chlist List supported architectures

-counts Show execution counts when the simulation ends

-end's' Specify the symbol to end simulation

-max 'c Specify the maximum number of instructions to
simulate

- menor y- segment s 'name [access] start size;' Specify the list of memory segments

- segnent s 'start;size;’ Specify the list of memory segments

- st ackpoi nter 's' Specify the starting stackpoint symbol

-startup's' Specify the startup completion point symbol

-trace Show instruction execution

- val ues 'address=value;' Specify a list of memory word values to simulate

- val ues?2 'address=value;' Specify a list of memory half word values to simulate
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Command-Line Scripting

emScript is a program that allows you to run SEGGER Embedded Studio's JavaScript (ECMAScript) interpreter

from the command line.

The primary purpose of emScript is to facilitate the creation of platform-independent build scripts.

Syntax

emScript [options] file
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Command-line options

This section describes the command-line options accepted by emScript.
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-define (Define global variable)

Syntax

-define variable=value

Description
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-help (Show usage)

Syntax

-help

Description

Display usage information and command line options.
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-load (Load script file)

Syntax

-load path

Description

Loads the script file path.
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-define (Verbose output)

Syntax

-verbose

Description

Produces verbose output.
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emScript classes

emScript provides the following predefined classes:

BinaryFile
CWSys
WScript

193

Utilities Reference



SEGGER Embedded Studio Reference Manual Utilities Reference

Example uses

The following example demonstrates using emScript to increment a build number:
First, add a JavaScript file to your project called i ncbui | d. j s containing the following code:

function incbuild()

{
var file = "buil dnum h"
var text = "#define BU LDNUMBER "
var s = CWBys.readStringFronFile(file)
var n;
if (s == undefined)
n=1
el se
n = eval (s.substring(text.length)) + 1;
CWBys. writeStringToFile(file, text + n);
}

/| Executed when script | oaded.
i ncbuild();

Add afile called get bui | dnum h to your project containing the following code:

#1 f ndef GETBUI LDNUM_H
#def i ne GETBUI LDNUM_H

unsi gned get Bui | dNunber () ;

#endi f

Add afile called get bui | dnum ¢ to your project containing the following code:

#i ncl ude "getbuil dnum h"
#i ncl ude "bui | dnum h"

unsi gned get Bui | dNunber ()
{

}

return BU LDNUMBER;

Now, to combine these:

Set the Build Options > Always Rebuild project property of get bui | dnum c to Yes.
Set the User Build Step Options > Pre-Compile Command project property of get bui | dnum ¢ to
"$(StudioDir)/bin/emScript" -load "$(ProjectDir)/incbuild.js".
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Embed

Embed is a program that converts a binary file into a C/C++ array definition.

The primary purpose of the Embed tool is to provide a simple method of embedding files into an application.
This may be useful if you want to include firmware images, bitmaps, etc. in your application without having to
read them first from an external source.

Syntax

embed variable_name input_file output _file

variable_name is the name of the C/C++ array to be initialised with the binary data.

input_file is the path to the binary input file.

output_file is the path to the C/C++ source file to generate.

Example

To convert a binary file image.bin to a C/C++ file called image.h:
enbed ing i mage. bi n i nage. h
This will generate the following output in image.h:

static const unsigned char ing[] = {
0x5B, 0x95, 0xA4, 0x56, 0x16, Ox5F, 0x2D, 0x47,
0xC5, 0x04, 0xD4, 0x8D, 0x73, 0x40, 0x31, 0x66,
Ox3E, 0x81, 0x90, 0x39, O0xA3, Ox8E, 0x22, 0x37,
0x3C, 0x63, 0xC8, 0x30, 0x90, 0xO0C, 0x54, OxA4,
OxA2, 0x74, 0xC2, 0x8C, 0x1D, 0x56, 0x57, 0xO05,
0x45, OxCE, 0x3B, 0x92, OxAD, 0x0B, 0x2C, 0x39,
0x92, 0x59, 0xB9, 0x9D, 0x01, 0x30, 0x59, Ox9F,
0xC5, OxEA, OxCE, 0x35, OxF6, 0x4B, 0x05, OxBF
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Command-Line License Manager

The emLicense program can be used to install, remove and list licenses from the command line.

Usage Description

enLi cense install license-strings... Install licenses

enli cense list List all installed licenses

enLi cense remove license-ids... Remove licenses

Option Description

-erase-all -existing Erase all existing licenses when installing
-ver bose Produce verbose output

The install command can be used to install licenses:

$ enLicense install |icense-strings...

The list command can be used to list installed licenses:

$ enlicense i st

Product: SEGGER Enbedded Studio

Et hernet MAC Address Lock: 01-02-03-04-05-06 (CK)
Li censed to: Joe Bl oggs

Li cense I D: 00010203- 04050607- 08090A0B- 0CODOEOF

The remove command can be used to uninstall licenses:

$ enLicense renpve 00010203-04050607- 08090A0B- 0CODOEOF
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Linker script file generator

The command line program mkld generates a GNU Id linker script from a SEGGER Embedded Studio memory
map or section placement file.
Syntax
mkld -memory-map-file inputfile outputfile [options]
mkld -memory-map-segments segments outputfile [options]
Description

inputfile is the name of the SEGGER Embedded Studio memory map file to generate the Id script from.
segments is a list of memory segments of the form SegmentName RWX Address Size
outputfile is the the name of the Id script file to write.
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Command-line options

This section describes the command-line options accepted by mkid.
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-check-section-overflow

Syntax

-check-section-overflow

Description

Add checks for memory section overflow to the linker script.
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-check-segment-overflow

Syntax

-check-segment-overflow

Description

Add checks for memory segment overflow to the linker script.
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-disable-missing-runin-error

Syntax

-disable-missing-runin-error

Description

Discard any sections with a missing run in section.
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-memory-map-macros

Syntax

-memory-map-macros macro=value[;macro=valuel

Description

Define SEGGER Embedded Studio macros to use when reading a memory map file.
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-no-check-unplaced-sections

Syntax

-no-check-unplaced-sections

Description

Removes checks for unplaced memory sections from the linker script.
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-no-ctors

Syntax

-no-ctors

Description

Ignore the .ctors section.
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-no-dtors

Syntax

-no-ctors

Description

Ignore the .dtors section.
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-section-placement-file

Syntax

-section-placement-file filename

Description

Generate a GNU Id linker script from the SEGGER Embedded Studio section placement file filename. If this option
is used, a memory map file should also be specified with the -memory-map-file option.
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-section-placement-macros

Syntax

-section-placement-macros macro=value;macro=value]

Description

Define SEGGER Embedded Studio macros to use when reading a section placement file.
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-symbols

Syntax

-symbols symbol=value[;symbol=value]

Description

Add extra symbol definitions to the Id linker script.

208



SEGGER Embedded Studio Reference Manual Utilities Reference

Package Generator

To create a package the program mkpkg can be used. The set of files to put into the package should be

in the desired location in the $( PackagesDi r) directory. The mkpkg command should be run with
$(PackagesDi r) asthe working directory and all files to go into the package must be referred to using
relative paths. A package must have a package description file that is placed in the $( PackagesDi r) /
packages directory. The package description file name must end with _package. xm . If a package is to
create entries in the new project wizard then it must have a file name pr oj ect _t enpl at es. xni .

For example, a package for the mythical FX150 processor would supply the following files:

A project template file called t ar get s/ FX150/ pr oj ect _t enpl at es. xmri . The format of the
project templates file is described in Project Templates file format.

The $( PackagesDi r) -relative files that define the functionality of the package.

A package description file called packages/ FX150_package. xm . The format of the package
description file is described in Package Description file format.

The package file FX150. hzg would be created using the following command line:
nkpkg -c packages/ FX150. hzq t ar get s/ FX150/ proj ect _tenpl ates. xml  packages/ FX150_package. xm
You can exclude specific files or directories from being added to a package using the -exclude option:

nmkpkg -c packages/ FX150. hzq t arget s/ FX150 -excl ude targets/FX150/ excluded\file.txt -exclude
t ar get s/ FX150/ excl uded_di rect ory packages/ FX150_package. xni

You can list the contents of the package using the -t option:
nkpkg -t packages/ FX150. hzq
You can remove an entry from a package using the -d option:
nkpkg -d packages/ FX150. hzq -d fil enane
You can add or replace a file into an existing package using the -r option:
nkpkg -r packages/ FX150. hzq -r fil enane
You can extract files from an existing package using the -x option:
nkpkg -x packages/ FX150. hzq out put _directory
You can automate the package creation process using a Combining project type.

Using the new project wizard create a combining project in the directory $( PackagesDi r)
Set the Output File Path property to be $( PackagesDi r) / packages/ nypackage. hzq
Set the Combine command property to $( St udi oDi r) / bi n/ nkpkg -c¢

$( Conbi ni ngQut put Fi | ePat h) $( Conbi ni ngRel | nput Pat hs)

Add the files you want to go into the package into the project using the Project Explorer
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Right-click the project node in the Project Explorer and choose Build

When a package is installed, the files in the package are copied into the desired $( PackagesDi r) -relative

locations. When afile is copied into the $( PackagesDi r ) / packages directory and its filename ends with
_package. xml thefile $( PackagesDi r)/ packages/ i nst al | ed_packages. xm is updated with an

entry:

<include fil enane="FX150_package. xm " />

During development of a package you can manually edit this file. The same applies to the file
$(PackagesDir)/targets/project_tenplates.xm which will contain a reference to your

proj ect tenpl ates. xmnl file.

Usage:
nkpkg [options] package_filename file1 file2

Option

-C
- conpr ess level

-d

- excl ude path

-f

-overwite

-no-date

-r

-readonl y

-set - attr attribute=value

-sub- arch-endi an
-sub-arch-endi an-conpatiblity
- sub- base-type type
-sub-no-descri pti on-nodi fy

- sub- r egexp name suffix regexp

- sub-t ype type
-t
-V

-V

Description
Create a new package.

Change compression level (0 for none, 9 for
maximum).

Remove files from a package.

Exclude path when adding files to a package.

Output files to stdout.

Overwrite existing files.

Do not add date attribute to package.

Replace files in a package.

Force all files to have read only attribute.

Set package attribute to value.

Create architecture and endian specific sub packages.

Create architecture and endian specific sub packages
including compatibility packages for versions of the
IDE that don't have $( Li bEndi an) macro.

Specify the type description of the base package.
Do not modify sub package descriptions.

Create sub package containing files matching regular
expression.

Specify the type description of the sub packages.
List the contents of a package.
Be chatty.

Show version information.
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Option Description

- X Extract files from a package.

See also Command-line Package Manager.
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Command-Line Package Manager

The pkg program can be used to download, install, remove and search for packages from the command line.

Usage

pkg hi st ory package_names...

pkg i nstall package names...

pkg install -rmanual package.files...
pkg |i st

pkg |i st -installed

pkg |i st -installed-names

pkg | i st -dependencies package_names...
pkg | i st -dependents package_names...
pkg renove package_names...

pkg renove -all

pkg sear ch keywords...

pkg update

pkg upgrade

pkg upgr ade package_names...

Option

- Dmacro=value

- keepgoi ng

-l egacy

-nodel et e
-noverify

- out put f or mat string
- packagesdi r directory
- packagesur| url

- qui et

-root userdi r directory
-verbose

-yes

Macro
$(Descri ption)
$( Nane)

Description

List version history of packages
Download and install packages
Manually install package files
List all available packages

List installed packages

List installed package names
List package dependencies

List dependent packages
Remove packages

Remove all packages

Search for packages

Update list of available packages
Upgrade all installed packages
Upgrade selected packages

Description

Set a global macro

Continue when errors occur

Include legacy packages

Don't delete downloaded packages after installation
Don't verify downloaded packages

Specify list/search output format string

Set the packages directory to be directory
Set the URL of the packages website to be ur/
Do not output any progress messages

Set the root user data directory to directory
Produce verbose output

Answer yes to all questions without prompting

Description
Package description

Package name
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Macro Description
$(Title) Package title
$( Ver si on) Package version

Before you can download, install or search for packages you must first update the local list of available packages:
$ pkg update
The search command can be used to search for a specific package:

$ pkg search |ibcxx
I'ibcxx_arm- ARM |ibcxx Library Package (1.1)

The install command can be used to install a package:
$ pkg install |ibcxx_arm
The list command can be used to list installed packages:

$ pkg list -installed
libcxx_arm- ARM Ilibcxx Library Package (1.1)

The history command can be used to show package history:

$ pkg history libcxx_arm
I'i bcxx_arm - 1ibcxx Library Package [ ARM

1.1 (Installed)
- Fixed nane of Type Interpretation File.

1.0
- Initial rel ease.

Specific versions of a package can be installed:
$ pkg install libcxx_arm1.0

The upgrade command can be used to upgrade to the latest version of a package:
$ pkg upgrade |ibcxx_arm

The remove command can be used to uninstall a package:
$ pkg renove |ibcxx_arm

See also Package Generator.
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File formats

This section describes the file formats SEGGER Embedded Studio uses:

Memory Map file format

Describes the memory map file format that defines memory regions and registers in a microcontroller.

Section Placement file format
Describes the section placement file format that maps program sections to memory areas in the target

microcontroller.

Project file format
Describes the format of SEGGER Embedded Studio project files.

Project Templates file format
Describes the format of project template files used by the New Project wizard.

Property Groups file format

Describes the format of the property groups file you can use to define meta-properties.

Package Description file format
Describes the format of the package description files you use to create packages other users can install in
SEGGER Embedded Studio.

External Tools file format
Describes the format of external tool configuration files you use to extend SEGGER Embedded Studio.

Debugger Type Interpretation file format
Describes the format of the debugger type interpretation file.
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Memory Map file format

SEGGER Embedded Studio memory-map files are structured using XML syntax for its simple construction and

parsing.

The first entry of the project file defines the XML document type used to validate the file format.
<! Board_Menory_Definition_File>

The next entry is the Root element. There can only be one Root element in a memory map file:
< name="My Board">

A Root element has a nane attribute every element in a memory map file has a nane attribute. Names should
be unique within a hierarchy level. Within a Root element, there are Menor ySegnent elements that represent

regions within the memory map.

< nane="My Board">
< name="Fl ash" start="0x1000" size="0x200" access="ReadOnly">

Menor ySegrent elements have the following attributes:

start:The start address of the memory segment. A simple expression, usually a hexadecimal number with
a Ox prefix.

size:The size of the memory segment. A simple expression, usually a hexadecimal number with a 0x prefix.
access:The permissible access types of the memory segment. One of ReadOnl y, Read/ Wi te,
WiteOnly,orNone.

address_symbol:A symbolic name for the start address of the memory segment.

size_symbol:A symbolic name for the size of the memory segment.

end_symbol:A symbolic name for the end address of the memory segment.

Regi st er G- oup elements are used to organize registers into groups. Regi st er elements are used to define

peripheral registers:

< nane="My Board" >
< name="Systen' start="0x2000" size="0x200" >
< nane="Peri pheral 1" start="0x2100" size="0x10" >
< name="Regi ster1" start="+0x8" size="4" >

Regi st er G oup elements have the same attributes as Menor ySegment elements. Regi st er elements

have the following attributes:

name:Register names should be valid C/C++ identifier names, i.e., alphanumeric characters and
underscores are allowed but names cannot start with a number.

start:The start address of the memory segment. Either a C-style hexadecimal number or, if given a + prefix,
an offset from the enclosing element's start address.

size:The size of the register in bytes, either 1, 2, or 4.
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access:The same as the access attribute of the Menor ySegrent element.
address_symbol:The same as the addr ess_synbol attribute of the Menor ySegment element.

A Regi st er element can contain Bi t Fi el d elements that represent the bits in a peripheral register:

< nanme="My Board" >
< name="Syst em' start="0x2000" size="0x200" >
< nane="Peri pheral 1" start="0x2100" size="0x10" >
< nane="Regi ster1" start="+0x8" size="4" >
< nanme="Bits 0 _to 3" start="0" size="4" />

Bi t Fi el d elements have the following attributes:

name:The same as the nane attribute of the Regi st er G oup element.
start:The starting bit position, 031.
size:The total number of bits, 132.

ABi tfi el delementcan contain Enumelements:

< nane="My Board" >
< name="Peri pheral 1" start="0x2100" size="0x10" >
< nanme="Regi ster1" start="+0x8" size="4" >
< name="Bits 0 to 3" start="0" size="4" />
< nane="Enun8" start="3" />
< name="Enunb" start="5" />

You can import CMSIS SVD files (see http://www.onarm.com/) into a memory map using the | mpor t SVD

element:

< filenane="$(TargetsDir)/targets/Manufacturerl/ Processorl.svd. xm ">

Thef i | enan® attribute is an absolute filename which is macro-expanded using SEGGER Embedded Studio

system macros.

When a memory map file is loaded either for the memory map viewer or to be used for linking or debugging, it is
preprocessed using the (as yet undocumented) SEGGER Embedded Studio XML preprocessor.
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Section Placement file format

SEGGER Embedded Studio section-placement files are structured using XML syntax to enable simple

construction and parsing.

The first entry of the project file defines the XML document type used to validate the file format:
<! Li nker _Pl acenent _Fi |l e>

The next entry is the Root element. There can only be one Root element in a memory map file:
< nane="Fl ash Pl acenent" >

A Root element has a nane attribute. Every element in a section-placement file has a nane attribute. Each
name should be unique within its hierarchy level. Within a Root element, there are Menor ySegnent elements.
These correspond to memory regions defined in a memory map file that will be used in conjunction with the

section-placement file when linking a program. For example:

< nane="Fl ash Pl acenent" >
< nane="FLASH' >

A Menor ySegnent contains Progr anSect i on elements that represent program sections created by the C/
C++ compiler and assembler. The order of Pr ogr anSect i on elements within a Menor ySegnent element
represents the order in which the sections will be placed when linking a program. The first Pr ogr anfSect i on

will be placed first and the last one will be placed last.

< name="My Board" >
< nane="FLASH' >
< name=".text">

Pr ogr antect i on elements have the following attributes:

address_symbol:A symbolic name for the start address of the section.

alignment.The required alignment of the program section; a decimal number specifying the byte
alignment.

end_symbol:A symbolic name for the end address of the section.

load:If Yes, the section is loaded. If No, the section isn't loaded.

runin:This specifies the name of the section to copy this section to. Multiple sections can be specified
separated by a semicolon, the first section that exists will be used.

size:The optional size of the program section in bytes, a hexadecimal number with a Ox prefix. The macro
S(SEGMENT_SIZE_REMAINING) can be used for size calcuations based on the remaining number of bytes in
the segment.

size_symbol:A symbolic name for the size of the section.

start:The optional start address of the program section, a hexadecimal number with a Ox prefix.

When a section placement file is used for linking it is preprocessed using the (as yet undocumented) SEGGER

Embedded Studio XML preprocessor.
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Project file format

SEGGER Embedded Studio project files are held in text files with the . enPr 0j ect extension. Because you may
want to edit project files, and perhaps generate them, they are structured using XML syntax to enable simple

construction and parsing.
The first entry of the project file defines the XML document type used to validate the file format:

<! CrossStudi o_Project _File>

The next entry is the sol ut i on element; there can only be one sol ut i on element in a project file. This
specifies the solution name displayed in the Project Explorer and has a version attribute that defines the file-
format version of the project file. Solutions can contain projects, projects can contain folders and files, and

folders can contain folders and files. This hierarchy is reflected in the XML nestingfor example:

< versi on="1" Nane="sol uti onnanme" >
< Nane="pr oj ect nane" >
< Nane="fil enane" />
< Nanme="f ol der nane" >
< Name="fi | enane2" />
</ >
</ >
</ >

Note that each entry has a Nane attribute. Names of pr oj ect elements must be unique to the solution, and

names of f ol der elements must be unique to the project, but names of files do not need to unique.

Eachfi |l e element musthaveaf i | e_namne attribute that is unique to the project. Ideally, the f i | e_namne
is a file path relative to the project (or solution directory), but you can also specify a full file path, if you want to.
File paths are case-sensitive and use "/" as the directory separator. They may contain macro instantiations, so file

paths cannot contain the "$" character. For example
< file_nane="$(StudioDir)/source/crt0.s" Nane="crt0.s" />
will be expanded using the value of $(StudioDir) when the file is referenced from SEGGER Embedded Studio.

Project properties are held in configuration elements with the Nane attribute of the configuration element
corresponding to the configuration name, e.g., "Debug". At a given project level (i.e., solution, project, folder),
there can only be one named configuration elementi.e., all properties defined for a configuration are in single

configuration element.

< Name="pr oj ect nane" >

< proj ect type="Library" Nane="Conmon" />

< Narme="Rel ease" buil d_debug_i nf or mati on="No" />
</ >

You can use the i nport element to link projects:

< file nanme="target/libc.enProject" />
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Project Templates file format

The SEGGER Embedded Studio New Project dialog works from a file called pr oj ect _t enpl at es. xm in the
t ar get s subdirectory of the SEGGER Embedded Studio installation directory. Because you may want to add

your own new project types, they are structured using XML syntax to enable simple construction and parsing.
The first entry of the project file defines the XML document type used to validate the file format:
<! Project Tenplates Fil e>

The next entry is the pr 0] ect s element, which is used to group a set of new project entries into an XML

hierarchy.
< >
< >
</ >

Each entry has a pr oj ect element that contains the class of the project (attribute capt i on), the name of the
project (attribute nane), its type (attribute t ype) and a description (attribute descri pt i on). For example:

< capti on="ARM Eval uat or 7T" nane="Execut abl e"
description="An executable for an ARM Eval uator7T." type="Executabl e"/>

The project type can be one of these:

Executable: a fully linked executable.
Library: a static library.

Object file: an object file.

Staging: a staging project.
Combining: a combining project.

Externally Built Executable: an externally built executable.

The configurations to be created for the project are defined using the conf i gur at i on element, which must
have a nane attribute:

< nane="ARM RAM Rel ease"/ >

The property values to be created for the project are defined using the pr oper t y element. If you have a
defined value, you can specify this using the val ue attribute and, optionally, set the property in a defined
confi gurati on,such as:

< nane="target _reset_script" configurati on="RAM
val ue="Eval uat or 7T_Reset Wt hRamAt Zero()" />

Alternatively, you can include a property that will be shown to the user, prompting them to supply a value as

part of the new-project process.

< name="11i nker _out put_format"/>
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The folders to be created are defined using the f ol der element. The f ol der element must have a hane

attribute and can also haveaf i | t er attribute. For example:
< nanme="Source Files" filter="c;cpp;cxx;cc;h;s;asminc" />

The files to be in the project are specified using the f i | e element. You can use build-system macros (see
Project macros) to specify files located in the SEGGER Embedded Studio installation directory. Files will be
copied to the project directory or just left as references, depending on the value of the sour ce attribute:

< nanme="nmai n. ¢c" source="$(Studi oDir)/sanpl es/ Shared/ main.c"/>
< nane="$( St udi oDir)/source/thunb_crt0.s"/>

You can define the set of configurations that can be referred to in the top-level conf i gur at i ons element:

< >
< >
</ >

This contains the set of all configurations that can be created when a project is created. Each configuration is
defined using a conf i gur at i on element, which can define the property values for that configuration. For

example:

< nane="Debug" >
< name="bui | d_debug_i nf or mati on" val ue="Yes">
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Property Groups file format

The SEGGER Embedded Studio project system provides a means to create new properties that change a number
of project property settings and can also set C pre-processor definitions when selected. Such properties are
called property groups and are defined in a property-groups file. The property-group file to use for a project

is defined by the Property Groups File property. These files usually define target-specific properties and are

structured using XML syntax to enable simple construction and parsing.

The first entry of the property groups file defines the XML document type, which is used to validate the file
format:

<! CrossStudi o_G oup_Val ues>

The next entry is the pr oper t yG oups element, which is used to group a set of property groups entries into
an XML hierarchy:

<

<gr ouphdot s
</ propertyG oups>

Each group has the name of the group (attribute namne), the name of the options category (attribute gr oup),
short (attribute shor t ) and long (attribute | ong) help descriptions, and a default value (attribute def aul t ).

For example:

< short="Target Processor" group="Build Options" short="Target Processor"
| ong="Sel ect a set of target options" nane="Target" default="STRO12FWM4" />

Each group has a number of gr oupEnt r y elements that define the enumerations of the group.

Each gr oupEnt r y has the name of the entry (attribute nane), e.g.:

< nanme="STR910FWB2" >

A gr oupEnt ry has the property values and C pre-processor definitions that are set when the gr oupEnt ry is
selected; they are specified with pr oper t y and cdef i ne elements. For example:

< >
< >
< >
< >
</ >
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A pr opert y element has the property's name (attribute nan®e), its value (attribute val ue), and an optional
configuration (attribute conf i gur at i on):

< nane="11inker_nmenory_map_file"
val ue="$(Studi oDir)/targets/ST_STRO1x/ ST_STR910FMB2_Menor yMap. xm " />

A cdef i ne element has the C preprocessor name (attribute nane) and its value (attribute val ue):

< val ue="STR910FM32" nane="TARGET_PROCESSCR' />
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Package Description file format

Package-description files are XML files used by SEGGER Embedded Studio to describe a support package, its
contents, and any dependencies it has on other packages.

Each package file must contain one package element that describes the package. Optionally, the package
element can contain a collection of f i | e, hi st ory,and docunent at i on elements to be used by SEGGER
Embedded Studio for documentation purposes.

The filename of the package-description file should match that of the package and end in "_package.xm/".

Below is an example of two package-description files. The first is for a base chip-support package for the

LPC2000; the second is for a board-support package dependent on the first:

Philips_LPC2000_package.xml

<! CrossStudi o_Package Description_Fil e>
< cpu_manuf act urer ="Phi |l i ps" cpu_fam | y="LPC2000" version="1.1" ses_versions="8:1-"
aut hor =" SEGGER' >
< file name="$(TargetsDir)/Philips_ LPC210X/ arm target_ Philips_LPC210X. ht nf
title="LPC2000 Support Package Docunentation" />
< file_name="$(TargetsDir)/Philips_LPC210X/ Loader.enProject" title="LPC2000 Loader
Application Solution" />
< title="System Files">
< file_nanme="$(TargetsDir)/Philips_LPC210X/ Philips_LPC210X_Startup.s" title="LPC2000
Startup Code" />
< file_nane="$(TargetsDir)/Philips_LPC210X/ Philips_LPC210X Target.js" title="LPC2000
Target Script" />
</ >
< >
< name="1. 1" >
< >Corrected LPC21xx header files and menory nmaps to include GPIO ports 2
and 3. </ >
< >Modi fi ed | oader nmenmory map so that .libmem sections will be placed
correctly. </ >
</ >
< nane="1.0" >
< >l nitial Release.</ >
</ >
</ >
< >
< nanme="Supported Targets">
<p>Thi s CPU support package supports the follow ng LPC2000 targets:
< >
<l >LPC2103</ || >
<l >LPC2104</ || >
<l >LPC2105</ | i >
<l i >LPC2106</ || >
<l I >LPC2131</ || >
<l >LPC2132</ || >
<l >LPC2134</ || >
<l 1 >LPC2136</! | >
<l >LPC2138</| | >
</ ul >
</ p>
</ >
</ >
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</ >

CrossFire_LPC2138_package.xml

<! CrossSt udi o_Package_Descri ption_Fil e>

< cpu_manuf acturer="Philips" cpu_fam |y="LPC2000" cpu_nane="LPC2138"
boar d_manuf act urer =" Rowl ey Associ ates" board_nanme="CrossFire LPC2138"
dependenci es="Phi | i ps_LPC2000" version="1.0">

< file_name="$(Sanpl esDir)/CrossFire_LPC2138/ CrossFire_LPC2138. enProj ect”
title="CrossFire LPC2138 Sanpl es Sol ution" />
< file_nane="$(Sanpl esDir)/CrossFire_LPC2138/ctl/ctl.enProject"” title="CrossFire
LPC2138 CTL Sanpl es Sol ution" />
</ >

Package elements

The package element describes the support package, its contents, and any dependencies it has on other

packages. Valid attributes for this element are:

Attribute
aut hor

boar d_rmanuf act urer

board_name

conpany_name

cpu_famly

cpu_nanuf act urer

cpu_name

description

dependenci es

installation_directory

repl aces

Description
The author of the package.

The manufacturer of the board supported by the
package (if omitted, CPU manufacturer will be used).

The name of the specific board supported by the
package (only required for board-support packages).

The name of the company to group the package under
in the package dialogs. (if omitted, the Board/CPU
manufacturer will be used).

The family name of the CPU supported by the package
(optional).

The manufacturer of the CPU supported by the
package.

The name of the specific CPU supported by the
package (may be omitted if the CPU family is specified).

A description of the package (optional).

A semicolon-separated list of packages the package
requires to be installed in order to work (optional).

The directory in which the package should be installed
(optional - if undefined, defaults to "$(PackagesDir)").

A semicolon-separated list of package names listing
the packages that this package replaces. The replaced
packages are marked as legacy packages and are only
visible in the package manager if the if the Include
Legacy Packages option is selected (optional).
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deprecat ed If set to true, indicates that the package has been
deprecated. Deprecated packages are marked as
legacy packages and are only visible in the package
manager if the if the Include Legacy Packages option is
selected (optional).

ses_versions A string describing which version of SEGGER
Embedded Studio supports the package. The format of
the string is target_id_number:version_range_string.

title A short description of the package (optional).

uninstalls A semicolon-separated list of packages names listing
the packages to be uninstalled if this package is
installed (optional).

version The package version number.

File elements

Thefi | e elementis used by SEGGER Embedded Studio for documentation purposes by adding links to files of

interest within the package such as example project files and documentation.

Attribute Description
file_nane The file path of the file.
title A description of the file.

Optionally, f i | e elements can be grouped into categories using the gr oup element.

Group elements

The gr oup element is used for categorizing files described by f i | e elements into a particular group.

Attribute Description
title Title of the group.
History elements

The hi st or y element is used to hold a description of the package's version history.

The hi st or y element should contain a collection of ver si on elements.

Version element

The ver si on element is used to hold the description of a particular version of the package.
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Attribute Description

nane The name of the version being described.

The ver si on element should contain a collection of descri pt i on elements.

Description elements

Each descri pt i on element contains text that describes a feature of the package version.

Documentation elements

The docunent at i on element is used to provide arbitrary documentation for the package.

The document at i on element should contain a collection of one or more sect i on elements.

Section elements
The sect i on element contains package documentation in XHTML format.

Attribute Description

name The title of the documentation section.

target_id_number

The following table lists the possible target ID numbers:

Target ID
ARM 8
RISC-V 20

version_range_string
Thever si on_range_st ri ng can be any of the following:

version_number:The package will only work on version_number.

version_number-:The package will work on version_number or any future version.
-version_number:The package will work on version_number or any earlier version.
low_version_number-high_version_number:The package will work on low_version_number,

high_version_number or any version in between.
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External Tools file format

SEGGER Embedded Studio external-tool configuration files are structured using XML syntax for its simple

construction and parsing.

Tool configuration files

The SEGGER Embedded Studio application will read the tool configuration file when it starts up. By default,
SEGGER Embedded Studio will read the file $(StudioUserDir)/tools.xml.

Structure

All tools are wrapped in a tools element:
< >
</ >
Inside the tools element are item elements that define each tool:

< >
< nanme="1 ogi cal nane">

</ >
</ >

The item element requires an name attribute, which is an internal name for the tool, and has an optional wait
element. When SEGGER Embedded Studio invokes the tool on a file or project, it uses the wait element to
determine whether it should wait for the external tool to complete before continuing. If the wait attribute is not

provided or is set to yes, SEGGER Embedded Studio will wait for external tool to complete.
The way that the tool is presented in SEGGER Embedded Studio is configured by elements inside the

element.

menu

The menu element defines the wording used inside menus. You can place a shortcut to the menu using an

ampersand, which must be escaped using &amp in XML, before the shortcut letter. For instance:

< > PC-1int (Unit Check)</ >

text

The optional text element defines the wording used in contexts other than menus, for instance when the tool
appears as a tool button with a label. If text is not provided, the tool's textual appearance outside the menuis

taken from the menu element (and is presented without an shortcut underline). For instance:
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< >PC-lint (Unit Check)</ >

tip
The optional tip element defines the status tip, shown on the status line, when moving over the tool inside
SEGGER Embedded Studio:

< >Run a PC-lint unit checkout on the selected file or folder</ >

key

The optional key element defines the accelerator key, or key chord, to use to invoke the tool using the keyboard.
You can construct the key sequence using modifiers Ctrl, Shift, and Alt, and can specify more than one key in a

sequence (note: Windows and Linux only; OS X does not provide key chords). For instance:

< SCirl+L, Crl +l </ >

message

The optional message element defines the text shown in the tool log in SEGGER Embedded Studio when

running the tool. For example:

< >Linting</ >

match

The optional match element defines which documents the tool will operator on. The match is performed using
the file extension of the document. If the file extension of the document matches one of the wildcards provided,

the tool will run on that document. If there is no match element, the tool will run on all documents. For instance:

< >* ¢;*. cpp</ >

output

The optional output element defines the name of the output file created by the tool. If this element is specified
the the output file will be opened in the editor when the tool has finished execution. The macros $(InputPath)

and $(InputBaseName) can be used to name the output file. For Instance:

< >$( | nput BaseNane) . t xt </ >

commands

The commands element defines the command line to run to invoke the tool. The command line is expanded
using macros applicable to the file derived from the current build configuration and the project settings. Most

importantly, the standard $(InputPath) macro expands to a full pathname for the target file.
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Additional macros constructed by SEGGER Embedded Studio are:

$(DEFINES) is the set of -D options applicable to the current file, derived from the current configuration
and project settings.
S(INCLUDES) is the set of -1 options applicable to the current file, derived from the current configuration

and project settings.

For instance:

< >
$(LINTDIR)/ | i nt-nt -i$(LINTDIR) /I nt $(LINTDIR)/ | nt/co-gcc. | nt
$(DEFI NES) $(INCLUDES) -D_GNUC__ -u -b +nmacros -w2 -e537 +fie +ffn -wi dth(0,4) -hFl
-format =% : % : %C:. s% : s%n $( | nput Pat h)
</ >

In this example we intend $(LINTDIR) to point to the directly where PC-lint is installed and for $(LINTDIR) to
be defined as a SEGGER Embedded Studio global macro. You can set global macros using Tools > Options >

Building > Global Macros.

Note that additional &quot entities are placed around pathnames in the commands sectionthis is to ensure
that paths that contain spaces are correctly interpreted when the command is executed by SEGGER Embedded
Studio.
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Debugger Type Interpretation file format

SEGGER Embedded Studio debugger type interpretation files are used by the debugger to provide list and string
displays of C++ template container types. The files are structured using XML syntax for its simple construction

and parsing.
Consider the following C++ template type

tenmpl ate <cl ass _Type> cl ass VeryBasi cArray

{

private:
size_ t m Count;
_Type *m pDat a;
publi c:
VeryBasi cArray(size_t count)
m Count ( count)
m pDat a( new _Type[ count])

}
Ver yBasi cArray<i nt> basi cArray(5);
To display a variable of this type as a list the type interpretation file contains the following entry
< Nanme="VeryBasi cArrayé&l t; *&gt ;"
Head="( ($(T)*) HEAD) . m pDat a"
Dat a=" (*( $( T0) *) CURRENT) "

Lengt h="(($(T)*) HEAD) . m Count "
Next =" CURRENT+si zeof ($(T0))"/>

The Name attribute is used to match the template type name note that the &It and &gt xml entities are used to

match the template argument.

When an entry has been matched the head of the list is located by evaluating the debugger expression in the
Head attribute. The debugger expressions can contain macros that refer to the matched template type and will
use the symbols HEAD and CURRENT.

The macro $(T) refers to the instantiated template type, for the above example $(T)=VeryBasicArray<int>.
The template arguments are referred to using macros $(T0), for the above example $(T0)=int.

The symbol HEAD is the address of the variable being displayed, for the above example if the variable
basicArray is allocated at address 0x20004000 then the Head expression

((VeryBasi cArray<i nt >*) 0x20004000) . m pDat a

will be evaluated by the debugger, note that the . operator and the -> operator are equivalent in debugger

expressions.

To display an element the debugger will evaluate the Data expression. This expression contains the symbol
CURRENT which is the address of the element to display, for the above example the first element is at the
address basicArray.m_pData which is allocated at address 0x20008000 then the Data expression
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(*(i nt*) 0x20008000)

will be evaluated by the debugger.

To increment the CURRENT symbol the Next expression
0x20008000+si zeof (i nt)

will be evaluated by the debugger.

Before the CURRENT symbol is incremented the debugger needs to check if it is at the end of list. The can be

done either as a Condition expression or as a Length expression
((VeryBasi cArray<i nt >*) 0x20004000) . m_Count

The String display is simpler than the List display since the characters are contiguous and optionally null

terminated. The Data and Length expressions are supported, for example

< Name="stri ng"
Data="*(($(T) *)HEAD)._M start_of _storage. _M data"
Lengt h="(($(T) *)HEAD). M finish-(($(T) *)HEAD). M start_of storage. Mdata"/>

is used to display STLPort std::string types.
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Appendices

Building Environment Options

Build

Property

Automatically Build Before Debug
Envi ronnment /Bui | d/ Bui | d Before
DebugBoolean

Confirm Automatically Build Before Debug
Envi ronment / Bui | d/ Show Bui | d Before
DebugBoolean

Confirm Debugger Stop
Envi ronnent / Bui | d/ Confi rm Debugger
St opBoolean

Display ETA
Envi ronnent / Bui | d/ Di spl ay ETABoolean

Display Progress Bar
Envi ronnent / Bui | d/ Di spl ay Progress
Bar Boolean

Echo Build Command Lines
Envi r onnent / Bui | d/ Show Conmand
Li nesBoolean

Echo Raw Error/Warning Output
Envi r onnent / Bui | d/ Show Unpar sed Error
Qut put Boolean

Find Error After Building
Envi ronnment/Bui | d/ Find Error After
Bui | dBoolean

Global Macros
Envi ronnent / Macr os/ G obal Macr osStringList

Keep Going On Error
Envi ronnent / Bui | d/ Keep Goi ng On
Er r or Boolean

Save Project File Before Building
Envi ronnent / Bui | d/ Save Project File On
Bui | dBoolean

Show Build Information
Envi r onnent / Bui | d/ Show Bui | d
| nf or mat i onBoolean

Description

Enables auto-building of a project before downloading
if it is out of date.

Enables the display of the auto-building popup.

Present a warning when you start to build that requires
the debugger to stop.

Selects whether to attempt to compute and display
the ETA on building.

Selects whether to display progress bar on building.

Selects whether build command lines are written to
the build log.

Selects whether the unprocessed error and warning
output from tools is displayed in the build log.

Moves the cursor to the first diagnostic after a build
completes with errors.

Build macros that are shared across all solutions and

projects e.g. paths to library files.

Build doesn't stop on error.

Selects whether to save the project file prior to build.

Show build information.
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Build Acceleration

Property

Disable Unity Build
Envi ronnment / Bui | d/ Di sabl e Unity
Bui | dBoolean

Parallel Building Threads
Envi ronnent / Bui | d/ Bui | di ng
Thr eadsIntegerRange

Build Log

Property

Order

Envi ronnent / Bui | d Log/ Or der Enumeration

Show Command Lines
Envi ronnent/Bui | d
Li nesBoolean

Log/ Show Conmmand

Show Errors

Envi ronnent / Bui | d Log/ Show Err or sBoolean

Show Notes

Envi ronnent / Bui | d Log/ Show Not esBoolean

Show Other Lines
Envi ronnent/ Bui | d
Li nesBoolean

Log/ Show C her

Show Warnings

Envi ronment / Bui | d Log/ Show War ni ngsBoolean

Window

Property

Show Build Log On Build
Envi ronnent / Show Transcri pt On
Bui | dBoolean

Appendices

Description
Ignore Unity Build project properties and always build

individual project components.

The number of threads to launch when building.

Description
Specifies whether the build log output is ordered by
time or by building thread.

Selects whether to show or hide lines containing build
commands in the build log.

Selects whether to show or hide lines containing errors
in the build log.

Selects whether to show or hide lines containing notes
in the build log.

Selects whether to show or hide unclassified lines in
the build log.

Selects whether to show or hide lines containing
warnings in the build log.

Description

Show the build log when a build starts.
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Appendices

Debugging Environment Options

Breakpoint

Property

Disassembly Breakpoints
Envi r onment / Debugger / Di sassenbl y
Br eakpoi nt sBoolean

Focus On Breakpoint
Envi r onnent / Debugger / Focus On
Br eakpoi nt Boolean

Debug Terminal

Property

Debug Terminal Command Line
Debug Ter m nal / Debug Ter i nal Cormmand
Li neString

Debug Terminal TTY
Debug Ter mi nal / TTYString

Display

Property
Close Disassembly On Mode Switch

Envi r onnent / Debugger/ Cl ose Di sassenbly On

Mode Swi t chBoolean

Data Tips Display a Maximum Of
Envi r onnent / Debugger / Maxi mum Ar r ay
El ement s Di spl ayedintegerRange

Default Display Mode
Envi ronnent / Debugger/ Defaul t Vari abl e
Di spl ay ModeEnumeration

Display Floating Point Number In
Envi r onnent / Debugger / Fl oati ng Poi nt
Format Di spl ayCustom

Maximum Backtrace Calls
Envi r onnent / Debugger / Maxi mum Backtr ace
Cal | sintegerRange

Description

What to do with disassembly breakpoints on debug
stop/start.

Focus IDE when breakpoint is hit.

Description

Specifies the command line to use when debugging a
program that runs in an external terminal.

Specifies the path to the terminal device to use as
debug terminal. For example, '/dev/pts/1".

Description

Close Disassembly On Mode Switch.

Selects the maximum number of array elements
displayed in a data tip.

Selects the format that data values are shown in.

The printf format directive used to display floating
point numbers.

Selects the maximum number of calls when
backtracing.
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Prompt To Display If More Than
Envi r onnent / Debugger/ Array El enents
Pronmpt Si zelntegerRange

Show Data Tips In Text Editor
Envi r onment / Debugger / Show Dat a Ti psBoolean

Show ELF Header
El f Dwar f / Envi r onnent / Show ELF
Header Boolean

Show Folds In Disassembly
Envi r onnent / Debugger / Di sassenbl y Show
Fol dsBoolean

Show Labels In Disassembly
Envi r onnent / Debugger / Di sassenbl y Show
Label sBoolean

Show Source In Disassembly
Envi r onnent / Debugger / Di sassenbl y Show
Sour ceBoolean

Show char * as null terminated string
Envi r onnent / Debugger / Di spl ay Char
St ri ngBoolean

Ptr As

Source Path
Envi r onment / Debugger / Sour ce Pat hStringList

Use objdump For File Disassembly
El f Dwar f / Envi ronnment / Use Cbj dunp For
Di sassenbl yBoolean

Extended Data Tips

Property

ASCl
Envi r onnent / Debugger / Ext ended Tool tip
Di spl ay Mbde/ ASCI | Boolean

Binary
Envi r onnent / Debugger / Ext ended Tool tip
Di spl ay Mbde/ Bi nar yBoolean

Decimal
Envi r onnent / Debugger / Ext ended Tool tip
Di spl ay Mbde/ Deci mal Boolean

Hexadecimal
Envi r onnent / Debugger / Ext ended Tool tip
Di spl ay Mbde/ Hexadeci mal Boolean

Appendices

The array size to display with prompt.

Show Data Tips In Text Editor.

Display ELF Headers when executable and object files
are displayed in text editor.

Show Folds In Disassembly.

Show Labels In Disassembly.

Show Source In Disassembly.

Show char * as null terminated string.

Global search path to find source files.

Specifies whether to use objdump to disassemble files
rather than the built-in disassembler.

Description

Display ASCIl extended data tips.

Display Binary extended data tips.

Display Decimal extended data tips.

Display Hexadecimal extended data tips.
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Octal
Envi r onment / Debugger / Ext ended Tool tip Display Octal extended data tips.
Di spl ay Mode/ Cct al Boolean

Unsigned Decimal
Envi r onment / Debugger / Ext ended Tool tip Display Unsigned Decimal extended data tips.
Di spl ay Mode/ Unsi gned Deci nmal Boolean

Ozone

Property Description

Ozone Executable

. The path to the Ozone executable.
ARM Debugger/ Ozone Execut abl eFileName

Target

Property Description

Switch Project To Text Editor

Switch Deb er Project To Text Editor.
Envi ronnent / Debugger/ Swi t ch Pr oj ect Boolean WI 199 ) xLEdl

Window

Property Description

Clear Debug Terminal On Run
Envi ronnent/ Cl ear Debug Termi nal On
RunBoolean

Clear the debug terminal automatically when a
program is run.

Hide Output Window On Successful Load
Debuggi ng/ Hi de Transcript On Successf ul
LoadBoolean

Hide the Output window when a load completes
without error.

Show Target Log On Load

Show the target log when a load starts.
Debuggi ng/ Show Transcri pt On LoadBoolean 9 9
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IDE Environment Options

Browser

Property

Text Size
Envi ronnent / Browser/ Text Si zeEnumeration

Underline Hyperlinks In Browser
Envi ronnent / Browser/ Under | i ne Web
Li nksBoolean

File Extension

Property

ELF Archive File Extensions
El f Dwar f / Envi ronnent / Archi ve File
Ext ensi onsStringList

ELF Executable File Extensions
El f Dwar f / Envi ronnent / Execut abl e Fil e
Ext ensi onsStringList

ELF Object File Extensions
El f Dwar f / Envi ronment / Cbj ect Fil e
Ext ensi onsStringList

File Search

Property

Collapse Search Results
Find In Files/Collapse ResultsBoolean

Files To Exclude
Find In Files/Exclude File TypesStringList

Files To Search
Find In Files/File TypeStringList

Find History
Find In Files/Find H storyStringList

Flat Search Result Output
Find In Files/Flat QutputBoolean

Appendices

Description

Sets the text size of the integrated HTML and help
browser.

Enables underlining of hypertext links in the
integrated HTML and help browser.

Description

The file extensions used for ELF archive files.

The file extensions used for ELF executable files.

The file extensions used for ELF object files.

Description
Whether to initially collapse search results.

The wildcard used to exclude files in Find In Files
searches.

The wildcard used to match files in Find In Files
searches.

The list of strings recently used in searches.

Whether to display file search results as a flat list.
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Folder History

Find In Files/Fol der Hi st orysStringlList

Match Case
Find In Files/Match CaseBoolean

Match Whole Word
Find In Files/Match Whol e Wr dBoolean

Replace History
Find In Files/Replace Hi st oryStringList

Search Dependencies
Find In Files/Search Dependenci esBoolean

Search In
Find In Fil es/ Cont ext Enumeration

Use Regular Expressions
Find In Files/Use RegExpBoolean

Find And Replace

Property

Greedy Regular Expressions
Fi nd/ Greedy RegExpBoolean

Internet

Property

Automatically Check For Packages
Envi ronnent /| nt er net / Check PackagesBoolean

Automatically Check For Updates
Envi ronnent /| nt er net/ Check Updat esBoolean

Check For Latest News
Envi ronnent /| nt er net/ RSS Updat eBoolean

Enable Connection Debugging
Envi ronnment / | nt er net/ Enabl e
Debuggi ngBoolean

External Web Browser
Envi r onnent / Ext er nal

HTTP Caching
Envi ronnent/ I nt er net/ HTTP Cachi ngBoolean

HTTP Proxy Host
Envi ronnent /| nt er net/ HTTP Proxy
Ser ver String

Web Br owser FileName

Appendices

The set of folders recently used in file searches.

Whether the case of letters must match exactly when
searching.

Whether the whole word must match when searching.

The list of strings recently used in searches.

Controls searching of dependent files."

Where to look to find files.

Whether to use a regular expression or plain text
search.

Description

Enables greedy matching when using regular
expressions.

Description
Specifies whether to enable downloading of the list of

available packages.

Specifies whether to check for software updates.

Specifies whether to update the latest news window.

Controls debugging traces of internet connections and
downloads.

The path to the external web browser to use when
accessing non-local files.

Specifies if caching should be permitted when carrying

out HTTP requests.

Specifies the IP address or hostname of the HTTP proxy
server. If empty, no HTTP proxy server will be used.
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HTTP Proxy Port
Envi ronnent /| nt er net/ HTTP Pr oxy
Por t IntegerRange

Maximum Download History Items
Envi ronnent/ | nt er net/ Max Downl oad Hi story
| t emsIntegerRange

Language Server

Property

Additional clangd Options
Envi ronnent / Language Server/ Addi ti onal
cl angd Opti onsStringList

Enable Language Server Debugging
Envi ronnent / Language Server/Enabl e
Debuggi ngBoolean

Launcher

Property

Confirm Check Solution Target
Envi ronnent / Launcher/ Confi rm Check
Sol uti on Tar get Boolean

Launch Latest Installations Only
Envi ronnent / Launcher Use Lat est
Installati ons Onl yBoolean

Launcher Enabled

Envi ronnent / Launcher Enabl edBoolean

Licensing

Property

Check J-Link For Licenses
Envi ronnent / Check J-Li nk LicensesBoolean

Package Manager

Property

Appendices

Specifies the HTTP proxy server's port number.

The maximum amount of download history kept in the
downloads window.

Description

Specifies additional command line options to use
when starting clangd.

Controls debugging traces of language servers.

Description

Specifies whether the SEGGER Embedded Studio
launcher should present a warning if the solution
being launched targets a device it does not support.

Specifies whether the SEGGER Embedded Studio
launcher should only consider the latest installations
when deciding which one to use.

Specifies whether the SEGGER Embedded Studio
launcher should be used when the operating system
or an external application requests a file to be opened.

Description

Specifies whether to check J-Link's for licenses.

Description
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Check Solution Package Dependencies
Envi r onnent / Package/ Check Sol uti on
Package Dependenci esBoolean

Delete Package Downloads
Envi r onnent / Package/ Del et e
Downl oadsBoolean

Install Default Packages
Envi r onnent / Package/ | nst al |
PackagesBoolean

Def aul t

Package Directory
Envi r onnent / Package/ Dest i nati on
Di r ect or yString

Parallel Download And Install
Envi r onnment / Package/ Par al | el
| nst al | Boolean

Downl oad And

Show Check For Packages Dialog
Envi ronnent / Package/ Show Check For
Packages Di al ogBoolean

Show Logos
Envi ronnent / Package/ Show LogosEnumeration

Verify Package Downloads
Envi ronment / Package/ Veri fy
Downl oadsBoolean

Print

Property

Bottom Margin
Envi ronnment / Pri nti
Mar gi nintegerRange

ng/ Bott om

Left Margin

Envi ronnent/ Pri nting/ Left Margi nintegerRange

Page Orientation

Envi ronnent/ Printing/ Ori ent ati onEnumeration

Page Size

Envi ronnent/ Pri nti ng/ Page Si zeEnumeration

Right Margin
Envi ronnment / Pri nti
Mar gi nintegerRange

ng/ Ri ght

Top Margin

Envi ronnment/ Pri nti ng/ Top Mar gi nintegerRange

Appendices

Specifies whether to check package dependencies
when a solution is loaded.

Specifies whether to delete downloaded package files
after they have been installed.

Specifies whether default packages should be installed
on startup if they are not installed already.

Specifies the directory packages are installed to.

Specifies whether the package manager should
download and install packages in parallel.

Specifies whether the package manager should
prompt for a package list refresh.

Specifies whether the package manager should display
company logos.

Specifies whether to carry out an MD5 sum check on
downloaded package files.

Description

The page's bottom margin in millimetres.

The page's left margin in millimetres.

The page's orientation.

The page's size.

The page's right margin in millimetres.

The page's top margin in millimetres.
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References Search

Property

Flat Search Result Output
Fi nd Ref erences/Fl at CQut put Boolean

Startup

Property

Allow Multiple SEGGER Embedded Studios
Envi ronnent/Pernmit Multiple Studio
I nst ancesBoolean

Load Last Project On Startup
Envi ronnent/ Load Last Project On
St ar t upBoolean

New Project Directory
Envi ronment / Gener al / Sol uti on
Di r ect or yString

Show Support Expired Dialog

Envi ronnent / Support Rem nder NagBoolean

Sort Project File On Save
Envi ronment / Sort Proj ect Fil eBoolean

Splash Screen
Envi ronnent / Spl ash Scr eenEnumeration

Status Bar

Property

(Visible)
Envi ronnent / St at us Bar Boolean

Show Build Status Pane
Envi ronnent / Gener al / St at us Bar/ Show Bui |l d
St at usBoolean

Show Caret Position Pane
Envi ronnent / Gener al / St at us Bar/ Show Car et
PosBoolean

Show Insert/Overwrite Status Pane
Envi ronnent / Gener al / St at us Bar/ Show
I nsert MbdeBoolean

Appendices

Description

Whether to display reference search results as a flat list.

Description

Allow more than one SEGGER Embedded Studio to run
at the same time.

Specifies whether to load the last project the next time
SEGGER Embedded Studio runs.

The directory where projects are created.

Specifies whether to show the support expired dialog.

The project file is sorted when it is saved.

How to display the splash screen on startup.

Description

Show or hide the status bar.

Show or hide the Build pane in the status bar.

Show or hide the Caret Position pane in the status bar.

Show or hide the Insert/Overwrite pane in the status
bar.
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Show Read-Only Status Pane
Envi ronnent / Gener al / St at us
Onl yBoolean

Bar / Show Read

Show Size Grip
Envi ronnent / Gener al / St at us
G i pBoolean

Bar / Show Si ze

Show Target Pane
Envi ronnent / Gener al / St at us
Tar get Boolean

Bar / Show

Show Time Pane
Envi ronnent / Gener al / St at us
Ti meBoolean

Bar / Show

Title Bar

Property

Show Full Solution Path
Envi ronnent/ General / Titl e Bar/ Show Ful |
Sol uti on Pat hBoolean

User Interface

Property

Application Main Font
Envi ronnent / Appl i cati on Mai n Font Font

Application Monospace Font
Envi ronment / Appl i cati on Monospace
Font FixedPitchFont

Default Document Markup Language Operation
Envi ronnent / Def aul t Docunent Mar kup
Language Oper at i onEnumeration

Error Display Timeout
Envi ronment / Err or
Ti meout IntegerRange

Di spl ay

Errors Are Displayed

Envi ronnent/ Error Di spl ay ModeEnumeration

File Size Display Units
Envi ronnent/ Si ze Di spl ay Unit Enumeration

Number File Names in Menus

Envi ronnent / Nunber MenusBoolean

Appendices

Show or hide the Read Only pane in the status bar.

Show or hide the status bar size grip.

Show or hide the Target pane in the status bar.

Show or hide the Time pane in the status bar.

Description

Show the full solution path in title bar.

Description

The font to use for the user interface as a whole.

The fixed-size font to use for the user interface as a
whole.

The default operation to carry out when opening
HTML and Markdown files.

The minimum time, in seconds, that errors are shown
for in the status bar.

How errors are reported in SEGGER Embedded Studio.

How to display sizes of items in the user interface. SI
defines TkB=1000 bytes, IEC defines 1kiB=1024 bytes,
Alternate S| defines 1kB=1024 bytes.

Number the first nine file names in menus for quick
keyboard access.
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Qt Style Sheet
Envi ronnent/ Q¢ Styl e Sheet FileName

Show Large Icons In Toolbars
Envi r onnent / Gener al / Lar ge | consEnumeration

Show Ribbon
Envi ronnent / Gener al / Ri bbon/ ShowBoolean

Show Window Selector On Ctrl+Tab
Envi ronnent / Show Sel ect or Boolean

Theme
Envi ronnent / St udi o ThenmeEnumeration

Window Menu Contains At Most
Envi ronnent / Max W ndow Menu
| t enslintegerRange

Appendices
The Qt style sheet to use in order to customize the user
interface (experimental).

Show large or small icons on toolbars.

Show or hide the ribbon.
Present the Window Selector on Next Window and
Previous Window commands activated from the

keyboard.

The user interface style and color theme to use.

The maximum number of windows appearing in the
Windows menu.
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Appendices

Programming Language Environment Options

Assembly Language

Property

Column Guide Columns
Text Editor/Indent/Assenbly
Col utm  Gui desString

Language/

Indent Mode
Text Editor/Indent/Assenbly
| ndent ModeEnumeration

Language/

Indent Size
Text Editor/Indent/Assenbly
Si zelntegerRange

Language/

Tab Size
Text Editor/Indent/Assenbly
Si zelntegerRange

Language/ Tab

Use Tabs
Text Editor/|ndent/Assenbly
TabsBoolean

Language/ Use

User-Defined Keywords
Text Editor/Indent/Assenbly
Keywor dsStringList

Language/

Cand C++

Property

Column Guide Columns
Text Editor/Indent/C and
Qui desString

C++/ Col um

Indent Mode
Text Editor/Indent/C and C++/| ndent
ModeEnumeration

Indent Size
Text Editor/Indent/C and C++/
Si zelntegerRange

On Type Formatting
Text Editor/C and C++/ Formatting/ On Type
For mat t i ngBoolean

Description

The columns that guides are drawn for.

How to indent when a new line is inserted.

The number of columns to indent a code block.

The number of columns between tabstops.

Insert tabs when indenting.

Additional identifiers to highlight as keywords.

Description

The columns that guides are drawn for.

How to indent when a new line is inserted.

The number of columns to indent a code block.

Use the code formatter to format the code as it is
edited.
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Tab Size
Text Editor/Indent/C and C++/ Tab
Si zelntegerRange

Use Tabs
Text Editor/Indent/C and C++/ Use
TabsBoolean

User-Defined Keywords
Text Editor/Indent/C and C++/
Keywor dsStringlList

Default

Property

Column Guide Columns
Text Editor/|ndent/ Default/Colum
Qui desString

Indent Mode
Text Editor/|ndent/Default/Indent
ModeEnumeration

Indent Size
Text Editor/I|ndent/Defaul t/Si zelntegerRange

Tab Size
Text Editor/Indent/Default/Tab
Si zelntegerRange

Use Tabs
Text Editor/Indent/Default/Use TabsBoolean

User-Defined Keywords
Text Editor/|ndent/Default/
Keywor dsStringlList

JSON

Property

Column Guide Columns
Text Editor/Indent/JSON Col utm Gui desString

Indent Mode
Text Editor/Indent/JSON | ndent
ModeEnumeration

Indent Size
Text Editor/1ndent/JSOV Si zelntegerRange

Appendices

The number of columns between tabstops.

Insert tabs when indenting.

Additional identifiers to highlight as keywords.

Description

The columns that guides are drawn for.

How to indent when a new line is inserted.

The number of columns to indent a code block.

The number of columns between tabstops.

Insert tabs when indenting.

Additional identifiers to highlight as keywords.

Description

The columns that guides are drawn for.

How to indent when a new line is inserted.

The number of columns to indent a code block.
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Tab Size
Text Editor/Indent/JSON Tab Si zelntegerRange

Use Tabs
Text Editor/|ndent/JSON Use TabsBoolean

User-Defined Keywords
Text Editor/ 1 ndent/JSON Keywor dsStringList

Java

Property

Column Guide Columns
Text Editor/Indent/Javal/ Col uim Gui desString

Indent Mode
Text Editor/Indent/Java/l ndent
ModeEnumeration

Indent Size
Text Editor/Indent/Java/ Si zelntegerRange

Tab Size
Text Editor/Indent/Javal/ Tab Si zelntegerRange

Use Tabs
Text Editor/|ndent/Javal/ Use TabsBoolean

User-Defined Keywords
Text Edi tor/ 1 ndent/Java/ Keywor dsStringList

JavaScript

Property

Column Guide Columns
Text Editor/Indent/JavaScri pt/ Col umm
Qui desString

Indent Mode
Text Editor/Indent/JavaScri pt/| ndent
ModeEnumeration

Indent Size
Text Editor/Indent/JavaScri pt/
Si zelntegerRange

Tab Size
Text Editor/Indent/JavaScri pt/ Tab
Si zelntegerRange

Appendices

The number of columns between tabstops.

Insert tabs when indenting.

Additional identifiers to highlight as keywords.

Description

The columns that guides are drawn for.

How to indent when a new line is inserted.

The number of columns to indent a code block.

The number of columns between tabstops.

Insert tabs when indenting.

Additional identifiers to highlight as keywords.

Description

The columns that guides are drawn for.

How to indent when a new line is inserted.

The number of columns to indent a code block.

The number of columns between tabstops.
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Use Tabs
Text Editor/Indent/JavaScript/ Use
TabsBoolean

User-Defined Keywords
Text Editor/Indent/JavaScri pt/
Keywor dsStringlList

XML

Property

Column Guide Columns
Text Editor/Indent/ XM/ Col unm CGui desString

Indent Mode
Text Editor/Indent/ XM/ | ndent
MbdeEnumeration

Indent Size
Text Editor/1ndent/ XM/ Si zelntegerRange

Tab Size
Text Editor/Indent/ XM/ Tab Si zelntegerRange

Use Tabs
Text Editor/Indent/ XM/ Use TabsBoolean

User-Defined Keywords
Text Editor/ 1 ndent/ XM/ Keywor dsStringList

Appendices

Insert tabs when indenting.

Additional identifiers to highlight as keywords.

Description

The columns that guides are drawn for.

How to indent when a new line is inserted.

The number of columns to indent a code block.

The number of columns between tabstops.

Insert tabs when indenting.

Additional identifiers to highlight as keywords.
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Appendices

Source Control Environment Options

External Tools

Property

Diff Command Line
Envi ronnent / Sour ce Code Control/
Di f f CommandStringlList

Merge Command Line
Envi ronnent / Sour ce Code Control /
Mer geConmandStringList

Preference

Property

Add Immediately
Envi ronnent / Sour ce Code Control /| medi
AddBoolean

Commit Immediately
Envi ronnent / Source Code Control /| nmedi
Comni t Boolean

Get Immediately
Envi ronnent / Source Code Control /| nmedi
Get Boolean

Lock Immediately
Envi ronnent / Source Code Control /| nredi
LockBoolean

Remove Immediately
Envi ronnent / Source Code Control /| nmredi
RenpveBoolean

Resolved Immediately
Envi ronnent / Source Code Control /| nmredi
Resol vedBoolean

Revert Immediately
Envi ronnent / Source Code Control /| nredi
Rever t Boolean

Unlock Immediately
Envi ronnent / Sour ce Code Control /| nredi
Unl ockBoolean

ate

ate

ate

ate

ate

ate

ate

ate

Description

The diff command line.

The merge command line.

Description

Bypasses the confirmation dialog and immediately
adds items to source control.

Bypasses the confirmation dialog and immediately
commits items.

Bypasses the confirmation dialog and immediately
gets items from source control.

Bypasses the confirmation dialog and immediately
locks items.

Bypasses the confirmation dialog and immediately
removes items from source control.

Bypasses the confirmation dialog and immediately
mark items resolved.

Bypasses the confirmation dialog and immediately
revert items.

Bypasses the confirmation dialog and immediately
unlocks items.
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Update Immediately
Envi ronnent / Sour ce Code Control /| nmedi at e
Updat eBoolean

Bypasses the confirmation dialog and immediately
updates items.
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Appendices

Text Editor Environment Options

Auto Recovery

Property

Auto Recovery Backup Time
Text Editor/Auto Recovery Backup
Ti nelntegerRange

Auto Recovery Keep Time
Text Editor/Auto Recovery Keep
Ti meIntegerRange

Cursor Fence

Property

Bottom Margin
Text Editor/ Margi ns/ Bot t omintegerRange

Keep Cursor Within Fence
Text Editor/ Margi ns/ Enabl edBoolean

Left Margin
Text Editor/ Margi ns/ Lef t IntegerRange

Right Margin
Text Editor/ Margi ns/ Ri ght IntegerRange

Top Margin
Text Editor/ Margi ns/ ToplntegerRange

Editing

Property

Allow Drag and Drop Editing
Text Editor/Drag Drop EditingBoolean

Bold Popup Diagnostic Messages

Text Editor/Bold Popup Di agnosti csBoolean

Column-mode Tab
Text Editor/Col utmm Mbde TabBoolean

Confirm Modified File Reload
Text Editor/Confirm Mdified File
Rel oadBoolean

Description

The time in minutes between saving of auto recovery
backups files or 0 to disable generation of backup files.

The time in days to keep unrecovered backup files or 0
to disable deletion of unrecovered backup files.

Description

The number of lines in the bottom margin.

Enable margins to fence and scroll around the cursor.

The number of characters in the left margin.

The number of characters in the right margin.

The number of lines in the right margin.

Description

Enables dragging and dropping of selections in the
text editor.

Displays popup diagnostic messages in bold for easier
reading.

Tab key moves to the next textual column using the
line above.

Display a confirmation prompt before reloading a file
that has been modified on disk.
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Copy Action When Nothing Selected
Text Editor/ Copy Acti onEnumeration

Cut Action When Nothing Selected
Text Editor/Cut Acti onEnumeration

Cut Single Blank Line
Text Editor/Cut Bl ank Li nesBoolean

Diagnostic Cycle Mode
Text Editor/Di agnostic Cycle
ModeEnumeration

Edit Read-Only Files
Text Editor/Edit Read Onl yBoolean

Enable Virtual Space

Text Editor/Enable Virtual SpaceBoolean

Numeric Keypad Editing
Text Editor/Numeric Keypad Enabl edBoolean

Tab Key Indents Preprocessor Directives
Text Editor/ Tab Key I ndents Preprocessor
Di recti vesBoolean

Undo And Redo Behavior
Text Editor/Undo MbdeEnumeration

Find And Replace

Property

Case Sensitive Matching
Text Editor/Find/ Mat ch CaseBoolean

Find History
Text Edi tor/Fi nd/ H st or yStringList

Regular Expression Matching
Text Editor/Find/ Use RegExpBoolean

Replace History
Text Editor/ Repl ace/ Hi st or yStringList

Whole Word Matching
Text Editor/Find/ Match Whol e Wor dBoolean

Appendices

What Copy copies when nothing is selected.

What Cut cuts when nothing is selected.

Selects whether to place text on the clipboard when

a single blank line is cut. When set to Yes, cutting

a single blank line will put the blank line on the
clipboard. When set to No, cutting a single blank line
deletes the line and does not place it on the clipboard.

Iterates through diagnostics either from most severe
to least severe or in reported order.

Allow editing of read-only files.
Permit the cursor to move into locations that do not
currently contain text.

Selects whether the numeric keypad plus and minus
buttons copy and cut text.

Enables or disables the indentation of C preprocessor
directives when using tab key indentation on a
selection.

How Undo and Redo group your typing when it is
undone and redone.

Description

Enables or disables the case sensitivity of letters when
searching.

The list of strings recently used in searches.

Enables regular expression matching rather than plain
text matching.

The list of strings recently used in replaces.

Enables or disables whole word matching when
searching.
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Formatting

Property

Formatting Options
Text Editor/Formatting Opti onsStringList

Formatting Style
Text Editor/Formatting Styl eEnumeration

Use .clang-format File
Text Editor/Use .clang-formt Fil eBoolean

International

Property

Auto-Detect UTF-8
Text Editor/ Aut o- Det ect UTF- 8Boolean

Default Text File Encoding
Text Editor/Default CodecEnumeration

Verify Text File Decoding
Text Editor/Verify DecodeBoolean

Mouse

Property

Alt+Left Click Action
Envi ronnent/ Proj ect Explorer/Alt+Left
Cl i ck Acti onEnumeration

Alt+Middle Click Action
Envi ronnent/ Proj ect Explorer/At+M ddl e
Cl i ck Acti onEnumeration

Alt+Right Click Action
Envi ronnment / Proj ect Expl orer/ Al t +Ri ght
Cl i ck Acti onEnumeration

Copy On Mouse Select
Text Editor/ Copy On Mouse Sel ect Boolean

Ctrl+Left Click Action
Envi ronnent/ Proj ect Explorer/Ctrl +Left
Cick Acti onEnumeration

Appendices

Description

Specify Clang-Format options. See https://
clang.llvm.org/docs/ClangFormatStyleOptions.html for
a description of the Clang-Format options available.

Select a set of formatting options based on a named
standard.

Load code formatting style configuration from
a .clang-format file located in one of the parent
directories of the source file rather than use the
formatting options.

Description
Auto-detect UTF-8 encoding without signature.

The encoding to use if not overridden by a project
property or file is not in a known format.

Specifies whether the decoding of a text file should be
verified when file is loaded.

Description

The action the editor performs on Alt+Left Click.

The action the editor performs on Alt+Middle Click.

The action the editor performs on Alt+Right Click.

Automatically copy text to clipboard when marking a
selection with the mouse.

The action the editor performs on Ctrl+Left Click.
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Ctrl+Middle Click Action
Envi ronnent/ Proj ect Explorer/Ctrl+M ddl e
Cl i ck Acti onEnumeration

Ctrl+Right Click Action
Envi ronnent / Proj ect Explorer/ Crl +Ri ght
Click Acti onEnumeration

Middle Click Action
Envi ronment / Proj ect Explorer/Mddle dick
Act i onEnumeration

Mouse Wheel Adjusts Font Size
Text Editor/Muse Weel
Si zeBoolean

Shift+Middle Click Action
Envi ronment / Proj ect Expl orer/ Shift+M ddl e
Click Acti onEnumeration

Shift+Right Click Action
Envi ronnent / Proj ect Expl orer/ Shift+Ri ght
Click Acti onEnumeration

Adj ust s Font

Programmer Assistance

Property

ATTENTION Tag List
Text Editor/ ATTENTI ON TagsStringList

Ask For Index

Text Editor/Ask For | ndexBoolean

Auto-Comment Text
Text Editor/Aut o Comrent Boolean

Auto-Surround Text
Text Editor/Auto SurroundBoolean

Check Spelling

Text Editor/Spell Checki ngBoolean

Code Completion Characters
Text Editor/Code Conpl etion
Char act er sintegerRange

Code Completion Replaces Existing Word
Text Editor/Conpl etion Replaces Existing
Wor dBoolean

Appendices

The action the editor performs on Ctrl+Middle Click.

The action the editor performs on Ctrl+Right Click.

The action the editor performs on Middle Click.

Enable or disable resizing of font by mouse wheel
when CTRL key pressed.

The action the editor performs on Shift+Middle Click.

The action the editor performs on Shift+Right Click.

Description
Set the tags to display as ATTENTION comments.

Ask to index the project if goto symbol fails in current
editor context.

Enable or disable automatically swapping
commenting on source lines by typing '/* with an
active selection.

Enable or disable automatically surrounding selected
text when typing triangular brackets, quotation marks,
parentheses, brackets, or braces.

Enable spell checking in comments.

The minimum number of word characters required
before showing the code completion suggestions
while typing.

Replace existing word with completion suggestion if
cursor is located on one.
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Code Completion Suggestion Selection Key
Text Editor/Suggestion Sel ection
KeyEnumeration

Display Code Completion Suggestions While Typing
Text Editor/Suggest Conpletion Wile
Typi ngBoolean

Enable Popup Diagnostics
Text Editor/Enabl e Popup
Di agnost i csBoolean

FIXME Tag List
Text Edi tor/FlI XME TagsStringList

Inactive Code Opacity
Text Editor/lnactive Code
Opaci t yIntegerRange

Include Preprocessor Definitions in Suggestions
Text Editor/Preprocessor Definition
Suggest i onsBoolean

Include Templates in Suggestions
Text Editor/ Tenpl ate Suggesti onsBoolean

Lint Tag List
Text Editor/LlI NT TagsStringList

Select First Code Completion Selection
Text Editor/Select First Suggesti onBoolean

Show Diagnostics
Text Editor/ Show Di agnosti csEnumeration

Show Inactive Code
Text Editor/ Show | nacti ve CodeEnumeration

Show Inline Diagnostics
Text Editor/Show Inline
Di agnost i csEnumeration

Show Symbol Declaration Tooltips
Text Editor/ Show Tool ti pBoolean

Template Characters To Match
Text Editor/ Tenpl ate Suggesti ons
Char act er sintegerRange

Save

Property

Backup File History Depth
Text Editor/Backup Fil e Dept hintegerRange

Appendices

The key used to select a code completion suggestion.

Enable code completion as you type without needing
to use the show suggestions key (Ctrl+J).

Enables on-screen popup diagnostics messages.

Set the tags to display as FIXME comments.

Specifies the opacity of code that has been
conditionally excluded by the preprocessor.

Include or exclude preprocessor definitions in code
completion suggestions.

Include or exclude templates in code completion
suggestions.

Set the tags to display as Lint directives.

Automatically select first suggestion when showing
suggestions

Enables on-screen diagnostics in the text editor.

Show code that has been conditionally excluded by
the preprocessor.

Enables inline diagnostics in the text editor.

Show tooltips when hovering over symbols.

The number of characters to match before suggesting
a template.

Description

The number of backup files to keep when saving an
existing file.
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Default Line Endings
Text Editor/Default Line Endi ngsEnumeration

Delete Trailing Space On Save
Text Editor/Delete Trailing Space On
SaveBoolean

Format On Save
Text Editor/Format On SaveEnumeration

Tab Cleanup On Save
Text Editor/Cd eanup Tabs On SaveEnumeration

Visual Appearance

Property

Fold Comments
Text Editor/Fol d Comrent sBoolean

Fold Preprocessor Directives
Text Editor/Fold Preprocessor
Di recti vesBoolean

Font
Text Editor/ Font FixedPitchFont

Font Rendering
Text Editor/Font Renderi ngEnumeration

Font Smoothing Threshold
Text Editor/Antialias Threshol dintegerRange

Hide Cursor When Typing
Text Editor/H de Cursor When Typi ngBoolean

Highlight All Selected Text
Text Editor/H ghlight All
Text Boolean

Sel ect ed

Highlight Cursor Line

Text Editor/H ghlight Cursor LineBoolean

Highlight References
Text Editor/Highlight ReferencesBoolean

Horizontal Scroll Bar

Text Editor/HScroll BarEnumeration

Insert Caret Style
Text Editor/Insert Caret Styl eEnumeration

Line Numbers

Text Editor/Li ne Nunber MydeEnumeration

Appendices

The line ending format to use for a new file or a file
where the existing line ending format cannot be
determined.

Deletes trailing whitespace from each line when a file
is saved.

Formats text when a file is saved.

Cleans up tabs when afile is saved.

Description

Allow multiline comments to be collapsed.

Allow preprocessor directives to be collapsed.

The font to use for text editors.

The font rendering scheme to use in text editors.

The minimum size for font smoothing: font sizes
smaller than this will have antialiasing turned off.

Hide or show the I-beam cursor when you start to type.

Enable or disable visually highlighting all text that
matches the current selection.

Enable or disable visually highlighting the cursor line.

Enable or disable visually highlighting of references.

Show or hide the horizontal scroll bar.

How the caret is displayed with the editor in insert
mode.

How often line numbers are displayed in the margin.
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Mate Match Off Screen
Text Editor/NMate Match O f ScreenBoolean

Mate Matching Mode
Text Editor/Mate Matchi ng MbdeEnumeration

Maximum Collapsed Fold Preview Lines
Text Edi t or/ Maxi num Col | apsed Fol d
Previ ew Li nesintegerRange

Minimum Scroll Width

Text Editor/M ni mum Scrol | W dt hintegerRange

Overwrite Caret Style
Text Editor/Overwrite Caret
St yl eEnumeration

Selection Opacity
Text Editor/ Sel ecti on Opaci t ylntegerRange

Show Bookmarks In Vertical Scroll Bar
Text Editor/Show Booknarks In Vertical
Scrol | Bar Boolean

Show Breakpoints In Vertical Scroll Bar
Text Editor/Show Breakpoints In Vertical
Scrol I Bar Boolean

Show Caret Position In Vertical Scroll Bar
Text Editor/Show Caret In Verti cal
Bar Boolean

Scrol |

Show Diagnostic Icons In Gutter
Text Editor/Di agnostic | consBoolean

Show Errors In Vertical Scroll Bar
Text Editor/Show Errors In Vertical
Scrol | Bar Boolean

Show Fold Gutter
Text Editor/Fold QutterBoolean

Show Icon Gutter
Text Editor/lcon QutterBoolean

Show Mini Toolbar

Text Editor/M ni Tool bar Boolean

Show Toolbar
Text Editor/ Showw dget Stri pBoolean

Show Warnings In Vertical Scroll Bar
Text Editor/Show Warnings In Vertical
Scrol | Bar Boolean

Use I-beam Cursor
Text Editor/|beam cur sorBoolean

Appendices

Specifies whether braces, brackets, and parentheses
are matched when off screen.

Controls when braces, brackets, and parentheses are
matched.

The maximum number of lines to show in a collapsed
fold preview tooltip.

Specifies the minimum width of the scrolling region in
characters.

How the caret is displayed with the editor in overwrite
mode.

Specifies the opacity of text selection.

Annotate the vertical scroll bar with bookmark
positions.

Annotate the vertical scroll bar with breakpoint
positions.

Annotate the vertical scroll bar with the caret's
position within the document.

Enables display of diagnostic icons in the icon gutter.

Annotate the vertical scroll bar with error positions.

Show or hide the left-hand gutter containing folding
controls.

Show or hide the left-hand gutter containing
breakpoint, bookmark, and optional diagnostic icons.

Show the mini toolbar when selecting text with the
mouse.
Show or hide the Editor toolbar in the dock window.

Annotate the vertical scroll bar with warning positions.

Show an I-beam or arrow cursor in the text editor.
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Appendices
Vertical Scroll Bar
. . Show or hide the vertical scroll bar.
Text Editor/VScroll BarEnumeration
View Whitespace
. i . Make whitespace characters visible in the text editor.
Text Editor/Vi ew Wit espaceBoolean
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Appendices

Windows Environment Options

Autos

Property

Show Digit Separator
Envi r onnent / Aut osW ndow Show Di gi t
Separ at or Boolean

Show Member Functions
Envi r onnent / Aut osW ndow Show Menber
Funct i onsBoolean

Show Variable Address Column
Envi r onnment / Aut osW ndow Show Addr ess
Col utTmBoolean

Show Variable Size Column
Envi r onnent / Aut osW ndow Show Si ze
Col utmBoolean

Show Variable Type Column
Envi r onnent / Aut osW ndow Show Type
Col umBoolean

Call Stack

Property

Execution Frame at Top
Envi ronnent/ Cal | Stack/ Most Recent At
TopBoolean

Show Call Address
Envi ronnent/ Cal | St ack/ Show Cal |
Addr essBoolean

Show Call Source Location
Envi ronnent/ Cal | St ack/ Show Cal |
Locat i onBoolean

Show Frame Size
Envi ronnent/ Cal | St ack/ Show St ack
UsageBoolean

Show Frame Size In Bytes

Envi ronnent/ Cal | Stack/ Show Stack Usage

I n Byt esBoolean

Description

Show digit separator in variable value display.

Controls whether C++ class member functions are
displayed.

Controls whether the variable address column is
displayed.

Controls whether the variable size column is displayed.

Controls whether the variable type column is
displayed.

Description

Controls whether the most recent call is at the top or
the bottom of the list.

Enables the display of the call address in the call stack.

Enables the display of the call source location in the
call stack.

Enables the display of the amount of stack used by the
call.

Display the stack usage in bytes rather than words.
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Show Parameter Names
Envi ronnent/ Cal | St ack/ Show Par anet er
NanesBoolean

Show Parameter Types
Envi ronnent/ Cal | Stack/ Show Par anet er
TypesBoolean

Show Parameter Values
Envi ronnment/ Cal | St ack/ Show Par anet er
Val uesBoolean

Show Stack Pointer
Envi ronnent/ Cal | St ack/ Show St ack
Poi nt er Boolean

Show Stack Usage
Envi ronnment / Cal | St ack/ Show Cunul ati ve
St ack UsageBoolean

Show Stack Usage In Bytes
Envi ronnent/ Cal | Stack/ Show Cunul ati ve
Stack Usage | n Byt esBoolean

Clipboard Ring

Property

Maximum Items Held In Ring
Envi ronnent/ d i pboard Ri ng/ Max
Ent ri esintegerRange

Preserve Contents Between Runs
Envi ronnent / Cl i pboard Ri ng/ SaveBoolean

Debug Terminal

Property

Backscroll Buffer Lines
Debug Ter m nal / Backscrol | Buffer
Li nesIntegerRange

Use Window System Colors
Debug Term nal / Use W ndow System
Col or sBoolean

Appendices

Enables the display of parameter names in the call
stack.

Enables the display of parameter types in the call stack.

Enables the display of parameter values in the call
stack.

Enables the display of the stack pointer in the call
stack.

Enables the display of the amount of stack used.

Display the stack usage in bytes rather than words.

Description

The maximum number of items held on the clipboard
ring before they are recycled.

Save the clipboard ring across SEGGER Embedded
Studio runs.

Description

The number of lines you can see when you scroll
backward in the debug terminal window.

Substitute window system colors for ANSI black
background and white foreground in debug terminal.
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Find Symbol Dialog

Property

Group Symbols
W ndows/ Fi nd Synbol
Synbol sBoolean

Di al og/ G oup

Scope

W ndows/ Fi nd Synbol Di al og/ ScopeEnumeration

Frame Buffer

Property

Maximum Frame Buffer Height
Envi ronnent / Frane Buffer W ndow Maxi mum
Hei ght IntegerRange

Maximum Frame Buffer Width
Envi ronnent / Frame Buffer W ndow Maxi mum
W dt hintegerRange

Show Frame Buffer Tooltips
Envi ronnent / Frane Buffer W ndow Di spl ay
Tool ti psBoolean

Globals

Property

Show Digit Separator
Envi ronnent / A obal sW ndow Show Di gi t
Separ at or Boolean

Show Member Functions
Envi ronnent / A obal sW ndow Show Menber
Funct i onsBoolean

Show Variable Address Column
Envi ronnent / A obal sW ndow Show Addr ess
Col utmBoolean

Show Variable Size Column
Envi ronnent / A obal sW ndow Show Si ze
Col utmBoolean

Show Variable Type Column
Envi ronnent / A obal sW ndow Show Type
Col utMmBoolean

Appendices

Description

Group symbols by type.

Specifies whether to search for symbols in the entire
workspace or only the current document.

Description

Specifies the maximum frame buffer height.

Specifies the maximum frame buffer width.

Specifies whether tooltips are displayed in the frame
buffer window.

Description

Show digit separator in variable value display.

Controls whether C++ class member functions are
displayed.

Controls whether the variable address column is
displayed.

Controls whether the variable size column is displayed.

Controls whether the variable type column is
displayed.
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Locals

Property

Show Digit Separator
Envi ronnent / Local sW ndow' Show Di gi t
Separ at or Boolean

Show Member Functions
Envi ronnent / Local sW ndow Show Menber
Funct i onsBoolean

Show Struct Offsets
Envi r onnent / Wat ch4W ndow Show St r uct
O f set sBoolean

Show Struct Offsets
Envi r onnent / Wat ch3W ndow Show St r uct
O f set sBoolean

Show Struct Offsets
Envi r onnent / Wat ch2W ndow Show St r uct
O f set sBoolean

Show Struct Offsets
Envi r onnent / Wat ch1W ndow Show St r uct
O f set sBoolean

Show Struct Offsets
Envi r onnent / Aut osW ndow Show St r uct
O f set sBoolean

Show Struct Offsets
Envi ronnent / A obal sW ndow Show St ruct
O f set sBoolean

Show Struct Offsets
Envi ronnent / Local sW ndow Show St r uct
O f set sBoolean

Show Variable Address Column
Envi ronnent / Local sW ndow Show Addr ess
Col utmBoolean

Show Variable Size Column
Envi r onnent / Local sW ndow Show Si ze
Col utTmBoolean

Show Variable Type Column
Envi ronnent / Local sW ndow Show Type
Col umBoolean

Appendices

Description

Show digit separator in variable value display.

Controls whether C++ class member functions are
displayed.

Show offsets of structure fields in the address column.

Show offsets of structure fields in the address column.

Show offsets of structure fields in the address column.

Show offsets of structure fields in the address column.

Show offsets of structure fields in the address column.

Show offsets of structure fields in the address column.

Show offsets of structure fields in the address column.

Controls whether the variable address column is
displayed.

Controls whether the variable size column is displayed.

Controls whether the variable type column is
displayed.
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Memory

Property

Confirm Large Download
Envi ronnent / Menmory W ndow Confi rm
Si zeBoolean

Group Auto Columns
Envi ronnent / Memory W ndow G oup Aut o
Col utmmsBoolean

Locate Sets Entry Width
Envi ronnent / Menory W ndow Locate Sets
Ent ry W dt hBoolean

Locate Sets Size
Envi ronnent / Menory W ndow Locate Sets
Si zeBoolean

Scroll Wheel Modifies Start Address
Envi ronnent / Menory W ndow Scrol | Wheel
Modi fies Start AddressBoolean

Selecting Modifies Start Address
Envi ronnent / Menory W ndow Sel ecti ng
Modi fies Start AddressBoolean

Outline

Property

Group Top-Level Declarations
W ndows/ Qut | i ne/ G oup Top Level
| t emsBoolean

Show Function Arguments

W ndows/ Qut | i ne/ Show Functi on Ar gsBoolean

Project Explorer

Property

Add Filename Replace Macros
Envi ronnent / Proj ect Expl orer/Fil enanme
Repl ace Macr osStringlList

Check Solution Target
Envi ronnent / Proj ect Expl orer/ Check
Sol uti on Tar get Boolean

Appendices

Description

Present a warning if you attempt to download a large
amount of memory in the memory window.

Selects whether columns are grouped in automatic
column mode.

Set the memory window entry width if possible when
locating.

Set the memory window size when locating.

Selects whether the mouse scroll wheel can change
the memory window start address.

Selects whether the memory window start address can
change when selecting.

Description

Group consecutive top-level variable and type
declarations.

Show function arguments.

Description

Macros (system and global) used to replace the start of
a filename on project file addition.

Specifies whether to check target is correct when
loading a solution.
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Color Project Nodes
Envi ronnent / Proj ect Expl orer/ Col or
NodesBoolean

Confirm Configuration Folder Delete
Proj ect Expl orer/ Confirm Configuration
Fol der Del et eBoolean

Confirm File Replacement Warning
Proj ect Explorer/ConfirmFile Repl acenent
War ni ngBoolean

Confirm Forget Modified Options
Proj ect Explorer/Confirm Rej ect Property
ChangesBoolean

Context Menu Edit Options At Top
Envi ronment / Proj ect Expl orer/ Cont ext Menu
Properties PositionBoolean

Context Menu Uses Common Folder
Envi ronnent / Proj ect Expl or er/ Cont ext Menu
Common Fol der Boolean

External Editor
Envi ronnent / Pr oj ect
Edi t or FileName

Expl or er/ Ext er nal

Highlight Dynamic Items
Envi ronnent / Pr oj ect
Over | ayBoolean

Expl or er/ Show Dynami c

Highlight External Items
Envi ronnent / Pr oj ect
Local Overl ayBoolean

Expl or er/ Show Non-

Output Files Folder
Envi ronment / Pr oj ect
Fi | esBoolean

Read-Only Data In Code
Envi ronnent / Proj ect Explorer/Statistics
Read- Onl y Dat a Handl i ngBoolean

Expl or er/ Show Qut put

Show Dependencies
Envi ronnent / Proj ect Expl or er/ Dependenci es
Di spl ayEnumeration

Show Favorite Properties
Envi ronnent / Proj ect Expl or er/ Cont ext Menu
Show Favori t esBoolean

Show File Count on Folder
Envi ronnent / Proj ect Expl or er/ Count
Fi | esBoolean

Appendices

Show the project nodes colored for identification in
the Project Explorer.

Display a confirmation prompt before deleting a
configuration folder cotaining properties.

Display a confirmation prompt before replacing
project files for import and creation

Display a confirmation prompt before forgetting
option modifications.

Controls where Edit Options are displayed by the
Project Explorer's context menu.

Controls how common options are displayed by the
Project Explorer's context menu.

The file name of the application to use as the external
text editor. The external editor is started by holding
down the Shift key when opening files from the
project explorer.

Show an overlay on an item if it is populated from a
dynamic folder.

Show an overlay on an item if it is not held within the
project directory.

Show the build output files in an Output Files folder in
the project explorer.

Configures whether read-only data contributes to the
Code or Data statistic.

Controls how the dependencies are displayed.

Controls if favorite properties are displayed by the
Project Explorer's context menu.

Show the number of files contained in a folder as a
badge in the Project Explorer.
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Show Modified Options on Folder/File
Envi ronnent / Pr oj ect Expl or er/ Show
Modi fi ed Properti esBoolean

Show Options
Envi ronnent / Proj ect Expl orer/Properties
Di spl ayEnumeration

Show Project Count on Solution
Envi ronment / Proj ect Expl or er/ Count
Pr oj ect sBoolean

Show Source Control Annotation
Envi ronment / Proj ect Expl or er/ Show Sour ce
Control Annot ati onBoolean

Show Statistics Rounded
Envi ronnment / Proj ect Explorer/Statistics
For mat Boolean

Source Control Status Column
Envi ronnent / Proj ect Expl orer/ Show Sour ce
Control Col utmBoolean

Starred Files Names
Envi ronnent / Proj ect Explorer/Starred File
Nanmes StringList

Statistics Column
Envi ronnent/ Proj ect Explorer/Statistics
Di spl ayBoolean

Synchronize Explorer With Editor
Envi ronnent / Proj ect Expl orer/ Sync
Edi t or Boolean

Use Common Options Folder
Envi ronnent / Proj ect Expl orer/ Conmon
Properties Di spl ayBoolean

Registers 1

Property

Show Digit Separator
Envi ronment / Regi st er s1W ndow Show Di gi t
Separ at or Boolean

Show Register Address Column
Envi r onment / Regi st er s1W ndow Show Addr ess
Col utmBoolean

Appendices

Show if a folder or file has modified options as a badge
in the Project Explorer.

Controls how the options are displayed.

Show the number of projects contained in a solution
as a badge in the Project Explorer.

Annotate items in the project explorer with their
source control status.

Show exact or rounded sizes in the project explorer.

Show the source control status column in the project
explorer.

The list of wildcard-matched file names that are
highligted with stars, to bring attention to themselves,
in the Project Explorer.

Show the code and data size columns in the Project
Explorer.

Synchronizes the Project Explorer with the document
being edited.

Controls how common options are displayed.

Description

Show digit separator in register value display.

Controls whether the register address column is
displayed.
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Registers 2

Property

Show Digit Separator
Envi ronment / Regi st er s2W ndow Show Di gi t
Separ at or Boolean

Show Register Address Column
Envi r onnment / Regi st er s2W ndow/ Show Addr ess
Col urmBoolean

Registers 3

Property

Show Digit Separator
Envi r onnent / Regi st er s3W ndow Show Di gi t
Separ at or Boolean

Show Register Address Column
Envi r onnent / Regi st er s3W ndow Show Addr ess
Col utMmBoolean

Registers 4

Property

Show Digit Separator
Envi ronnent / Regi st er s4W ndow Show Di gi t
Separ at or Boolean

Show Register Address Column
Envi r onnent / Regi st er s4W ndow' Show Addr ess
Col utmBoolean

Source Navigator

Property

Group Symbols
W ndows/ Sour ce Navi gat or/ Group
Synbol sBoolean

Scope
W ndows/ Sour ce Navi gat or / ScopeEnumeration

Appendices

Description

Show digit separator in register value display.

Controls whether the register address column is
displayed.

Description

Show digit separator in register value display.

Controls whether the register address column is
displayed.

Description

Show digit separator in register value display.

Controls whether the register address column is
displayed.

Description

Group symbols by type.

Specifies whether to search for symbols in the entire
workspace or only the current document.
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Symbol Browser

Property Description

Code Field
Envi ronnment / Synbol Browser/ Di spl ay Selects whether the Code field is displayed.
CodeBoolean

Const Field
Envi ronnment / Synbol Browser/ Di spl ay Selects whether the Const field is displayed.
Const Boolean

Data Field
Envi ronnment / Synbol Browser/ Di spl ay Selects whether the Data field is displayed.
Dat aBoolean

Frame Size Field
Envi ronment / Synbol Browser/Di spl ay Frame Selects whether the Frame Size field is displayed.
Si zeBoolean

Range Field
Envi ronnment / Synbol Browser/ Di spl ay Selects whether the Range field is displayed.
RangeBoolean

Section Field
Envi ronment / Synbol Browser/ Di spl ay Selects whether the Section field is displayed.
Sect i onBoolean

Size Field
Envi ronment / Synbol Browser/ Di spl ay Selects whether the Size field is displayed.
Si zeBoolean

Sort Criteria
Envi ronment / Synbol Br owser/ Selects how to sort or group the symbols displayed.
G oupi ngEnumeration

Type Field

Envi ronment / Synbol Browser/ Di spl ay Selects whether the Type field is displayed.
TypeBoolean

Value Field

Envi ronment / Synbol Browser/ Di spl ay Selects whether the Value field is displayed.

Val ueBoolean

Terminal Emulator

Property Description

Backscroll Buffer Lines
Term nal Emul at or/ Backscrol | Buffer
Li nesIntegerRange

The number of lines you can see when you scroll
backward in the terminal emulator window.
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Baud Rate
Ter mi nal Emul at or/ Communi cat i ons/ Baud
Rat eEnumeration

Data Bits
Ter mi nal Emul at or/ Communi cat i ons/ Dat a
Bi t sEnumeration

Flow Control
Ter mi nal Emul at or/ Conmuni cat i ons/ Fl ow
Cont r ol Enumeration

Line Feed On Carriage Return

Term nal Enul ator/Line Feed On Carri age

Ret ur nBoolean

Local Echo
Term nal Enmul at or/ Local EchoBoolean

Maximum Input Block Size
Term nal Enul at or/ Maxi mum | nput Bl ock
Si zelntegerRange

Parity
Ter mi nal Emul at or / Communi cat i ons/
Par i t yEnumeration

Port
Ter mi nal Emul at or / Communi cat i ons/
Por t COMPort

Port Used By Target Interface
Term nal Enul at or/ Conmruni cat i ons/ Port
Used By Target InterfaceBoolean

Set DTR
Ter m nal Emul at or / Conmuni cat i ons/
DTRBoolean

Stop Bits
Ter mi nal Enul at or/ Comruni cat i ons/ St op
Bi t sEnumeration

Watch 1

Property

Show Digit Separator
Envi r onnent / Vat ch1W ndow/ Show Di gi t
Separ at or Boolean

Show Member Functions
Envi r onnent / Wat ch1W ndow Show Menber
Funct i onsBoolean

Appendices

Baud rate used when transmitting and receiving data.

Number of data bits to use when transmitting and
receiving data.

The flow control method to use.

Append a line feed character when a carriage return
character is received.

Displays every character typed before sending to the
remote computer.

The maximum number of bytes to read at a time.

Parity used when transmitting and receiving data.

The communications port to use, e.g. /dev/ttySO0, /dev/
ttyS1, etc.

The COM port will be disconnected when the target
interface is connected and reconnected when the
target interface is disconnected.

Set the DTR signal.

Number of stop bits to use when transmitting data.

Description

Show digit separator in variable value display.

Controls whether C++ class member functions are
displayed.
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Show Variable Address Column
Envi r onnent / Wat ch1W ndow Show Addr ess
Col unmBoolean

Show Variable Size Column
Envi r onnent / Wat ch1W ndow Show Si ze
Col unmBoolean

Show Variable Type Column
Envi r onnent / WVt ch1W ndow Show Type
Col umBoolean

Watch 2

Property

Show Digit Separator
Envi r onnent / Wat ch2W ndow/ Show Di gi t
Separ at or Boolean

Show Member Functions
Envi r onnent / Wat ch2W ndow Show Menber
Funct i onsBoolean

Show Variable Address Column
Envi r onnent / Wat ch2W ndow/ Show Addr ess
Col utmBoolean

Show Variable Size Column
Envi r onnent / Wat ch2W ndow Show Si ze
Col utTmBoolean

Show Variable Type Column
Envi r onnent / Vat ch2W ndow Show Type
Col utmmBoolean

Watch 3

Property

Show Digit Separator
Envi r onnent / Wt ch3W ndow/ Show Di gi t
Separ at or Boolean

Show Member Functions
Envi r onnent / Wat ch3W ndow Show Menber
Funct i onsBoolean

Show Variable Address Column
Envi r onnent / Wat ch3W ndow Show Addr ess
Col umBoolean

Appendices

Controls whether the variable address column is
displayed.

Controls whether the variable size column is displayed.

Controls whether the variable type column is
displayed.

Description

Show digit separator in variable value display.

Controls whether C++ class member functions are
displayed.

Controls whether the variable address column is
displayed.

Controls whether the variable size column is displayed.

Controls whether the variable type column is
displayed.

Description

Show digit separator in variable value display.

Controls whether C++ class member functions are
displayed.

Controls whether the variable address column is
displayed.
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Show Variable Size Column
Envi r onnent / Wat ch3W ndow Show Si ze
Col unmBoolean

Show Variable Type Column
Envi r onnent / Wat ch3W ndow Show Type
Col unmBoolean

Watch 4

Property

Show Digit Separator
Envi r onnent / at ch4W ndow/ Show Di gi t
Separ at or Boolean

Show Member Functions
Envi r onnent / Wat ch4W ndow Show Menber
Funct i onsBoolean

Show Variable Address Column
Envi r onnent / Wat ch4W ndow Show Addr ess
Col ummBoolean

Show Variable Size Column
Envi r onnent / Wat ch4W ndow Show Si ze
Col umBoolean

Show Variable Type Column
Envi r onnent / Vat ch4W ndow Show Type
Col utMmBoolean

Windows

Property

Buffer Grouping
Envi ronnent / W ndows/ Gr oupi hgEnumeration

Show File Path as Tooltip
Envi ronment / W ndows/ Show Fi | enane
Tool ti psBoolean

Show Line Count and File Size
Envi r onnent / W ndows/ Show Si zesBoolean

Appendices

Controls whether the variable size column is displayed.

Controls whether the variable type column is
displayed.

Description

Show digit separator in variable value display.

Controls whether C++ class member functions are
displayed.

Controls whether the variable address column is
displayed.

Controls whether the variable size column is displayed.

Controls whether the variable type column is
displayed.

Description
How the files are grouped or listed in the Windows

window.

Show the full file name as a tooltip when hovering
over files in the Windows window.

Show the number of lines and size of each file in the
windows list.
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Code Options

Assembler

Property

Additional Assembler Options
asm addi ti onal _opti onsStringList

Additional Assembler Options From File
asm addi ti onal _opti ons_from fil eProjFileName

Assembler
arm assenbl er _vari ant Enumeration

Backup Additional Assembler Options
asm addi ti onal _opti ons_backupString

Run Preprocessor
arm preprocess_assenbl y_codeBoolean

Build

Property

Always Rebuild
bui | d_al ways_r ebui | dBoolean

Batch Build Configurations
bat ch_bui | d_confi gur at i onsStringList

Build Options Generic File Name
bui | d_generi c_opti ons_fil e_nanmeProjFileName

Build Quietly
bui | d_qui et | yBoolean

Compilation Database File
conpi | ati on_dat abase_fi | eFileName

Dependency File Name
bui | d_dependency_fi | e_naneFileName

Enable Unused Symbol Removal
bui I d_renove_unused_synbol sEnumeration

Exclude From Build
bui | d_excl ude_from bui | dBoolean

Appendices

Description

Enables additional options to be supplied to the
assembler. This property will have macro expansion
applied toit.

Enables additional options to be supplied to the
assembler from a file. This property will have macro
expansion applied to it.

Specifies which assembler to use. SEGGER Assembler:
Technology preview - For test purposes only.

Value of additional assembler options prior to generic
options processing.

The assembly code file is preprocessed before
assembly

Description

Specifies whether or not to always rebuild the project/
folder/file.

The set of configurations to batch build.

The file name containing the generic options.

Suppress the display of startup banners and
information messages.

The name of the compilation database file

The file name to contain the dependencies.
Enable the removal of unused symbols from the
executable.

Specifies whether or not to exclude the project/folder/
file from the build.

272



SEGGER Embedded Studio Reference Manual

GCC Prefix
gcc_prefi xString

GCC Target
gcc_t ar get String

GCC Version
gcc_ver si onString

Generate Compilation Database
gener at e_conpi |l ati on_dat abase_fi | eBoolean

Generate Dependency File
bui | d_gener at e_dependency_fi | eEnumeration

Include Debug Information
bui | d_debug_i nf or mat i onBoolean

Inputs File
i nputs_fi | eFileName

Inputs Order
i nput s_or der StringList

Intermediate Directory
bui | d_i nt er medi at e_di r ect or yDirPath

Is C++ Project
i s_cpp_pr oj ect Enumeration

Object File Name
bui | d_obj ect _fi | e_nanmeFileName

Output Directory
bui | d_out put _di r ect or yDirPath

Preprocess Output File Name
bui | d_preprocess_out put _fil e_nanmeFileName

Project Can Build In Parallel
project _can_buil d_i n_paral | el Enumeration

Project Dependencies
pr oj ect _dependenci esStringList

Project Directory
proj ect _di rect or yString

Appendices

The string that is prepended to the gcc toolname e.g
arm-none-eabi-. The macro $(GCCPrefix) is set to this
value for external build command lines.

The macro $(GCCTarget) is set to this value for build
command lines.

The macro $(GCCVersion) is set to this value for build
command lines.

Generate a JSON formatted file named by the
Compilation Database property.

Generate a dependency file

Specifies whether symbolic debug information is
generated.

Specifies the inputs file to be used for Linking/
Archiving. The files listed in this file will be used rather
than the outputs of the project.

Specifies the order to supply input files to be used for
Linking/Archiving.

Specifies a relative path to the intermediate file
directory. This property will have macro expansion
applied to it. The macro $(IntDir) is set to this value.

Supply C++ include directories and libraries to the
project build.

Specifies a name to override the default object file
name.

Specifies a relative path to the output file directory.
This property will have macro expansion applied

to it. The macro $(OutDir) is set to this value. The
macro $(RootRelativeOutDir) is set relative to the Root
Output Directory if specified.

Specifies a name to override the default preprocess
output file name.

Specifies that dependent projects can be built in
parallel. Default is No for Staging and Combining
project types, Yes for all other project types.

Specifies the projects that are built before the
current project is built. For Staging project types the
dependent projects are built in sequence.

Path of the project directory relative to the directory
containing the project file. The macro $(ProjectDir) is
set to the absolute path of this property.
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Project Macros
macr osStringList

Project Type
pr oj ect _t ypeEnumeration

Property Groups File
property_groups_fil e_pat hProjFileName

Root Output Directory
bui | d_r oot _out put _di r ect or yDirPath

Suppress Warnings
bui | d_suppr ess_war ni ngsBoolean

Toolchain Directory
bui | d_t ool chai n_di r ect or yDirPath

Treat Warnings as Errors
bui | d_treat _warni ngs_as_err or sBoolean

Use External GCC
use_ext er nal _gccBoolean

Code Analyzer

Property

Analyze After Compile
anal yze_aft er _conpi | eBoolean

Analyze Command
anal yze_commandCommandLine

Analyze Command Options C
anal yze_conmand_c_opt i onsStringList

Analyze Command Options C++
anal yze_command_cpp_opt i onsStringList

Appendices

Specifies macro values which are expanded in
project properties and for file names in Common
configuration only. Each macro is defined as
name=value and are seperated by ;.

Specifies the type of project to build. The options are
Executable, Library, Object file, Staging, Combining,
Externally Built Executable, Externally Built Library,
Externally Built Object file, Preprocess.

The file containing the property groups for this project.
This is applicable to Executable and Externally Built
Executable project types only.

Allows a common root output directory to be specified
that can be referenced using the $(RootOutDir) macro.

Don't report warnings.

Specify the root of the toolchain directory. This
property will have macro expansion applied to it. The
macro $(ToolChainDir) is set to this value.

Treat all warnings as errors.

The build will issue gcc commands.

Description
Run the static code analyzer after compile

The command to execute for the Analyze action. This
property will have macro expansion applied to it with
the additional macros:

$(DEFINES) contains a space seperated list

of preprocessor definitions as set in the
Preprocessor Definitions property.

S(INCLUDES) contains a space seperated list of
user include directories as set in the User Include
Directories property.

Options to supply to the analyze command for C
source files.

Options to supply to the analyze command for C++
source files.
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Clang Tidy Checks C
cl ang_ti dy_checks_cStringList

Clang Tidy Checks C++
cl ang_ti dy_checks_cppStringList

Code Generation

Property

ARM ABI Type
ar m_abi Enumeration

ARM Advanced SIMD Auto Vectorize
arm advanced_SI MD_aut o_vect ori zeBoolean

ARM Advanced SIMD Type
arm advanced_SI MD_t ypeEnumeration

Appendices

Checks to supply to clang-tidy for C source files.

Checks to supply to clang-tidy for C++ source files.

Description

Specifies the ABI type to generate code for. The
options are:

AAPCS generate calls to the C library to
implement floating point operations.
None will not specify the ABI.

Enable automatic code generation for Advanced SIMD.

Specifies the Advanced SIMD type to generate code
for. The options are:

NEON - Cortex-A based processors
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ARM Architecture
arm ar chi t ect ur eEnumeration

Appendices

Specifies the version of the instruction set to generate
code for. The options are:

v4T - ARM7TDMI and ARM920T processors
V5TE - ARMOE, Feroceon and XScale processors
v6 - ARM11 processors

v6M - Cortex-MO/M1 processors

v7M - Cortex-M3 processors

V7EM - Cortex-M4/M7 processors

V7R - Cortex-R4/R5/R8 processors

v7A - Cortex-A5/A7/A8/A9/A17 processors

v8R - Cortex-R52 processors

v8A - Cortex-A32/A35/A53/A55/A57/A72/A73/A75
processors

v8M_Baseline - Cortex M23 processor
v8M_Mainline - Cortex M33 processor
v8.1M_Mainline - Cortex-M55/M85 processors
None

The corresponding preprocessor definitions:

__ARM_ARCH_4T__

_ ARM_ARCH_5TE__

__ ARM_ARCH_6__

__ ARM_ARCH_6M__

_ ARM_ARCH_7M__

__ ARM_ARCH_7EM__
__ARM_ARCH_7R__

__ ARM_ARCH_7A__
__ARM_ARCH_8R__

_ ARM_ARCH_8A__
__ARM_ARCH_8M_BASELINE__
__ARM_ARCH_8M_MAINLINE__
__ARM_ARCH_81M_MAINLINE__

are defined.
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Specifies the core to generate code for. The options
are:

ARM7TDMI, ARM7TDMI-S, ARM720T

ARM920T, ARM946E-S, ARM966E-S, ARM9I68E-S,
ARM926EJ-S

ARM1136J-S, ARM1136JF-S, ARM1176JZ-S,
ARM1176JZF-S

Cortex-MO, Cortex-M0O+, Cortex-M1, Cortex-M23,
Cortex-M3, Cortex-M33, Cortex-M4, Cortex-M55,
Cortex-M7, Cortex-M85

Cortex-R4, Cortex-R4F, Cortex-R5, Cortex-R7,
Cortex-R8

Cortex-R52

Cortex-A5, Cortex-A7, Cortex-A8, Cortex-A9,
Cortex-A15, Cortex-A17

Cortex-A32, Cortex-A35, Cortex-A53, Cortex-A55,
Cortex-A57, Cortex-A72, Cortex-A73, Cortex-A75
XScale

None

ARM Core Type
ar m cor e_t ypeEnumeration

If this property is set to None then the architecture
property is used

Specifies the FP ABI type to generate code for. The
options are:

Soft generate calls to the C library to implement
floating point operations.

SoftFP generate VFP code to implement floating
point operations.

Hard generate VFP code to implement floating
point operations and use VFP registers to pass
floating point parameters on function calls.
None will not specify the FP ABI or the FPU.

ARM FP ABI Type
ar m f p_abi Enumeration
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ARM FPU Type
ar m f pu_t ypeEnumeration

Additional C++ Modules
gcc_addi ti onal _nodul esStringlList

Byte Order
ar m_endi anEnumeration

CMO0/CM0+/CM1 Has Small Multiplier
armcnD_has_smal | _mul ti pli er Boolean

Code Model.
ar nb4_code_nodel Enumeration

Data Model.
ar nb4_abi Enumeration

Data Sections
gcc_dat a_sect i onsBoolean

Appendices

Specifies the FPU type to generate code for. The
options are:

VFP - ARM9/ARM11 based processors

VFP9 - the same as VFP

VFPv3-D32 - Cortex-A/Cortex-R based processors
VFPv3-D16 - Cortex-A/Cortex-R based processors
VFPv4-D32 - Cortex-A/Cortex-R based processors
VFPv4-D16 - Cortex-A/Cortex-R based processors
FPv4-SP-D16 - Cortex-M4 processors
FPv5-SP-D16 - Cortex-M7/M33/R52 processors
FPv5-D16 - Cortex-M7/M55 processors
FP-ARMv8 - Cortex-A/Cortex-R processors

The corresponding preprocessor definitions:

_ ARM_ARCH_VFP__
__ARM_ARCH_VFP3_D32__
__ARM_ARCH_VFP3_D16__

__ ARM_ARCH_VFP4_D32__
__ARM_ARCH_VFP4_D16__
__ARM_ARCH_FPV4_SP_D16__
__ ARM_ARCH_FPV5_SP_D16__
__ARM_ARCH_FPV5_D16__

__ ARM_ARCH_FP_ARMvS8__

are defined.

Add additional C++ Modules to the module mapper
file of the form name=filename.

Specify the byte order of the target processor. The
options are:

Little little endian code and data.

Big big endian code and data.

BE-8 little endian code and big endian data.
None do not specify the endian.

The CM0/CMO0+/CM1 core has the small multiplier.

Specify the code model to generate code for.

Specify the data model to generate code for.

Place each data item in it's own section.

278



SEGGER Embedded Studio Reference Manual

Debugging Level
gcc_debuggi ng_| evel Enumeration

Disable Function Inlining
gcc_di sabl e_function_inlini ngBoolean

Dwarf Version
gcc_dwar f _ver si onEnumeration

Enable Coroutine Support
gcc_enabl e_cor out i nesBoolean

Enable Exception Support
cpp_enabl e_except i onsEnumeration

Enable Linker Relaxation
rv_r el axEnumeration

Enable Modules Support
gcc_enabl e_nodul esBoolean

Enable Precompiled Header File
gcc_enabl e_preconpi | ed_header Boolean

Enable RTTI Support
cpp_enabl e_rtti Enumeration

Enable Save Restore
rv_save_r est or eEnumeration

Enable Stack Overflow Prevention
st ack_overfl ow_preventi onBoolean

Enable Use Of __ cxa_atexit
gcc_use_cxa_at _exi t Boolean

Enable Use Of __cxa_guard_acquire/release
gcc_t hread_saf e_st ati csBoolean

Enumeration Size
gcc_short _enunEnumeration

FP16 Format.
arm f pl6_f or mat Enumeration

Fast Math
gcc_fast _mat hEnumeration

Appendices

Specifies the level of debugging information to
generate. The options are:

None - no debugging information

Level 1 - backtrace and line number debugging
information

Level 2 - Level 1 and variable display debugging
information

Level 3 - Level 2 and macro display debugging
information

Disable auto inlining of functions when optimization
enables this.

Specifies the version of Dwarf debugging information
to generate.

Specifies whether coroutine support is enabled for C+
+ programs.

Specifies whether exception support is enabled for C+
+ programs.

If enabled the linker may be able to optimize the
instructions used to access symbols.

Specifies whether modules support is enabled for C++
programs.

Enable use of a precompiled header file for the project.

Specifies whether RTTI support is enabled for C++
programs.

If enabled use smaller but slower prolog and epilog
code.

Enable Stack Overflow Prevention.
For more information read: https://wiki.segger.com/
Stack_Overflow_Prevention

Enable compiler usage of __cxa_atexit.

Enable compiler usage of __cxa_guard/acquire/release
to enable thread-safe initialization of local statics.

Select between minimal container sized enumerations
and int sized enumerations.

The format of 16-bit floating point numbers.

Enable fast-math mode.
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Function Sections
gcc_function_secti onsBoolean

GNU Tools Prefix
rv_t ool chai n_pr ef i xString

Generate Dwarf Debug Types
gcc_dwar f _gener at e_debug_t ypesBoolean

Generate Dwarf Pubnames
gcc_dwar f _gener at e_pubnanesBoolean

Generate Listing File
asm generate_l|isting_fil eBoolean

Instruction Set
arm_i nstructi on_set Enumeration

Instrument Functions
arm_i nstrument _f unct i onsBoolean

Is C++ Module
i s_cpp_nodul eEnumeration

Keep Link Time Optimization Intermediate Files
i nk_keep_lto_fil esBoolean

Link Time Optimization
link_time_optin zati onBoolean

Link Time Optimization Additional Options
It o_addi ti onal _opti onsStringList

Long Calls
arm_| ong_cal | sBoolean

Machine Outliner [segger-cc]
cl ang_nmachi ne_out | i ner Enumeration

Math Errno
ar m_mat h_er r noEnumeration

Merge Globals [segger-cc]
cl ang_ner ge_gl obal sBoolean

No COMMON
gcc_no_commonEnumeration

Omit Frame Pointer
gcc_onit_franme_poi nt er Enumeration

Appendices

Place each function in it's own section.

The RISC-V GNU tools prefix e.g andes-, the macro
$(GCCTarget) has this value prepended to it.

Generate Dwarf .debug_types section.

Generate Dwarf .debug_pubnames
and .debug_pubtypes sections.

An source/assembler listing file is generated which can
be found in the output files folder

Specifies the instruction set to generate code for.

Specifies whether instrumentation calls are generated
for function entry and exit.

The file contains an importable C++ module unit.

Specifies whether to keep the link time optimization
resolution and object files.

Specifies whether the project should be built for
optimization at link time.

Enables additional options to be supplied to the link
time optimization process

Specifies whether function calls are made using
absolute addresses.

Select machine outliner mode. An optimization

that reduces code size by identifying identical code
sequences across functions and replaces them with
a call to a function which contains the identical code
sequence.

Set errno after calling math functions that are
executed with a single instruction, e.g., sqrt.

Select whether global declarations are merged. This
may reduce code size and increase execution speed
for some applications. However, if functions are not
used in an application and are eliminated by the
linker, merged globals may increase the data size
requirement of an application.

Don't put globals in the common section

Specifies whether a frame pointer register is omitted if
not required.
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Optimization Level
gcc_optim zati on_| evel Enumeration

Outline Atomics
armb4_out | i ne_at om csEnumeration

Precompiled Header File
gcc_preconpi | ed_header Boolean

RISC-V ABI
r v_abi Enumeration

Appendices

Specifies the optimization level to use. The options are:

None - don't specify an optimization level

Debug - optimize for debug experience.

Level 0 - no optimization, fastest compilation and
best debug experience.

Level 1 - optimize minimally.

Level 2 for speed

Level 2 balanced

Level 2 for size

Level 3 for more speed - optimize even more, will
take longer to compile and may produce much
larger code.

Enable or disable calls to out-of-line helpers to
implement atomic operations

The precompiled header file for the project.

Specifies the floating point instruction set to generate
code for. The options are:
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ilp32 - software floating point

ilp32d - hardware double precision floating point
ilp32e - embedded abi

ilp32f - hardware single precision floating point
Ip64 - software floating point

Ip64d - hardware double precision floating point
Ip64f - hardware single precision floating point
None - do not supply an abi command line option
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Specifies the instruction set to generate code for. The
options are:

rv32e - RV32E with no extensions
rv32ec - RV32E with C extension
rv32ea - RV32E with A extension
rv32eac - RV32E with A and C extension
rv32em - RV32E with M extension
rv32emc - RV32E with M and C extensions
rv32ema - RV32E with M and A extensions
rv32emac - RV32E with M, A and C extensions
rv32i - RV32l with no extensions
rv32ia - RV32l with A extension
rv32ic - RV32l with C extension
rv32iac - RV32l with A and C extensions
rv32im - RV32l with M extension
rv32imc - RV32l with M and C extensions
rv32imf - RV32l with M and F extensions
rv32imfc - RV32l with M, F and C extensions

RISC-V ISA rv32ima - RV32l with M and A extensions

rv architect ur eEnumeration rv32imac - RV32l with M, A and C extensions

a rv32imaf - RV32l with M, A and F extensions

rv32imafc - RV32l with M, A, F and C extensions
rv32g - RV32l with M, A, F and D extensions
rv32gc - RV32l with M, A, F, D and C extensions
rv64i - RV64l with no extensions
rv64ia - RV64l with A extension
rvé64ic - RV64l with C extension
rv64im - RV64l with M extension
rv64imc - RV64| with M and C extensions
rv64imf - RV64l with M, and F and C extensions
rv64imfc - RV64l with M, F and C extensions
rv64ima - RV64l with M and A extensions
rvé4imac - RV64l with M, A and C extensions
rve4imaf - RV64! with M, A and F extensions
rve4imafc - RV64l with M, A, F and C extensions
rv64g - RV64l with M, A, F and D extensions
rvé4gc - RV64l with M, A, F, D and C extensions
None - do not supply an architecture command
line option

RISC-V ISA Extension

rv_ar ch_ext String

RISC-V ISA P Extension
rv_ar ch_pBoolean

RISC-V ISA V Extension
rv_arch_vBoolean

Additional extensions to supply to the tools

Add support for P extension

Add support for V extension
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RISC-V ISA Zba Extension
rv_ar ch_zbaBoolean

RISC-V ISA Zbb Extension
rv_arch_zbbBoolean

RISC-V ISA Zbc Extension
rv_arch_zbcBoolean

RISC-V ISA Zbkb Extension
rv_ar ch_zbkbBoolean

RISC-V ISA Zbkx Extension
rv_arch_zbkxBoolean

RISC-V ISA Zbs Extension
rv_arch_zbsBoolean

RISC-V ISA Zcb Extension
rv_ar ch_zcbBoolean

RISC-V ISA Zcmp Extension
rv_arch_zcnpBoolean

RISC-V ISA Zfinx Extension
rv_arch_zfi nxBoolean

RISC-V ISA Zicond Extension
rv_ar ch_zi condBoolean

RISC-V ISA Zicsr Extension
rv_arch_zi csrBoolean

RISC-V ISA Zifencei Extension
rv_arch_zi f encei Boolean

RISC-V ISA Zmmul Extension
rv_ar ch_zmmul Boolean

RISC-V Memory Code Model
rv_ncnodel Enumeration

Relocation Model [segger-cc]
cl ang_rel ocat i on_nodel Enumeration

Signed Char
gcc_si gned_char Enumeration

Stack Sizes
gener at e_st ack_si zesBoolean

Appendices

Add support for Zba extension

Add support for Zbb extension

Add support for Zbc extension

Add support for Zbkb extension

Add support for Zbkx extension

Add support for Zbs extension

Add support for Zcb extension

Add support for Zcmp extension

Add support for Zfinx extension

Add support for Zicond extension

Add support for Zicsr extension

Add support for Zifencei extension

Add support for Zmmul extension

Specifies the 64-bit code model to generate code for.
The options are:

medlow - memory map has address ranges of
-2Gb to +2Gb

medany - memory map has address ranges of
+2Gb

None - do not supply an mcmodel command line
option

Select relocation model.

The char type is considered to be signed char.

Generate stack sizes section
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Strict Aliasing
gcc_strict _al i asi ngEnumeration

Thread Model [segger-cc]
cl ang_t hr ead_nodel Enumeration

Thread-Local Storage Model
gcc_t | s_nodel Enumeration

Thread-Local Storage Pointer
arm tl| s_nodel Enumeration

Unaligned Access Support
arm unal i gned_accessEnumeration

Unaligned Access Support.
rv_unal i gned_accessEnumeration

Unwind Tables
arm unwi nd_t abl esEnumeration

Use Builtins
arm use_bui | ti nsEnumeration

Vector Extension
arm v81lM nve_t ypeEnumeration

Wide Character Size
gcc_wchar _si zeEnumeration

v7A/v7R Has Integer Divide Instructions

arm v7_has_divide_instructi onsBoolean

v8.1M Has PACBTI Instructions
arm v81M has_pacbt i Boolean

v8A Architecture Extension

arm v8A archit ect ure_ext ensi onEnumeration

v8A Has BF16 Instructions
arm v8A has_bf 16Boolean

Appendices

Strictest aliasing rules are allowed for optimization.

Select thread model.

Thread-local storage model.

Thread-local storage pointer access model.

Unaligned word and half-words can be accessed. The
options are:

Yes enable unaligned word and half-words.
No disable unaligned word and half-words.
Auto disable unaligned word and half-word
access for v4T/v5TE/v6M/v8M_Baseline
architectures, enable for others.

Unaligned word and half-words can be accessed. The
options are:

Yes enable unaligned word and half-words.
No disable unaligned word and half-words.

Generate unwind tables for C code.

Use built-in library functions e.g. scanf.

Specifies the vector extension type to generate code
for. The options are:

MVE - integer instructions
MVE.FP - integer and single precision floating-
point instructions

Select between standard 32-bit or shorter 16-bit size
for wide characters and wchar_t.

The v7A architecture has integer divide instructions

in both ARM and Thumb instruction sets. The v7R
architecture has integer divide instructions in the ARM
instruction set. The v7R architecture always has integer
divide instructions in the Thumb instruction set.

The v8.1M architecture has PACBTI instructions.

The v8A architecture extension.

The v8A architecture has brain half-precision floating
point instructions.
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v8A Has CRC Instructions
arm v8A has_cr cBoolean

v8A Has Crypto Instructions
arm v8A has_crypt oBoolean

v8A Has FP16 Instructions
arm v8A has_f pl6Boolean

v8A Has FP16FML Instructions
arm v8A has_f p16f nl Boolean

v8A Has IBMM Instructions
arm v8A has_i 8mmBoolean

v8M Has CMSE Instructions
arm v8M has_cnseBoolean

v8M Has DSP Instructions
arm v8M has_dspBoolean

Combining

Property

Combine Command
conbi ne_commandCommandLine

Combine Command Working Directory
conbi ne_comrand_wdString

Output File Path
conbi ne_out put _fi | epat hString

Set To Read-only
conbi ne_set _r eadonl yEnumeration

Compiler
Property

Additional C Compiler Only Options
c_only_addi ti onal _opti onsStringList

Additional C Compiler Only Options From File
c_only_additional _options_fromfil eProjFileNa

Appendices

The v8A architecture has CRC instructions.

The v8A architecture has crypto instructions.

The v8A architecture has half-precision floating point
instructions.

The v8A architecture has half-precision floating point
fmla instructions.

The v8A architecture has 8-bit integer maxtrix multiply
instructions.

The v8M architecture has CMSE instructions.

The v8M architecture has DSP instructions.

Description

The command to execute. This property will have
macro expansion applied to it with the macro
$(CombiningOutputFilePath) set to the output
filepath of the combine command and the macro
$(CombiningRellnputPaths) is set to the (project
relative) names of all of the files in the project.

The working directory in which the combine command
is run. This property will have macro expansion applied
toit.

The output file path the stage command will create.

This property will have macro expansion applied to it.

Set the output file to read only or read/write.

Description

Enables additional options to be supplied to the
C compiler only. This property will have macro
expansion applied to it.

Enables additional options to be supplied to the C
compiler only from a file. This property will have macro
expansion applied to it.
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Additional C++ Compiler Only Options
cpp_only_addi ti onal _opti onsStringList

Additional C++ Compiler Only Options From File

cpp_only_additional _options_fromfil eProjFile

Additional C/C++ Assembler Options
c_asm addi ti onal _opti onsStringList

Additional C/C++ Compiler Options
c_addi ti onal _opti onsStringList

Additional C/C++ Compiler Options From File
c_addi ti onal _options_from fil eProjFileName

Backup Additional C Compiler Only Options
c_only_additional _options_backupString

Backup Additional C++ Compiler Only Options
cpp_only_additi onal _opti ons_backupString

Backup Additional Compiler Options
c_addi ti onal _opti ons_backupString

C Language Standard
gcc_c_l anguage_st andar dEnumeration

C++ Language Standard
gcc_cpl uspl us_I anguage_st andar dEnumeration

Color Diagnostics
conpi | er _col or _di agnost i csEnumeration

Compile C Files As C++
c_files_are_cppBoolean

Appendices

Enables additional options to be supplied to the
C++ compiler only. This property will have macro
expansion applied to it.

Enables additional options to be supplied to the C++
compiler only from a file. This property will have macro
expansion applied to it.

Enables additional options to be supplied to the
assembler when used by the C/C++ compiler. This
property will have macro expansion applied to it.

Enables additional options to be supplied to the C/C+
+ compiler. This property will have macro expansion
applied toit.

Enables additional options to be supplied to the C/C
++ compiler from a file. This property will have macro
expansion applied to it.

Value of additional C compiler options prior to generic
options processing

Value of additional C++ compiler options prior to
generic options processing

Value of additional compiler options prior to generic
options processing

Specifies the language standard to use when
compiling Cfiles. The options are:

None - don't specify a language standard
¢89/gnu89
€90/gnu90
€99/gnu99
c11/gnuli
c17/gnu17

Specifies the language standard to use when
compiling C files. The options are:

None - don't specify a language standard
c++98/gnu++98
c++11/gnu++11
c++14/gnu++14
c++20/gnu++20
c++17/gnu++17

Specifies whether to enable color diagnostic output.

Compile files that have the .c extension with the C++
compiler.
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Compiler
arm _conpi | er _vari ant Enumeration

Compiler Has -Oz

gcc_has_Oz_optim zati on_| evel Boolean

Enable All Warnings
gcc_enabl e_al | _war ni ngsBoolean

Enable All Warnings C Compiler Only Command Line
Options

gcc_c_only_all _warni ngs_command_| i ne_optio

Enable All Warnings C++ Compiler Only Command
Line Options

gcc_cpp_only_all _warni ngs_command_| i ne_opt

Enable All Warnings Command Line Options

Appendices

Specifies which compiler to use.

The compiler support the -Oz optization level.

Enables the compiler warnings that are specified in the
Enable All Warnings (C Compiler Only) Command Line
Options properties.

The command line options supplied to the C compiler
when Enable All Warnings is enabled.

The command line options supplied to the C++
compiler when Enable All Warnings is enabled.

The command line options supplied to the compiler

gcc_al |l _warni ngs_command_| i ne_opt i onsStringL when Enable All Warnings is enabled.

Enforce ANSI Checking
c_enforce_ansi _checki ngBoolean

Enforce ANSI Checking C Command Line Options

Perform additional checks for ensure strict
conformance to the selected ISO (ANSI) C or C++
standard.

The command line options supplied to the C compiler

gcc_c_only_enforce_ansi _checki ng_command_| when Enforce ANSI Checking is enabled.

Enforce ANSI Checking C++ Command Line Options

The command line options supplied to the C++

gcc_cpp_onl y_enforce_ansi _checki ng_conmmand compiler when Enforce ANSI Checking is enabled.

Enforce ANSI Checking Command Line Options

The command line options supplied to the compiler

gcc_enforce_ansi _checki ng_conmand_| i ne_opt when Enforce ANSI Checking is enabled.

GNU Version [segger-cc]
cl ang_gnu_ver si onEnumeration

Keep Assembly Source
arm keep_assenbl yBoolean

Keep Preprocessor Output
arm keep_preprocessor _out put Boolean

No Unsupported Architecture [segger-cc]

segger _cc_no_unsupported_ar chi t ect ur eBooleal

Show Caret
conpi | er _di agnosti cs_show_car et Enumeration

Supply Absolute File Path
arm suppl y_absol ute_fi | e_pat hBoolean

Supply Execution Character Set

Specifies value of __GNU__ and related macros
Specifies whether assembly code generated by the
compiler is kept.

Specifies whether preprocessor output generated by
the compiler is kept.

Disable unsupported architecture warning.
Specifies whether caret is displayed in compiler

diagnostics.

Specifies whether absolute file paths are supplied to
the compiler.

Specifies whether to supply the editor file encoding as

conpi | er _suppl y_edi t or _execut e_char set Boole the execution character set.

Supply Input Character Set

Specifies whether to supply the editor file encoding as

conpi | er _suppl y_edi tor _i nput _char set Boolean the input character set.
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Use Compiler Driver
use_conpi |l er _dri ver Boolean

External Build

Property

Archive Command
ext er nal _ar chi ve_comandCommandLine

Appendices

The build will issue cc commands.

Description

The command line to archive object files. This property
will have macro expansion applied to it with the
additional macros:
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$(TargetPath) contains the full file name of the
Library File Name property

$(RelTargePath) contains the project directory
relative file name of the Object File Name
property.

$(Objects) a space seperated list of files to archive,
generated from the source files of the project OR.
$(ObjectsFilePath) contains the full file name of
the file containing the list of files to archive
$(RelObjectsFilePath) contains the project
directory relative file name of the file containing
the list of files to link
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The command line to assemble an assembly source
file. This property will have macro expansion applied
to it with the additional macros:

$(TargetPath) contains the full file name of the
Object File Name property.

$(RelTargePath) contains the project directory
relative file name of the Object File Name
property.

$(AsmOptions) contains a space seperated list
of options as set in the Additional Assembler
Options property.

$(DependencyPath) contains the filename of
the .d file that is required to be output by the
compilation for dependency support.
$(RelDependencyPath) contains the relative
filename of the .d file that is required to be output
by the compilation for dependency support.
$(Defines) contains a space seperated list

of preprocessor definitions as set in the
Preprocessor Definitions property.
$(Undefines) contains a space seperated list

of preprocessor undefinitions as set in the
Preprocessor Definitions property.

$(Includes) contains a space seperated list of
user include directories as set in the User Include
Directories property.

S(IncludeFiles) contains a space seperated list of
include files as set in the Include Files property.

Assemble Command
ext er nal _assenbl e_commandCommandLine

Build Command The command line to build the executable e.g. make.
ext ernal _bui | d_commandCommandLine This property will have macro expansion applied to it.
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C Compile Command
ext ernal _c_conpi | e_conmandCommandLine

Appendices

The command line to compile a C source file. This
property will have macro expansion applied to it with
the additional macros:
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$(TargetPath) contains the full file name of the
Object File Name property.

$(RelTargePath) contains the project directory
relative file name of the Object File Name
property.

$(COptions) contains a space seperated list of
options as set in the C Additional C/C++ Compiler
Options property.

$(COnlyOptions) contains a space seperated list
of options as set in the C Additional C Compiler
Only Options property.

$(DependencyPath) contains the filename of

the .d file that is required to be output by the
compilation for dependency support.
$(RelDependencyPath) contains the relative
filename of the .d file that is required to be output
by the compilation for dependency support.
$(Defines) contains a space seperated list

of preprocessor definitions as set in the
Preprocessor Definitions property.

$(Undefines) contains a space seperated list

of preprocessor undefinitions as set in the
Preprocessor Definitions property.

$(Includes) contains a space seperated list of
user include directories as set in the User Include
Directories property.

S(IncludeFiles) contains a space seperated list of
include files as set in the Include Files property.
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C++ Compile Command
ext ernal _cpp_conpi | e_comandCommandLine

Appendices

The command line to compile a C++ source file. This
property will have macro expansion applied to it with
the additional macros:
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$(TargetPath) contains the full file name of the
Object File Name property.

$(RelTargePath) contains the project directory
relative file name of the Object File Name
property.

$(COptions) contains a space seperated list of
options as set in the C Additional C/C++ Compiler
Options property.

$(CppOnlyOptions) contains a space seperated
list of options as set in the C Additional C++
Compiler Only Options property.
$(DependencyPath) contains the filename of

the .d file that is required to be output by the
compilation for dependency support.
$(RelDependencyPath) contains the relative
filename of the .d file that is required to be output
by the compilation for dependency support.
$(Defines) contains a space seperated list

of preprocessor definitions as set in the
Preprocessor Definitions property

$(Undefines) contains a space seperated list

of preprocessor undefinitions as set in the
Preprocessor Definitions property.

$(Includes) contains a space seperated list of
user include directories as set in the User Include
Directories property.

S(IncludeFiles) contains a space seperated list of
include files as set in the Include Files property.
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The command line to link an executable. This property
will have macro expansion applied to it with the
additional macros:

$(TargetPath) contains the full file name of the
Executable File Name property.
$(RelTargePath) contains the project directory
relative file name of the Executable File Name
property.

$(LinkOptions) contains a space seperated list of
options as set in the Additional Linker Options
property.

$(Objects) a space seperated list of files to link,
generated from the source files of the project and
the outputs of any dependent projects OR.
$(ObjectsFilePath) contains the full file name of
the file containing the list of files to link
$(RelObjectsFilePath) contains the project
directory relative file name of the file containing
the list of files to link

$(LinkerScriptPath) contains the full file name of
the Linker Script File property.
$(RelLinkerScriptPath) contains the project
directory relative file name of the Linker Script
File property.

$(MapPath) contains the full file name of the
required map file.

$(RelMapPath) contains the project directory
relative file name of the required map file.

C++ Link Command
ext ernal _cpp_Il i nk_commandCommandLine

The command line to clean the executable e.g. make
clean. This property will have macro expansion applied
toit.

Clean Command
ext er nal _cl ean_comandCommandLine
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Link Command
ext ernal _I i nk_comandCommandLine

Objects File
ext ernal _obj ects_fil e_naneCommandLine

File

Property

File Encoding
fi | e_codecEnumeration

Appendices

The command line to link an executable. This property
will have macro expansion applied to it with the
additional macros:

$(TargetPath) contains the full file name of the
Executable File Name property.
$(RelTargePath) contains the project directory
relative file name of the Executable File Name
property.

$(LinkOptions) contains a space seperated list of
options as set in the Additional Linker Options
property.

$(Objects) a space seperated list of files to link,
generated from the source files of the project and
the outputs of any dependent projects OR.
$(ObjectsFilePath) contains the full file name of
the file containing the list of files to link
$(RelObjectsFilePath) contains the project
directory relative file name of the file containing
the list of files to link

$(LinkerScriptPath) contains the full file name of
the Linker Script File property.
$(RelLinkerScriptPath) contains the project
directory relative file name of the Linker Script
File property.

$(MapPath) contains the full file name of the
required map file.

$(RelMapPath) contains the project directory
relative file name of the required map file.

The name of the file containing the list of files to
archive or link, generated from the source files of

the project.This property will have macro expansion
applied to it. The macro $(ObjectsFilePath) is set to this
value.

Description

Specifies the encoding to use when reading and
writing the file.
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File Name
fil e_nanmeString

File Open Action
fil e_open_wi t hEnumeration

File Type
fil e_t ypeEnumeration

Flag
file_fl agEnumeration

Folder

Property

Dynamic Folder Directory
pat hDirPath

Dynamic Folder Exclude
excl udeStringlList

Dynamic Folder Filter
filterString

Dynamic Folder Recurse
r ecur seBoolean

Unity Build Exclude Filter
uni ty_bui |l d_excl ude_fil t er String

Unity Build File Name
unity_buil d_fil e_nanmeFileName

General

Property

Environment Variables
envi ronment _vari abl esStringList

Inherited Configurations
i nherited_configurationsStringList

Appendices

The name of the file. This property will have global
macro expansion applied to it. The following macros
are set based on the value: $(InputDir) relative
directory of file, $(InputName) file name without
directory or extension, $(InputFileName) file name,
S(InputExt) file name extension, $(InputPath) absolute
path to the file name, $(RellnputPath) relative path
from project directory to the file name.

Specifies how to open the file when it is double
clicked.

The type of file. Default setting uses the file extension
to determine file type.

Flag which you can use to draw attention to important
files in your project.

Description

Dynamic folder directory specification - ; seperated
directory names that will have global macro expansion
applied to them.

Dynamic folder exclude specification - ; seperated
wildcards.

Dynamic folder filter specification - ; seperated
wildcards.

Dynamic folder recurse into subdirectories.

The filter specification to exclude from the unity build
- ; seperated wildcards.

The file name created that #includes all files in the
folder for the unity build.

Description
Environment variables to set on solution load.

The list of configurations that are inherited by this
configuration.
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Library

Property

DSO Handle Value
I i nk_dso_handl e_val ueString

Debug I/0 Implementation
arm | i nk_debugi o_t ypeEnumeration

Enable Locales
LI BRARY_ LOCALESEnumeration

Exclude Default Library Helper Functions
link use nulti _threaded_|ibrariesBoolean

Include Standard Libraries
i nk_i ncl ude_st andard_| i brari esBoolean

Library ARM Architecture
arm_|i brary_archit ect ur eEnumeration

Library Extension Suffix
i nk_li bext_suffixString

Library File Name
bui | d_out put _fil e_nameFileName

Library Heap
LI BRARY_HEAP_TYPEEnumeration

Library Heap Locking
LI BRARY_HEAP_LOCKI NGEnumeration

Appendices

Description

The value to set the __dso_handle symbol to, an
empty value will not set the symbol

Specifies which Debug I/0 mechanism to use for I/0
operations.
Options are:

Breakpoint: Hardware breakpoint instruction and
memory locations are used

DCC: ARM debug communication channel is used
Memory Poll: Memory locations are polled

Enable localization for input/output functions and
character classification and conversion.
Options are:

Minimal: small implementation for functions
such as isupper() and tolower()..
Full: locale support.

Specifies whether to exclude default library helper
functions.

Specifies whether the standard libraries should be
linked into your application.

Specifies the architecture variant of the library to link
with. The default uses the ARM Architecture value

Specifies a suffix to add to the $(LibExt) macro

Specifies a name to override the default library file
name.

Specifies how the library heap is implemented.
Options are:

Basic: Use low-overhead heap allocator.
Minimal: Use alloc-only heap allocator.
Real-Time: Use real-time heap allocator.
None: Do not implement heap allocator. (Use
application-supplied allocator).

Specifies how the library heap locking is implemented.
Options are:

Disable Interrupts: Disable global interrupts.
User: Call user supplied __heap_lock/
__heap_unlock functions.
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Library 1/0
LI BRARY_I O_TYPEEnumeration

Library Instruction Set
arm_|ibrary_instruction_set Enumeration

Library Optimization
arm.|ibrary_optim zati onEnumeration

Library Optimization
rv_library_optim zati onEnumeration

Standard Libraries Configuration Prefix
link_standard_Ilibraries_configuration_pref

Standard Libraries Directory
|l i nk_standard_Ii braries_directoryString

Linker

Property

Additional Input Files
| i nker _addi tional _fil esStringList

Additional Linker Options
| i nker _addi ti onal _opti onsStringList

Appendices

Specifies how the library does I/0.
Options are:

RTT: Use SEGGER Real-Time Transfer for I/

O operations without halting the system.
Recommended for maximum speed.
SEMIHOST: Format output and write to RAM
buffer. Halt CPU for I/0 operation. Provides hosted
file 1/0.

SEMIHOST (host-formatted): Halt CPU for I/0
operation. Recommended for minimum size.
SWO: Format output and write to RAM buffer.
Use SWO for Output operation. Use CMSIS
ITM_RxBuffer/ITM_RXBUFFER_EMPTY memory
access for Input Operation.

SWO (Interrupts Disabled): Format output
and write to RAM buffer. Use SWO for Output
operation with interrupts disabled. Use CMSIS
ITM_RxBuffer/ITM_RXBUFFER_EMPTY memory
access for Input Operation.

None: Do not include I/0 implementation. Use
user-supplied I/0 Mechanism.

For more information read: https://wiki.segger.com/
Embedded_Studio_Library_IO

Specifies the instruction set variant of the libraries to
link with, Default will use the Instruction Set value.

Specifies whether to link with libraries optimized for
speed or size.

Specifies whether to link with libraries optimized for
speed or size.

Specifies the prefix to prepend to the library build
configuration.

Specifies where to find the standard libraries

Description

Enables additional object and library files to be
supplied to the linker.

Enables additional options to be supplied to the linker.
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Additional Linker Options From File

Appendices

Enables additional options to be supplied to the linker

l'i nker _addi tional _options_from fil eProjFileNafrom a file.

Additional Linker Script Generator Options
arm addi ti onal _nkl d_opt i onsStringList

Additional Output Format
| i nker _out put _f or mat Enumeration

Additional System Libraries
| i nker _addi tional _system | i brari esStringList

Align ro Section [segger-Id]
I'i nk_al i gn_r oEnumeration

Align rw Section [segger-Id]
I'i nk_al i gn_r wEnumeration

Align rx Section [segger-Id]
I'i nk_al i gn_r xEnumeration

Align zi Section [segger-Id]
I'i nk_al i gn_zi Enumeration

Allow Multiple Symbol Definition

arm | inker_allow rultiple_definitionBoolean

Backup Additional Linker Options
| i nk_addi ti onal _opti ons_backupString

Breakpad Symbols Directory
I i nker _breakpad_synbol s_di r ect or yString

CMSE Import Library File

Enables additional options to be supplied to the linker
script generator.

The format used when creating an additional linked
output file.The options are:

None do not create an additional output file.
bin create a binary file.

srec create a Motorola S-Record file.

hex create an Intel Hex file.

Enables additional system libraries to be supplied to
the linker.

Specifies the linker byte alignment of the ro section

Specifies the linker byte alignment of the rw section

Specifies the linker byte alignment of the rx section

Specifies the linker byte alignment of the zi section

Do not report error if the same symbol is defined more
than once in object files/libraries.

Value of additional linker options prior to generic
options processing

Specifies location of the breakpad symbols directory.

Specifies the name of the CMSE import library to

arm | inker_cnse_inmport_library_fil e_naneFilegenerate.

Check CMSE Import Library File

Specifies the name of the file to check the generated

arm | i nker _check_cnse_i nport _library_file_CMSEimport library with.

Check For Memory Section Overflow

Specifies whether the linker should check whether

armlibrary _check _menmory_secti on_overfl owB program sections exceed their specified size.

Check For Memory Segment Overflow

Specifies whether the linker should check whether

armlibrary_check_menory_segnment _over f | owB program sections fit in their memory segments.

Deduplicate Code Sections [segger-Id]
| i nk_dedupe_codeBoolean

Deduplicate Data Sections [segger-Id]
| i nk_dedupe_dat aBoolean

Specifies whether the linker finds readonly code
sections that are identical and discard duplicates.

Specifies whether the linker finds readonly data
sections that are identical and discard duplicates.
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Default Fill Pattern

arm.|inker_script_generator_default fill _p

Emit Relocations
arm.|linker_emt_rel ocati onsEnumeration

Enable Call Springboarding [segger-Id]
rv_spri ng_boar dEnumeration

Enable Outline Optimization [segger-Id]
rv_out | i neEnumeration

Enable Tail Merging [segger-Id]
rv_tail _mer geEnumeration

Entry Point
gcc_entry_poi nt String

Gap Fill Value [segger-Id]
arm | inker _additional _output file_ gap fill

Generate Breakpad Symbols
| i nker _gener at e_br eakpad_synbol sBoolean

Generate Linker Map File
I'i nker _map_fil eBoolean

Generate Linker Script
arm gener at e_| i nker _scri pt Boolean

Generate Log File [segger-Id]
I'i nker _I og_fil eBoolean

Generate Map File [segger-Id]
I'i nk_rmap_fi | eEnumeration

Indirect File Name
|'i nker _i ndirect _fil e_nanmeString

Indirect File Supported
i nker _use_indirect fil esBoolean

Inline Small Functions [segger-Id]
I'i nk_i nl i neBoolean

Keep Indirect Files
| i nker _keep_i ndi rect _fi |l esBoolean

Keep Symbols
I'i nker _keep_synbol sStringList

Link Dependent Projects
| i nk_dependent _pr oj ect sBoolean

Appendices

Specifies the default pattern used to fill unspecified
regions of memory in a generated linker script. This
pattern maybe overidden by the fill attribute of a
program section in the section placement file.

Output relocation information into the executable.
If enabled the linker may be able to optimize the

instructions used for function calls.

If enabled the linker may be able to reduce code size
by extracting common code into subroutines.

If enabled the linker may be able to reduce code size
by extracting common code immediately before
function return.

Specifies the entry point of the program. None will not
supply an entry point to the linker.

The value to fill unused space between sections. This
is supplied to segger-Id and the additional output file
creation build step.

Specifies whether to generate breakpad symbols from
the linked image.

Specifies whether to generate a linkage map file.

Specifies whether a linker script file should be
generated from the section placement and/or memory
map files.

Specifies whether to generate a linkage log file.

Specifies whether to generate a linkage map file.

The name of the generated indirect file.

Linker can use @indirect file for input files.

Specifies whether the linker inlines small functions at
the call site rather than calling the function.

Keep generated linker indirect files.

Specifies the symbols that should be kept by the linker
even if they are not reachable.

Specifies whether to link the output of dependent
library projects.
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Link Whole Archive
arm_| i nker _whol e_ar chi veStringList

Linker
arm | i nker _vari ant Enumeration

Linker Map File Name
I'i nker _map_fi | e_naneFileName

Linker Script File
link_linker_script_fil eProjFileName

Linker Search Path
arm | i nker _sear ch_pat hStringList

Linker Symbol Definitions

I'i nk_synbol _defi ni ti onsStringList
Map File Format [segger-Id]

i nk_map_fil e_f or mat Enumeration

Memory Map File
I'i nker _menory_map_fi | eProjFileName

Memory Map Macros
| i nker _nmenory_map_nmacr osStringList

Memory Segments
| i nker _secti on_pl acement s_segnent sStringList

Merge Sections [segger-Id]
| i nk_mer ge_sect i onsBoolean

Merge String Constants [segger-Id]
|'i nk_mer ge_stri ngsBoolean

No Enum Size Warning
arm | i nker _no_enum si ze_war ni ngBoolean

No Start File
arm | inker_no_start_fil esBoolean

No Wide Char Size Warning
arm_| i nker _no_wchar _si ze_war ni ngBoolean

Pad ro Section [segger-Id]
| i nk_pad_r oBoolean

Pad rw Section [segger-Id]
| i nk_pad_r wBoolean

Pad rx Section [segger-Id]
| i nk_pad_r xBoolean

Appendices

List the archives that require to be linked in whole.

Specifies which linker to use.

The file name to contain the linkage map file.

The name of the manual linker script file.

Specify the linker script search path.

Specifies one or more linker symbol definitions.

Specifies map file format generated by the linker.

The name of the file containing the memory map
description.

Macro values to substitue in memory map nodes. Each
macro is defined as name=value and are seperated by
The start, access and size of named segments in the
target, these are used when no memory map file is
available.Each segment is specified by NAME RWX
HEXSTART HEXSIZE for example FLASH RX 0x08000000
0x00010000

Specifies whether the linker merges compatible
sections.

Specifies whether the linker merges duplicate string
constants.

Do not generate warnings when object files have
different ARM EABI enum size attributes.

Do not use startup files when linking.

Do not generate warnings when object files have
different ARM EABI wide character size attributes.

Specifies whether the linker pads the ro section

Specifies whether the linker pads the rw section

Specifies whether the linker pads the rx section
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Pad zi Section [segger-Id]

. . Specifies whether the linker pads the zi section
| i nk_pad_zi Boolean

Section Placement File The name of the file containing section placement

l'i nker _section_pl acenment _fi | eProjFileName description.

Section Placement Macros Macro values to substitue in section placement nodes -
|'i nker _secti on_pl acerment _nmacr osStringList MACRO1=value1;MACRO2=value2.

Start/End Group Required Linker requires --start-group and --end-group for input
l'i nker _requires_start _groupBoolean files.

Strip Debug Information Specifies whether debug information should be

l'i nker _strip_debug_i nformat i onBoolean stripped from the linked image.

Strip Symbols

T e Specifies whether symbols should be stripped.

Supply Library Linker Symbols Specifies whether the library symbols are supplied to
l'ink_supply_library_linker_synbol sBoolean the linker command line.

Supply Memory Segments To Linker [segger-Id] Specifies whether to supply memory segments on the
I'i nker _suppl y_nenory_segnent sBoolean linker command line.

Suppress Warning on Executable Stack

. No warning on executable stack.
arm | i nker _no_war n_on_execut abl e_st ackBoole

Suppress Warning on Mismatch

_ _ No warning on mismatched object files/libraries.
arm_| i nker _no_war n_on_nmni smat chBoolean

Suppress Warning on RWX Segments

. No warning on RWX segments.
arm_| i nker _no_war n_on_rwx_segmnent sBoolean

Symbols File

Specify th f bols file to link.
arm | i nker _synbol s_fi | esFileName pecily the hame of a symbols THie to fin

Thread Pointer Model [segger-Id]

. ) Controls how the thread pointer register is used.
rv_t hread_poi nt er _nbdel Enumeration

Treat Libraries As Object Files Specifies whether the linker treats libraries as a set of
linker _treat libraries_as_object fil esBoole objectfiles.

Treat Linker Warnings as Errors

. . Treat linker warnings as errors.
arm | i nker _treat_warni ngs_as_error sBoolean

Use Manual Linker Script

. . : : Specifies whether to use a manual linker script.
link_use_linker_script_fil eBoolean

Package

Property Description
Package Dependencies Specifies the packages the current project depends
package_dependenci esStringList upon.
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Package Directory
package_di r ect or yDirPath

Preprocessor

Property
Add Property Group Options

add_property_group_i ncl udes_def i nesBoolean

Ignore Includes
c_i gnore_i ncl udesBoolean

Include Files
c_incl ude_fil esStringList

Include Files Assembler Only
c_i nclude_fil es_asm onl yStringList

Include Files C Compiler Only
c_include_fil es_c_onl yStringList

Include Files C++ Compiler Only
c_include_fil es_cpp_onl yStringList

Macro Files
c_macros_fi | esStringList

Macro Files Assembler Only
c_macros_fil es_asm onl yStringList

Macro Files C Compiler Only
c_macros_fil es_c_onl yStringList

Macro Files C++ Compiler Only
c_macros_fil es_cpp_onl yStringList

Preprocessor Definitions
c_preprocessor _definitionsStringList

Preprocessor Definitions Assembler Only

c_preprocessor_definitions_asm onl yStringList

Preprocessor Definitions C Compiler Only
c_preprocessor _definitions_c_onl yStringList

Appendices

Specifies the directory packages are installed to. If no
directory is specified, the default package directory is
used.

Description

Supply the defines and includes that are selected by
the property group.

Ignore the include directories properties.

Specifies the list of files to include before
preprocessing. This property will have macro
expansion applied to it.

Specifies the list of files to include before
preprocessing. This property will have macro
expansion applied to it.

Specifies the list of files to include before
preprocessing. This property will have macro
expansion applied to it.

Specifies the list of files to include before
preprocessing. This property will have macro
expansion applied to it.

Specifies the list of macro files to include before
preprocessing. This property will have macro
expansion applied to it.

Specifies the list of macro files to include before
preprocessing. This property will have macro
expansion applied to it.

Specifies the list of macro files to include before
preprocessing. This property will have macro
expansion applied to it.

Specifies the list of macro files to include before
preprocessing. This property will have macro
expansion applied to it.

Specifies one or more preprocessor definitions. This
property will have macro expansion applied to it.

Specifies one or more preprocessor definitions. This
property will have macro expansion applied to it.

Specifies one or more preprocessor definitions. This
property will have macro expansion applied to it.
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Preprocessor Definitions C++ Compiler Only Specifies one or more preprocessor definitions. This
c_preprocessor_definitions_cpp_onl yStringList property will have macro expansion applied to it.

Preprocessor Undefinitions Specifies one or more preprocessor undefinitions. This
c_preprocessor _undefi niti onsStringList property will have macro expansion applied to it.
Preprocessor Undefinitions Assembler Only Specifies one or more preprocessor undefinitions. This

c_preprocessor_undefini ti ons_asm onl yStringL property will have macro expansion applied to it.

Preprocessor Undefinitions C Compiler Only Specifies one or more preprocessor undefinitions. This
c_preprocessor_undefinitions_c_onl yStringList property will have macro expansion applied to it.

Preprocessor Undefinitions C++ Compiler Only Specifies one or more preprocessor undefinitions. This
c_preprocessor_undefi niti ons_cpp_onl yStringL property will have macro expansion applied to it.

System Include Directories Specifies the system include path. This property will
c_system.incl ude_di rect ori esStringList have macro expansion applied to it.

Undefine All Preprocessor Definitions

. o Does not define any standard preprocessor definitions.
c_undefine_al |l _preprocessor_definitionsBool

User Include Directories Specifies the user include path. This property will have
c_user _i ncl ude_di rect ori esStringList macro expansion applied to it.
User Include Directories Assembler Only Specifies the user include path. This property will have

c_user _incl ude_di rectori es_asm onl yStringList macro expansion applied to it.

User Include Directories C Compiler Only Specifies the user include path. This property will have
c_user _include_directories_c_onl yStringList macro expansion applied to it.

User Include Directories C++ Compiler Only Specifies the user include path. This property will have
c_user _include_directories_cpp_onl yStringList macro expansion applied to it.

Printf/Scanf

Property Description

Printf Floating Point Supported Are floating point numbers supported by the printf
|'i nker _printf_fp_enabl edEnumeration function group.

Printf Integer Support The largest integer type supported by the printf

i nker _printf_fnt_| evel Enumeration function group.

Printf Width/Precision Supported Enables support for width and precision specification

l'i nker _printf_wi dth_precision_support edBoolin the printf function group.

Scanf Classes Supported Enables support for %l...] and %[A...] character class
| i nker _scanf _char act er _gr oup_mat chi ng_enab matching in the scanf functions.

Scanf Floating Point Supported Are floating point numbers supported by the scanf

| i nker _scanf _f p_enabl edBoolean function group.

Scanf Integer Support The largest integer type supported by the scanf

|l i nker _scanf fnt | evel Enumeration function group.

Wide Characters Supported Are wide characters supported by the printf function
I'i nker _printf_wchar_enabl edBoolean group.
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Project

Property

Flag
proj ect _f | agEnumeration

Runtime Memory Area

Property

Heap Size
arm | i nker _heap_si zelntegerRange

Heap Size
heap_si zelntegerRange

Main Stack Size
arm | i nker _st ack_si zelntegerRange

Process Stack Size

arm_| i nker _process_st ack_si zelntegerRange

Stack Size
st ack_si zelntegerRange

Stack Size (Abort Mode)
arm | i nker _abt _st ack_si zelntegerRange

Stack Size (FIQ Mode)
arm | i nker _fiq_stack_si zelntegerRange

Stack Size (IRQ Mode)
arm | i nker _i rq_stack_si zelntegerRange

Stack Size (Supervisor Mode)
arm | i nker _svc_st ack_si zelntegerRange

Stack Size (Undefined Mode)
arm_| i nker _und_st ack_si zelntegerRange

Section

Property

Code Section Name
def aul t _code_sect i onString

Constant Section Name
def aul t _const _sect i onString

Appendices

Description

Flag which you can use to draw attention to important
projects in your solution.

Description

The size of the heap in bytes. The size must be a
multiple of 8. The preprocessor define __HEAP_SIZE__
is set to this value.

The size of the heap in bytes. The size must be a
multiple of 16.

The size of the main stack in bytes. The size must be a
multiple of 8.

The size of the process stack in bytes. The size must be
a multiple of 8.

The size of the stack in bytes. The size must be a
multiple of 16.

The size of the Abort mode stack in bytes. The size
must be a multiple of 8.

The size of the FIQ mode stack in bytes. The size must
be a multiple of 8.

The size of the IRQ mode stack in bytes. The size must
be a multiple of 8.

The size of the Supervisor mode stack in bytes. The size
must be a multiple of 8.

The size of the Undefined mode stack in bytes. The size
must be a multiple of 8.

Description

Specifies the default name to use for the program code
section.

Specifies the default name to use for the read-only
constant section.
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Data Section Name
def aul t _dat a_sect i onString

ISR Section Name
defaul t _i sr_secti onString

Vector Section Name
def aul t _vect or _secti onString

Zeroed Section Name
defaul t _zeroed_secti onString

Solution

Property

Flag
sol uti on_f | agEnumeration

Properties Filter
properties_filterStringList

Source Code

Property
Additional Code Completion Compiler Options

code_conpl eti on_opt i onsStringList

Inhibit Source Indexing
proj ect _i nhi bi t _i ndexi ngBoolean

Source Code Control Directory
sour ce_code_control _di rect or yDirPath

Staging

Property

Output File Path
st age_out put _fi | epat hString

Set To Read-only
st age_set _r eadonl yEnumeration

Stage Command
st age_commandCommandLine

Appendices

Specifies the default name to use for the initialized,
writable data section.

Specifies the default name to use for the ISR code.

Specifies the default name to use for the interrupt
vector section.

Specifies the default name to use for the zero-
initialized, writable data section.

Description

Flag which you can use to draw attention to important
projects in your solution.

The names of project properties that can be displayed
at the solution

Description

Additional source indexing and code completion
compiler options.

Disable source indexing and code completion for files/
folders/projects that would normally be indexed (C/C+
+ files in executable and library projects).

Source code control directory root.

Description

The output file path the stage command will create.
This property will have macro expansion applied to it.

Set the output file permissions to read only or read/
write.

The command to execute. This property will have
macro expansion applied to it with the additional
$(StageOutputFilePath) macro set to the output
filepath of the stage command.
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Stage Command Working Directory
st age_commuand_wdString

Stage Project Command
st age_post _bui | d_commandCommandLine

Stage Project Command Working Directory
st age_post _bui | d_command_wdString

User Build Step

Property

Link Patch Command
I i nker _pat ch_bui | d_commandCommandLine

Link Patch Working Directory
| i nker _pat ch_bui | d_comand_wdDirPath

Post-Archive Command
archi ve_post _bui | d_conmandCommandLine

Post-Archive Working Directory
ar chi ve_post _bui | d_conmand_wdDirPath

Post-Build Command
post _bui | d_comandCommandLine

Post-Build Command Control
post _bui | d_command_cont r ol Enumeration

Post-Build Command Working Directory
post _bui | d_command_wdString

Post-Compile Command
conpi | e_post _bui | d_conmandCommandLine

Post-Compile Working Directory
conpi | e_post _bui | d_conmand_wdDirPath

Appendices

The working directory in which the stage command is
run. This property will have macro expansion applied
toit.

The command to execute after staging commands
have executed. This property will have macro
expansion applied to it.

The working directory where the post build command
runs. This property will have macro expansion applied
toit.

Description

A command to run after the link but prior to additional
binary file generation. This property will have

macro expansion applied to it with the additional
$(TargetPath) macro set to the output filepath of the
linker command.

The working directory where the link patch command
is run. This property will have macro expansion applied
toit.

A command to run after the archive command has
completed.This property will have macro expansion
applied to it with the additional $(TargetPath) macro
set to the output filepath of the archive command.

The working directory where the post-archive
command is run. This property will have macro
expansion applied to it.

The command to execute after a project build. This
property will have macro expansion applied to it.

Controls when the post-build command is run, either
Always Run or when Run When Build Has Occurred.

The working directory in which the post-build
command is run. This property will have macro
expansion applied to it.

A command to run after the compile command has
completed. This property will have macro expansion
applied to it with the additional $(TargetPath) macro
set to the output filepath of the compiler command.

The working directory where the post-compile
command is run. This property will have macro
expansion applied to it.
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Post-Link Command
I'i nker _post _bui | d_commandCommandLine

Post-Link OQutput File
| i nker _post _bui | d_command_out put _fi | eString

Post-Link Working Directory
|'i nker _post _bui | d_conmand_wdDirPath

Pre-Build Command
pre_bui | d_commandCommandLine

Pre-Build Command Control
pre_bui | d_conmand_cont r ol Enumeration

Pre-Build Command Working Directory
pre_bui | d_comrand_wdString

Pre-Compile Command
conpi | e_pre_bui | d_commandCommandLine

Pre-Compile Command Output File Path

Appendices

A command to run after the link command has
completed.This property will have macro expansion
applied to it with the additional $(TargetPath) macro
set to the output filepath of the linker command and
$(PostLinkOutputFilePath) set to the value of the
output filepath of the post link command.

The name of the file created by the post-link
command. This property will have macro expansion
applied toit.

The working directory where the post-link command is
run. This property will have macro expansion applied
toit.

The command to execute before a project build. This
property will have macro expansion applied to it.

Controls when the pre-build command is run, either
Always Run or when Run When Build Required.

The working directory in which the pre-build
command is run. This property will have macro
expansion applied to it.

A command to run before the compile command. This
property will have macro expansion applied to it.

The pre-compile generated file name. This property

conpi | e_pre_buil d_command_out put _fi | e_nane will have macro expansion applied to it.

Pre-Compile Working Directory
conpi | e_pre_bui | d_comand_wdDirPath

Pre-Link Command
|'i nker _pre_bui | d_commandCommandLine

Pre-Link Working Directory
I'i nker _pre_bui | d_command_wdDirPath

The working directory where the pre-compile
command is run. This property will have macro
expansion applied to it.

A command to run before the link command. This
property will have macro expansion applied to it.

The working directory where the pre-link command is
run. This property will have macro expansion applied
toit.
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Debug Options

Debugger

Property

Alternative LDR Disassembly
debug_al ternati ve_| dr _di sBoolean

CPU Register File
debug_cpu_regi sters_fil eProjFileName

Command Arguments
debug_command_ar gunent sString

Debug Additional Configurations
debug_addi ti onal _confi gur ati onsStringList

Debug Additional Projects
debug_dependent _pr oj ect sStringList

Debug Project Name
debug_pr oj ect _naneString

Debug Symbols File[0]
ext ernal _debug_synbol s_fi | e_naneProjFileName

Debug Symbols File[1]
ext ernal _debug_synbol s_fi | e_nanmelProjFileName

Debug Symbols File[2]
ext ernal _debug_synbol s_fi | e_nanme2ProjFileName

Debug Symbols File[3]
ext ernal _debug_synbol s_fi | e_nanme3ProjFileName

Debug Symbols Load Address[0]
ext ernal _debug_synbol s_| oad_addr essString

Debug Symbols Load Address[1]
ext ernal _debug_synbol s_| oad_addr ess1String

Debug Symbols Load Address[2]
ext ernal _debug_synbol s_| oad_addr ess2String

Debug Symbols Load Address[3]
ext ernal _debug_synbol s_| oad_addr ess3String

Debug Terminal Log File
debug_term nal _I| og_fi |l eUnknown

Appendices

Description
Show alternative disassembly of |dr*/vldr instructions

The name of the file containing CPU register
definitions.

The command arguments passed to the executable.
This property will have macro expansion applied to it.

The debugger will load and debug the specified
additional configurations.

The debugger will load (if not already loaded by
Load Additional Projects) and debug the specified
additional projects.

The name of the project used by the debugger when
debugging multiple projects

The name of the debug symbols file. This property will
have macro expansion applied to it. If it is not defined
then the main load file is used.

The name of the debug symbols file. This property will
have macro expansion applied to it. If it is not defined
then the main load file is used.

The name of the debug symbols file. This property will
have macro expansion applied to it. If it is not defined
then the main load file is used.

The name of the debug symbols file. This property will
have macro expansion applied to it. If it is not defined
then the main load file is used.

The (code) address to be added to the debug symbol
(code) addresses.

The (code) address to be added to the debug symbol
(code) addresses.

The (code) address to be added to the debug symbol
(code) addresses.

The (code) address to be added to the debug symbol
(code) addresses.

A file to write the output from the debug terminal to.
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Default debuglO implementation
ar m_debugl O_I npl enent at i onEnumeration

Display DCC data
ar m di spl ay_DCCBoolean

Entry Point Symbol
debug_entry_poi nt _synbol String

HTML Watch File
debug_ht m _wat chProjFileName

Has Hypervisor Mode
arm_has_hyper vi sor _nodeBoolean

Has Monitor Mode
arm has_noni t or _nodeBoolean

Has Vector Catch
arm_has_vect or _cat chBoolean

ISA Extensions Debug
rv_debug_ext ensi onsEnumeration

Ignore .debug_aranges Section
debug_i gnor e_debug_ar angesBoolean

Ignore .debug_frame Section
debug_i gnor e_debug_f r anmeBoolean

Load Additional Projects
debug_I| oad_addi ti onal _pr oj ect sStringList

Memory Upload Page Size
debug_nenory_upl oad_page_si zelnteger

RTT Control Block Address
debug_RTTCBString

RTT Enable
debug_enabl e_RTTBoolean

Register Definition File

debug_regi ster_definition_fil eProjFileName

Register Definition File Type

debug_regi ster_definition_file_typeEnumerati

Reserved Member Name
reser vedMenber _naneString

Restrict Memory Access
debug_restrict_nenory_accessBoolean

Run To
debug_i ni ti al _br eakpoi nt String

Appendices

The default debuglO implementation used by the
debugger if symbols are unavailable.

The debugger will display data that is written to the
DCC when debuglO is not used.

Debugger will start execution at symbol if defined.

The file used by the debugger's HTML Watch window.

Show hypervisor mode registers

Show monitor mode registers

Vector catching is supported

Specify ISA extensions supported by debugger.

The debugger will not use the .debug_aranges section.

The debugger will not use the .debug_frame section.

The debugger will load the outputs of the specified
additional projects.

The aligned page size the debugger uses when
uploading address ranges.

The symbol or 0x prefixed address of the RTT control
block.

If enabled the debugger will service RTT input/output

in the debug terminal.

The name of the file containing register definitions.

The type of the file containing register definitions.

The struct reserved member name. Struct members
that contain the (case insensitive) string will not be
displayed.

If enabled the debugger will only display variables and
backtrace in the address ranges of the memory map or
the sections in the elf file.

The initial breakpoint to set
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Run To Control

Specify when the initial breakpoint should be set
debug_i ni ti al _breakpoi nt _set _opti onEnumerati pecily when the Initlal breakpoint should be se

Start Address The address to start the externally built executable
external _start_addr essString running from.

If Yes the debugger will start execution from the entry
Start From Entry Point Symbol point symbol. If No the debugger will start execution
debug_start_from entry_poi nt _synbol Enumerati from the target specific location. If Don't the debugger
will not start execution.

Starting Stack Pointer Value
debug_st ack_poi nt er _st art String

The symbol or 0x prefixed value to set the stack
pointer on start debugging.

Specifies the point in the program where startup is
complete. Software breakpoints and debuglO will be
enabled after this point has been reached.

Startup Completion Point
debug_start up_conpl eti on_poi nt StringList

Target Connection Specifies the target to connect to for debugging
debug_t arget _connect i onEnumeration actions.

The name of the device to connect to. This property
will have macro expansion applied to it. The macro
$(DeviceName) is set to the value of this property.

Target Device [ARM]
arm_t arget _devi ce_naneString

The name of the device to connect to. This property
will have macro expansion applied to it. The macro
$(DeviceName) is set to the value of this property.

Target Device [RISC-V]
target _devi ce_naneString

Thread Maximum

The maximum number of threads to display.
debug_t hr eads_maxIntegerRange

Threads Script File

The th i h .
debug_t hr eads_scri pt ProjFileName e threads script used by the debugger

Type Interpretation File

debug_type il eFileName Specifies the type interpretation file to use.

Type Interpretation File 2

debug_type_fil e_2String

Working Directory
debug_wor ki ng_di r ect or yDirPath

GDB Server

Property

Specifies the second type interpretation file to use.

The working directory for a debug session. This
property will have macro expansion applied to it.

Description

Specifies whether memory can be access while target
is running. If set to No, target will be stopped each
time memory is accessed.

Allow Memory Access During Execution
gdb_server _al | ow_nenory_access_duri ng_exec

Auto Start GDB Server Specifies whether a GDB server should be started on
gdb_server _aut ost art _ser ver Boolean connect.
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Breakpoint Types
gdb_br eakpoi nt _t ypesEnumeration

CSR Registers [RISC-V]
gdb_server _csr_regi st er sStringList

Connect Timeout
gdb_server _connect _ti neout Integer

GDB Server Command Line
gdb_server _conmand_| i neCommandLine

Host
gdb_server _host naneString

Ignore Checksum Errors

gdb_server _i gnore_checksum err or sBoolean

Log File
gdb_server _| og_fi | eUnknown

Port
gdb_server _port Integer

Read Timeout
gdb_server _read_ti meout Integer

Register Access
gdb_server _regi st er _accessEnumeration

Reset and Stop Command
gdb_server _reset _commandString

Target XML File
gdb_server _target _xm _fil eFileName

Type
gdb_server _t ypeEnumeration

Write Timeout
gdb_server_write_timeout Integer

J-Link
Property

Additional J-Link Options
JLi nkExecut eCommandStringList

Enable Adaptive Clocking
adapt i veEnumeration

Appendices

Specifies the type of breakpoints to use.

Specifies mapping from CSR register numbers
to GDB server register names, for example
"2000=csr_mmisc_ctl".

The length of time in seconds to attempt to connect to
server before failing.

The command line to start the gdb server

The hostname of the GDB server to connect to.

Specifies whether an incorrect GDB server checksum
causes and error.

Specifies a file to output a log of GDB server
transactions to.

The port number to use to connect to the GDB server.

The length of time in seconds to attempt to read from
server before failing.

Specifies how registers are accessed

The remote GDB server command to use to reset and
stop the target.

If specified, points to a target.xml file to use in place of
file returned by the GDB server.

Specifies the type of GDB server being connected
to. J-Link, OpenOCD, ST-LINK and pyOCD gdb server
implementations are currently supported.

The length of time in seconds to attempt to write to
server before failing.

Description

Specify additional J-Link options to allow enabling or
disabling advanced features and fine tuning.
For more information see J-Link Command Strings

Adaptive clocking is enabled.
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Erase All
target _| oader _erase_al | Enumeration

Exclude Flash Cache Range
JLi nkExcl udeFl ashCacheRangeString

Host Connection
Connect i onEnumeration

JTAG Instruction Register Size Before Target
arm | i nker_j tag_pad_post _i r IntegerRange

JTAG Number Of Devices Before Target
arm | i nker _jtag_pad_post _dr IntegerRange

Log File
JLi nkLogFi | eNaneFileName

Script File
JLi nkScri pt Fi | eNameFileName

Show Log Messages In Output Window
JLi nkShowlLogBoolean

Speed
speedintegerRange

Supply Power
suppl! yPower Boolean

Target Has Cycle Counter [RISC-V]
ri scv_has_cycl e_count er Boolean

Target Interface Type [ARM]
arm target _interface_typeEnumeration

Appendices

If set to Yes, all of the FLASH memory on the target will
be erased prior to downloading the application. If set
to No, only the areas of FLASH containing the program
being downloaded will be erased. If set to Default the
behaviour is target specific.

Address range to exclude from flash cache.
This can be specified by either 'start_address-
end_address' or 'address,size'.

For example: 0x08000000,0x10000.

Defines how to connect the host to the J-Link:

"USB": Connect to J-Link via USB

"USB S/N": Connect to J-Link with specified serial
number via USB e.g. USB 174300001

"IP S/N": Connect to J-Link with specified serial
number via IP e.g. IP 174300001

"IP n.n.n.n port": Connect to J-Link with specified
IP address and optional port number e.g. IP
192.168.20.20 19020

Specifies the number of bits in the instruction
register before the target (as seen from TDI), which
is the number of bits to pad the JTAG instruction
register with the BYPASS instruction after the target
instruction.

Specifies the number of devices before the target (as
seen from TDI), which is the number of bits to pad the
JTAG data register.

The file to output the J-Link log to.

The file path of the optional J-Link script file to use.

Display the J-Link log messages to the output window.

The required JTAG clock frequency in kHz (0 to auto-
detect best possible).

The J-Link supplies power to the target.

The target device implements the mcycle CSR.

Specifies the type of interface the target has. The
options are:

JTAG - Use JTAG interface
SWD - Use SWD interface
cJTAG - Use cJTAG interface
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Target Interface Type [RISC-V]
target _interface_typeEnumeration

Loader

Property

Additional Load File Address[0]
debug_addi ti onal _| oad_fil e_addr essString

Additional Load File Address[1]
debug_addi ti onal _| oad_fil e_addr ess1String

Additional Load File Address[2]
debug_addi ti onal _| oad_fil e_addr ess2String

Additional Load File Address[3]
debug_addi ti onal _| oad_fil e_addr ess3String

Additional Load File Type[0]
debug_addi ti onal _| oad_fi | e_t ypeEnumeration

Additional Load File Typel[1]
debug_addi ti onal _| oad_fil e_t ypelEnumeration

Additional Load File Type[2]
debug_addi ti onal _| oad_fil e_t ype2Enumeration

Additional Load File Type[3]
debug_addi ti onal _| oad_fi | e_t ype3Enumeration

Additional Load File[0]
debug_addi ti onal _| oad_fi | eProjFileName

Additional Load File[1]
debug_addi ti onal _| oad_fi | e1ProjFileName

Additional Load File[2]
debug_addi ti onal _| oad_fi | e2ProjFileName

Additional Load File[3]
debug_addi ti onal _| oad_fi | e3ProjFileName

Check Load Sections Fit Target Description

target _check_| oad_secti ons_fit Boolean

Load ELF Address Limit
debug_l oad_file_offset_|imtString

Appendices

Specifies the type of interface the target has. The
options are:

JTAG - Use JTAG interface
SWD - Use SWD interface
cJTAG - Use cJTAG interface

Description

The address to load the additional load file.

The address to load the additional load file.

The address to load the additional load file.

The address to load the additional load file.

The file type of the additional load file. The options are
Detect, elf, bin, ihex, hex, tihex, srec.

The file type of the additional load file. The options are
Detect, elf, bin, ihex, hex, tihex, srec.

The file type of the additional load file. The options are
Detect, elf, bin, ihex, hex, tihex, srec.

The file type of the additional load file. The options are
Detect, elf, bin, ihex, hex, tihex, srec.

Additional file to load on debug load. This property will
have macro expansion applied to it.

Additional file to load on debug load. This property will
have macro expansion applied to it.

Additional file to load on debug load. This property will
have macro expansion applied to it.

Additional file to load on debug load. This property will
have macro expansion applied to it.

Specifies whether load sections in the program match
the memory segments described in the memory map.

Restrict the Load ELF Offset.The Load ELF Offset will
not be added to addresses greater than or equal to this
address.
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The offset to add to the load addresses of the ELF
programs.This offset is added to any absolute
relocations of symbols (whose address is less than
Load ELF Offset Limit) if the load file contains
relocation sections.

Load ELF Offset
debug_l oad_fil e_of f set String

Load ELF Sections The debugger will load ELF sections rather than ELF
debug_I| oad_sect i onsEnumeration programs.
Load File The name of the main load file. This property will have

macro expansion applied to it. If it is not defined then

ext ernal _buil d_fil e_naneProjFileName . . .
- - - ! the output filepath of the linker command is used.

Load File Address
ext ernal _| oad_addr essString

The address to download the main load file to.

Load File Type The file type of the main load file. The options are
external _| oad_fil e_t ypeEnumeration Detect, elf, bin, ihex, hex, tihex, srec.

No Load Sections Names of (loadable) program sections or names of
target _| oader _no_| oad_sect i onsStringList memory segments not to load.

ST-Link

Property Description

Hold the target in hardware reset on connect and
Connect With Reset stops the target. This requires the nSRST signal to be
arm target_connect _w th_reset_stlinkBoolean connected and the target debug hardware to work
when in reset.

Host Connection

A number specifying the device to connect to.
STLi nkConnect i onEnumeration pecitying

Mass Erase Use Mass Erase rather than sector erase on flash
arm target _nmass_er aseBoolean programming.

Specifies the type of interface the target has. The

ST-Link Target Interface Type options are:

armtarget _interface_type_stlinkEnumeration JTAG - Use JTAG interface
SWD - Use SWD interface

STM32CubeProgrammer directory Specifies the installation directory of the
arm st nB2cubepr ogr ammer _di r ect or yDirPath STM32CubeProgrammer software.
Speed

: : The required JTAG/SWD clock frequency in kHz.
armtarget _interface_speed_stl i nkintegerRange

Simulator [ARM]

Property Description
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Max Instructions Maximum number of instructions to execute before
arm si mul at or _max_i nstructi onsString simulator is stopped.

Specifies the dll that simulates the memory system.

Memory Simulation File This property will have macro expansion applied to it.
arm si mul at or _nmenory_si mul ati on_fi | enamePrcIf not specified then the default memory simulation
will be used.

Memory half words to simulate specified
by a list of address=value expressions e.g.
0xE0082002=0xface;SystemInit=0x4770

Memory Simulation Half Words
arm si mul at or _menory_hal f _wor dsStringList

Parameter passed to the memory simulation. This
property will have macro expansion applied to it.The
format of this is specific to the memory simulation.
The default memory simulation takes a list of RX[RWX
'hex start address', 'hex size in bytes', 'default hex
word value' for example RX 00000000, 10000000,
FFFFFFFF;RWX 10000000, 10000000, CDCDCDCD.

Memory Simulation Parameter
arm si nul at or _menory_si mul ati on_paraneter$

Macros to apply to the parameter passed to the
Memory Simulation Parameter Macros memory simulation on creation. If null then the macro
arm si mul at or _nmenory_si mul ati on_par amet er _ MemorySegments is set to the value of the address
ranges specified by the project.

Memory words to simulate specified by
a list of address=value expressions e.g.
0xE0082000=0xfeedface;SystemInit=0xE12FFF1E

Memory Simulation Words
arm si nul at or _menory_wor dsStringList

SP Lower Stop when R13 value is less than the value of this

arm si nul at or _SP_I| ower String expression.

SP Upper Stop when R13 value is greater than the value of this
ar m si nul at or _SP_upper String expression.

Stop On Branch .

. Stop when the simulator executes a b . instruction.
arm si mul at or _st op_on_branch_dot Boolean

Stop On Memory Error Specifies the simulator behaviour when a memory
arm si nul at or _st op_on_r ead_wr i t eEnumeration error occurs.

Trace Buffer Size

. ) The number of trace entries to store.
arm si nmul ator_num trace_entri esinteger

Simulator [RISC-V]

Property Description

32-bit Divide Instruction Cost The number of cycles taken for a 32-bit divide
ri scv_simul ator_32bit_di vi de_cost Integer instruction.

32-bit Multiply Instruction Cost The number of cycles taken for a 32-bit multiply

riscv_simulator_32bit_multiply_costlInteger instruction.
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64-bit Divide Instruction Cost
ri scv_si mul at or _64bi t _di vi de_cost Integer

64-bit Multiply Instruction Cost
riscv_simulator_64bit_multiply_cost Integer

Count Cycles
ri scv_si mul at or _count _cycl esBoolean

Enable Timer Support
ri scv_si mul at or _support _mnti meBoolean

Max Instructions
ri scv_si mul at or _max_i nstructi onsString

Memory Simulation Half Words
ri scv_si mul at or _nmenory_hal f _wor dsStringList

Memory Simulation Words
ri scv_si mul at or _menory_wor dsStringList

SP Lower
ri scv_si mul at or _SP_| ower String

SP Upper
ri scv_si mul at or _SP_upper String

Software Interrupt Register Address
ri scv_software_interrupt_addressintegerHex

Stop On Jump .
ri scv_simul ator_stop_on_j unp_dot Boolean

Timer Comparator Register Address

ri scv_si mul ator _ti ner_conpar at or _addr essint

Timer Register Address
ri scv_simul ator _timer_addr essintegerHex

Trap On Unaligned Memory Access.
riscv_simulator_trap_on_unal i gnedBoolean

Target Script

Property

Attach Script
target _attach_scri ptJavaScript

Debug Begin Script
target _debug_begi n_scri pt JavaScript

Debug End Script
t ar get _debug_end_scri pt JavaScript

Appendices

The number of cycles taken for a 64-bit divide
instruction.

The number of cycles taken for a 64-bit multiply
instruction.

Display cycle counts rather than instruction counts.
Enable simulation of mtime and mtimecmp memory
mapped registers.

Maximum number of instructions to execute before
simulator is stopped.

Memory half words to simulate specified
by a list of address=value expressions e.g.
0xE0082002=0xface;SystemInit=0x8082

Memory words to simulate specified by
a list of address=value expressions e.g.
0xE0082000=0xfeedface;SystemInit=0x00008067

Stop when x2 value is less than the value of this
expression.

Stop when x2 value is greater than the value of this

expression.

The address of the msip register

Stop when the simulator executes a j . instruction.

The address of the mtimecmp register

The address of the mtime register

Trap on unaligned memory access.

Description

The script that is executed when the target is attached
to.

The script that is executed when the debugger begins
a debug session.

The script that is executed when the debugger ends a
debug session.
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Load Begin Script
target _| oad_begi n_scri pt JavaScript

Load End Script
target _| oad_end_scri pt JavaScript

Reset Script
target _reset_scri pt JavaScript

Target Script File
target _script_fil eFileName

Target Trace

Property
ITM Stimulus Port To Display

Appendices

The script that is executed when the debugger begins
a load.

The script that is executed when the debugger ends a
load.

The script that is executed when the target is reset.

The target script file, the contents of this file are
prepended to script project properties before they are
executed.

Description

Specifies the ITM Stimulus port to display in the debug

armtarget _itmstinmulus_port_di spl ayintegerR terminal -1 disables this

ITM Stimulus Ports Enable

armtarget _itmstinmulus_port_enabl eintegerHe

ITM Stimulus Ports Privilege

Specifies the ITM Stimulus ports to enable.

Specifies the ITM Stimulus ports to enable.

armtarget _itmstimulus_port_privil egelntege

ITM Timestamping

armtarget _itmtinestanpi ng_enabl eEnumeratio

ITM/DWT Data Trace PC
arm target _dwt _data_trace_PCBoolean

ITM/DWT PC Sampling

arm target _dwt _PC sanpling_enabl eEnumeration

ITM/DWT Trace Exceptions

armtarget_dwt _trace_excepti onsBoolean
MTB RAM Address

arm target _ntb_ram addr essintegerHex
MTB RAM Size

armtarget _ntb_ram si zeEnumeration

SWO Baud Rate

arm target _trace_SWO speedintegerRange

Trace Clock Speed

arm target _trace_cl ock_speedintegerRange

Specifies ITM timestamping. The options are:

Disable - disable timestamping
Local - use the local timestamp clock
Global - use the global timestamp clock

Specifies whether to trace the PC on data trace.

Specifies the DWT PC sampling rate.

Specifies whether to trace exception entry and return.

Specifies the MTB RAM Address - note that this must
be aligned to the MTB RAM size.

Specifies the MTB RAM size in bytes.

Specifies the baud rate of the SWO - zero selects auto
detection.

The speed of the trace clock. This is usually the same as
the CPU clock and is used to program the prescaler for
the SWO
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Specifies the type of trace interface the target has. The
options are:

SWO - Use asynchronous SWO trace interface.
Trace Interface Type TracePort - Use synchronous parallel trace
armtarget_trace_interface_typeEnumeration interface.

ETB - Use on-chip embedded trace buffer.

MTB - Use on-chip MTB - Cortex-MO0+ only.

None

Specifies the trace port size the target has. The options
are:

1-bit
2-bit
4-bit
8-bit
16-bit
24-bit
32-bit

Trace Port Size
armtarget _trace_port_si zeEnumeration
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System Macros

System Macro Values

Property
S(Date)
$( Dat e) String

$(DateDay)
$( Dat eDay) String

$(DateMonth)
$( Dat eMont h) String

S(DateYear)
$( Dat eYear ) String

$(DesktopDir)

$( Deskt opDi r) String
$(DocumentsDir)

$( Docurnent sDi r) String

S(EmbeddedStudioVersionNumber)
$( EnbeddedSt udi oVer si onNunber ) String

$(HomeDir)

$( HoreDi r) String
$(HostArch)

$( Host Ar ch) String

S(HostArchClass)
$( Host Ar chd ass) String

$(HostDLL)
$( Host DLL) String

S(HostDLLExt)
$( Host DLLEXxt ) String

$(HostEXE)
$( Host EXE) String

S(HostOS)

$( Host OS) String
S(UJLinkDir)

$(JLi nkDi r) String

$(Micro)
$(M cro) String

Appendices

Description

Day Month Year e.g. 21 June 2011.

Day e.g. 21.

Month e.g. 01 to 12.

Year e.g. 2011.

Path to users desktop directory.

Path to users documents directory.

The release version number.

Path to users home directory.

The CPU architecture that SEGGER Embedded Studio is
running on e.g. x86.

The class of CPU architecture that SEGGER Embedded
Studio is running on e.g. intel, arm.

The file extension for dynamic link libraries on the CPU
that SEGGER Embedded Studio is running on e.g. .dll.

The file extension for dynamic link libraries used by the
operating system that SEGGER Embedded Studio is
running on e.g. .dll, .so, .dylib.

The file extension for executables on the CPU that
SEGGER Embedded Studio is running on e.g. .exe.

The name of the operating system that SEGGER
Embedded Studio is running on e.g. win.

Path to J-Link software.

The SEGGER Embedded Studio target e.g. ARM.
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$(PackagesDir)
$(PackagesDi r) String

S(Platform)
$( Pl at f or ) String

$(ProductNameShort)
$( Pr oduct NaneShor t ) String

$(StudioArchiveFileExt)
$( St udi 0Ar chi veFi | eExt ) String

$(StudioBuildToolExeName)
$( St udi oBui | dTool ExeNanre) String

$(StudioBuildToolName)
$( St udi oBui | dTool Nane) String

$(StudioDir)

$( St udi oDi r) String
$(StudioExeName)

$( St udi oExeNane) String

$(StudioLicenseToolExeName)
$( St udi oLi censeTool ExeNane) String

$(StudioLicenseToolName)
$( St udi oLi censeTool Nane) String

$(StudioMajorVersion)
$( St udi oMaj or Ver si on) String

$(StudioMinorVersion)
$( St udi oM nor Ver si on) String

$(StudioName)
$( St udi oNane) String

$(StudioNameShort)
$( St udi oNaneShor t ) String

$(StudioPackageFileExt)
$( St udi oPackageFi | eExt ) String

$(StudioProjectFileExt)
$( St udi oPr oj ect Fi | eExt ) String

$(StudioScriptToolExeName)
$( St udi oScri pt Tool ExeNane) String

$(StudioScriptToolName)
$( St udi oScri pt Tool Nane) String

$(StudioSessionFileExt)
$( St udi oSessi onFi | eExt ) String

$(StudioSimulatorExeName)
$( St udi 0Si mul at or ExeNanre) String

Appendices

Path to the users packages directory.

The target platform.

The product name.

The filename extension of a studio archive file.

The filename of the build tool executable.

The name of the build tool executable.

The install directory of the product.

The filename of the studio executable.

The filename of the license tool executable.

The name of the license tool executable.

The major release version of software.

The minor release version of software.

The full name of studio.

The short name of studio.

The filename extension of a studio package file.

The filename extension of a studio project file.

The filename of the script tool executable.

The name of the script tool executable.

The filename extension of a studio session file.

The filename of the simulator executable.
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$(StudioSimulatorName)
$( St udi 0Si mul at or Nang) String

$(StudioUserDir)

$( St udi oUser Di r) String
$(TargetlD)

$( Tar get | D) String
S(Time)

$(Ti nme) String
$(TimeHour)

$(Ti meHour ) String
$(TimeMinute)

$( Ti meM nut e) String

$(TimeSecond)
$( Ti meSecond) String

S(UnixTime)
$( Uni xTi me) String

Appendices

The name of the simulator executable.

The directory containing the user data.

ID number representing the SEGGER Embedded Studio
target.

Hour:Minutes:Seconds e.g. 15:34:03.

Hour e.g. 15.

Minute e.g. 34.

Seconds e.g. 03.

Seconds since 00:00, Jan 1 1970 UTC
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Build Macros

(Build Macro Values)

Property

S(ABI)

$( ABI ) String

$(AR)

$( AR) String

$(AS)

$( AS) String

S(Arch)

$( Ar ch) String

S(Arch)

$( Ar ch) String
$(AsmOptions)

$( AsmOpt i ons) String
$(CQ)

$( CO) String

$(CC)

$( CC1) String

$(CCPP)

$( CCPP) String

S(CLANG)

$( CLANG) String
S(CLANGTIDY)

$( CLANGTI DY) String
$(COnlyOptions)

$( COnl yOpt i ons) String
$(COptions)

$( COpt i ons) String
$(CombiningOutputFilePath)
$( Conbi ni ngQut put Fi | ePat h) String
$(CombiningRellnputPaths)
$( Conbi ni ngRel I nput Pat hs) String
$(Configuration)

$( Confi gurati on) String

$(ConfigurationHash)
$( Conf i gur at i onHash) String

Appendices

Description

The value of the RISC-V ABI Type project property.

The path to the binutils ar command.

The path to the binutils as command.

The lower case value of the ARM Architecture project
property.

The value of the RISC-V ISA project property.

A space seperated list of assembler options for the
external assemble command.

The path to the cc command.

The path to the gcc cc1 command.

The path to the cc command.

The path to the clang command.

The path to the clang-tidy command.

A space seperated list of compiler options for the
external c compile command.

A space seperated list of compiler options for the
external c and c++ compile commands.

The full path of the output file of the combining
command.

The relative inputs to the combining command.

The build configuration e.g. ARM Flash Debug.

The hash value of build configuration.
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$(CoreType)

$( Cor eType) String
S(Defines)

$( Def i nes) String
$(DependencyPath)
$( DependencyPat h) String
S(EXE)

$( EXE) String
S(Endian)

$( Endi an) String
S(FPABI)

$( FPABI ) String
S(FPU)

$( FPU) String
S(FPU2)

$( FPU2) String
S(FPU3)

$( FPU3) String

$(FolderName)
$( Fol der Nane) String

$(FolderPath)
$( Fol der Pat h) String

$(GCQ)

$( GCO) String
$(GCCPrefix)

$( GCCPr ef i x) String
$(GCCTarget)

$( GCCTar get ) String
$(GCCVersion)

$( GCCVer si on) String

$(GPLUSPLUS)
$( GPLUSPLUS) String

S(IncludeFiles)
$( 1 ncl udeFi | es) String

S(Includes)
$( I ncl udes) String

S(InputDir)
$(1 nput Di r) String

S(InputExt)
$( 1 nput Ext ) String

Appendices

The lower case value of the ARM Core Type project
property.

The preprocessor defines property value for the
external compile command.

The path of the dependency file for the external
compile command.

The default file extension for an executable file
including the dot e.g. .elf.

The lower case value of the Byte Order project
property.
The value of the ARM FP ABI Type project property.

The lower case value of the ARM FPU Type project
property.

Alternative value of the ARM FPU Type project
property.

Alternative value of the ARM FPU Type project
property.

The folder name of the containing folder.

The folder path of the containing folders.

The path to the gcc command.

The macro-expanded value of the GCC Prefix project
property.

The macro-expanded value of the GCC Target project
property.

The macro-expanded value of the GCC Version project
property.

The path to the g++ command.

The user includes property value for the external
compile command.

The user directories property value for the external
compile command.

The absolute directory of the input file.

The extension of an input file not including the dot e.g
cpp.
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S(InputFileName)
$(1 nput Fi | eNane) String

S(InputName)

$( 1 nput Nane) String
S(InputPath)

$( | nput Pat h) String
$(IntDir)

$(1 nt Di r) String
$(LD)

$( LD) String

$(LIB)

$( LI B) String

$(LIBLTO)
$(LI BLTO) String

S(LTO1)

$(LTOL) String

S(LibArch)

$( Li bAr ch) String
S(LibEndianExt)

$(Li bEndi anExt ) String
S(LibExt)

$(Li bExt ) String
S(LinkLibraries)

$(Li nkLi brari es) String
$(LinkOptions)

$(Li nkOpt i ons) String
$(LinkerScriptPath)

$(Li nker Scri pt Pat h) String

S(MacroFiles)
$( Macr oFi | es) String

$(MapPath)

$( MapPat h) String
$(MemorySegments)

$( Menor ySegnent s) String

$(0BJ)

$( OBJ) String
$(OBJCOPY)

$( OBJCOPY) String

$(OBJDUMP)
$( OBJDUNP) String

Appendices

The name of an input file relative to the project
directory.

The name of an input file relative to the project
directory without the extension.

The absolute name of an input file including the
extension.

The macro-expanded value of the Intermediate
Directory project property.

The path to the binutils |d command.

The default file extension for a library file including the
dot e.g. lib.

The path to the LTO dll.

The path to the gcc Ito1 command.

The library architecture.

The endian specific library extension.

The architecture and build specific library extension.

The value of the Standard Libraries Directory project
property.

A space seperated list of compiler options for the
external link command.

The full path of the linker script file for the link
command.

The user macros property value for the external
compile command.

The full path of the map file of the external link
command.

The value of the Memory Segments property supplied
to pre/post link command.

The default file extension for an object file including
the dot e.g. .0.

The path to the binutils objcopy command.

The path to the binutils objdump command.

323



SEGGER Embedded Studio Reference Manual

$(Objects)
$( Obj ect s) String

$(ObjectsFilePath)

$( oj ect sFi | ePat h) String
$(OutDir)

$(Qut Di r) String
$(PackageExt)

$( PackageExt ) String

$(PostLinkOutputFilePath)
$( Post Li nkQut put Fi | ePat h) String

$(ProjectDir)
$( Proj ect Di r) String

$(ProjectName)
$( Proj ect Nane) String

$(ProjectNodeName)
$( Pr oj ect NodeNane) String

S(RANLIB)
$( RANLI B) String

$(RelDependencyPath)
$( Rel DependencyPat h) String

$(RellnputDir)

$(Rel I nput Di r) String
$(RellnputPath)

$( Rel | nput Pat h) String

$(RelLinkerScriptPath)
$( Rel Li nker Scri pt Pat h) String

$(RelMapPath)
$( Rel MapPat h) String

$(RelObjectsFilePath)
$( Rel Ooj ect sFi | ePat h) String

$(RelTargetPath)
$( Rel Tar get Pat h) String

$(RootOutDir)
$( Root Qut Di r) String

$(RootRelativeOutDir)
$( Root Rel ati veQut Di r) String

$(SASM)
$( SASM String

Appendices

A space seperated list of files for the external archive or
link command.

The full path containing the files for the external
archive or link command.

The macro-expanded value of the Output Directory
project property.

The file extension of a package file e.g. emPackage.

The full path of the output file of the post link
command.

The absolute value of the Project Directory project
property of the current proje ct. If this isn't set then the
directory containing the solution file.

The project name of the current project.

The name of the selected project node.

The path to the binutils ranlib command.

The relative path of the dependency file for the
external compile command.

The relative path to the directory containing the input
file from the project directory or dot if not relative.

The relative path to the input file from the project
directory or the full path if not relative.

The relative path of the linker script file for the link
command.

The relative path of the map file of the external link
command.

The relative path containing the files for the external
archive or link command.

The project directory relative path of the output file of
the link or compile command.

The macro-expanded value of the Root Output
Directory project property.

The relative path to get from the path specified by
the Output Directory project property to the path
specified by the Root Output Directory project

property.

The path to the SEGGER assembler.
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$(sCO)
$( SCC) String

S(SLINK)

$( SLI NK) String
S(STRIP)

$( STRI P) String
$(SolutionDir)

$( Sol uti onDi r) String
$(SolutionExt)

$( Sol uti onExt ) String

S(SolutionFileName)
$( Sol uti onFi | eNane) String

$(SolutionName)
$( Sol uti onNane) String

$(SolutionPath)
$( Sol uti onPat h) String

$(StageOutputFilePath)
$( St ageQut put Fi | ePat h) String

$(TargetPath)
$( Tar get Pat h) String

$(ToolChainDir)
$( Tool Chai nDi r) String

$(Undefines)
$( Undef i nes) String

Appendices

The path to the SEGGER compiler.

The path to the SEGGER linker.

The path to the binutils strip command.

The absolute path of the directory containing the
solution file.

The extension of the solution file without the dot.

The filename of the solution file.

The basename of the solution file.

The absolute path of the solution file.

The full path of the output file of the stage command.
The full path of the output file of the link or compile
command.

The macro-expanded value of the Tool Chain
Directory project property.

The preprocessor undefines property value for the
external compile command.

325



SEGGER Embedded Studio Reference Manual Appendices

BinaryFile
The following table lists the BinaryFile object's member functions.

BinaryFile.crc32(offset, length) returns the CRC-32 checksum of an address range length bytes long, starting

at offset. This function computes a CRC-32 checksum on a block of data using the standard CRC-32 polynomial
(0x04C11DB7) with an initial value of OXFFFFFFFF. Note that this implementation doesn't reflect the input or the
output and the result is inverted.

BinaryFile.length() returns the length of the binary file in bytes.

BinaryFile.load(path) loads binary file from path.

BinaryFile.loadAppend(path) loads binary file from path and appends it to the binary image.
BinaryFile.peekBytes(offset, length) returns byte array containing length bytes peeked from offset.

BinaryFile.peekUint32(offset, littleEndian) returns a 32-bit word peeked from offset. The littleEndian argument
specifies the endianness of the access, if true or undefined it will be little endian, otherwise it will be big endian.

BinaryFile.pokeBytes(offset, byteArray) poke byte array byteArray to offset.

BinaryFile.pokeUint32(offset, value, littleEndian) poke a value to 32-bit word located at offset. The littleEndian
argument specifies the endianness of the access, if true or undefined it will be little endian, otherwise it will be
big endian.

BinaryFile.resize(length, fill) resizes the binary image to length bytes. If the operation extends the size, the
binary image will be padded with bytes of value fill.

BinaryFile.save(path) saves binary file to path.

BinaryFile.saveRange(path, offset, length) saves part of the binary file to path. The offset argument specifies
the byte offset to start from. The length argument specifies the maximum number of bytes that should be
saved.
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CWSys

The following table lists the CWSys object's member functions.

CWSys.appendStringToFile(path, string) appends string to the end of the file path.
CWSys.copyFile(srcPath, destPath) copies file srcPath to destPath.

CWSys.crc32(array) returns the CRC-32 checksum of the byte array array. This function computes a CRC-32
checksum on a block of data using the standard CRC-32 polynomial (0x04C11DB7) with an initial value of
OxFFFFFFFF. Note that this implementation doesn't reflect the input or the output and the result is inverted.

CWSys.fileExists(path) returns true if file path exists.

CWSys fileSize(path) return the number of bytes in file path.

CWSys.getRunStderr() returns the stderr output from the last CWSys.run() call.
CWSys.getRunStdout() returns the stdout output from the last CWSys.run() call.
CWSys.makeDirectory(path) create the directory path.

CWSys.packU32(array, offset, number, le) packs number into the array at offset.
CWSys.popup(text, caption) prompt the user with text and return true for yes and false for no.
CWSys.readByteArrayFromFile(path) returns the byte array contained in the file path.
CWSys.readStringFromFile(path) returns the string contained in the file path.
CWSys.removeDirectory(path) remove the directory path.

CWSys.removeFile(path) deletes file path.

CWSys.renameFile(oldPath, newPath) renames file oldPath to be newPath.

CWSys.run(cmd, wait) runs command line cmd optionally waits for it to complete if wait is true.
CWSys.unpackU32(array, offset, le) returns the number unpacked from the array at offset.
CWSys.writeByteArrayToFile(path, array) creates a file path containing the byte array array.

CWSys.writeStringToFile(path, string) creates a file path containing string.
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Debug

The following table lists the Debug object's member functions.

Debug.evaluate(expression) evaluates debug expression and returns it as a JavaScript value.

Debug.getfunction(address) return function name containing address.
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ElfFile

The following table lists the ElfFile object's member functions.

ElfFile.crc32(address, length, virtualNotPhysical, padding, programNotSection) returns the CRC-32
checksum of an address range length bytes long, located at address. If virtualNotPhysical is true or undefined,
address is a virtual address otherwise it is a physical address. If padding is defined, it specifies the byte value
used to fill gaps in the program. If programNotSection is true or undefined, data is read using program headers
rather than section headers. This function computes a CRC-32 checksum on a block of data using the standard
CRC-32 polynomial (0x04C11DB7) with an initial value of OXFFFFFFFF. Note that this implementation doesn't
reflect the input or the output and the result is inverted.

ElfFile.findProgram(address) returns an object with start, the data and the size to allocate of the EIf program
that contains address.

ElfFile.getEntryPoint() returns the entry point in the ELF file.

ElfFile.getSection(name) returns an object with start and the data of the Elf section corresponding to the
name.

ElfFile.isLittleEndian() returns true if the Elf file has numbers encoded as little endian.
ElfFile.load(path) loads Elf file from path.

ElfFile.peekBytes(address, length, virtualNotPhysical, padding, programNotSection) returns byte array
containing length bytes peeked from address. If virtualNotPhysical is true or undefined, address is a virtual
address otherwise it is a physical address. If padding is defined, it specifies the byte value used to fill gaps in
the program. If programNotSection is true or undefined, data is read using program headers rather than section
headers.

ElfFile.peekUint32(address, virtualNotPhysical) returns a 32-bit word peeked from address. If
virtualNotPhysical is true or undefined, address is a virtual address otherwise it is a physical address.

ElfFile.pokeBytes(address, byteArray, virtualNotPhysical) poke byte array byteArray to address. If
virtualNotPhysical is true or undefined, address is a virtual address otherwise it is a physical address.

ElfFile.pokeUint32(address, value, virtualNotPhysical) poke a value to 32-bit word located at address. If
virtualNotPhysical is true or undefined, address is a virtual address otherwise it is a physical address.

ElfFile.save(path) saves Elf file to path.

ElfFile.symbolValue(symbol) returns the value of symbol in Elf file.
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Targetinterface

The following table lists the Targetinterface object's member functions.

Targetinterface.crc32(address, length) reads a block of bytes from target memory starting at address for
length bytes, generates a crc32 on the block of bytes and returns it.

Targetinterface.delay(ms) waits for ms milliseconds

Targetinterface.error(message) terminates execution of the script and outputs a target interface error
message to the target log.

Targetinterface.executeFunction(address, parameter, timeout) calls a function at address with the parameter
and returns the function result. The timeout is in milliseconds.

Targetinterface.expandMacro(string) returns the string with macros expanded.

Targetinterface.findByte(address, length, byte) returns the index of the byte in the specified target memory
range.

Targetinterface.findNotByte(address, length, byte) returns the index of the byte that isn't in the specified
target memory range.

Targetinterface.getProjectProperty(savename) returns the value of the savename project property.
Targetinterface.getTargetProperty(savename) returns the value of the savename target property.
Targetinterface.go() allows the target to run.

Targetinterface.isStopped() returns true if the target is stopped.
Targetinterface.message(message) outputs a target interface message to the target log.

Targetinterface.peekBinary(address, length, filename) reads a block of bytes from target memory starting at
address for length bytes and writes them to filename.

Targetinterface.peekByte(address) reads a byte of target memory from address and returns it.

Targetinterface.peekBytes(address, length) reads a block of bytes from target memory starting at address for
length bytes and returns the result as an array containing the bytes read.

Targetinterface.peekMultUint16(address, length) reads length unsigned 16-bit integers from target memory
starting at address and returns them as an array.

Targetinterface.peekMultUint32(address, length) reads length unsigned 32-bit integers from target memory
starting at address and returns them as an array.

Targetinterface.peekUint16(address) reads a 16-bit unsigned integer from target memory from address and
returns it.

Targetinterface.peekUint32(address) reads a 32-bit unsigned integer from target memory from address and
returns it.

Targetinterface.peekWord(address) reads a word as an unsigned integer from target memory from address
and returns it.

Targetinterface.pokeBinary(address, filename) reads a block of bytes from filename and writes them to target
memory starting at address.

Targetinterface.pokeByte(address, data) writes the byte data to address in target memory.
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Targetinterface.pokeBytes(address, data) writes the array data containing 8-bit data to target memory at
address.

Targetinterface.pokeMultUint16(address, data) writes the array data containing 16-bit data to target memory
at address.

Targetinterface.pokeMultUint32(address, data) writes the array data containing 32-bit data to target memory
at address.

Targetinterface.pokeUint16(address, data) writes data as a 16-bit value to address in target memory.
Targetinterface.pokeUint32(address, data) writes data as a 32-bit value to address in target memory.
Targetinterface.pokeWord(address, data) writes data as a word value to address in target memory.
Targetinterface.readBinary(filename) reads a block of bytes from filename and returns them in an array.
Targetinterface.reset() resets the target.

Targetinterface.resetAndStop() resets and stops the target.

Targetinterface.runFromAddress(address, timeout) start the target executing at address and waits for a
breakpoint to be hit. The timeout is in milliseconds.

Targetinterface.runFromToAddress(from, to, timeout) start the target executing at address from and waits for
the breakpoint to be hit. The timeout is in milliseconds.

Targetinterface.runToAddress(address, timeout) sets a breakpoint at address, starts the target executing and
waits for the breakpoint to be hit. The timeout is in milliseconds.

Targetinterface.setTargetProperty(savename) set the value of the savename target property.
Targetinterface.stop() stops the target.

Targetinterface.writeBinary(array, filename) write the bytes in array to filename.
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WScript

The following table lists the WScript object's member functions.

WScript.Echo(s) echos string s to the output terminal.
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