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1. Introduction

This document describes the installation and use of Cypress’ Clock Programmer software. This soft-
ware is used as a standalone application to program Cypress Clock devices through the use of
JEDEC files. If the information in this guide is not sufficient to resolve any issues while using the
Clock Programmer, use the support resources listed in the next section.

The Clock Programmer is an additional utility bundled with the PSoC Programmer release. You must
download and install PSoC Programmer to use the Clock Programmer.

1.1 Support

Free support for PSoC Programmer and Clock Programmer is available online at www.cypress.com.
Resources include training seminars, discussion forums, application notes, PSoC consultants, Tight-
Link technical support, Email/Knowledge Base, and Application Support Technicians.

Technical support is also available by phone at 1-800-541-4736.

Before using Cypress support services, know the version of PSoC Programmer and Clock program-
mer installed on your system. To determine the version, build, or service pack of PSoC Programmer,
click Help > About Clock Programmer.

1.2 Product Upgrades

Cypress provides scheduled upgrades and version enhancements for PSoC Programmer and Clock
Programmer free-of-charge. You can download them directly from www.cypress.com under Support
& Community > Software Tools. Also provided are critical updates to system documentation under
Design Resources or go to the Design Resources section at www.cypress.com.

1.3 Document Conventions

Convention Usage

Courier New
Displays file locations, user entered text, and source code:
C:\ ...cd\icc\

Italics
Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed, Bold]
Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open
Represents menu paths:
File > Open > New Project

Bold
Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Text in gray boxes Describes Cautions or unique functionality of the product.

http://www.cypress.com/psoc
www.cypress.com
http://www.cypress.com
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2. Installation

The Clock Programmer is bundled with PSoC Programmer. You must install PSoC Programmer to
use Clock Programmer. PSoC Programmer may be downloaded directly from www.cypress.com/
psocprogrammer.

2.1 Setup

You can install only one version of PSoC Programmer on your computer. Clock Programmer is part
of this installation package. Cypress recommends that you update to the latest release. Based on
our product policy, it should be a superset of all previous releases (unless otherwise specified). The
initial release of the Clock Programmer, version 1.0, was PSoC Programmer 3.05.

Downloading and installing from the Cypress website:

1.  Go to www.cypress.com/psocprogrammer. 

2.  Locate PSoC Programmer Setup.exe and download the file.

3.  Open PSoC Programmer.exe to start the setup wizard.

4.  Follow the onscreen prompts to install PSoC Programmer - Typical Installation.

If an earlier version of PSoC Programmer is already installed, the Setup Wizard prompts you to
delete the older version. The default PSoC Programmer installation folder is:

C:\Program Files (x86)\Cypress\Programmer

http://www.cypress.com/psocprogrammer
www.cypress.com/psocprogrammer
www.cypress.com/psocprogrammer
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3. Using Clock Programmer

The Clock Programmer opens a JEDEC file, connects to a programming device, selects target
devices, programs, reads, saves, verifies, and runs a checksum.

3.1 Starting the Clock Programmer

Follow these steps to start programming:

1. Set up all hardware, including the clock device to program (target device).

2. Start the Clock Programmer from the Microsoft Windows Start menu.

The alternate method to start Clock Programmer is to launch directly from: [ProgrammerInstal-
lationFolder]\ClockProgrammer.exe

Figure 3-1.  Clock Programmer
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3.2 Connecting to a Programmer Tool

The Clock Programmer currently supports the following hardware programming tools:

■ CY3240USB IIC Bridge (USB-I2C converter tool available as a part of CY3675 Kit). 
Note: the bridge is not compatible with the CY3676 and CY3677 EVKs;

■ KitProg (built-in USB-I2C converter as a part of the CY367x Evaluation Kits);

■ MiniProg3 (Versatile PSoC programmer/debugger that also includes USB-I2C converter tool).

At startup, the Clock Programmer automatically detects any programming device that is connected.
The status bar at the bottom right of the GUI changes from Not Connected (red) to Connected
(green). Additionally, the status text window will display messages as the Clock Programmer detects
and opens the programming port (Figure 3.3). The connected USBIIC Bridge's (or other supported
hardware) firmware version is also displayed.

Figure 3-2.  Successful Connection of USB-I2C Device

3.3 Selecting a Clock Device

The Clock Programmer allows you to select a target Clock device from a Device List tree menu. The
device selected must match the connected kit (and the type of Socket Adapter Board). To expand a
collapsed tree, click the ‘+’ icon next to the device family name. To collapse the device family tree,
click the ‘–’ icon. Select the device by clicking and highlighting the desired device.

Figure 3-3.   Device List
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Under the Device Information display area (see Figure 3-4), the selected clock device’s information
is displayed. This updates each time a new target clock device is selected.

Figure 3-4.  Device Information

3.4 I2C Settings

If the selected target device belongs to the CY27400 or CY29400 family, then the I2C settings
become available. The I2C address must be set manually to match the exact I2C address designed
using the CyClockWizard configuration project. The corresponding address is also incorporated in
the JEDEC file.

The default I2C device address must be used if you are programming an empty device for the first
time. This can be found in the Clock Device Datasheet (for example, the CY27400 device's default
address is 0x69 = 105 and the CY29400 device's default address is 0x55 = 85).

Clock Programmer will scan and try to program the I2C device. Connect fails if:

■ No device is connected on the bus.

■ The device connected does not correspond to the device selected in the Device List.

■ Wrong I2C address.

■ The CY29400 device is connected to the CY3240USB IIC Bridge.

3.5 Opening a JEDEC File

You must load a JEDEC file into the Clock Programmer before programming a device. The Clock
Programmer programs devices only using the JEDEC file format.

To select a file for programming:

1.  Click File Load  or press [F4].

2.  In the Open dialog box, browse to the folder containing the file, then select a file.

3.  Click Open.

The status window will return with a successful message:
Active JEDEC file set at 1:47:18 PM| C:\Documents and Settings\wbz\Desk-
top\JEDEC_CY25402.jed
Frequency Information

(…additional data pertaining to the JEDEC file.)
Load JEDEC at 1:47:18 PM 

After loading the JEDEC file, JEDEC Information displays critical information regarding the JEDEC
file. These features include the file name, checksum, and supported devices. These fields are
updated as new JEDEC files are loaded.
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Figure 3-5.  JEDEC Information

3.6 Connecting and Disconnecting

The Clock Programmer allows you to connect to the target device. The Connect and Disconnect but-
tons can initiate these actions. Before connecting to the target device, you must connect the pro-
grammer to the PC and the target device. When connected to the target clock device, you can
disconnect using the Disconnect button. 

When using the CY3240 USBIIC Bridge with the CY27400 devices, ensure that the INT pin is not
connected to the target's XRES pin. Since the Bridge's INT pin is always set LOW, it is the active
reset signal for this family.

Do not use the CY3240 USBIIC Bridge with the CY29400 devices.

MiniProg3 powers the device automatically (1.8 V) during connection if no external power is
detected. The Disconnect button will power off the target.

During connection, Clock Programmer checks the kit's firmware and hardware version. If an irrele-
vant kit is connected, then the appropriate message appears in the Log Window. For example, if you
selected the CY22381F Clock Device but connected to the CY3675 Kit, then a warning message
appears asking you to change the kit or kit's firmware.

3.6.1 Changing Firmware for CY3675 Kit A and CY3675 Kits

CY3675 Kit A is identical to the CY3675 Kit from a hardware standpoint. The only difference is the
firmware required to support two sets of Clock Device MPNs. The default firmware supports one set
of clock devices (for example, CY25701). The second set of clock devices, such as CY22381F,
require a different firmware to be programmed on the CY3675 kit hardware. These clock MPNs that
require a firmware change from the default shipped firmware are mentioned under the CY3675 Kit A
category (see Figure 3-1).

1.  Disconnect the USBIIC Bridge from the PC and Kit's Baseboard.

2.  Connect the MiniProg1 programmer to the PC and Kit's Baseboard (Figure 3-6).

3.  From the Windows Start Menu, open Cypress > PSoC Programmer.

4.  Set PSoC Programmer Configuration:

a. Programming Mode: Power Cycle

b. Verification: On

c. AutoDetection: On

d. Protocol: ISSP

e. Connector: 5p (5-pin header)

f. Voltage: 5.0 V

5.  Click File > File Load or press [F4].

6.  Select necessary Kit Firmware: [ProgrammerInstallationFolder]\Clock\Firmware

7.  Click File > Program or press [F5].
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Figure 3-6.  Kit Firmware Upgrading Setup

After successful firmware programming, the new kit version should be displayed, as described in
Section 3.2 Connecting to a Programmer Tool on page 8.

3.7 Program

You must load a JEDEC file into the Clock Programmer to program a clock device.

To program a device:

1.  Open the Clock Programmer.

2.  Connect the programmer to the PC.

3.  Load the JEDEC File.

4.  Click Connect.

5.  Click Program  or press [F5].

3.8 Checksum

When you press the Checksum button, the Clock Programmer will retrieve the checksum data from
the target board.

To read the checksum from the device:

1.  Open the Clock Programmer.

2.  Connect the programmer to the PC.

3.  Load the JEDEC file.

4.  Click Connect.

5.  Click Checksum  or press [F6].

3.9 Read

Press the Read button to read out the target's clock device programmable memory content.

To read the data from the clock device:

1.  Open the Clock Programmer.

2.  Connect the programmer to the PC.

3.  Click Connect.

4.  Click Read  or press [F7]. 
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3.10 Save

Click the Save button to save information into a text file.

To save the data from the clock device:

1.  Open the Clock Programmer

2.  Connect the programmer to the PC.

3.  Click Connect.

4.  Click Save  or press [F8].

3.11 Verify

You have the option to verify the contents on a target clock device against a selected JEDEC file.
The Verify function reads/verifies the target clock device’s contents and compares the checksums
against the loaded JEDEC file.

To verify the configuration image in the clock device against the JEDEC file, execute the following:

1.  Open the Clock Programmer.

2.  Connect the programmer to the PC.

3.  Load the JEDEC file.

4.  Click Connect.

5.  Click Verify  or press [F9].

3.12 Advanced Programming Information

The Clock Programmer uses the shared architecture with PSoC Programmer. PSoC Programmer
provides a COM interface to generate user-specific applications by calling low-level API functions. In
the PSoC Programmer root installation directory, the Examples and Documentation folders contain
all the information to create unique applications with the PSoC Programmer COM.

3.13 Windows 8.1 Problems & Solutions

The Clock Programmer does not detect USB2IIC Bridge in Windows version 8.1 and later.

To fix this problem, follow these steps:

1.  Connect MiniProg1 to USB2IIC Bridge as shown in Figure 3-8.

2.  From the Windows Start menu, open PSoC Programmer.

3.  Set PSoC Programmer Configuration:

a. Programming Mode: Power Cycle

b. Verification: On

c. AutoDetection: On

d. Protocol: ISSP

e. Connector: 5p (5-pin header)

f. Voltage: 5.0 V

4.  Click File > File Load or press [F4].

5.  Select USBIIC Bridge Firmware: [Programmer Installation Folder]\usbtoiic.hex

6.  Click File > Program or press [F5].
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After successful firmware programming, the new USBIIC Bridge version should be 1.36 or higher.
Version 1.36 is the minimal requirement for normal operation under Windows 8.1 or later (see
Figure 3-7).

Figure 3-7.  Clock Programmer Running on Windows 8.1 OS

Figure 3-8.  USBIIC Bridge Connected with MiniProg1

3.14 Error Codes

The Clock Programmer displays error messages on the status text window when there is any failure
during runtime (only for CY3675 kit and CY3675 Kit A). Error codes are appended to the error mes-
sages. 

Error Code Description

001

Communication error occurred while reset. 

External power supply might not be connected. 

USBIIC might not be connected to the CyClockMaker.

002

Communication error occurred while operating USB LED (D5). 

External power supply might not be connected. 

USBIIC might not be connected to the CyClockMaker.

003

Communication error occurred while operating ERR LED (D2). 

External power supply might not be connected. 

USBIIC might not be connected to the CyClockMaker.

004

Communication error occurred while operating Prog LED (D3). 

External power supply might not be connected. 

USBIIC might not be connected to the CyClockMaker.
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005

Communication error occurred while operating Chk LED (D4). 

External power supply might not be connected. 

USBIIC might not be connected to the CyClockMaker.

006

Communication error occurred while checking daughter board. 

External power supply might not be connected. 

USBIIC might not be connected to the CyClockMaker.

007

Communication error occurred while validating device.

External power supply might not be connected. 

USBIIC might not be connected to the CyClockMaker.

008

Communication error occurred while reading data.

External power supply might not be connected. 

USBIIC might not be connected to the CyClockMaker.

009

Read operation has failed. 

The device might be broken. 

The device in the socket might be placed in wrong direction. 

There might be no device in the socket.

010

Communication error occurred while shifting data. 

External power supply might not be connected. 

USBIIC might not be connected to the CyClockMaker.

011

Write operation has failed. 

The device in the socket might be placed in wrong direction.

There might be no device in the socket.

012

Communication error occurred while programming data.

External power supply might not be connected. 

USBIIC might not be connected to the CyClockMaker.

013

Communication error occurred while verifying programmed data. 

External power supply might not be connected. 

USBIIC might not be connected to the CyClockMaker.

014

Device Validation has failed. 

The device could have been programmed already. 

There could be no device in the socket. 

The device in the socket might be placed in wrong direction.

Error Code Description
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