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 Getting Started with the tinyAVR® 2 Family

Introduction

Author: Rupali Honrao, Microchip Technology Inc.

This application note outlines how to get started with the tinyAVR® 2 Family of microcontrollers.

Refer to the data sheet for further information on the differences between the tinyAVR® 2 Family devices.

Features Presented in this Document
• Getting Started with tinyAVR® 2 Family Microcontrollers and Tools
• Getting Started with ATtiny1627 Curiosity Nano and Microchip Studio 7.0
• Getting Started with ATtiny1627 Curiosity Nano and MPLAB® X
• Code Examples in Atmel START and GitHub
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1. Relevant Devices
This section lists the relevant devices for this document. The following figures show the different family devices,
laying out pin count variants and memory sizes:

• Vertical migration upwards is possible without code modification, as these devices are pin-compatible and
provide the same or more features

• Horizontal migration to the left reduces the pin count and, therefore, the available features
• Devices with different Flash memory sizes typically also have different SRAM and EEPROM

Figure 1-1. tinyAVR® 2 Family Overview
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2. Get the Device Data Sheet
Product pages

• Program Memory Size 4 KB
– www.microchip.com/wwwproducts/en/ATtiny424
– www.microchip.com/wwwproducts/en/ATtiny426
– www.microchip.com/wwwproducts/en/ATtiny427

• Program Memory Size 8 KB
– www.microchip.com/wwwproducts/en/ATtiny824
– www.microchip.com/wwwproducts/en/ATtiny826
– www.microchip.com/wwwproducts/en/ATtiny827

• Program Memory Size 16 KB
– www.microchip.com/wwwproducts/en/ATtiny1627
– www.microchip.com/wwwproducts/en/ATtiny1624
– www.microchip.com/wwwproducts/en/ATtiny1627

• Program Memory Size 32 KB
– www.microchip.com/wwwproducts/en/ATtiny3224
– www.microchip.com/wwwproducts/en/ATtiny3226
– www.microchip.com/wwwproducts/en/ATtiny3227

Documents

These documents are to be found on the product page for the specific product.
• ATtiny[product number(s)] Data Sheet (.pdf)
• ATtiny[product number(s)] Silicon Errata and Data Sheet Clarification (.pdf)

The documentation for the tinyAVR® 2 Family is split into two document types:

• Data sheet(1) (includes device description, number of peripherals, pinout and electrical characteristics)
• Errata (includes known errata for the device)

Note: 
1. For devices that are future products, the product brief is available instead of the data sheet.
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3. Relevant Documents
All relevant documents can be found under the documentation tab on the product page.

Below is a list of documents relevant to tinyAVR® 2 Family Microcontrollers.

• Technical Briefs:
– How to use the 12-Bit Differential ADC with PGA in Single Mode
– How to use the 12-Bit Differential ADC in Series Accumulation Mode
– How to use the 12-Bit Differential ADC with PGA in Burst Accumulation Mode

• Application Notes:
– How to use Force Sensitive Resistor with 12-Bit ADC
– Low-Power, Cost-Efficient PIR Motion Detection Using The tinyAVR® 2 Family
– Using Matrix Keypad With AVR® Devices

• Training Manual:
– Getting Started with tinyAVR 2 Family ADC Hands-on
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4. Get the Tools
Microchip Studio 7.0, which uses the GCC compiler, can be utilized as an IDE to get started with tinyAVR® 2 Family.

MPLAB® X, which uses the GCC or XC8 compiler, can be utilized as an IDE to get started with tinyAVR® 2 Family.

4.1 Get the ATtiny1627 Curiosity Nano Hardware User Guide
User 

Switch
User LED

(LED0)
AT�ny1627

MCU
32.768 kHz 

Crystal FootprintDebuggerPower/Status
LED

Micro-USB
Connector

Web page: www.microchip.com/developmenttools/productdetails.aspx?partno=DM080104

Get the kit: www.microchipdirect.com/ProductSearch.aspx?Keywords=DM080104

Document/file:
• ATtiny1627 Curiosity Nano Hardware User Guide (.pdf)

Key Features

• ATtiny1627 Microcontroller
• One Yellow User LED
• One Mechanical User Switch
• Footprint for 32.768 kHz Crystal
• On-Board Debugger:

– Board identification in Microchip Studio/Microchip MPLAB® X
– One green power and status LED
– Programming and debugging
– Virtual COM port (CDC)
– Two logic analyzer channels (DGI GPIO)

• USB Powered
• Adjustable Target Voltage:

– MIC5353 LDO regulator controlled by the on-board debugger
– 1.8-5.1 V output voltage (limited by USB input voltage)
– 500 mA maximum output current (limited by ambient temperature and output voltage)

The ATtiny1627 Curiosity Nano user guide covers how to power the kit and the detailed information on board
components, extension interface, and the hardware guide.
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4.2 Get Code Examples from Atmel START
The code examples are available through Atmel START, which is a web-based tool that enables the configuration
of the application code through a Graphical User Interface (GUI). The code can be downloaded for Atmel Studio,
MPLAB® X and IAR Embedded Workbench® via the direct example code link below or the Browse Examples button
on the Atmel START front page.

The Atmel START webpage can be found here: Atmel START.

Code Examples

Finding code examples for devices in the tinyAVR 2 Family can be done by searching for the device name (e.g.,
ATtiny1627), in the Atmel START example browser.

Click User Guide in Atmel START for details and information about example projects. The User Guide button can be
found in the example browser and by clicking the project name in the dashboard view within the Atmel START project
configurator.

Microchip Studio/Atmel Studio

Download the code as a .atzip file for Microchip Studio/Atmel Studio from the example browser in Atmel START by
clicking Download Selected example. To download the file from within Atmel START, click Export project followed
by Download pack.

Double click the downloaded .atzip file, and the project will be imported to Microchip Studio/Atmel Studio 7.0

MPLAB® X

Download the code as a .atzip file for MPLAB X IDE from within Atmel START by clicking Export project followed
by Download pack.

To open the Atmel START example in MPLAB X, select from the menu in MPLAB X, File > Import > START MPLAB
Project and navigate to the .atzip file.

IAR Embedded Workbench®

For information on how to import the project in IAR Embedded Workbench, open the Atmel START User Guide,
select Using Atmel Start Output in External Tools, and IAR Embedded Workbench. A link to an online version of
the Atmel START User Guide can be found by clicking Help from the Atmel START front page or Help And Support
within the project configurator, both located in the upper right corner of the page.

4.3 Get Code Examples from GitHub
The code examples are available through GitHub, which is a web-based server that provides the application codes
through a Graphical User Interface (GUI). The code examples can be opened in both Microchip Studio and MPLAB
X. To open the Microchip Studio project in MPLAB X, select from the menu, File > Import > Atmel Studio Project,
and navigate to the .cproj file.

The GitHub webpage: GitHub.

Code Examples

Finding code examples for devices in the tinyAVR 2 Family can be done by searching for the device name (e.g.,
ATtiny1627), in the GitHub example browser.

View Code Examples on GitHub
Click to browse repositories

Download the code as a .zip file from the example page on GitHub by clicking the Clone or download button.
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4.4 Get Microchip Studio 7.0
Webpage: Microchip Studio

Document/file:
• Microchip Studio for AVR and SAM Devices 7.0 Installer (.exe)

Microchip Studio 7.0 or later is the preferred IDE for developing and debugging firmware for the tinyAVR® 2 Family.

For device support, refer to 4.7  Get Device Support for Microchip Studio.

4.5 Get MPLAB® X
Webpage: MPLAB® X IDE

Document/file:
• MPLAB X

MPLAB X can be utilized as an IDE for developing and debugging firmware for the tinyAVR® 2 Family.

For device support, refer to 4.8  Get Device Support for MPLAB X.

4.6 Get IAR Embedded Workbench® for AVR®

Webpage: https://www.iar.com/iar-embedded-workbench/#!?architecture=AVR

Document/file: IAR Embedded Workbench installer for AVR®.

4.7 Get Device Support for Microchip Studio
Microchip Studio: Support for new devices in Microchip Studio can be added by using the Device Pack Manager,
which is found under Tools → Device Pack Manager.

For the tinyAVR® 2 Family, update to the latest version by performing the following steps:
1. Click Check for Updates.
2. For tinyAVR® 2 Family, select the latest available version of ATtiny_DFP.
3. Click Install.

For offline installers, go to packs.download.microchip.com/. To install a package, double click on the installer file and
follow the instructions. Any open Microchip Studio window will have to be closed for the installation to take effect.

IAR™: Support for new devices in IAR Embedded Workbench can be added by installing the latest service pack.
The service pack is available at My Pages on https://iar.com (MyPages is available for users with registered IAR™

licenses, using the same email address that was used to register the license).

4.8 Get Device Support for MPLAB® X
MPLAB X: Support for new devices in MPLAB X can be added by using the MPLAB Pack Manager, which is found
under Tools → Packs.

For the tinyAVR® 2 Family, update to the latest version by performing the following steps:
1. Click Check for Updates.
2. For the tinyAVR® 2 Family, select the latest available version of ATtiny_DFP.
3. Click Install.

For offline installers, go to packs.download.microchip.com/. To install a package, double click on the installer file and
follow the instructions. Any open MPLAB X window will have to be closed for the installation to take effect.
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5. Microchip Studio Users Getting Started

5.1 Microchip Studio with ATtiny1627 Curiosity Nano
Prerequisites

• Microchip Studio 7.0.2537 or later installed
• The ATtiny1627 Curiosity Nano Board is connected to Atmel Studio 7.0 via the on-board USB connector, which

is connected to the embedded debugger. The kit will be powered by the USB, and the embedded debugger will
enable debugging and programming via the USB.

Workflow

1. Launch Microchip Studio 7.0.
2. The page shown below will appear when ATtiny1627 Curiosity Nano is connected to Atmel Studio 7.0.

Figure 5-1.  ATtiny1627 Curiosity Nano Page in Microchip Studio

3. Start creating a new project by clicking New → Project... or by using the Ctrl+Shift+N shortcut, as shown in
Figure 5-2.
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Figure 5-2. Create New Project in Microchip Studio

4. Select the GCC C Executable Project template, as shown in Figure 5-3, type in the name of the solution and
project (e.g., GETTING_STARTED and LED_TOGGLE), and click OK.
Figure 5-3. New Project Wizard

5. Select ATtiny1627 as shown in Figure 5-4, and click OK.
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Figure 5-4. Device Selection Wizard

A new project with a main.c file associated will be generated in Microchip Studio.
6. Replace the main.c file with the following code snippet:

int main (void)
{
  /* Configure SW0 as input */
  PORTC.DIRCLR = PIN4_bm;
  /*Enable internal pull up for SW0*/
  PORTC.PIN4CTRL  = PORT_PULLUPEN_bm; 
  /* Configure LED0 pin as output */
  PORTB.DIRSET = PIN7_bm;
    
  while (1)
  {
    /* Check the status of SW0 */
    /* 0: Pressed */
    if (!(PORTC.IN & (PIN4_bm)))
    {
      /* LED0  off */
      PORTB.OUTSET = PIN7_bm;
    }
    /* 1: Released */
    else
    {
      /* LED0 on */
      PORTB.OUTCLR = PIN7_bm;
    }
  }
}

In the code editor, the code will appear, as shown in Figure 5-5.
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Figure 5-5. Code Editor Window

7. Open project properties by clicking Project → Properties or by using the ALT+F7 shortcut.
8. In the Tool view (see Figure 5-6), set Selected debugger/programmer to nEDBG and Interface to UPDI.
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Figure 5-6. Debugger and Interface for ATtiny1627

9. Build the project by clicking Build → Build Solution or by using the F7 shortcut.
10. Program ATtiny1627 with the project code and start debugging by clicking Debug → Start debugging

and break or by using the ALT+F5 shortcut. The application is programmed onto the device, and program
execution will break in the main() function.

11. Run the code by clicking Debug → Continue or by using the F5 shortcut.
12. Verify that LED0 is lit when SW0 is pushed on the ATtiny1627 Curiosity Nano.

 AN3456
Microchip Studio Users Getting Started

© 2021 Microchip Technology Inc.  Application Note DS00003456B-page 13



6. MPLAB® X Users Getting Started

6.1 MPLAB® X with ATtiny1627 Curiosity Nano
Prerequisites

• MPLAB X installed
• The ATtiny1627 Curiosity Nano Board is connected to MPLAB X via the on-board USB connector, which is

connected to the embedded debugger. The kit will be powered by the USB, and the embedded debugger will
enable debugging and programming via the USB.

Workflow

1. Launch MPLAB X.
2. The page shown in Figure 6-1 will appear when ATtiny1627 Curiosity Nano is connected to MPLAB X.

Figure 6-1. ATtiny1627 Curiosity Nano Page in MPLAB® X

3. Start creating a new project by clicking File → New Project... or by using the Ctrl+Shift+N shortcut, as shown
in Figure 6-2.
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Figure 6-2. Create New Project in MPLAB® X

4. Select the Categories → Microchip Embedded and Projects → Standalone Project template from Figure
6-6, and click Next.
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Figure 6-3. New Project Window

5. Select ATtiny1627 (see Figure 6-4) and click Next.
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Figure 6-4. Device Selection Window

Then select the board and the desired compiler, if there are any.
6. Type in the name of the project (e.g., LED_TOGGLE) and the project location (e.g., C:\microchip), and click

Finish.
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Figure 6-5. Project Name and Location Selection Window

7. Create a new main.c file by clicking File → New File... or by using Ctrl+N shortcut, as shown in Figure 6-6.
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Figure 6-6. Create a New File in MPLAB® X

8. Select the Categories → C and File Types → C Main File template from Figure 6-7, and click Next.

 AN3456
MPLAB® X Users Getting Started

© 2021 Microchip Technology Inc.  Application Note DS00003456B-page 19



Figure 6-7. New File Window

9. Type in the name of the file (e.g., main) and click Finish.
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Figure 6-8. File Name Window

10. Replace the main.c file with the following code snippet:

int main (void)
{
  /* Configure SW0 as input */
  PORTC.DIRCLR = PIN4_bm;
  /*Enable internal pull up for SW0*/
  PORTC.PIN4CTRL  = PORT_PULLUPEN_bm; 
  /* Configure LED0 pin as output */
  PORTB.DIRSET = PIN7_bm;
    
  while (1)
  {
    /* Check the status of SW0 */
    /* 0: Pressed */
    if (!(PORTC.IN & (PIN4_bm)))
    {
      /* LED0  off */
      PORTB.OUTSET = PIN7_bm;
    }
    /* 1: Released */
    else
    {
      /* LED0 on */
      PORTB.OUTCLR = PIN7_bm;
    }
  }
}

Add #inlude<avr/io.h> in main.c. In the code editor, the code will appear as shown in Figure 6-9.
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Figure 6-9. Code Editor Window

11. Build the code by clicking on Production → Clean and Build Main Project or by using the Shift + F11
shortcut.

12. Program ATtiny1627 with the project code and start debugging by clicking Debug → Debugging Main
Project.

13. Verify that LED0 is lit when SW0 is pushed on the ATtiny1627 Curiosity Nano.

 AN3456
MPLAB® X Users Getting Started

© 2021 Microchip Technology Inc.  Application Note DS00003456B-page 22



7. Additional Tool Support
Figure 7-1. STK600 Starter Kit

Table 7-1. STK600 Device Support for tinyAVR® 2 Family

Device Routing Card Socket Card

ATtiny1624 STK600-RC020T-104 STK600-SOIC

ATtiny1626 STK600-RC020T-104 STK600-SOIC

ATtiny1627 STK600-RC024T-103 STK600-QFN24

For device support for other devices, refer to: onlinedocs.microchip.com

Get the kit: https://www.microchipdirect.com/product/ATSTK600

Web page: http://www.microchip.com/ATSTK600

• Document/file:
– STK600 AVR Flash MCU Starter Kit User's Guide (.pdf)

The STK600 AVR Flash MCU Starter Kit User's Guide describes how to power the kit and includes detailed
information about board components, extension interface, and the hardware description.
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8. What's Next
For further information on related AVR products and IDE, refer to the links below:

Software:
• Microchip Studio
• Microchip Studio help: Help → View Help (shortcut CTRL+F1)
• Microchip Gallery
• MPLAB X
• IAR Embedded Workbench for AVR: Go to www.iar.com, search for "AVR".

Firmware:
• Atmel START documentation
• Atmel START examples
• GitHub examples

Hardware:
• AN2519: AVR Microcontroller Hardware Design Considerations
• AVR IBIS files
• AVR BDSL files

Recommended Programming/Debugging Tools:
• Atmel-ICE:

– User Guide
– Buy

• Power Debugger:
– User Guide
– Buy

• MPALB Snap:
– Buy

• MPLAB PICkit® 4:
– Buy

Other:
• AVR Freaks®: www.avrfreaks.net/
• Application notes:

www.microchip.com/en-us/products/microcontrollers-and-microprocessors/8-bit-mcus/avr-mcus

Find the preferred device and go to the product page. All relevant application notes can be found under the
documentation tab.

• AVR product selector:
www.microchip.com/en-us/products/microcontrollers-and-microprocessors/8-bit-mcus/avr-mcus

• More online technical documentation concerning various products: onlinedocs.microchip.com/
• Microchip Technical Support: microchipsupport.force.com/s/
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9. Revision History
Doc. Rev. Date Comments

B 06/2021 Added topic: Additional Tool Support. Replaced Atmel Studio to Microchip
Studio

A 07/2020 Initial document release
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The Microchip Website

Microchip provides online support via our website at www.microchip.com/. This website is used to make files and
information easily available to customers. Some of the content available includes:

• Product Support – Data sheets and errata, application notes and sample programs, design resources, user’s
guides and hardware support documents, latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical support requests, online
discussion groups, Microchip design partner program member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip press releases, listing of
seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service

Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will
receive email notification whenever there are changes, updates, revisions or errata related to a specified product
family or development tool of interest.

To register, go to www.microchip.com/pcn and follow the registration instructions.

Customer Support

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Embedded Solutions Engineer (ESE)
• Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to
help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: www.microchip.com/support

Microchip Devices Code Protection Feature

Note the following details of the code protection feature on Microchip devices:

• Microchip products meet the specifications contained in their particular Microchip Data Sheet.
• Microchip believes that its family of products is secure when used in the intended manner and under normal

conditions.
• There are dishonest and possibly illegal methods being used in attempts to breach the code protection features

of the Microchip devices. We believe that these methods require using the Microchip products in a manner
outside the operating specifications contained in Microchip’s Data Sheets. Attempts to breach these code
protection features, most likely, cannot be accomplished without violating Microchip’s intellectual property rights.

• Microchip is willing to work with any customer who is concerned about the integrity of its code.
• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of its code. Code

protection does not mean that we are guaranteeing the product is “unbreakable.” Code protection is constantly
evolving. We at Microchip are committed to continuously improving the code protection features of our products.
Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act.
If such acts allow unauthorized access to your software or other copyrighted work, you may have a right to sue
for relief under that Act.

 AN3456

© 2021 Microchip Technology Inc.  Application Note DS00003456B-page 26

http://www.microchip.com/
http://www.microchip.com/pcn
http://www.microchip.com/support


Legal Notice

Information contained in this publication is provided for the sole purpose of designing with and using Microchip
products. Information regarding device applications and the like is provided only for your convenience and may be
superseded by updates. It is your responsibility to ensure that your application meets with your specifications.

THIS INFORMATION IS PROVIDED BY MICROCHIP “AS IS”. MICROCHIP MAKES NO REPRESENTATIONS
OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY
OR OTHERWISE, RELATED TO THE INFORMATION INCLUDING BUT NOT LIMITED TO ANY IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY, AND FITNESS FOR A PARTICULAR PURPOSE
OR WARRANTIES RELATED TO ITS CONDITION, QUALITY, OR PERFORMANCE.

IN NO EVENT WILL MICROCHIP BE LIABLE FOR ANY INDIRECT, SPECIAL, PUNITIVE, INCIDENTAL OR
CONSEQUENTIAL LOSS, DAMAGE, COST OR EXPENSE OF ANY KIND WHATSOEVER RELATED TO THE
INFORMATION OR ITS USE, HOWEVER CAUSED, EVEN IF MICROCHIP HAS BEEN ADVISED OF THE
POSSIBILITY OR THE DAMAGES ARE FORESEEABLE. TO THE FULLEST EXTENT ALLOWED BY LAW,
MICROCHIP'S TOTAL LIABILITY ON ALL CLAIMS IN ANY WAY RELATED TO THE INFORMATION OR ITS USE
WILL NOT EXCEED THE AMOUNT OF FEES, IF ANY, THAT YOU HAVE PAID DIRECTLY TO MICROCHIP FOR
THE INFORMATION. Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk,
and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages, claims, suits, or
expenses resulting from such use. No licenses are conveyed, implicitly or otherwise, under any Microchip intellectual
property rights unless otherwise stated.

Trademarks

The Microchip name and logo, the Microchip logo, Adaptec, AnyRate, AVR, AVR logo, AVR Freaks, BesTime,
BitCloud, chipKIT, chipKIT logo, CryptoMemory, CryptoRF, dsPIC, FlashFlex, flexPWR, HELDO, IGLOO, JukeBlox,
KeeLoq, Kleer, LANCheck, LinkMD, maXStylus, maXTouch, MediaLB, megaAVR, Microsemi, Microsemi logo,
MOST, MOST logo, MPLAB, OptoLyzer, PackeTime, PIC, picoPower, PICSTART, PIC32 logo, PolarFire, Prochip
Designer, QTouch, SAM-BA, SenGenuity, SpyNIC, SST, SST Logo, SuperFlash, Symmetricom, SyncServer,
Tachyon, TimeSource, tinyAVR, UNI/O, Vectron, and XMEGA are registered trademarks of Microchip Technology
Incorporated in the U.S.A. and other countries.

AgileSwitch, APT, ClockWorks, The Embedded Control Solutions Company, EtherSynch, FlashTec, Hyper Speed
Control, HyperLight Load, IntelliMOS, Libero, motorBench, mTouch, Powermite 3, Precision Edge, ProASIC,
ProASIC Plus, ProASIC Plus logo, Quiet-Wire, SmartFusion, SyncWorld, Temux, TimeCesium, TimeHub, TimePictra,
TimeProvider, WinPath, and ZL are registered trademarks of Microchip Technology Incorporated in the U.S.A.

Adjacent Key Suppression, AKS, Analog-for-the-Digital Age, Any Capacitor, AnyIn, AnyOut, Augmented Switching,
BlueSky, BodyCom, CodeGuard, CryptoAuthentication, CryptoAutomotive, CryptoCompanion, CryptoController,
dsPICDEM, dsPICDEM.net, Dynamic Average Matching, DAM, ECAN, Espresso T1S, EtherGREEN, IdealBridge,
In-Circuit Serial Programming, ICSP, INICnet, Intelligent Paralleling, Inter-Chip Connectivity, JitterBlocker, maxCrypto,
maxView, memBrain, Mindi, MiWi, MPASM, MPF, MPLAB Certified logo, MPLIB, MPLINK, MultiTRAK, NetDetach,
Omniscient Code Generation, PICDEM, PICDEM.net, PICkit, PICtail, PowerSmart, PureSilicon, QMatrix, REAL ICE,
Ripple Blocker, RTAX, RTG4, SAM-ICE, Serial Quad I/O, simpleMAP, SimpliPHY, SmartBuffer, SMART-I.S., storClad,
SQI, SuperSwitcher, SuperSwitcher II, Switchtec, SynchroPHY, Total Endurance, TSHARC, USBCheck, VariSense,
VectorBlox, VeriPHY, ViewSpan, WiperLock, XpressConnect, and ZENA are trademarks of Microchip Technology
Incorporated in the U.S.A. and other countries.

SQTP is a service mark of Microchip Technology Incorporated in the U.S.A.

The Adaptec logo, Frequency on Demand, Silicon Storage Technology, and Symmcom are registered trademarks of
Microchip Technology Inc. in other countries.

GestIC is a registered trademark of Microchip Technology Germany II GmbH & Co. KG, a subsidiary of Microchip
Technology Inc., in other countries.

All other trademarks mentioned herein are property of their respective companies.
© 2021, Microchip Technology Incorporated, Printed in the U.S.A., All Rights Reserved.
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Quality Management System
For information regarding Microchip’s Quality Management Systems, please visit www.microchip.com/quality.
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