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Copyrights

© Cypress Semiconductor Corporation, 2017. This document is the property of Cypress Semiconductor Corporation and its
subsidiaries, including Spansion LLC (“Cypress”). This document, including any software or firmware included or referenced
in this document (“Software”), is owned by Cypress under the intellectual property laws and treaties of the United States and
other countries worldwide. Cypress reserves all rights under such laws and treaties and does not, except as specifically
stated in this paragraph, grant any license under its patents, copyrights, trademarks, or other intellectual property rights. If the
Software is not accompanied by a license agreement and you do not otherwise have a written agreement with Cypress
governing the use of the Software, then Cypress hereby grants you a personal, non-exclusive, nontransferable license
(without the right to sublicense) (1) under its copyright rights in the Software (a) for Software provided in source code form, to
modify and reproduce the Software solely for use with Cypress hardware products, only internally within your organization,
and (b) to distribute the Software in binary code form externally to end users (either directly or indirectly through resellers and
distributors), solely for use on Cypress hardware product units, and (2) under those claims of Cypress’s patents that are
infringed by the Software (as provided by Cypress, unmodified) to make, use, distribute, and import the Software solely for
use with Cypress hardware products. Any other use, reproduction, modification, translation, or compilation of the Software is
prohibited.

TO THE EXTENT PERMITTED BY APPLICABLE LAW, CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, WITH REGARD TO THIS DOCUMENT OR ANY SOFTWARE OR ACCOMPANYING HARDWARE, INCLUDING,
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE. To the extent permitted by applicable law, Cypress reserves the right to make changes to this document without
further notice. Cypress does not assume any liability arising out of the application or use of any product or circuit described in
this document.  Any information provided in this document, including any sample design information or programming code, is
provided only for reference purposes.  It is the responsibility of the user of this document to properly design, program, and test
the functionality and safety of any application made of this information and any resulting product. Cypress products are not
designed, intended, or authorized for use as critical components in systems designed or intended for the operation of
weapons, weapons systems, nuclear installations, life-support devices or systems, other medical devices or systems
(including resuscitation equipment and surgical implants), pollution control or hazardous substances management, or other
uses where the failure of the device or system could cause personal injury, death, or property damage (“Unintended Uses”).
A critical component is any component of a device or system whose failure to perform can be reasonably expected to cause
the failure of the device or system, or to affect its safety or effectiveness.  Cypress is not liable, in whole or in part, and you
shall and hereby do release Cypress from any claim, damage, or other liability arising from or related to all Unintended Uses
of Cypress products.  You shall indemnify and hold Cypress harmless from and against all claims, costs, damages, and other
liabilities, including claims for personal injury or death, arising from or related to any Unintended Uses of Cypress products.

Cypress, the Cypress logo, Spansion, the Spansion logo, and combinations thereof, WICED, PSoC, CapSense, EZ-USB, 
F-RAM, and Traveo are trademarks or registered trademarks of Cypress in the United States and other countries. For a more
complete list of Cypress trademarks, visit cypress.com. Other names and brands may be claimed as property of their respec-
tive owners. 
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Safety Information

Regulatory Compliance

The CY8CKIT-149 PSoC 4100S Plus Prototyping Kit is intended for use as a development platform
for hardware or software in a laboratory environment. The board is an open system design, which
does not include a shielded enclosure. This may cause interference to other electrical or electronic
devices in close proximity. In a domestic environment, this product may cause radio interference. In
such cases, you may be required to take adequate preventive measures. In addition, this board
should not be used near any medical equipment or RF devices.

Attaching additional wiring to this product or modifying the product operation from the factory default
settings may affect its performance and cause interference with other apparatus in the immediate
vicinity. If such interference is detected, suitable mitigating measures should be taken.

The PSoC 4100S Plus Prototyping Kit, as shipped from the
factory, has been verified to meet with requirements of CE as a
Class A product.

The CY8CKIT-149 PSoC 4100S Plus Prototyping Kit contains
electrostatic discharge (ESD) sensitive devices. Electrostatic charges
readily accumulate on the human body and any equipment, and can
discharge without detection. Permanent damage may occur on devices
subjected to high-energy discharges. Proper ESD precautions are
recommended to avoid performance degradation or loss of functionality.
Store unused CY8CKIT-149 PSoC 4100S Plus Prototyping Kit boards in
the protective shipping package.

End-of-Life/Product Recycling

This kit has an end-of life five years from the date of manufacture
mentioned on the back of the box. Contact your nearest recycler for
discarding the kit.
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Safety Information

General Safety Instructions

ESD Protection

ESD can damage boards and associated components. Cypress recommends that you perform
procedures only at an ESD workstation. If such a workstation is not available, use appropriate ESD
protection by wearing an anti-static wrist strap attached to the chassis ground (any unpainted metal
surface) on your board when handling parts.

Handling Boards

The CY8CKIT-149 PSoC 4100S Plus Prototyping Kit board is sensitive to ESD. Hold the board only 
by its edges. After removing the board from its box, place it on a grounded, static-free surface. Use a 
conductive foam pad if available. Do not slide board over any surface.
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1. Introduction

Thank you for your interest in the CY8CKIT-149 PSoC 4100S Plus Prototyping Kit. The PSoC 4100S
Plus Prototyping Kit is designed as an easy-to-use and inexpensive prototyping platform. The
PSoC 4100S Plus Prototyping Kit supports the PSoC 4100S Plus device, delivering a complete
system solution for a wide range of embedded applications at a very low cost. The PSoC 4100S Plus
device is a true programmable embedded system-on chip, integrating custom digital peripheral

functions, memory, and an ARM® Cortex®-M0+ MCU on a single chip with flexible automatic routing.
The programmable digital peripheral functions allow higher flexibility, in-field tuning of the design,
and faster time-to-market. It is a combination of MCU with standard communication and timing
peripherals, and a capacitive touch sensing system with best in class performance.

The PSoC 4100S Plus Prototyping Kit offers an open footprint breakout board to maximize the end-
utility of the PSoC 4100S Plus device. This kit provides a low-cost alternative to device samples
while providing a platform to easily develop and integrate the PSoC 4100S Plus device into your
end-system. In addition, the board includes the following features:

■ Two LEDs to provide feedback (One each for 4100S Plus device and EZ-BLE device) 

■ A push button to provide a simple user input 

■ Three CapSense buttons of different sizes with feedback LEDs

■ Six segment slider with feedback LEDs

■ EZ-BLE Module with feedback LED

■ External ECO crystal (4 MHz)

■ External WCO crystal (32.768 kHz)

■ 1.8 V to 5 V operation

The CY8CKIT-149 PSoC 4100S Plus prototyping kit also integrates Cypress KitProg2 that enables
onboard programming, debugging, and bridging functionalities, such as USB-UART and USB-I2C.
KitProg2 is used to program and debug the target PSoC 4100S Plus device and EZ-BLE Module
(see Figure 1-1). The prototyping kit allows you to separate the KitProg2 board from the target
PSoC 4100S Plus board.
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1.1 Kit Contents

The PSoC 4100S Plus Prototyping Kit contains a PSoC 4100S Plus Prototyping board and Quick
Start Guide. 

Figure 1-1.  CY8CKIT-149 PSoC 4100S Plus Prototyping Kit
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1.2 PSoC Creator

PSoC Creator™ is a state-of-the-art, easy-to-use integrated design environment (IDE). It introduces
revolutionary hardware and software co-design, powered by a library of pre-verified and pre-
characterized PSoC Components. With PSoC Creator, you can:

1. Drag and drop Components to build your hardware system design in the main design workspace.

2. Co-design your application firmware with the PSoC hardware.

3. Configure Components using configuration tools.

4. Explore the library of 100+ Components.

5. Review Component datasheets.

Figure 1-2.  PSoC Creator Features

PSoC Creator also enables you to tap into an entire tool ecosystem with integrated compiler chains
and programmers for PSoC devices.

For more information, visit www.cypress.com/psoccreator. Visit the PSoC Creator Video Training
Page for video tutorials on learning and using PSoC Creator.

 

www.cypress.com/psoccreator
http://www.cypress.com/?rID=40547
http://www.cypress.com/?rID=40547
http://www.cypress.com/?rID=40547
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1.2.1 PSoC Creator Code Examples

PSoC Creator includes a large number of code examples. These examples are available from the
PSoC Creator Start Page, as shown in Figure 1-3 or from the menu File > Code Example....

Code examples can speed up your design process by starting you off with a complete design,
instead of a blank page. The code examples also show how PSoC Creator Components can be
used for various applications. Code examples and documentation are included, as shown in
Figure 1-4 on page 11.

From the Find Code Example dialog shown in Figure 1-4 on page 11, you can

■ Filter for examples based on architecture or device family, that is, PSoC 3, PSoC 4, or PSoC 5LP, 
project name, or keyword

■ Select from the list of examples offered based on the Filter Options

■ Review the code example’s description (on the Documentation tab)

■ Review the code from the Sample Code tab. You can copy the code from this window and paste 
to your project, which can help speed up code development

■ Create a new project (and a new workspace if needed) based on the selection. This can speed 
up your design process by starting you off with a complete, basic design. You can then adapt that 
design to your application.

Figure 1-3.  Code Examples in PSoC Creator
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Figure 1-4.  Code Example Projects with Sample Code

1.2.2 Kit Code Examples

You can access the installed kit code examples from the PSoC Creator Start Page. To access these
examples, expand Kits under Start; then, expand the specific kit to see the code examples. For a list
of code examples that you can use on this kit, see the Code Examples chapter on page 26.

1.2.3 PSoC Creator Help

Launch PSoC Creator and navigate to the following items:

■ Quick Start Guide: Choose Help > Documentation > Quick Start Guide. This guide gives you 
the basics for developing PSoC Creator projects.

■ Simple Component Code Examples: Choose File > Code Example. These examples demon-
strate how to configure and use PSoC Creator Components. To access examples related to a 
specific Component, right-click the Component in the schematic or in the Component Catalog. 
Select Find Code Example in the context menu that appears.

■ System Reference Guide: Choose Help > System Reference Guides. This guide lists and 
describes the system functions provided by PSoC Creator.
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1.2.4 Component Datasheets

Right-click a Component and select Open Datasheet (see Figure 1-5).

Figure 1-5.  Opening Component Datasheet

1.3 Getting Started

This guide will help you get acquainted with the PSoC 4100S Plus Prototyping Kit:

■ The Software Installation chapter on page 16 describes the installation of the kit software. This 
includes installation of the PSoC Creator IDE for development and debugging the applications, 
and PSoC Programmer for programming hex files.

■ The Kit Operation chapter on page 20 describes the major features of the PSoC 4100S Plus Pro-
totyping Kit and functionalities such as programming, debugging, and the USB-UART and USB-
I2C bridges.

■ The Code Examples chapter on page 26 describes multiple code examples that will help you 
understand how to create your own PSoC 4100S Plus projects.

■ The Appendix chapter on page 32 describes the hardware content of the kit and the hardware 
operation, details about programming the kit using MiniProg3, Kit Schematics, and the bill of 
materials (BOM).
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1.4 Additional Learning Resources

Cypress provides a wealth of data at www.cypress.com to help you to select the right PSoC device
for your design, and to help you to quickly and effectively integrate the device into your design. For a
comprehensive list of resources, see KBA86521, How to Design with PSoC 3, PSoC 4, and
PSoC 5LP. The following is an abbreviated list for PSoC 4:

■ Overview: PSoC Portfolio and PSoC Roadmap.

■ Product Selectors: PSoC 4 Product Selector. In addition, PSoC Creator includes a device 
selection tool.

■ Datasheets: Describe and provide electrical specifications for the PSoC 4000, PSoC 4100, 
PSoC 4200, PSoC 4100M, PSoC 4200M, PSoC 4200L, and PSoC 4100S Plus devices.

■ CapSense Design Guide: Learn how to design capacitive touch-sensing applications with the 
PSoC 4 and PSoC Analog Coprocessor family of devices.

■ Application Notes and Code Examples: Cover a broad range of topics, from basic to advanced. 
Many of the application notes include code examples. Visit the PSoC 3/4/5 Code Examples web 
page for a list of all available PSoC Creator code examples. To access code examples from 
within PSoC Creator, see PSoC Creator Code Examples on page 10.

■ Technical Reference Manuals (TRM): Provide detailed descriptions of the architecture and 
registers in each PSoC 4 device family.

■ Development Kits:

❐ CY8CKIT-041, CY8CKIT-046, CY8CKIT-044, CY8CKIT-042, and CY8CKIT-040 are easy-to-
use and inexpensive development platforms. These kits include connectors for Arduino™ 
compatible shields and Digilent Pmod Peripheral Modules.

❐ CY8CKIT-043, CY8CKIT-049,  CY8CKIT-145, CY8CKIT-146, CY8CKIT-149, are very low-cost 
prototyping platforms for sampling PSoC 4 devices.

❐ CY8CKIT-001 is a common development platform for all PSoC family devices.

❐ The MiniProg3 device provides an interface for flash programming and debug.

■ Knowledge Base Articles (KBA): Provide design and application tips from experts on using the 
device. 

■ PSoC Creator Training: Visit www.cypress.com/go/creatorstart/creatortraining for a 
comprehensive list of video training on PSoC Creator.

■ Learning from Peers: Visit community.cypress.com/welcome to meet enthusiastic PSoC develop-
ers discussing the next-generation embedded systems on Cypress Developer Community 
Forums.

1.5 Technical Support

For assistance, visit Cypress Support or contact customer support at +1 (800) 541-4736 Ext. 3 (in
the USA) or +1 (408) 943-2600 Ext. 3 (International).

You can also use the following support resources if you need quick assistance:

■ Self-help (Technical Documents).

■ Local Sales Office Locations.

http://www.cypress.com/
http://www.cypress.com/?id=4&rID=77024
http://www.cypress.com/?id=4&rID=77024
http://www.cypress.com/?id=4&rID=77024
http://www.cypress.com/?id=4&rID=77024
http://www.cypress.com/psoc
http://www.cypress.com/?rID=86788
http://www.cypress.com/?id=4976
http://www.cypress.com/psoccreator
http://www.cypress.com/documentation/datasheets/psoc-4-psoc-4000-family-datasheet-programmable-system-chip-psoc
http://www.cypress.com/documentation/datasheets/psoc-4-psoc-4100-family-datasheet-programmable-system-chip-psoc
http://www.cypress.com/documentation/datasheets/psoc-4-psoc-4200-family-datasheet-programmable-system-chip-psoc
www.cypress.com/documentation/datasheets/psoc-4-psoc-4100m-family-datasheet
www.cypress.com/documentation/datasheets/psoc-4-psoc-4200m-family-datasheet
www.cypress.com/documentation/datasheets/psoc-4-psoc-4200l-family-datasheet
www.cypress.com/psoc4100splusdatasheet
http://www.cypress.com/?rID=78578&source=an79953
http://www.cypress.com/search/all?f[0]=meta_type%3Atechnical_documents&f[1]=resource_meta_type%3A574&f[2]=field_related_products%3A1297
http://www.cypress.com/search/all?f[0]=meta_type%3Asoftware_tools&f[1]=field_related_products%3A1297&f[2]=software_tools_meta_type%3A579
http://www.cypress.com/?rID=101641
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=117&id=4749&applicationID=0&l=0
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=110&id=4749&applicationID=0&l=0
http://www.cypress.com/CY8CKIT-041
http://www.cypress.com/CY8CKIT-046
http://www.cypress.com/CY8CKIT-044
http://www.cypress.com/cy8ckit-042
http://www.cypress.com/CY8CKIT-040
http://www.cypress.com/CY8CKIT-043
http://www.cypress.com/CY8CKIT-049
http://www.cypress.com/CY8CKIT-145
www.cypress.com/CY8CKIT-146
www.cypress.com/CY8CKIT-149
http://www.cypress.com/go/CY8CKIT-001
http://www.cypress.com/go/cy8ckit-002
https://community.cypress.com/community/knowledge-base-articles
http://www.cypress.com/go/creatorstart/creatortraining
https://community.cypress.com/welcome
http://www.cypress.com/support
http://www.cypress.com/search/all?f%5b0%5d=meta_type%3Atechnical_documents
http://www.cypress.com/?id=1062
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1.6 Document Conventions

Table 1-1.  Document Conventions for Guides

Convention Usage

Courier New Displays file locations, user entered text, and source code:
C:\...cd\icc\

Italics Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Creator User Guide.

[Bracketed, Bold] Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open Represents menu paths:
File > Open > New Project

Bold Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman Displays an equation:
2 + 2 = 4

Text in gray boxes Describes Cautions or unique functionality of the product.



CY8CKIT-149 PSoC® 4100S Plus Prototyping Kit Guide, Doc. #: 002-20729 Rev. *E 15

Introduction

1.7 Acronyms

Table 1-2.  Acronyms Used in this Document

Acronym Description

ADC Analog-to-Digital Converter

BCP Bridge Control Panel

BLE Bluetooth Low Energy

BOM Bill of Materials

CE Code Example

CMOD Modulator Capacitor

CMP Comparator

CTANK Shield tank capacitor

DAC Digital to Analog Converter

DPDT Double-Pole, Double-Throw

ECO External Crystal Oscillator

ESD Electrostatic Discharge

GPIO General Purpose Input/Output

I2C Inter-Integrated Circuit

IDAC Current DAC

IDE Integrated Design Environment

KBA Knowledge Based Article

LED Light-Emitting Diode

PSoC Programmable Systems-on-Chip

SAR Successive Approximation Register

SCB Serial Communication Block

SRAM Static Random Access Memory

SWD Serial Wire Debug

TCPWM Timer, Counter, Pulse Width Modulator

UART Universal Asynchronous Receiver Transmitter

USB Universal Serial Bus

WCO Watch Crystal Oscillator
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2. Software Installation

This chapter describes the steps to install the software tools and packages on a PC for using the
PSoC 4100S Plus Prototyping Kit. This includes the IDE on which the projects will be built and used
for programming.

2.1 Before You Begin

To install Cypress software, you will require administrator privileges. However, they are not required
to run the software that is already installed. Before you install the kit software, close any other
Cypress software that is currently running.

2.2 Install Software

Follow these steps to install the PSoC 4100S Plus Prototyping kit software:

1. Download the PSoC 4100S Plus Prototyping kit software from www.cypress.com/CY8CKIT-149. 
The kit software is available in three formats for download.

a. CY8CKIT-149 Kit Only: This executable file installs only the kit contents, which include kit 
code examples, hardware files, and user documents. This package can be used if all the 
software prerequisites (listed in step 5) are installed on your PC.

b. CY8CKIT-149 Kit Setup: This installation package contains the files related to the kit 
including PSoC Creator and PSoC Programmer. However, it does not include the Windows 
Installer or Microsoft .NET framework packages. If these packages are not on your PC the 
installer will direct you to download and install them from the Internet.

c. CY8CKIT-149 DVD ISO: This file is a complete package stored in a DVD-ROM image format 
that you can use to create a DVD or extract using an ISO extraction program such as WinZip 
or WinRAR. The file can also be mounted like a virtual CD/DVD using virtual drive programs 
such as Virtual CloneDrive and MagicISO. This package includes all the required software, 
utilities, drivers, hardware files, and user documents.

2. If you have downloaded the ISO file, mount it in a virtual drive. Extract the ISO contents if you do 
not have a virtual drive to mount. Double-click cyautorun.exe in the root directory of the extracted 
content or mounted ISO if “Autorun from CD/DVD” is not enabled on the PC. The installation 
window will appear automatically. 
Note: If you are using the Kit Setup or Kit Only file, then go to step 4 for installation.

www.cypress.com/CY8CKIT-149
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3. Click Install CY8CKIT-149 Kit to start the kit installation as shown in Figure 2-1.

Figure 2-1.  Kit Installer Screen

4. Select the directory in which you want to install the PSoC 4100S Plus Prototyping Kit-related 
files. Choose the directory and click Next.

5. When you click Next, the PSoC 4100S Plus Prototyping kit installer automatically installs the 
required software, if it is not present on your PC. Following are the required software:

a. PSoC Creator 4.2 or later: This software is available for download separately at 
www.cypress.com/psoccreator.

b. PSoC Programmer 3.27 or later: This is installed as part of PSoC Creator installation 
(www.cypress.com/programmer).

www.cypress.com/psoccreator
www.cypress.com/programmer
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6. Choose the Typical, Custom, or Complete installation type in the Product Installation Overview 
window, as shown in Figure 2-2. Click Next after selecting the installation type.

Note: Typical installation is recommended, however you can choose according to your require-
ment.

Figure 2-2.  Product Installation Overview

7.  Read the License agreement and select I accept the terms in the license agreement to 
continue with the installation. Click Next. When the installation begins, a list of packages appears 
on the installation page. A green check mark appears next to each package after successful 
installation.

8. Enter your contact information or select the check box Continue Without Contact Information. 
Click Finish to complete the PSoC 4100S Plus Prototyping kit installation.

After the installation is complete, the kit contents are available at the following location:
<Install_Directory>\CY8CKIT-149 PSoC 4100S Plus Prototyping Kit

Default location:

Windows OS (64-bit):

C:\Program Files (x86)\Cypress\CY8CKIT-149 PSoC 4100S Plus Prototyping Kit

Windows OS (32-bit):

C:\Program Files\Cypress\CY8CKIT-149 PSoC 4100S Plus Prototyping Kit

Note: For Windows 7/8/8.1 and later users, the installed files and the folder are read-only. To use the
installer code examples, follow the steps outlined in the Code Examples chapter on page 26.



CY8CKIT-149 PSoC® 4100S Plus Prototyping Kit Guide, Doc. #: 002-20729 Rev. *E 19

Software Installation

2.3 Uninstall Software

The software can be uninstalled using one of the following methods:

1. Go to Start > All Programs > Cypress > Cypress Update Manager and select Uninstall.

2. Go to Start > Control Panel > Programs and Features for Windows 7 or Add/Remove 
Programs for Windows XP and select Uninstall/Change. 
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3. Kit Operation

This chapter introduces you to different features of the PSoC 4100S Plus Prototyping Kit. This pri-
marily includes the programming and debugging functionalities, KitProg2 USB-UART and 
USB-I2C bridges, and the procedure to update the KitProg2 firmware.

3.1 Theory of Operation

Figure 3-1 shows the block diagram for the PSoC 4100S Plus Prototyping Kit.

Figure 3-1.  Block Diagram of PSoC 4100S Plus Prototyping Kit

The PSoC 4100S Plus Prototyping Kit is simplistic in design and focuses on providing you with
complete access to develop applications using the PSoC 4100S Plus device. This kit supports the
following features: 

■ PSoC 4100S Plus I/O Headers: The PSoC 4100S Plus Prototyping board brings all GPIOs of 
the target PSoC 4100S Plus device to the two expansion headers. This provides maximum 
access to the capabilities of the PSoC 4100S Plus device.

■ User LEDs: The onboard LEDs, LED1 and LED4 can be used to display outputs from the 
PSoC 4100S Plus device and EZ-BLE Module respectively. This includes modulating the bright-
ness of the LED to notify different states of the device. 

■ User Button: This kit has a push button, which can be used to provide an input to the 
PSoC 4100S Plus device. 
Note: The switch connects the PSoC 4100S Plus device pin (P3.7) to ground when pressed. 
Therefore, you need to configure the PSoC 4100S Plus device pin as ‘resistive pull-up’ for detect-
ing the switch press.

■ Six Segment CapSense Slider with Feedback LEDs: A six-segment CapSense Slider is pro-
vided in the snappable area of the kit. To evaluate the slider, six green LEDs are provided for 
feedback in the snappable area of the kit. The slider can perform in both Mutual Capacitance and 
Self Capacitance modes. 

Plus
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■ Three CapSense Buttons with User LEDs: Three CapSense buttons of different sizes are pro-
vided with this kit in the snappable area. To evaluate the buttons, three green LEDs are provided 
for feedback in the snappable area of the kit. These buttons can perform in both Self Capacitance 
and Mutual Capacitance modes.

■ EZ-BLE Module with User LED: EZ-BLE Module from Cypress is loaded on this kit with blue 
User LED connected to one of its GPIO. Using this module, you can work on various Bluetooth 
Low Energy (BLE) applications.

■ ECO Crystal: A 4-MHz crystal is loaded onboard for precision clock applications.

■ WCO Crystal: A 32.768-kHz crystal footprint is provided which can be loaded for precision clock 
applications.

■ Reset Button: This button is used to reset the PSoC 4100S Plus device when pressed.

■ Power LED: This LED indicates power is being supplied to the board. 

■ PSoC 4100S Plus Device: This is the target device (CY8C4147AZI-S475) on the board.

■ 5-pin Programming Headers: These are external programming headers that can be used to 
program the PSoC 4100S Plus device using a MiniProg3. Typically this connection is not 
required since the kit contains an integrated KitProg2.

■ PSoC 5LP IO Headers: Using these headers, you can evaluate the PSoC 5LP 
(CY8C5868LTI-LP039) device. The PSoC 5LP is used to implement the KitProg2 functionality by 
default.

■ Current Measurement Jumper: Using this jumper, you can measure the current consumed by 
the PSoC 4100S Plus device. This jumper is not populated by default. To use this jumper, you 
must remove the zero ohm resistor R53.

■ USB 2.0 Micro-B Connector: Using this USB Micro-B connector (J8), you can connect the kit to 
a PC using USB 2.0 Type-A to Micro-B Cable.

■ KitProg2: This is an onboard programmer/debugger utilizing a PSoC 5LP 
(CY8C5868LTI-LP039), which enables you to program and debug the target PSoC 4100S Plus 
device. It can also act as a USB-UART and UART-I2C bridge.
When used as a standalone module, KitProg2 can be used to program devices of PSoC 3, 
PSoC 4, or PSoC 5LP families through the SWD interface. For more details on the KitProg2 func-
tionality, see the KitProg2 User Guide.

■ KitProg2 Mode Selection Button: This button is used to switch between the KitProg2 modes as 
shown in Table 3-1. You can also use this button to provide an input to the PSoC 5LP in custom 
applications. Note that the switch connects the PSoC 5LP pin to ground when pressed. For more 
details, see the KitProg2 User Guide. 

■ KitProg2 Status LED: This LED gives the programming/mode status of KitProg2.

*Note: Toggling between programming modes can be done by pressing mode switch SW3. 

Table 3-1.  KitProg2 Mode Switching

KitProg2 Programming Modes * Status LED (LED3)

KitProg2 Program/Debug Mode (PPCOM mode) (default) ON

CMSIS-DAP & Mass Storage Programming Mode OFF

http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
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3.2 Programming and Debugging the Target PSoC 4100S Plus Device

The target PSoC 4100S Plus device can be programmed and debugged using the KitProg2. Before
programming the device, make sure that PSoC Creator and PSoC Programmer software are
installed on the PC. See Install Software on page 16 for more information.

3.2.1 Programming Using PSoC Creator

1. Make sure SW4 is switched to PSoC side. Connect the prototyping board to the PC through the
USB Micro-B Connector (J8) as shown in Figure 3-2. The kit enumerates as a composite device.
If you are plugging in the PSoC 4100S Plus Prototyping Kit to your PC for the first time, the kit
drivers will get installed automatically. The amber status LED (LED3) will turn ON to indicate suc-
cessful enumeration. If the amber status LED (LED3) is OFF, see the KitProg2 User Guide for
details on the KitProg2 status and troubleshooting instructions.

Figure 3-2.  Connecting the PSoC 4100S Plus Prototyping Kit to a Computer

2. Open the desired project in PSoC Creator. From the PSoC Creator, go to File > Open > Project/
Workspace. You can browse and open a previously saved project. If you want to open one of the 
code examples provided with the kit, follow the instructions in the Code Examples chapter on 
page 26.

http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
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3. Select the option Build > Build <Project_Name> or press [Shift] [F6] to build the project as 
shown in Figure 3-3.

Figure 3-3.  Build a Code Example

4. If there are no errors during build, program the firmware onto the kit by choosing Debug > 
Program or press [Ctrl] [F5], as shown in Figure 3-4. This programs the target PSoC 4100S Plus 
device on the PSoC 4100S Plus Prototyping Kit, and the kit is ready to use.

Figure 3-4.  Program Device in PSoC Creator
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3.2.2 Debugging Using PSoC Creator

For debugging the project using PSoC Creator, follow steps 1–3 from Programming Using PSoC
Creator on page 22 followed by:

1. Click the Debug icon  or press [F5]. Alternatively, you can use the option Debug > Debug.

2. Once the PSoC Creator opens in Debug mode, use the buttons on the toolbar to debug your 
application. 

For more details on using the debug features, see section 3.3 of the KitProg2 User Guide.

3.2.3 Programming Using PSoC Programmer

PSoC Programmer (3.27.0 or later) can be used to program existing .hex files into the PSoC 4100S
Plus Prototyping Kit. For a detailed explanation on how to program using PSoC Programmer, see
the Programming Using PSoC Programmer section in the KitProg2 User Guide.

3.2.4 Mass Storage Programming

The KitProg2 in the CY8CKIT-149 PSoC 4100S Plus Prototyping Kit supports programming through
a USB Mass Storage interface. This interface allows you to program the PSoC 4100S Plus device by
copying .hex files into an emulated USB Mass Storage device. For more details on using KitProg2 as
a Mass Storage Programmer, see the KitProg2 User Guide.

Note: Mass Storage Programming is only supported in KitProg2 v1.05 and later for PSoC 4100S
Plus devices.

3.3 USB-UART Bridge

The KitProg2 on the PSoC 4100S Plus Prototyping Kit can act as a USB-UART bridge. The UART
lines between the KitProg2 and the target are hard-wired on the board, through the snappable area,
with UART_RX assigned to P7[0] and UART_TX assigned to P7[1] on target PSoC 4100S Plus
device. For more details on the KitProg2 USB-UART functionality, see the USB-UART Bridge sec-
tion in the KitProg2 User Guide.

Figure 3-5.  UART Connection between KitProg2, PSoC 4100S Plus Device, and EZ-BLE Module 

http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
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3.4 USB-I2C Bridge

The KitProg2 can function as a USB-I2C bridge and communicate with the software utility Bridge
Control Panel (BCP). The I2C lines on target PSoC 4100S Plus device are P3[1] (SDA) and P3[0]
(SCL), which are hardwired on the board to the I2C lines of the KitProg2. The USB-I2C supports I2C
speeds of 50 kHz, 100 kHz, 400 kHz, and 1 MHz. For more details on the KitProg2 USB-I2C
functionality, see the USB-I2C Bridge section in the KitProg2 User Guide.

Figure 3-6.  I2C Connection between KitProg2, PSoC 4100S Plus Device, and EZ-BLE Module 

3.5 Updating the KitProg2 Firmware

The KitProg2 firmware normally does not require any update. You can use the PSoC Programmer
software to update the KitProg2 firmware if necessary. For a detailed explanation on how to update
the KitProg2 firmware, see Updating the KitProg2 Firmware in the KitProg2 User Guide. 

http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
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4. Code Examples

This chapter explains the code examples provided along with the PSoC 4100S Plus Prototyping Kit.
To access these code examples, download and install the CY8CKIT-149 PSoC 4100S Plus
Prototyping Kit setup file from the kit web page: www.cypress.com/CY8CKIT-149. After installation,
you can access the code example from the PSoC Creator Start Page as shown in Figure 4-1.

4.1 Using the Kit Code Examples

Follow these steps to open and use the code examples.

1. Launch PSoC Creator from the Windows Start menu (Start > All Programs > Cypress > 
PSoC Creator <version> > PSoC Creator <version>).

2. On the Start page, select Start > Kits > CY8CKIT-149. A list of code example appears as shown 
in Figure 4-1.

3. Click the desired code example and save it at a desired location. For the remaining steps, 
CExxxx.cywrk is used as a reference.

Figure 4-1.  Open Code Example from PSoC Creator

4. Build the code example by choosing Build > Build <Project Name> as shown in Figure 4-2. A 
.hex file is generated after a successful build process.

Figure 4-2.  Build Code Example from PSoC Creator

www.cypress.com/CY8CKIT-059
www.cypress.com/CY8CKIT-149
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5. Make sure switch position of SW4 is on PSoC side.

6. Connect the PSoC 4100S Plus Prototyping kit to the PC using the KitProg2 USB Micro-B 
connector J8 as described in Programming Using PSoC Creator chapter on page 22 to program 
the kit with this code example. If you are connecting the kit to the PC for the first time, wait for 
driver installation to complete before proceeding to the next step.

7. Choose Debug > Program in PSoC Creator as shown in Figure 4-3.

Figure 4-3.  Program Device in PSoC Creator

8. If the device is already acquired, programming will complete automatically and the result will 
appear in the PSoC Creator status bar at the bottom left side of the screen. If the device is yet to 
be acquired, the Select Debug Target window will appear. Select KitProg2/<serial number> and 
click Port Acquire as shown in Figure 4-4. 

Figure 4-4.  Port Acquire
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9. After the device is acquired, it appears in the tree structure below the KitProg2/<serial num-
ber>. Click OK / Connect to exit the window and start programming as shown in Figure 4-5.

Figure 4-5.  Connect Device from PSoC Creator and Program

10.Code Example Operation: 
This code example demonstrates the operation of a CapSense linear slider with six segments 
and three CapSense buttons. Data from the CapSense linear slider and buttons is sent to the 

CapSense Tuner using I2C communication. The CapSense button status is used to turn ON/OFF 
the corresponding LEDs on the kit. The CapSense slider is used to tun ON the LEDs relative to 
the position of touch. This code example also demonstrates a simple breathing effect of the LED 
with breath-in and breath-out rate of 1 Hz using the SmartIO and PWM Components. 

11.To understand detailed operation of the code example, open CE220891 CapSense with Breath-
ing LED.pdf as shown in Figure 4-6.

Figure 4-6.  Project Datasheet - CE220891 CapSense with Breathing LED.pdf 
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4.2 Using Built-in PSoC Creator Code Examples with the Kit

Follow these steps to open and use the built-in PSoC Creator examples.

1. Launch PSoC Creator from Start > All Programs > Cypress > PSoC Creator<version> > 
PSoC Creator <version>.

2. On the Start page, click Find Code Example... under Start or follow the menu File > Code 
Example... as shown in Figure 4-7.

Figure 4-7.  PSoC Creator Find Code Example... 
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3. In the Find Code Example window, set the Device family to PSoC 4100S as shown in 
Figure 4-8.

Figure 4-8.  Selecting PSoC 4100S Device in Find Code Example Window 

4. You can select the CE220891 CapSense with Breathing LED project and see how to use it with 
the CY8CKIT-149 kit.

5. Select the CE220891 CapSense with Breathing LED project and click Create Project as shown 
in Figure 4-9. Save the workspace to a desired location. 
Note: The code example that appears in PSoC Creator with installer package is same as the 
code example which is extracted using these steps.

Figure 4-9.  CE220891 CapSense with Breathing LED Code Example
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6. Open CE220891 CapSense with Breathing LED.pdf from the Workspace Explorer to learn more 
about the code example and its configuration. See Figure 4-10.

Figure 4-10.  Project Datasheet: CExxxx
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A. Appendix

A.1 Board Details

The PSoC 4100S Plus Prototyping kit consists of the following blocks:

■ PSoC 4100S Plus device (CY8C4147AZI-S475) 

■ PSoC 4100S Plus I/O headers J1 and J2

■ KitProg2 (PSoC 5LP) device (CY8C5868LTI-LP039) 

■ KitProg2 I/O headers J6 and J7

■ SWD connection headers J4 and J5

■ USB 2.0 Micro-B connector J8

■ One amber LED, LED2 (Power)

■ One amber LED, LED3 (KitProg2 Status)

■ One blue LED, LED1 (User)

■ One blue LED, LED4 (EZ-BLE User)

■ Six Green LEDs (LED5, LED6, LED7, LED8, LED9, LED10) (CapSense Slider User)

■ Three Green LEDs (LED11, LED12, LED13) (CapSense Button User)

■ EZ-BLE Module

■ ECO Crystal (4 MHz)

■ WCO Crystal (32.768 kHz)

■ One Push Button SW1 (User)

■ One Push Button SW2 (Reset) 

■ One Push Button SW3 (KitProg2 Mode)

■ Current Measurement Jumper J3 (foot-print only) (shorted by zero ohm resistor R53)

■ Perforated ‘snappable’ board design
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Figure A-1.  PSoC 4100S Plus Prototyping Kit Pin Details
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A.2 Hardware Details

A.2.1 Target Board

The target board uses the PSoC 4100S Plus device. PSoC 4100S Plus is a scalable and
reconfigurable platform architecture for a family of programmable embedded system controllers with
an ARM Cortex-M0+ CPU. It combines programmable and reconfigurable digital blocks with flexible
automatic routing. The PSoC 4100S Plus device, based on this platform architecture, is a
combination of a MCU with digital programmable logic, programmable interconnect, and standard
communication and timing peripherals. The PSoC 4100S Plus will be fully compatible with members
of the PSoC 4 platform for new applications and design needs. The digital subsystems allow
flexibility and in-field tuning of the design. For more information, see the PSoC 4100S Plus webpage
and the PSoC 4100S Plus Datasheet.

Figure A-2.  Schematic of PSoC 4100S Plus Device (Target)

www.cypress.com/CY8CKIT-149
www.cypress.com/psoc4100splusdatasheet
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A.2.2 KitProg2 Board

A PSoC 5LP on the KitProg2 board is used to program and debug the target PSoC 4100S Plus
device. The KitProg2 PSoC 5LP connects to the USB port of the PC through the USB 2.0 Micro-B
connector and to the SWD interface of the target PSoC 4100S Plus device. 

Figure A-3.  Schematic of PSoC 5LP (KitProg2) 
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A.2.3 Power Supply System

The power supply system on this board is dependent on a power source for most applications, you
can use the 5 V supply from the USB connection to power the system. You can also connect an
external power supply to the board for low-voltage applications. The kit supports the following
connections:

■ 5 V from the KitProg2 USB (J8)

■ 1.8 V to 5.0 V from a regulated supply connected to VTARG or VDDD

Note: To use an external power supply with the KitProg2 also connected to the PC USB, first remove
diode D1 from the board. This ensures that the VTARG supply from KitProg2 is not supplied to the
target device. KitProg2 measures the target voltage and adjusts the logic levels on the programming
pins accordingly.

A.2.3.1 Measure PSoC 4100S Plus Device Current Consumption

Follow these steps to measure the current consumption of the PSoC 4100S Plus device:

1. Remove the resistor R53 and install a 2-pin jumper in the supplied holes of J3.

2. Connect an ammeter across the 2-pin jumper to measure the current to the PSoC 4100S Plus 
device.

This method can be used either with USB power or with the power supplied to one of the VTARG
pins but NOT when supplying power to one of the VDDD pins.

After measuring the current consumption, populate resistor R53 or place a shorting jumper across
the two jumper pins for normal operation of the kit.

Note: After removing R53, system may have some leakage power. Below are some of the probable
paths for leakage:

1. Communication circuitry between KitProg2 and Target (I2C, UART, SWDIO)

2. Inductive Beads for BLE power circuitry

3. Reset switch between KitProg2 and target device along with BLE device

To get rid of the leakage power completely, remove the 0 ohm connection and inductive beats.

Caution: It is important to understand that this prototyping kit does not
have any onboard ESD protection circuitry. Therefore, the power source
for the PSoC 4100S Plus Prototyping Kit must be of high quality to make
sure that the board is protected from any over-current conditions and
swapped-power connections.
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A.2.4 Board Separation (Snapping)

The PSoC 4100S Plus Prototyping Kit consists of a PSoC 4100S Plus and a KitProg2 board. To sep-
arate the two boards for evaluation or development, break the two boards apart at the built-in perfo-
rated edge between J4 and J5. 

The easiest method of separating the two boards is to place the kit on the edge of a table, where the
edge of the table is directly below the perforated edge and the smaller KitProg2 board is off the table
edge. Press gently on the KitProg2 board and snap the two boards apart. If any material is removed
from the edge of the boards, use sheers to clean up the edge of the kit. 

The CapSense Slider and buttons can also be snapped out and used for standalone applications. To
reconnect the snapped CapSense boards, you can connect Male Berg Strips on the header and con-
nect the central board with CapSense Board.

Figure A-4.  PSoC 4100S Plus Prototyping kit Broken into Four Parts 

Caution: Once the boards are separated, direct UART and I2C
connections between the PSoC 4100S Plus device and KitProg2 are
lost. This is because the traces connecting the UART and I2C lines are
cut off during the separation. However, you can access KitProg2’s UART

and I2C lines through header J6.
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A.2.5 Header Connections

The PSoC 4100S Plus Prototyping kit supports a number of unpopulated headers on both the Kit-
Prog2 and the target PSoC 4100S Plus boards.

A.2.5.1 Functionality of the J1 and J2 Headers (Target Board)

The target PSoC 4100S Plus board contains two single inline headers (J1 and J2). These headers
are both 1×30-pin headers and include all of the I/Os available on the PSoC 4100S Plus device.
These headers support all of the available ports, GND, VDDD, VDDA, and connections to passive
elements and user-input devices. 

The J1 and J2 headers support 100-mil spacing, so you can solder connectors to connect the target
board to a development breadboard.

Figure A-5.  J1 and J2 Headers 
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Table A-1.  J1 Header Pin Details Table A-2.  J2 Header Pin Details

PSoC 4100S Plus Prototyping kit GPIO Header 

Pin Signal Description

J1_01 GND Ground

J1_02 P3_5 GPIO

J1_03 P3_4 GPIO/User LED

J1_04 P3_3 GPIO/SWDCLK

J1_05 P3_2 GPIO/SWDIO

J1_06 P3_1 GPIO/I2C_SDA

J1_07 P3_0 GPIO/I2C_SCL

J1_08 P6_5 GPIO/SLD_5

J1_09 P6_4 GPIO/SLD_4

J1_10 P6_2 GPIO/SLD_3

J1_11 P6_1 GPIO/SLD_2

J1_12 P6_0 GPIO/SLD_1

J1_13 P2_7 GPIO/SLD_0

J1_14 P2_6 GPIO

J1_15 P2_5 GPIO/SLD_SHIELD

J1_16 P2_4 GPIO

J1_17 P2_3 GPIO

J1_18 P2_2 GPIO/LED_10

J1_19 P2_1 GPIO

J1_20 P2_0 GPIO/LED_9

J1_21 P1_7 GPIO/SAR Bypass

J1_22 P1_6 GPIO/LED_8

J1_23 P1_5 GPIO

J1_24 P1_4 GPIO/LED_7

J1_25 P1_3 GPIO

J1_26 P1_2 GPIO/LED_6

J1_27 P1_1 GPIO/SLD_TX

J1_28 P1_0 GPIO/LED_5

J1_29 RESET RESET

J1_30 VDDD POWER

PSoC 4100S Plus Prototyping kit GPIO Header 

Pin Signal Description

J2_01 VDDD POWER

J2_02 P3_6 GPIO

J2_03 P3_7 GPIO/User Switch

J2_04 P4_0 GPIO

J2_05 P4_1 GPIO

J2_06 P4_2 GPIO

J2_07 P4_3 GPIO

J2_08 P4_4 GPIO/BTN2_RX0

J2_09 P4_5 GPIO/BTN1_RX0

J2_10 P4_6 GPIO/BTN0_RX0

J2_11 P4_7 GPIO

J2_12 P5_6 GPIO

J2_13 P5_7 GPIO/LED_13

J2_14 P7_0 GPIO/UART_RX

J2_15 P7_1 GPIO/UART_TX

J2_16 P0_0 GPIO

J2_17 P0_1 GPIO/BTN_SHIELD

J2_18 P0_2 GPIO/BTN_TX

J2_19 P0_3 GPIO

J2_20 P0_4 GPIO/WCO_IN

J2_21 P0_5 GPIO/WCO_OUT

J2_22 P0_6 GPIO/ECO_IN

J2_23 P0_7 GPIO/ECO_OUT

J2_24 P5_0 GPIO/BLE RX

J2_25 P5_1 GPIO/BLE TX

J2_26 P5_2 GPIO/LED_11

J2_27 P5_3 GPIO

J2_28 P5_5 GPIO/LED_12

J2_29 GND GROUND

J2_30 VDDA POWER
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A.2.5.2 Functionality of J4 and J5 Headers (PSoC 4100S Plus to KitProg2)

The KitProg2 and target boards each contain a 1x5-pin header. These headers provide a physical
connection between the two devices. Specifically, the connection includes the SWD interface,
required to program/debug the target PSoC 4100S Plus device and EZ-BLE Module, power, ground,
and reset.

Figure A-6.  J4 and J5 Headers 

When the boards are separated, the KitProg2 board can be used to program any other PSoC 3,
PSoC 4, PSoC 5LP family of devices via J4.

Table A-3.  Pin Details of J4 Header Table A-4.  Pin Details of J5 Header

PSoC 5LP KitProg2 Header (J4)

Pin Signal Description

J4_01 VTARG Power

J4_02 GND Ground

J4_03 P12.4 Reset

J4_04 P12.3 SWD_CLK

J4_05 P12.2 SWD_IO

PSoC 4100S Plus device Header (J5)

Pin Signal Description

J5_01 VTARG Power

J5_02 GND Ground

J5_03 XRES Reset

J5_04 P3.3 SWD_CLK

J5_05 P3.2 SWD_IO
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A.2.5.3 Functionality of J6 and J7 Headers (KitProg2)

The KitProg2 board contains two single inline headers (J6 and J7). Both are 1x7-pin-headers, used
to pull out several pins of the PSoC 5LP to support advanced features like a low-speed oscilloscope
and a low-speed digital logic analyzer. This header also contains the KitProg2 bridge pins that can
be used when the two boards are separated.

The J6 and J7 headers support 100-mil spacing, so you can solder connectors to connect the
KitProg2 board to a development breadboard.

Figure A-7.  J6 and J7 Headers

Table A-5.  Pin Details of J6 Table A-6.  Pin Details of J7

PSoC 5LP KitProg2 Header (J6)

Pin Signal Description

J6_01 VBUS Power

J6_02 GND Ground

J6_03 P12.5 GPIO

J6_04 P12.0 GPIO/I2C_SCL

J6_05 P12.1 GPIO/I2C_SDA

J6_06 P12.7 GPIO/UART_RX

J6_07 P12.6 GPIO/UART_TX

PSoC 5LP KitProg2 Header (J7)

Pin Signal Description

J7_01 GND Ground

J7_02 P3.0 GPIO

J7_03 P3.4 GPIO

J7_04 P3.5 GPIO

J7_05 P3.6 GPIO

J7_06 P0.2 GPIO

J7_07 P0.1 GPIO



CY8CKIT-149 PSoC® 4100S Plus Prototyping Kit Guide, Doc. #: 002-20729 Rev. *E 42

A.2.5.4 Functionality of Connector J8 (USB 2.0 Micro-B Connector)

This connector on the kit enables the user to connect the kit to PC using USB 2.0 Type-A to Micro-B
Cable on J8 (USB Micro-B connector).

Figure A-8.  USB 2.0 Micro-B connector J8

A.2.6 User and Passive Inputs

A.2.6.1 User Switch

The target PSoC 4100S Plus board contains a switch connected to the P3[7] pin on the
PSoC 4100S Plus device. This switch can be used for general user inputs or to control different
states in an application.

Figure A-9.  User Switch on the Board 
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A.2.6.2 Reset Switch

When the Reset button is pressed, the XRES line of the PSoC 4100S Plus device is pulled to
ground, which resets the target device.

Figure A-10.  Reset (RST) Switch 

A.2.6.3 Mode Switch (KitProg2)

The KitProg2 board contains a push button connected to P1.2 of the PSoC 5LP. When this button is
pressed, it toggles between KitProg2 mode and CMSIS-DAP/Mass Storage Mode. For more details,
see the KitProg2 User Guide.

Figure A-11.  Mode Switch 

http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
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A.2.6.4 CapSense Buttons

Three CapSense buttons (BTN0, BTN1, and BTN2) are provided on a breakout board to
demonstrate the CapSense button functionality of PSoC 4100S Plus device. All the I/Os used for
implementing the CapSense buttons are exposed through the headers J2 and J9. Shield for button
is connected to ground by default. If you want to connect it to port (P0.1), remove R57 and load R58.

Note: CapSense Buttons and Slider are covered with Acrylic overlay of 1mm thickness. This is
important parameter for tuning.

Figure A-12.  CapSense Buttons 

Note: Touching CapSense buttons and slider for about 2 sec will auto-reset the sensor, turning off
LEDs. This is due to the auto-reset feature enabled in CapSense component for the Code example
provided with the kit.
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A.2.6.5 CapSense Linear Slider

A 6-segment linear slider (SLD0, SLD1, SLD2, SLD3, SLD4, and SLD5) is provided on a breakout
board to demonstrate the CapSense slider functionality of PSoC 4100S Plus device. All the I/Os
used for implementing the CapSense Slider are exposed through the headers J1 and J10. Shield for
slider is connected to ground by default. If you want to connect it to port (P2.5), remove R26 and
load R25.

Note: CapSense Buttons and Slider are covered with Acrylic overlay of 1mm thickness. This is
important parameter for tuning.

Figure A-13.  CapSense Slider

Note: Touching CapSense buttons and slider for about 2 sec will auto-reset the sensor, turning off
LEDs. This is due to the auto-reset feature enabled in CapSense component for the Code example
provided with the kit.
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A.2.6.6 LEDs

The PSoC 4100S Plus Prototyping kit contains thirteen LEDs: 

■ The Amber Power LED (LED2): Indicates that the board is powered from the USB 2.0 Micro-B 
connector. This LED will not glow when the board is powered from VDDD or VTARG directly.

■ The Amber Status LED (LED3): Indicates the KitProg2 status connected to P1[4] of the KitProg2 
PSoC 5LP device. See Table A-7 below for a summary of the status LED states. For more details 
on the KitProg2 status LED, see the KitProg2 User Guide.

■ The blue LED (LED1): This is the user LED connected to P3[4] of the target PSoC 4100S Plus 
device.

■ One blue LED, LED4 (EZ-BLE User): This is the user LED connected to GPIO of EZ-BLE Mod-
ule.

■ Six Green LEDs (LED5, LED6, LED7, LED8, LED9, LED10) (CapSense Slider User): These are 
feedback LEDs for six segment slider.

■ Three Green LEDs (LED11, LED12, LED13) (CapSense Button User): These are feedback LEDs 
for CapSense buttons.

*Note: Toggling between programming modes can be done by pressing mode switch SW3. 

Note: User LEDs i.e. LED1 and LED4 will not work at 1.8V, other LEDs may work with very low
brightness.

Figure A-14.  Power LED

Figure A-15.  Status LED

Table A-7.  LED status for KitProg2 Modes

KitProg2 Programming Modes * Status LED (LED3)

KitProg2 Program / Debug Mode (PPCOM mode) (default) ON

CMSIS-DAP & Mass Storage Programming Mode OFF

http://www.cypress.com/documentation/development-kitsboards/kitprog2-user-guide
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Figure A-16.  User LED

Figure A-17.  Feedback LEDs for CapSense Button 

Figure A-18.  Feedback LEDs for CapSense Slider 
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A.2.6.7 System Capacitors

The CY8CKIT-149 PSoC 4100S Plus Prototyping Kit has eight capacitors in addition to power supply
decoupling capacitors:

■ Four CapSense capacitors (CMOD, CSH, CintA, CintB): Required for CapSense functionality of 
PSoC 4100S Plus device.

■ SAR bypass capacitor for PSoC 4100S Plus device (C1 - Loaded by default). To use port P1.7 as 
GPIO desolder C1.

■ Two biasing capacitors (C18 and C19 (No Load)): Required to interface an external 32.768 kHz 
crystal oscillator (WCO).

■ Two biasing capacitors (C28 and C26 (Loaded)): Required to interface an external 4 MHz crystal 
oscillator (ECO).

Figure A-19.  System Capacitors Circuit Diagram 
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A.2.6.8 EZ-BLE Module

The board includes an EZ-BLE Module, which is loaded by default. The EZ-BLE Module is a fully
integrated, 10 × 10 × 1.8 mm, fully certified, programmable module designed for ease-of-use and
reduced time-to-market. It contains Cypress' BLE chip, two crystals, chip antenna, shield, and pas-
sive components. For more details, see AN96841 - Getting Started With EZ-BLE Module. Visit
www.cypress.com/ez-ble module to buy the EZ-BLE Module.

Figure A-20.  EZ-BLE Connections 

http://www.cypress.com/documentation/application-notes/an96841-getting-started-ez-ble-module
www.cypress.com/ez-bleprocmodule
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The EZ-BLE Module includes the following connections to PSoC 4100S Plus and KitProg2:

■ UART connections to PSoC 4100S Plus through zero-ohm resistors R17 and R18 (see 
Figure A-20 and Table A-8). Note that R17 and R18 are not loaded by default.

■ I2C connections to KitProg2 and PSoC 4100S Plus device (see Table A-8).

■ SWD connections to KitProg2 through the DPDT switch SW4. The SWD connections are shared 
between the PSoC 4100S Plus and EZ-BLE devices.

Use DPDT switch SW4 to switch the SWD connections between PSoC 4100S Plus or EZ-BLE
Module as shown in Figure A-21.

Figure A-21.  DPDT Switch SW4 to Select between PSoC 4100S Plus and EZ-BLE 

A.3 PSoC 4100S Plus Prototyping Kit Schematics

Refer to the schematic file in the following path in the kit software installed:

<Install_Directory>\CY8CKIT-149 PSoC 4100S Plus Prototyping Kit\
<version>\Hardware\CY8CKIT-149 Schematic.pdf

Table A-8.  EZ-BLE Connections

EZ-BLE Connections

EZ-BLE
PSoC 4100S 

Plus
KitProg2 Description

BLE_TX, P1_5 P5_0  UART_RX

BLE_RX, P1_4 P5_1  UART_TX

BLE_SDA, P5_0 P3_1 P12_1 I2C_SDA

BLE_SCL, P5_1 P3_0 P12_0 I2C_SCL

BLE_SWDIO, P0_6  P12_2 SWDIO

BLE_SWDCLK, P0_7  P12_3 SWDCLK

P0_4 P3_6  GPIO

BLE_XRES RESET P12_4 RESET

P1_6   BLE LED

P4_1 P3_7  User Button
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A.4 Bill of Materials

Refer to the BOM file in the following path in the kit software installed:

<Install_Directory>\CY8CKIT-149 PSoC 4100S Plus Prototyping Kit\
<version>\Hardware\CY8CKIT-149 PCBA BOM.xlsm

A.5 Programming PSoC 4100S Plus Prototyping Kit Using MiniProg3/
KitProg2

The target board provides a provision to program the PSoC 4100S Plus device using MiniProg3 or
an external KitProg2 via the 5-pin SWD header. To do this, connect wires or a 5-pin 100-mil spaced
header to J5. The PSoC 4100S Plus Prototyping Kit supports both power cycle and reset
programming modes. 

Figure A-22.  Connecting the CY8CKIT-149 to a MiniProg3

Note: CY8CKIT-002 MiniProg3 is not part of the PSoC 4100S Plus Prototyping Kit contents and can
be purchased from the Cypress Online Store.

http://www.cypress.com/documentation/development-kitsboards/cy8ckit-002-psoc-miniprog3-program-and-debug-kit
http://www.cypress.com/cypress-store
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